41 lines
1.4 KiB
Diff
41 lines
1.4 KiB
Diff
From 4a85d0479392f5e1d5ec8623b66d7b52b8209043 Mon Sep 17 00:00:00 2001
|
|
From: Olly Betts <olly@survex.com>
|
|
Date: Wed, 11 Oct 2023 09:16:06 +1300
|
|
Subject: [PATCH] [PHP] Fix testcase director_finalizer with PHP 8.3
|
|
|
|
Fixes #2685
|
|
---
|
|
Examples/test-suite/php/director_finalizer_runme.php | 2 +-
|
|
configure.ac | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/Examples/test-suite/php/director_finalizer_runme.php b/Examples/test-suite/php/director_finalizer_runme.php
|
|
index f3a0c2c40..689f445d2 100644
|
|
--- a/Examples/test-suite/php/director_finalizer_runme.php
|
|
+++ b/Examples/test-suite/php/director_finalizer_runme.php
|
|
@@ -17,7 +17,7 @@ class MyFoo extends Foo {
|
|
if ($this->thisown) {
|
|
$this->orStatus(2);
|
|
}
|
|
- if (method_exists(get_parent_class(), "__destruct")) {
|
|
+ if (method_exists(parent::class, "__destruct")) {
|
|
parent::__destruct();
|
|
}
|
|
}
|
|
diff --git a/configure.ac b/configure.ac
|
|
index b9c1a2888..c06002872 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1835,7 +1835,7 @@ if test x"${PHPBIN}" = xno; then
|
|
PHP=
|
|
else
|
|
if test "x$PHPBIN" = xyes; then
|
|
- AC_CHECK_PROGS(PHP, [php8.1 php8.0 php7.4 php7.3 php7.2 php7.1 php7.0 php])
|
|
+ AC_CHECK_PROGS(PHP, [php8.3 php8.2 php8.1 php8.0 php7.4 php7.3 php7.2 php7.1 php7.0 php])
|
|
else
|
|
PHP=$PHPBIN
|
|
fi
|
|
--
|
|
2.41.0
|
|
|