swig/swig-configure-c99.patch

53 lines
1.6 KiB
Diff

Add missing #include directives to obtain additional function
prototypes. This avoids altering the result of this test with C99
compilers which do not support implicit function declarations.
Submitted upstream: <https://github.com/swig/swig/pull/2483>
diff --git a/CCache/configure b/CCache/configure
index 829db3db32ca442a..66f60da79446541e 100755
--- a/CCache/configure
+++ b/CCache/configure
@@ -4135,6 +4135,9 @@ else $as_nop
#include <sys/types.h>
#include <stdarg.h>
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
void foo(const char *format, ...) {
va_list ap;
int len;
@@ -4149,7 +4152,7 @@ void foo(const char *format, ...) {
exit(0);
}
-main() { foo("hello"); }
+int main(void) { foo("hello"); }
_ACEOF
if ac_fn_c_try_run "$LINENO"
diff --git a/CCache/configure.ac b/CCache/configure.ac
index 2db3553ce796ec21..9afd49e8370d4cac 100644
--- a/CCache/configure.ac
+++ b/CCache/configure.ac
@@ -63,6 +63,9 @@ AC_CACHE_CHECK([for C99 vsnprintf],ccache_cv_HAVE_C99_VSNPRINTF,[
AC_RUN_IFELSE([AC_LANG_SOURCE([[
#include <sys/types.h>
#include <stdarg.h>
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
void foo(const char *format, ...) {
va_list ap;
int len;
@@ -77,7 +80,7 @@ void foo(const char *format, ...) {
exit(0);
}
-main() { foo("hello"); }
+int main(void) { foo("hello"); }
]])],[ccache_cv_HAVE_C99_VSNPRINTF=yes],[ccache_cv_HAVE_C99_VSNPRINTF=no],[ccache_cv_HAVE_C99_VSNPRINTF=cross])])
if test x"$ccache_cv_HAVE_C99_VSNPRINTF" = x"yes"; then
AC_DEFINE(HAVE_C99_VSNPRINTF, 1, [ ])