Port configure script to C99
Related to: <https://fedoraproject.org/wiki/Changes/PortingToModernC> <https://fedoraproject.org/wiki/Toolchain/PortingToModernC>
This commit is contained in:
parent
3fe391e859
commit
f50f0e420e
52
swig-configure-c99.patch
Normal file
52
swig-configure-c99.patch
Normal file
@ -0,0 +1,52 @@
|
|||||||
|
Add missing #include directives to obtain additional function
|
||||||
|
prototypes. This avoids altering the result of this test with C99
|
||||||
|
compilers which do not support implicit function declarations.
|
||||||
|
|
||||||
|
Submitted upstream: <https://github.com/swig/swig/pull/2483>
|
||||||
|
|
||||||
|
diff --git a/CCache/configure b/CCache/configure
|
||||||
|
index 829db3db32ca442a..66f60da79446541e 100755
|
||||||
|
--- a/CCache/configure
|
||||||
|
+++ b/CCache/configure
|
||||||
|
@@ -4135,6 +4135,9 @@ else $as_nop
|
||||||
|
|
||||||
|
#include <sys/types.h>
|
||||||
|
#include <stdarg.h>
|
||||||
|
+#include <stdio.h>
|
||||||
|
+#include <stdlib.h>
|
||||||
|
+#include <string.h>
|
||||||
|
void foo(const char *format, ...) {
|
||||||
|
va_list ap;
|
||||||
|
int len;
|
||||||
|
@@ -4149,7 +4152,7 @@ void foo(const char *format, ...) {
|
||||||
|
|
||||||
|
exit(0);
|
||||||
|
}
|
||||||
|
-main() { foo("hello"); }
|
||||||
|
+int main(void) { foo("hello"); }
|
||||||
|
|
||||||
|
_ACEOF
|
||||||
|
if ac_fn_c_try_run "$LINENO"
|
||||||
|
diff --git a/CCache/configure.ac b/CCache/configure.ac
|
||||||
|
index 2db3553ce796ec21..9afd49e8370d4cac 100644
|
||||||
|
--- a/CCache/configure.ac
|
||||||
|
+++ b/CCache/configure.ac
|
||||||
|
@@ -63,6 +63,9 @@ AC_CACHE_CHECK([for C99 vsnprintf],ccache_cv_HAVE_C99_VSNPRINTF,[
|
||||||
|
AC_RUN_IFELSE([AC_LANG_SOURCE([[
|
||||||
|
#include <sys/types.h>
|
||||||
|
#include <stdarg.h>
|
||||||
|
+#include <stdio.h>
|
||||||
|
+#include <stdlib.h>
|
||||||
|
+#include <string.h>
|
||||||
|
void foo(const char *format, ...) {
|
||||||
|
va_list ap;
|
||||||
|
int len;
|
||||||
|
@@ -77,7 +80,7 @@ void foo(const char *format, ...) {
|
||||||
|
|
||||||
|
exit(0);
|
||||||
|
}
|
||||||
|
-main() { foo("hello"); }
|
||||||
|
+int main(void) { foo("hello"); }
|
||||||
|
]])],[ccache_cv_HAVE_C99_VSNPRINTF=yes],[ccache_cv_HAVE_C99_VSNPRINTF=no],[ccache_cv_HAVE_C99_VSNPRINTF=cross])])
|
||||||
|
if test x"$ccache_cv_HAVE_C99_VSNPRINTF" = x"yes"; then
|
||||||
|
AC_DEFINE(HAVE_C99_VSNPRINTF, 1, [ ])
|
@ -51,7 +51,7 @@
|
|||||||
Summary: Connects C/C++/Objective C to some high-level programming languages
|
Summary: Connects C/C++/Objective C to some high-level programming languages
|
||||||
Name: swig
|
Name: swig
|
||||||
Version: 4.1.1
|
Version: 4.1.1
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPL-3.0-or-later AND BSD-3-Clause
|
License: GPL-3.0-or-later AND BSD-3-Clause
|
||||||
URL: http://swig.sourceforge.net/
|
URL: http://swig.sourceforge.net/
|
||||||
Source0: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
|
Source0: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
|
||||||
@ -62,6 +62,7 @@ Source2: description-ccache.h2m
|
|||||||
Source3: ccache-swig.sh
|
Source3: ccache-swig.sh
|
||||||
Source4: ccache-swig.csh
|
Source4: ccache-swig.csh
|
||||||
%endif
|
%endif
|
||||||
|
Patch0: swig-configure-c99.patch
|
||||||
|
|
||||||
BuildRequires: coreutils
|
BuildRequires: coreutils
|
||||||
BuildRequires: findutils
|
BuildRequires: findutils
|
||||||
@ -340,6 +341,9 @@ install -pm 644 Tools/swig.gdb %{buildroot}%{_datadir}/%{name}/gdb
|
|||||||
%{_datadir}/%{name}/gdb
|
%{_datadir}/%{name}/gdb
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 12 2023 Florian Weimer <fweimer@redhat.com> - 4.1.1-2
|
||||||
|
- Port configure script to C99
|
||||||
|
|
||||||
* Thu Dec 01 2022 Jitka Plesnikova <jplesnik@redhat.com> - 4.1.1-1
|
* Thu Dec 01 2022 Jitka Plesnikova <jplesnik@redhat.com> - 4.1.1-1
|
||||||
- Update to 4.1.1
|
- Update to 4.1.1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user