Add Patch1 from upstream
Do not dump Octave core in examples/test suite scripts Add Patch2 for Fedora >= 26, backported from upstream Support for Octave 4.2
This commit is contained in:
parent
65e54ee746
commit
dfde9f6191
1395
swig-3.0.11_octave-no-core-dump.patch
Normal file
1395
swig-3.0.11_octave-no-core-dump.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -587,7 +587,7 @@ Index: swig-3.0.11/configure.ac
|
||||
===================================================================
|
||||
--- swig-3.0.11.orig/configure.ac
|
||||
+++ swig-3.0.11/configure.ac
|
||||
@@ -1017,30 +1017,77 @@ OCTAVE_SO=.oct
|
||||
@@ -1018,30 +1018,77 @@ OCTAVE_SO=.oct
|
||||
AC_ARG_WITH(octave, AS_HELP_STRING([--without-octave], [Disable Octave])
|
||||
AS_HELP_STRING([--with-octave=path], [Set location of Octave executable]),[OCTAVEBIN="$withval"], [OCTAVEBIN="$alllang_default"])
|
||||
|
||||
@ -673,7 +673,7 @@ Index: swig-3.0.11/configure.ac
|
||||
AC_MSG_CHECKING([for Octave preprocessor flags])
|
||||
OCTAVE_CPPFLAGS=
|
||||
for var in CPPFLAGS INCFLAGS ALL_CXXFLAGS; do
|
||||
@@ -1052,8 +1099,9 @@ if test -n "$OCTAVE"; then
|
||||
@@ -1053,8 +1100,9 @@ if test -n "$OCTAVE"; then
|
||||
done
|
||||
done
|
||||
AC_MSG_RESULT([$OCTAVE_CPPFLAGS])
|
||||
@ -684,7 +684,7 @@ Index: swig-3.0.11/configure.ac
|
||||
for var in ALL_CXXFLAGS; do
|
||||
for flag in `env - ${mkoctfile} -p ${var}`; do
|
||||
case ${flag} in
|
||||
@@ -1065,28 +1113,20 @@ if test -n "$OCTAVE"; then
|
||||
@@ -1066,28 +1114,20 @@ if test -n "$OCTAVE"; then
|
||||
save_CXXFLAGS="${CXXFLAGS}"
|
||||
CXXFLAGS="-Werror -O0"
|
||||
AC_COMPILE_IFELSE([
|
||||
@ -716,3 +716,9 @@ Index: swig-3.0.11/configure.ac
|
||||
fi
|
||||
|
||||
AC_SUBST(OCTAVE)
|
||||
Index: swig-3.0.11/Lib/perl5/std_wstring.i
|
||||
===================================================================
|
||||
--- /dev/null
|
||||
+++ swig-3.0.11/Lib/perl5/std_wstring.i
|
||||
@@ -0,0 +1 @@
|
||||
+%include <typemaps/std_string.swg>
|
||||
|
10
swig.spec
10
swig.spec
@ -42,11 +42,12 @@ Source3: ccache-swig.sh
|
||||
Source4: ccache-swig.csh
|
||||
|
||||
Patch0: swig308-Do-not-use-isystem.patch
|
||||
Patch1: https://github.com/swig/swig/commit/9e66af3fefa07fad0103f97eef8e1dc86b3498ba.patch#/swig-3.0.11_octave-no-core-dump.patch
|
||||
|
||||
# Support for Octave 4.2. Drop patch on v3.0.12 release.
|
||||
# Backported from https://github.com/swig/swig/pull/875.
|
||||
%if 0%{?fedora} >= 26
|
||||
Patch1: swig-3.0.11_octave42.patch
|
||||
Patch2: swig-3.0.11_octave42.patch
|
||||
%endif # 0#{?fedora} >= 26
|
||||
|
||||
BuildRequires: perl, pcre-devel
|
||||
@ -139,8 +140,9 @@ in gdb.
|
||||
%setup -q -n swig-%{version}
|
||||
|
||||
%patch0 -p1 -b .isystem
|
||||
%patch1 -p1 -b .ioctave_core_dump
|
||||
%if 0%{?fedora} >= 26
|
||||
%patch1 -p1 -b .ioctave42
|
||||
%patch2 -p1 -b .ioctave42
|
||||
%endif # 0#{?fedora} >= 26
|
||||
|
||||
for all in CHANGES README; do
|
||||
@ -289,7 +291,9 @@ install -pm 644 Tools/swig.gdb %{buildroot}%{_datadir}/%{name}/gdb
|
||||
|
||||
%changelog
|
||||
* Sat Jan 14 2017 Björn Esser <besser82@fedoraproject.org> - 3.0.11-2
|
||||
- Add Patch1 for Fedora >= 26, backported from upstream
|
||||
- Add Patch1 from upstream
|
||||
- Do not dump Octave core in examples/test suite scripts
|
||||
- Add Patch2 for Fedora >= 26, backported from upstream
|
||||
- Support for Octave 4.2
|
||||
|
||||
* Mon Jan 02 2017 Jitka Plesnikova <jplesnik@redhat.com> - 3.0.11-1
|
||||
|
Loading…
Reference in New Issue
Block a user