Fix configure to properly check version of Go 1.10; Update conditions for tests
This commit is contained in:
parent
f3809a515c
commit
9d7264020b
21
swig-3.0.12-Fix-configure-for-Go-1_10.patch
Normal file
21
swig-3.0.12-Fix-configure-for-Go-1_10.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
diff -up swig-3.0.12/configure.ac.go110 swig-3.0.12/configure.ac
|
||||||
|
--- swig-3.0.12/configure.ac.go110 2018-02-13 13:08:16.543632561 +0100
|
||||||
|
+++ swig-3.0.12/configure.ac 2018-02-13 13:56:20.241295155 +0100
|
||||||
|
@@ -2606,7 +2606,7 @@ else
|
||||||
|
esac
|
||||||
|
AC_MSG_CHECKING([whether go version is too old])
|
||||||
|
case $go_version in
|
||||||
|
- go1.1* | go1.0* | go1 )
|
||||||
|
+ go1.1 | go1.0* | go1 )
|
||||||
|
AC_MSG_RESULT([yes - minimum version is 1.2])
|
||||||
|
GO=
|
||||||
|
GOOPT="-intgosize 32"
|
||||||
|
@@ -2624,7 +2624,7 @@ else
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
case $go_version in
|
||||||
|
- go1.0* | go1 | go1.1*)
|
||||||
|
+ go1.0* | go1 | go1.1)
|
||||||
|
GOOPT="$GOOPT -use-shlib"
|
||||||
|
;;
|
||||||
|
go1.2*)
|
26
swig.spec
26
swig.spec
@ -8,31 +8,30 @@
|
|||||||
%{!?phplang:%global phplang 0}
|
%{!?phplang:%global phplang 0}
|
||||||
%{!?rubylang:%global rubylang 1}
|
%{!?rubylang:%global rubylang 1}
|
||||||
|
|
||||||
%ifarch aarch64 %{arm} %{mips} ppc64le ppc %{power64} s390 s390x
|
|
||||||
%{!?golang:%global golang 0}
|
|
||||||
%{!?Rlang:%global Rlang 0}
|
|
||||||
%{!?javalang:%global javalang 0}
|
|
||||||
%else
|
|
||||||
%if 0%{?rhel}
|
%if 0%{?rhel}
|
||||||
%{!?golang:%global golang 0}
|
%{!?golang:%global golang 0}
|
||||||
|
%{!?octave:%global octave 0}
|
||||||
%{!?Rlang:%global Rlang 0}
|
%{!?Rlang:%global Rlang 0}
|
||||||
%else
|
%else
|
||||||
%{!?golang:%global golang 1}
|
%{!?octave:%global octave 1}
|
||||||
%{!?Rlang:%global Rlang 1}
|
%{!?Rlang:%global Rlang 1}
|
||||||
%endif
|
%endif
|
||||||
|
%ifarch aarch64 %{arm} %{mips} ppc64le ppc %{power64} s390 s390x
|
||||||
|
%{!?javalang:%global javalang 0}
|
||||||
|
%else
|
||||||
%{!?javalang:%global javalang 1}
|
%{!?javalang:%global javalang 1}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if 0%{?rhel}
|
%ifarch %{ix86} x86_64 %{arm} aarch64 ppc64le
|
||||||
%{!?octave:%global octave 0}
|
%{!?golang:%global golang 1}
|
||||||
%else
|
%else
|
||||||
%{!?octave:%global octave 1}
|
%{!?golang:%global golang 0}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
Summary: Connects C/C++/Objective C to some high-level programming languages
|
Summary: Connects C/C++/Objective C to some high-level programming languages
|
||||||
Name: swig
|
Name: swig
|
||||||
Version: 3.0.12
|
Version: 3.0.12
|
||||||
Release: 15%{?dist}
|
Release: 16%{?dist}
|
||||||
License: GPLv3+ and BSD
|
License: GPLv3+ and BSD
|
||||||
URL: http://swig.sourceforge.net/
|
URL: http://swig.sourceforge.net/
|
||||||
Source0: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
|
Source0: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
|
||||||
@ -51,6 +50,7 @@ Patch2: https://patch-diff.githubusercontent.com/raw/swig/swig/pull/968/swig-no
|
|||||||
Patch3: swig-3.0.12-Fix-generated-code-for-constant-expressions-containi.patch
|
Patch3: swig-3.0.12-Fix-generated-code-for-constant-expressions-containi.patch
|
||||||
Patch4: swig-3.0.12-Fix-type-promotion-wrapping-some-non-trivial-constan.patch
|
Patch4: swig-3.0.12-Fix-type-promotion-wrapping-some-non-trivial-constan.patch
|
||||||
Patch5: swig-3.0.12-Correct-php-testcase.patch
|
Patch5: swig-3.0.12-Correct-php-testcase.patch
|
||||||
|
Patch6: swig-3.0.12-Fix-configure-for-Go-1_10.patch
|
||||||
|
|
||||||
BuildRequires: perl-interpreter, pcre-devel
|
BuildRequires: perl-interpreter, pcre-devel
|
||||||
BuildRequires: python2-devel, python3-devel
|
BuildRequires: python2-devel, python3-devel
|
||||||
@ -82,6 +82,7 @@ BuildRequires: octave-devel
|
|||||||
%endif
|
%endif
|
||||||
%if %{golang}
|
%if %{golang}
|
||||||
BuildRequires: golang
|
BuildRequires: golang
|
||||||
|
BuildRequires: golang-shared
|
||||||
BuildRequires: golang-src
|
BuildRequires: golang-src
|
||||||
%endif
|
%endif
|
||||||
%if %{lualang}
|
%if %{lualang}
|
||||||
@ -149,6 +150,7 @@ in gdb.
|
|||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
%patch4 -p1
|
%patch4 -p1
|
||||||
%patch5 -p1
|
%patch5 -p1
|
||||||
|
%patch6 -p1
|
||||||
|
|
||||||
for all in CHANGES README; do
|
for all in CHANGES README; do
|
||||||
iconv -f ISO88591 -t UTF8 < $all > $all.new
|
iconv -f ISO88591 -t UTF8 < $all > $all.new
|
||||||
@ -295,6 +297,10 @@ install -pm 644 Tools/swig.gdb %{buildroot}%{_datadir}/%{name}/gdb
|
|||||||
%{_datadir}/%{name}/gdb
|
%{_datadir}/%{name}/gdb
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 14 2018 Jitka Plesnikova <jplesnik@redhat.com> - 3.0.12-16
|
||||||
|
- Update conditions for tests
|
||||||
|
- Fix configure to properly check version of Go 1.10
|
||||||
|
|
||||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.12-15
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.12-15
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user