- don't output -L$libdir in -ldflags
This commit is contained in:
parent
b955979fee
commit
9159806f29
34
swig-1.3.21-ldflags.patch
Normal file
34
swig-1.3.21-ldflags.patch
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
|
||||||
|
Prevent the -ldflags output from including -L/usr/lib, since this will break
|
||||||
|
e.g. the Subversion build will then pick up system libraries rather than
|
||||||
|
local ones.
|
||||||
|
|
||||||
|
--- SWIG-1.3.21/configure.in.ldflags 2004-09-30 15:26:03.000000000 +0100
|
||||||
|
+++ SWIG-1.3.21/configure.in 2004-09-30 15:28:49.000000000 +0100
|
||||||
|
@@ -16,16 +16,16 @@
|
||||||
|
#define SWIG_LANG "-tcl"
|
||||||
|
|
||||||
|
/* Values returned by SWIG when invoked with the -ldflags option */
|
||||||
|
-#define SWIG_GUILE_RUNTIME "-L" LIBDIR " -lswigguile" RELEASE_SUFFIX
|
||||||
|
-#define SWIG_GUILESCM_RUNTIME "-L" LIBDIR " -lswigguilescm" RELEASE_SUFFIX
|
||||||
|
-#define SWIG_MZSCHEME_RUNTIME "-L" LIBDIR " -lswigmz" RELEASE_SUFFIX
|
||||||
|
-#define SWIG_PERL_RUNTIME "-L" LIBDIR " -lswigpl" RELEASE_SUFFIX
|
||||||
|
-#define SWIG_PIKE_RUNTIME "-L" LIBDIR " -lswigpike" RELEASE_SUFFIX
|
||||||
|
-#define SWIG_PHP_RUNTIME "-L" LIBDIR " -lswigphp4" RELEASE_SUFFIX
|
||||||
|
-#define SWIG_PYTHON_RUNTIME "-L" LIBDIR " -lswigpy" RELEASE_SUFFIX
|
||||||
|
-#define SWIG_RUBY_RUNTIME "-L" LIBDIR " -lswigrb" RELEASE_SUFFIX
|
||||||
|
-#define SWIG_TCL_RUNTIME "-L" LIBDIR " -lswigtcl" RELEASE_SUFFIX
|
||||||
|
-#define SWIG_CHICKEN_RUNTIME "-L" LIBDIR " -lswigchicken" RELEASE_SUFFIX
|
||||||
|
+#define SWIG_GUILE_RUNTIME "-lswigguile" RELEASE_SUFFIX
|
||||||
|
+#define SWIG_GUILESCM_RUNTIME "-lswigguilescm" RELEASE_SUFFIX
|
||||||
|
+#define SWIG_MZSCHEME_RUNTIME "-lswigmz" RELEASE_SUFFIX
|
||||||
|
+#define SWIG_PERL_RUNTIME "-lswigpl" RELEASE_SUFFIX
|
||||||
|
+#define SWIG_PIKE_RUNTIME "-lswigpike" RELEASE_SUFFIX
|
||||||
|
+#define SWIG_PHP_RUNTIME "-lswigphp4" RELEASE_SUFFIX
|
||||||
|
+#define SWIG_PYTHON_RUNTIME "-lswigpy" RELEASE_SUFFIX
|
||||||
|
+#define SWIG_RUBY_RUNTIME "-lswigrb" RELEASE_SUFFIX
|
||||||
|
+#define SWIG_TCL_RUNTIME "-lswigtcl" RELEASE_SUFFIX
|
||||||
|
+#define SWIG_CHICKEN_RUNTIME "-lswigchicken" RELEASE_SUFFIX
|
||||||
|
])
|
||||||
|
|
||||||
|
dnl Checks for programs.
|
@ -4,13 +4,14 @@
|
|||||||
Summary: Connects C/C++/Objective C to some high-level programming languages.
|
Summary: Connects C/C++/Objective C to some high-level programming languages.
|
||||||
Name: swig
|
Name: swig
|
||||||
Version: 1.3.21
|
Version: 1.3.21
|
||||||
Release: 4
|
Release: 5
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
URL: http://swig.sourceforge.net/
|
URL: http://swig.sourceforge.net/
|
||||||
Source: http://download.sourceforge.net/swig/swig-%{version}.tar.gz
|
Source: http://download.sourceforge.net/swig/swig-%{version}.tar.gz
|
||||||
Patch1: swig-1.3.19-pylib.patch
|
Patch1: swig-1.3.19-pylib.patch
|
||||||
Patch2: swig-1.3.21-destdir.patch
|
Patch2: swig-1.3.21-destdir.patch
|
||||||
|
Patch3: swig-1.3.21-ldflags.patch
|
||||||
BuildRoot: %{_tmppath}/swig-root
|
BuildRoot: %{_tmppath}/swig-root
|
||||||
BuildPrereq: perl, python-devel
|
BuildPrereq: perl, python-devel
|
||||||
%if %{tcl}
|
%if %{tcl}
|
||||||
@ -33,6 +34,7 @@ tool for building user interfaces.
|
|||||||
%setup -q -n SWIG-%{version}
|
%setup -q -n SWIG-%{version}
|
||||||
%patch1 -p1 -b .pylib
|
%patch1 -p1 -b .pylib
|
||||||
%patch2 -p1 -b .destdir
|
%patch2 -p1 -b .destdir
|
||||||
|
%patch3 -p1 -b .ldflags
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./autogen.sh
|
./autogen.sh
|
||||||
@ -61,6 +63,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/aclocal/swig.m4
|
%{_datadir}/aclocal/swig.m4
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 30 2004 Joe Orton <jorton@redhat.com> 1.3.21-5
|
||||||
|
- don't output -L$libdir in -ldflags
|
||||||
|
|
||||||
* Wed Sep 22 2004 Florian La Roche <Florian.LaRoche@redhat.de>
|
* Wed Sep 22 2004 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||||
- add ldconfig calls to post/postun
|
- add ldconfig calls to post/postun
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user