Update to 2.0.5
- patches merged - swig204-rh753321.patch - swig204-rh679948.patch - swig204-rh770696.patch Signed-off-by: Adam Tkac <atkac@redhat.com>
This commit is contained in:
parent
668562cac2
commit
7a4ff2cd66
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@ swig-2.0.0.tar.gz
|
||||
/swig-2.0.2.tar.gz
|
||||
/swig-2.0.3.tar.gz
|
||||
/swig-2.0.4.tar.gz
|
||||
/swig-2.0.5.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
4319c503ee3a13d2a53be9d828c3adc0 swig-2.0.4.tar.gz
|
||||
762760512887873b68325fcbd391c145 swig-2.0.5.tar.gz
|
||||
|
17
swig.spec
17
swig.spec
@ -9,18 +9,15 @@
|
||||
|
||||
Summary: Connects C/C++/Objective C to some high-level programming languages
|
||||
Name: swig
|
||||
Version: 2.0.4
|
||||
Release: 7%{?dist}
|
||||
Version: 2.0.5
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+ and BSD
|
||||
Group: Development/Tools
|
||||
URL: http://swig.sourceforge.net/
|
||||
Source: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
|
||||
Patch1: swig-1.3.23-pylib.patch
|
||||
Patch4: swig203-rh706140.patch
|
||||
Patch5: swig204-rh753321.patch
|
||||
Patch6: swig204-rh752054.patch
|
||||
Patch7: swig204-rh679948.patch
|
||||
Patch8: swig204-rh770696.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: perl, python-devel, pcre-devel
|
||||
@ -57,11 +54,8 @@ This package contains documentation for SWIG and useful examples
|
||||
%setup -q -n swig-%{version}
|
||||
%patch1 -p1 -b .pylib
|
||||
%patch4 -p1 -b .rh706140
|
||||
%patch5 -p0 -b .rh753321
|
||||
# Apply patch 6 when guile2 gets into distro
|
||||
#%patch6 -p1 -b .rh752054
|
||||
%patch7 -p0 -b .rh679948
|
||||
%patch8 -p1 -b .rh770696
|
||||
|
||||
# as written on https://fedoraproject.org/wiki/Packaging_talk:Perl, section 2
|
||||
# (specific req/prov filtering). Before you remove this hack make sure you don't
|
||||
@ -137,6 +131,13 @@ rm -rf %{buildroot}
|
||||
%doc Doc Examples LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
|
||||
|
||||
%changelog
|
||||
* Mon Apr 23 2012 Adam Tkac <atkac redhat com> 2.0.5-1
|
||||
- update to 2.0.5
|
||||
- patches merged
|
||||
- swig204-rh753321.patch
|
||||
- swig204-rh679948.patch
|
||||
- swig204-rh770696.patch
|
||||
|
||||
* Thu Apr 19 2012 Adam Tkac <atkac redhat com> - 2.0.4-7
|
||||
- drop Octave support on RHEL
|
||||
|
||||
|
@ -1,273 +0,0 @@
|
||||
Index: configure.in
|
||||
===================================================================
|
||||
--- configure.in (revision 12773)
|
||||
+++ configure.in (revision 12774)
|
||||
@@ -923,19 +923,20 @@
|
||||
|
||||
AC_MSG_CHECKING(for Octave header files)
|
||||
if test -n "$OCTAVE"; then
|
||||
- OCTAVEDIR="/usr/include"
|
||||
+ OCTAVECONFIG=[`echo $OCTAVEBIN | sed 's|octave\([^/]*\)$|octave-config\1|'`]
|
||||
+ if test -r "$OCTAVECONFIG"; then
|
||||
+ OCTAVEDIR=`$OCTAVECONFIG -p OCTINCLUDEDIR | sed 's|/octave$||'`
|
||||
+ else
|
||||
+ OCTAVEDIR="/usr/include"
|
||||
+ fi
|
||||
if test "$OCTAVEDIR" != ""; then
|
||||
- dirs="$OCTAVEDIR"
|
||||
+ dirs="$OCTAVEDIR/octave $OCTAVEDIR"
|
||||
OCTAVEEXT=""
|
||||
for i in $dirs; do
|
||||
if test -r $i/octave/oct.h; then
|
||||
OCTAVEEXT="$i"
|
||||
break;
|
||||
fi
|
||||
- if test -r $i/octave/octave/oct.h; then
|
||||
- OCTAVEEXT="$i/octave"
|
||||
- break;
|
||||
- fi
|
||||
done
|
||||
if test "$OCTAVEEXT" = "" ; then
|
||||
AC_MSG_RESULT(not found)
|
||||
Index: Lib/octave/octrun.swg
|
||||
===================================================================
|
||||
--- Lib/octave/octrun.swg (revision 12773)
|
||||
+++ Lib/octave/octrun.swg (revision 12774)
|
||||
@@ -399,6 +399,10 @@
|
||||
Swig::erase_rtdir(types[j].second.ptr);
|
||||
}
|
||||
|
||||
+ dim_vector dims(void) const {
|
||||
+ return dim_vector(1,1);
|
||||
+ }
|
||||
+
|
||||
octave_value as_value() {
|
||||
++count;
|
||||
return Swig::swig_value_ref(this);
|
||||
@@ -928,6 +932,9 @@
|
||||
octave_base_value *empty_clone() const
|
||||
{ return new octave_swig_ref(0); }
|
||||
|
||||
+ dim_vector dims(void) const
|
||||
+ { return ptr->dims(); }
|
||||
+
|
||||
bool is_defined() const
|
||||
{ return ptr->is_defined(); }
|
||||
|
||||
Index: Examples/octave/functor/Makefile
|
||||
===================================================================
|
||||
--- Examples/octave/functor/Makefile (revision 12773)
|
||||
+++ Examples/octave/functor/Makefile (revision 12774)
|
||||
@@ -19,3 +19,4 @@
|
||||
rm -f $(TARGET).py
|
||||
|
||||
check: all
|
||||
+ $(MAKE) -f $(TOP)/Makefile octave_run
|
||||
Index: Examples/octave/pointer/Makefile
|
||||
===================================================================
|
||||
--- Examples/octave/pointer/Makefile (revision 12773)
|
||||
+++ Examples/octave/pointer/Makefile (revision 12774)
|
||||
@@ -17,3 +17,4 @@
|
||||
rm -f $(TARGET).py
|
||||
|
||||
check: all
|
||||
+ $(MAKE) -f $(TOP)/Makefile octave_run
|
||||
Index: Examples/octave/funcptr/Makefile
|
||||
===================================================================
|
||||
--- Examples/octave/funcptr/Makefile (revision 12773)
|
||||
+++ Examples/octave/funcptr/Makefile (revision 12774)
|
||||
@@ -17,3 +17,4 @@
|
||||
rm -f $(TARGET).py
|
||||
|
||||
check: all
|
||||
+ $(MAKE) -f $(TOP)/Makefile octave_run
|
||||
Index: Examples/octave/extend/Makefile
|
||||
===================================================================
|
||||
--- Examples/octave/extend/Makefile (revision 12773)
|
||||
+++ Examples/octave/extend/Makefile (revision 12774)
|
||||
@@ -19,3 +19,4 @@
|
||||
rm -f $(TARGET).py
|
||||
|
||||
check: all
|
||||
+ $(MAKE) -f $(TOP)/Makefile octave_run
|
||||
Index: Examples/octave/simple/Makefile
|
||||
===================================================================
|
||||
--- Examples/octave/simple/Makefile (revision 12773)
|
||||
+++ Examples/octave/simple/Makefile (revision 12774)
|
||||
@@ -17,3 +17,4 @@
|
||||
rm -f $(TARGET).py
|
||||
|
||||
check: all
|
||||
+ $(MAKE) -f $(TOP)/Makefile octave_run
|
||||
Index: Examples/octave/operator/runme.m
|
||||
===================================================================
|
||||
--- Examples/octave/operator/runme.m (revision 12773)
|
||||
+++ Examples/octave/operator/runme.m (revision 12774)
|
||||
@@ -4,21 +4,21 @@
|
||||
a = example.ComplexVal(2,3);
|
||||
b = example.ComplexVal(-5,10);
|
||||
|
||||
-printf("a = %s\n",a);
|
||||
-printf("b = %s\n",b);
|
||||
+printf("a = %s\n",disp(a));
|
||||
+printf("b = %s\n",disp(b));
|
||||
|
||||
c = a + b;
|
||||
-printf("c = %s\n",c);
|
||||
-printf("a*b = %s\n",a*b);
|
||||
-printf("a-c = %s\n",a-c);
|
||||
+printf("c = %s\n",disp(c));
|
||||
+printf("a*b = %s\n",disp(a*b));
|
||||
+printf("a-c = %s\n",disp(a-c));
|
||||
|
||||
e = example.ComplexVal(a-c);
|
||||
-printf("e = %s\n",e);
|
||||
+printf("e = %s\n",disp(e));
|
||||
|
||||
# Big expression
|
||||
f = ((a+b)*(c+b*e)) + (-a);
|
||||
-printf("f = %s\n",f);
|
||||
+printf("f = %s\n",disp(f));
|
||||
|
||||
# paren overloading
|
||||
-printf("a(3)= %s\n",a(3));
|
||||
+printf("a(3)= %s\n",disp(a(3)));
|
||||
|
||||
Index: Examples/octave/operator/example.i
|
||||
===================================================================
|
||||
--- Examples/octave/operator/example.i (revision 12773)
|
||||
+++ Examples/octave/operator/example.i (revision 12774)
|
||||
@@ -10,13 +10,13 @@
|
||||
|
||||
/* An output method that turns a complex into a short string */
|
||||
%extend ComplexVal {
|
||||
- char *__str() {
|
||||
+ char *__str__() {
|
||||
static char temp[512];
|
||||
sprintf(temp,"(%g,%g)", $self->re(), $self->im());
|
||||
return temp;
|
||||
}
|
||||
|
||||
- ComplexVal __paren(int j) {
|
||||
+ ComplexVal __paren__(int j) {
|
||||
return ComplexVal($self->re()*j,$self->im()*j);
|
||||
}
|
||||
};
|
||||
Index: Examples/octave/operator/Makefile
|
||||
===================================================================
|
||||
--- Examples/octave/operator/Makefile (revision 12773)
|
||||
+++ Examples/octave/operator/Makefile (revision 12774)
|
||||
@@ -19,3 +19,4 @@
|
||||
rm -f $(TARGET).m
|
||||
|
||||
check: all
|
||||
+ $(MAKE) -f $(TOP)/Makefile octave_run
|
||||
Index: Examples/octave/callback/Makefile
|
||||
===================================================================
|
||||
--- Examples/octave/callback/Makefile (revision 12773)
|
||||
+++ Examples/octave/callback/Makefile (revision 12774)
|
||||
@@ -19,3 +19,4 @@
|
||||
rm -f $(TARGET).py
|
||||
|
||||
check: all
|
||||
+ $(MAKE) -f $(TOP)/Makefile octave_run
|
||||
Index: Examples/octave/reference/Makefile
|
||||
===================================================================
|
||||
--- Examples/octave/reference/Makefile (revision 12773)
|
||||
+++ Examples/octave/reference/Makefile (revision 12774)
|
||||
@@ -19,3 +19,4 @@
|
||||
rm -f $(TARGET).py
|
||||
|
||||
check: all
|
||||
+ $(MAKE) -f $(TOP)/Makefile octave_run
|
||||
Index: Examples/octave/funcptr2/Makefile
|
||||
===================================================================
|
||||
--- Examples/octave/funcptr2/Makefile (revision 12773)
|
||||
+++ Examples/octave/funcptr2/Makefile (revision 12774)
|
||||
@@ -17,3 +17,4 @@
|
||||
rm -f $(TARGET).py
|
||||
|
||||
check: all
|
||||
+ $(MAKE) -f $(TOP)/Makefile octave_run
|
||||
Index: Examples/octave/enum/Makefile
|
||||
===================================================================
|
||||
--- Examples/octave/enum/Makefile (revision 12773)
|
||||
+++ Examples/octave/enum/Makefile (revision 12774)
|
||||
@@ -19,3 +19,4 @@
|
||||
rm -f $(TARGET).py
|
||||
|
||||
check: all
|
||||
+ $(MAKE) -f $(TOP)/Makefile octave_run
|
||||
Index: Examples/octave/class/Makefile
|
||||
===================================================================
|
||||
--- Examples/octave/class/Makefile (revision 12773)
|
||||
+++ Examples/octave/class/Makefile (revision 12774)
|
||||
@@ -19,3 +19,4 @@
|
||||
rm -f $(TARGET).py
|
||||
|
||||
check: all
|
||||
+ $(MAKE) -f $(TOP)/Makefile octave_run
|
||||
Index: Examples/octave/variables/Makefile
|
||||
===================================================================
|
||||
--- Examples/octave/variables/Makefile (revision 12773)
|
||||
+++ Examples/octave/variables/Makefile (revision 12774)
|
||||
@@ -17,3 +17,4 @@
|
||||
rm -f $(TARGET).py
|
||||
|
||||
check: all
|
||||
+ $(MAKE) -f $(TOP)/Makefile octave_run
|
||||
Index: Examples/octave/template/Makefile
|
||||
===================================================================
|
||||
--- Examples/octave/template/Makefile (revision 12773)
|
||||
+++ Examples/octave/template/Makefile (revision 12774)
|
||||
@@ -19,3 +19,4 @@
|
||||
rm -f $(TARGET).py
|
||||
|
||||
check: all
|
||||
+ $(MAKE) -f $(TOP)/Makefile octave_run
|
||||
Index: Examples/octave/constants/Makefile
|
||||
===================================================================
|
||||
--- Examples/octave/constants/Makefile (revision 12773)
|
||||
+++ Examples/octave/constants/Makefile (revision 12774)
|
||||
@@ -19,3 +19,4 @@
|
||||
rm -f $(TARGET).py
|
||||
|
||||
check: all
|
||||
+ $(MAKE) -f $(TOP)/Makefile octave_run
|
||||
Index: Examples/octave/contract/Makefile
|
||||
===================================================================
|
||||
--- Examples/octave/contract/Makefile (revision 12773)
|
||||
+++ Examples/octave/contract/Makefile (revision 12774)
|
||||
@@ -17,3 +17,4 @@
|
||||
rm -f $(TARGET).py
|
||||
|
||||
check: all
|
||||
+ $(MAKE) -f $(TOP)/Makefile octave_run
|
||||
Index: Examples/Makefile.in
|
||||
===================================================================
|
||||
--- Examples/Makefile.in (revision 12773)
|
||||
+++ Examples/Makefile.in (revision 12774)
|
||||
@@ -333,6 +333,7 @@
|
||||
# Make sure these locate your Octave installation
|
||||
OCTAVE_INCLUDE= $(DEFS) @OCTAVEEXT@
|
||||
OCTAVE_LIB =
|
||||
+OCTAVE = @OCTAVE@
|
||||
|
||||
# Extra Octave specific dynamic linking options
|
||||
OCTAVE_DLNK = @OCTAVEDYNAMICLINKING@
|
||||
@@ -359,6 +360,15 @@
|
||||
$(CXXSHARED) -g $(CFLAGS) $(OBJS) $(IOBJS) $(OCTAVE_DLNK) $(LIBS) $(CPP_DLLIBS) -o $(LIBPREFIX)$(TARGET)$(OCTAVE_SO)
|
||||
|
||||
# -----------------------------------------------------------------
|
||||
+# Running an Octave example
|
||||
+# -----------------------------------------------------------------
|
||||
+
|
||||
+OCTSCRIPT = runme.m
|
||||
+
|
||||
+octave_run: $(OCTSCRIPT)
|
||||
+ env LD_LIBRARY_PATH=.:$$LD_LIBRARY_PATH OCTAVEPATH=$(srcdir):$$OCTAVEPATH $(OCTAVE) $(OCTSCRIPT) >/dev/null
|
||||
+
|
||||
+# -----------------------------------------------------------------
|
||||
# Cleaning the octave examples
|
||||
# -----------------------------------------------------------------
|
||||
|
@ -1,27 +0,0 @@
|
||||
Index: Source/Swig/stype.c
|
||||
===================================================================
|
||||
--- Source/Swig/stype.c (revision 12813)
|
||||
+++ Source/Swig/stype.c (revision 12814)
|
||||
@@ -823,7 +823,8 @@
|
||||
Insert(result, 0, "(");
|
||||
Append(result, ")");
|
||||
}
|
||||
- isreference = 1;
|
||||
+ if (!isfunction)
|
||||
+ isreference = 1;
|
||||
} else if (SwigType_isarray(element)) {
|
||||
DOH *size;
|
||||
if (firstarray && !isreference) {
|
||||
@@ -869,10 +870,8 @@
|
||||
cast = NewStringf("(%s)", result);
|
||||
}
|
||||
if (name) {
|
||||
- if (!isfunction) {
|
||||
- if (isreference) {
|
||||
- Append(cast, "*");
|
||||
- }
|
||||
+ if (isreference) {
|
||||
+ Append(cast, "*");
|
||||
}
|
||||
Append(cast, name);
|
||||
}
|
@ -1,11 +0,0 @@
|
||||
--- trunk/Lib/php/phprun.swg 2011/03/12 01:38:27 12528
|
||||
+++ trunk/Lib/php/phprun.swg 2011/05/24 03:59:35 12710
|
||||
@@ -192,7 +192,7 @@
|
||||
swig_object_wrapper *value;
|
||||
void *p;
|
||||
int type;
|
||||
- char *type_name;
|
||||
+ const char *type_name;
|
||||
|
||||
value = (swig_object_wrapper *) zend_list_find(z->value.lval, &type);
|
||||
if ( flags & SWIG_POINTER_DISOWN ) {
|
Loading…
Reference in New Issue
Block a user