Fix PHP test, it fails with PHP 8.3
This commit is contained in:
parent
bef85e9f4f
commit
6463e51599
40
swig-PHP-Fix-testcase-director_finalizer-with-PHP-8.3.patch
Normal file
40
swig-PHP-Fix-testcase-director_finalizer-with-PHP-8.3.patch
Normal file
@ -0,0 +1,40 @@
|
||||
From 4a85d0479392f5e1d5ec8623b66d7b52b8209043 Mon Sep 17 00:00:00 2001
|
||||
From: Olly Betts <olly@survex.com>
|
||||
Date: Wed, 11 Oct 2023 09:16:06 +1300
|
||||
Subject: [PATCH] [PHP] Fix testcase director_finalizer with PHP 8.3
|
||||
|
||||
Fixes #2685
|
||||
---
|
||||
Examples/test-suite/php/director_finalizer_runme.php | 2 +-
|
||||
configure.ac | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Examples/test-suite/php/director_finalizer_runme.php b/Examples/test-suite/php/director_finalizer_runme.php
|
||||
index f3a0c2c40..689f445d2 100644
|
||||
--- a/Examples/test-suite/php/director_finalizer_runme.php
|
||||
+++ b/Examples/test-suite/php/director_finalizer_runme.php
|
||||
@@ -17,7 +17,7 @@ class MyFoo extends Foo {
|
||||
if ($this->thisown) {
|
||||
$this->orStatus(2);
|
||||
}
|
||||
- if (method_exists(get_parent_class(), "__destruct")) {
|
||||
+ if (method_exists(parent::class, "__destruct")) {
|
||||
parent::__destruct();
|
||||
}
|
||||
}
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index b9c1a2888..c06002872 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1835,7 +1835,7 @@ if test x"${PHPBIN}" = xno; then
|
||||
PHP=
|
||||
else
|
||||
if test "x$PHPBIN" = xyes; then
|
||||
- AC_CHECK_PROGS(PHP, [php8.1 php8.0 php7.4 php7.3 php7.2 php7.1 php7.0 php])
|
||||
+ AC_CHECK_PROGS(PHP, [php8.3 php8.2 php8.1 php8.0 php7.4 php7.3 php7.2 php7.1 php7.0 php])
|
||||
else
|
||||
PHP=$PHPBIN
|
||||
fi
|
||||
--
|
||||
2.41.0
|
||||
|
@ -63,7 +63,7 @@
|
||||
Summary: Connects C/C++/Objective C to some high-level programming languages
|
||||
Name: swig
|
||||
Version: 4.1.1
|
||||
Release: 10%{?dist}
|
||||
Release: 11%{?dist}
|
||||
License: GPL-3.0-or-later AND BSD-3-Clause
|
||||
URL: https://www.swig.org/
|
||||
Source0: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
|
||||
@ -83,6 +83,8 @@ Patch1: swig-octave-8.1.patch
|
||||
Patch2: swig-ocaml-5.0.patch
|
||||
# Fix a test that is broken with python 3.12
|
||||
Patch3: swig-python-3.12.patch
|
||||
# Fix a test that is broken with PHP 8.3
|
||||
Patch4: swig-PHP-Fix-testcase-director_finalizer-with-PHP-8.3.patch
|
||||
|
||||
BuildRequires: coreutils
|
||||
BuildRequires: findutils
|
||||
@ -369,6 +371,9 @@ install -pm 644 Tools/swig.gdb %{buildroot}%{_datadir}/%{name}/gdb
|
||||
%{_datadir}/%{name}/gdb
|
||||
|
||||
%changelog
|
||||
* Wed Oct 11 2023 Jitka Plesnikova <jplesnik@redhat.com> - 4.1.1-11
|
||||
- Fix PHP test, it fails with PHP 8.3
|
||||
|
||||
* Thu Oct 05 2023 Richard W.M. Jones <rjones@redhat.com> - 4.1.1-10
|
||||
- OCaml 5.1 rebuild for Fedora 40
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user