Update to 2.0.8 (#851364)
- swig207-rh830660.patch merged - swig207-r13128.patch merged - swig-rh841245.patch merged Signed-off-by: Adam Tkac <vonsch@gmail.com>
This commit is contained in:
parent
66d69eb527
commit
62ea443cf6
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@ swig-2.0.0.tar.gz
|
||||
/swig-2.0.5.tar.gz
|
||||
/swig-2.0.6.tar.gz
|
||||
/swig-2.0.7.tar.gz
|
||||
/swig-2.0.8.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
8c2f6a9f51677647a64c8adb1b176299 swig-2.0.7.tar.gz
|
||||
69f917e870efc0712c06ab53217b28d1 swig-2.0.8.tar.gz
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff -up swig-2.0.7/Lib/perl5/noembed.h.rh841245 swig-2.0.7/Lib/perl5/noembed.h
|
||||
--- swig-2.0.7/Lib/perl5/noembed.h.rh841245 2012-07-19 15:37:51.842209067 +0200
|
||||
+++ swig-2.0.7/Lib/perl5/noembed.h 2012-07-19 15:38:00.288182523 +0200
|
||||
@@ -64,9 +64,6 @@
|
||||
#ifdef eof
|
||||
#undef eof
|
||||
#endif
|
||||
-#ifdef bool
|
||||
- #undef bool
|
||||
-#endif
|
||||
#ifdef close
|
||||
#undef close
|
||||
#endif
|
16
swig.spec
16
swig.spec
@ -9,18 +9,15 @@
|
||||
|
||||
Summary: Connects C/C++/Objective C to some high-level programming languages
|
||||
Name: swig
|
||||
Version: 2.0.7
|
||||
Release: 4%{?dist}
|
||||
Version: 2.0.8
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+ and BSD
|
||||
Group: Development/Tools
|
||||
URL: http://swig.sourceforge.net/
|
||||
Source: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
|
||||
Patch4: swig203-rh706140.patch
|
||||
Patch6: swig204-rh752054.patch
|
||||
Patch7: swig207-rh830660.patch
|
||||
Patch8: swig207-r13128.patch
|
||||
Patch9: swig207-setools.patch
|
||||
Patch10:swig-rh841245.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: perl, python-devel, pcre-devel
|
||||
@ -59,10 +56,7 @@ This package contains documentation for SWIG and useful examples
|
||||
# Apply patch 6 when guile2 gets into distro
|
||||
#%patch6 -p1 -b .rh752054
|
||||
|
||||
%patch7 -p1 -b .rh830660
|
||||
%patch8 -p0 -b .r13128
|
||||
%patch9 -p1 -b .setools
|
||||
%patch10 -p1 -b .rh841245
|
||||
|
||||
# as written on https://fedoraproject.org/wiki/Packaging_talk:Perl, section 2
|
||||
# (specific req/prov filtering). Before you remove this hack make sure you don't
|
||||
@ -138,6 +132,12 @@ rm -rf %{buildroot}
|
||||
%doc Doc Examples LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
|
||||
|
||||
%changelog
|
||||
* Wed Sep 12 2012 Adam Tkac <atkac redhat com> 2.0.8-1
|
||||
- update to 2.0.8 (#851364)
|
||||
- swig207-rh830660.patch merged
|
||||
- swig207-r13128.patch merged
|
||||
- swig-rh841245.patch merged
|
||||
|
||||
* Thu Jul 19 2012 Adam Tkac <atkac redhat com> 2.0.7-4
|
||||
- don't clean "bool" definition in PERL 5 environment (#841245)
|
||||
|
||||
|
@ -1,22 +0,0 @@
|
||||
Index: Source/Modules/lang.cxx
|
||||
===================================================================
|
||||
--- Source/Modules/lang.cxx (revision 13127)
|
||||
+++ Source/Modules/lang.cxx (revision 13128)
|
||||
@@ -2623,7 +2623,7 @@
|
||||
Delete(expected_name_resolved);
|
||||
}
|
||||
if (illegal_name) {
|
||||
- Swig_warning(WARN_LANG_RETURN_TYPE, input_file, line_number, "Function %s must have a return type. Ignored.\n", Swig_name_decl(name));
|
||||
+ Swig_warning(WARN_LANG_RETURN_TYPE, input_file, line_number, "Function %s must have a return type. Ignored.\n", Swig_name_decl(n));
|
||||
Swig_restore(n);
|
||||
return SWIG_NOWRAP;
|
||||
}
|
||||
@@ -2760,7 +2760,7 @@
|
||||
}
|
||||
|
||||
if (illegal_name) {
|
||||
- Swig_warning(WARN_LANG_ILLEGAL_DESTRUCTOR, input_file, line_number, "Illegal destructor name %s. Ignored.\n", Swig_name_decl(name));
|
||||
+ Swig_warning(WARN_LANG_ILLEGAL_DESTRUCTOR, input_file, line_number, "Illegal destructor name %s. Ignored.\n", Swig_name_decl(n));
|
||||
Swig_restore(n);
|
||||
Delete(expected_name);
|
||||
return SWIG_NOWRAP;
|
@ -1,11 +0,0 @@
|
||||
diff -up swig-2.0.7/Lib/python/pyhead.swg.rh830660 swig-2.0.7/Lib/python/pyhead.swg
|
||||
--- swig-2.0.7/Lib/python/pyhead.swg.rh830660 2012-06-12 15:04:54.360670826 +0200
|
||||
+++ swig-2.0.7/Lib/python/pyhead.swg 2012-06-12 15:05:24.119620754 +0200
|
||||
@@ -5,6 +5,7 @@
|
||||
#define PyInt_Check(x) PyLong_Check(x)
|
||||
#define PyInt_AsLong(x) PyLong_AsLong(x)
|
||||
#define PyInt_FromLong(x) PyLong_FromLong(x)
|
||||
+#define PyInt_FromSize_t(x) PyLong_FromSize_t(x)
|
||||
#define PyString_Check(name) PyBytes_Check(name)
|
||||
#define PyString_FromString(x) PyUnicode_FromString(x)
|
||||
#define PyString_Format(fmt, args) PyUnicode_Format(fmt, args)
|
Loading…
Reference in New Issue
Block a user