Fix tests against GCC12, enable Guile tests
This commit is contained in:
parent
3b059fb6f1
commit
4adf2d1284
26
swig-4.0.2-gcc-12-warning-fix-in-test-case.patch
Normal file
26
swig-4.0.2-gcc-12-warning-fix-in-test-case.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From 76d5a9ec270a763c892ae28070e391cf99e0b7cd Mon Sep 17 00:00:00 2001
|
||||
From: William S Fulton <wsf@fultondesigns.co.uk>
|
||||
Date: Tue, 18 Jan 2022 21:37:02 +0000
|
||||
Subject: [PATCH] gcc-12 warning fix in test-case
|
||||
|
||||
Closes #2145
|
||||
---
|
||||
Examples/test-suite/nested_class.i | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Examples/test-suite/nested_class.i b/Examples/test-suite/nested_class.i
|
||||
index b10c33949..c778a12cf 100644
|
||||
--- a/Examples/test-suite/nested_class.i
|
||||
+++ b/Examples/test-suite/nested_class.i
|
||||
@@ -201,7 +201,7 @@ struct Outer {
|
||||
Integer xx;
|
||||
} MultipleInstanceAnonDerived1, MultipleInstanceAnonDerived2, *MultipleInstanceAnonDerived3, MultipleInstanceAnonDerived4[2];
|
||||
|
||||
-#if defined(__GNUC__) || defined(_MSC_VER) || defined(SWIG)
|
||||
+#if (defined(__GNUC__) && __GNUC__ < 12) || defined(_MSC_VER) || defined(SWIG)
|
||||
/* some compilers do not accept these */
|
||||
struct : public InnerMultiple {
|
||||
Integer xx;
|
||||
--
|
||||
2.31.1
|
||||
|
15
swig.spec
15
swig.spec
@ -15,7 +15,7 @@
|
||||
%endif
|
||||
|
||||
%{!?tcl:%global tcl 1}
|
||||
%{!?guile:%global guile 0}
|
||||
%{!?guile:%global guile 1}
|
||||
%{!?lualang:%global lualang 1}
|
||||
%{!?perllang:%global perllang 1}
|
||||
# Disable PHP test it fails with 8.1.0
|
||||
@ -54,7 +54,7 @@
|
||||
Summary: Connects C/C++/Objective C to some high-level programming languages
|
||||
Name: swig
|
||||
Version: 4.0.2
|
||||
Release: 11%{?dist}
|
||||
Release: 12%{?dist}
|
||||
License: GPLv3+ and BSD
|
||||
URL: http://swig.sourceforge.net/
|
||||
Source0: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
|
||||
@ -77,13 +77,18 @@ Patch4: swig-4.0.2-Support-PHP8.patch
|
||||
Patch5: swig-octave-6.patch
|
||||
# Fix overload_simple_cast test with Python 3.10 GH#2044
|
||||
Patch6: swig-4.0.2-Fix-overload_simple_cast-test-with-Python-3.10.patch
|
||||
# gcc-12 warning fix in test-case
|
||||
Patch7: swig-4.0.2-gcc-12-warning-fix-in-test-case.patch
|
||||
|
||||
BuildRequires: coreutils
|
||||
BuildRequires: findutils
|
||||
BuildRequires: make
|
||||
BuildRequires: perl-interpreter, pcre-devel
|
||||
BuildRequires: python%{python3_pkgversion}-devel
|
||||
BuildRequires: autoconf, automake, gawk, dos2unix
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: help2man
|
||||
BuildRequires: sed
|
||||
BuildRequires: perl-devel
|
||||
BuildRequires: perl(base)
|
||||
BuildRequires: perl(Config)
|
||||
@ -217,6 +222,9 @@ done
|
||||
%if ! %{golang}
|
||||
--without-go \
|
||||
%endif
|
||||
%if ! %{guile}
|
||||
--without-guile \
|
||||
%endif
|
||||
%if %{octave}
|
||||
--with-octave=%{_bindir}/octave \
|
||||
--without-maximum-compile-warnings \
|
||||
@ -347,6 +355,9 @@ install -pm 644 Tools/swig.gdb %{buildroot}%{_datadir}/%{name}/gdb
|
||||
%{_datadir}/%{name}/gdb
|
||||
|
||||
%changelog
|
||||
* Fri Jan 21 2022 Jitka Plesnikova <jplesnik@redhat.com> - 4.0.2-12
|
||||
- Fix tests against GCC12, enable Guile tests
|
||||
|
||||
* Wed Nov 24 2021 Jitka Plesnikova <jplesnik@redhat.com> - 4.0.2-11
|
||||
- Disable PHP test, it fails with PHP 8.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user