Fix generated code for constant expressions containing wchar_t L literals
This commit is contained in:
parent
9f0aa1bdd1
commit
1c915ba221
26
swig-3.0.12-Correct-php-testcase.patch
Normal file
26
swig-3.0.12-Correct-php-testcase.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
From 0a9113dcba2930b658cb67f9ba1c63ad8eebd88f Mon Sep 17 00:00:00 2001
|
||||||
|
From: William S Fulton <wsf@fultondesigns.co.uk>
|
||||||
|
Date: Tue, 19 Sep 2017 07:37:29 +0100
|
||||||
|
Subject: [PATCH] Correct php testcase
|
||||||
|
|
||||||
|
---
|
||||||
|
Examples/test-suite/php/preproc_constants_runme.php | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/Examples/test-suite/php/preproc_constants_runme.php b/Examples/test-suite/php/preproc_constants_runme.php
|
||||||
|
index ef32867..bd216c2 100644
|
||||||
|
--- a/Examples/test-suite/php/preproc_constants_runme.php
|
||||||
|
+++ b/Examples/test-suite/php/preproc_constants_runme.php
|
||||||
|
@@ -61,8 +61,8 @@ check::equal(gettype(preproc_constants::EXPR_OR), "integer", "preproc_constants.
|
||||||
|
check::equal(gettype(preproc_constants::EXPR_LAND), "boolean", "preproc_constants.EXPR_LAND has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants::EXPR_LOR), "boolean", "preproc_constants.EXPR_LOR has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants::EXPR_CONDITIONAL), "double", "preproc_constants.EXPR_CONDITIONAL has unexpected type");
|
||||||
|
+check::equal(gettype(preproc_constants::EXPR_MIXED1), "double", "preproc_constants.EXPR_MIXED1 has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants::EXPR_WCHAR_MAX), "integer", "preproc_constants.EXPR_WCHAR_MAX has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants::EXPR_WCHAR_MIN), "integer", "preproc_constants.EXPR_WCHAR_MIN has unexpected type");
|
||||||
|
-check::equal(gettype(preproc_constants::EXPR_MIXED1), "integer", "preproc_constants.EXPR_MIXED1 has unexpected type");
|
||||||
|
|
||||||
|
?>
|
||||||
|
--
|
||||||
|
2.9.5
|
||||||
|
|
@ -0,0 +1,191 @@
|
|||||||
|
From 90ba174fcea1618af57aa594199541d47a89b7f6 Mon Sep 17 00:00:00 2001
|
||||||
|
From: William S Fulton <wsf@fultondesigns.co.uk>
|
||||||
|
Date: Sun, 17 Sep 2017 19:02:55 +0100
|
||||||
|
Subject: [PATCH 1/2] Fix generated code for constant expressions containing
|
||||||
|
wchar_t L literals.
|
||||||
|
|
||||||
|
Such as:
|
||||||
|
# define __WCHAR_MAX (0x7fffffff + L'\0')
|
||||||
|
|
||||||
|
Reported on swig-user mailing list.
|
||||||
|
---
|
||||||
|
CHANGES.current | 5 +++++
|
||||||
|
Examples/test-suite/csharp/preproc_constants_c_runme.cs | 3 ++-
|
||||||
|
Examples/test-suite/csharp/preproc_constants_runme.cs | 2 ++
|
||||||
|
Examples/test-suite/d/preproc_constants_c_runme.1.d | 2 ++
|
||||||
|
Examples/test-suite/d/preproc_constants_c_runme.2.d | 2 ++
|
||||||
|
Examples/test-suite/d/preproc_constants_runme.1.d | 2 ++
|
||||||
|
Examples/test-suite/d/preproc_constants_runme.2.d | 2 ++
|
||||||
|
Examples/test-suite/php/preproc_constants_c_runme.php | 2 ++
|
||||||
|
Examples/test-suite/php/preproc_constants_runme.php | 2 ++
|
||||||
|
Examples/test-suite/php5/preproc_constants_c_runme.php | 2 ++
|
||||||
|
Examples/test-suite/php5/preproc_constants_runme.php | 2 ++
|
||||||
|
Examples/test-suite/preproc_constants.i | 3 +++
|
||||||
|
Source/CParse/parser.y | 2 +-
|
||||||
|
13 files changed, 29 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
#diff --git a/CHANGES.current b/CHANGES.current
|
||||||
|
#index 1e4a244..b455a9f 100644
|
||||||
|
#--- a/CHANGES.current
|
||||||
|
#+++ b/CHANGES.current
|
||||||
|
#@@ -7,6 +7,11 @@ the issue number to the end of the URL: https://github.com/swig/swig/issues/
|
||||||
|
# Version 4.0.0 (in progress)
|
||||||
|
# ===========================
|
||||||
|
#
|
||||||
|
#+2017-09-17: wsfulton
|
||||||
|
#+ Fix generated code for constant expressions containing wchar_t L literals such as:
|
||||||
|
#+ # define __WCHAR_MAX (0x7fffffff + L'\0')
|
||||||
|
#+ # define __WCHAR_MIN (-__WCHAR_MAX - 1)
|
||||||
|
#+
|
||||||
|
# 2017-09-10: mlamarre
|
||||||
|
# [Python] Patch #1083. Define_DEBUG to 1 to do exactly like Visual Studio
|
||||||
|
# /LDd, /MDd or /MTd compiler options.
|
||||||
|
diff --git a/Examples/test-suite/csharp/preproc_constants_c_runme.cs b/Examples/test-suite/csharp/preproc_constants_c_runme.cs
|
||||||
|
index 76c684d..1c28e49 100644
|
||||||
|
--- a/Examples/test-suite/csharp/preproc_constants_c_runme.cs
|
||||||
|
+++ b/Examples/test-suite/csharp/preproc_constants_c_runme.cs
|
||||||
|
@@ -61,7 +61,8 @@ public class runme {
|
||||||
|
assert( typeof(int) == preproc_constants_c.EXPR_LAND.GetType() );
|
||||||
|
assert( typeof(int) == preproc_constants_c.EXPR_LOR.GetType() );
|
||||||
|
assert( typeof(double) == preproc_constants_c.EXPR_CONDITIONAL.GetType() );
|
||||||
|
-
|
||||||
|
+ assert( typeof(int) == preproc_constants_c.EXPR_WCHAR_MAX.GetType() );
|
||||||
|
+ assert( typeof(int) == preproc_constants_c.EXPR_WCHAR_MIN.GetType() );
|
||||||
|
}
|
||||||
|
static void assert(bool assertion) {
|
||||||
|
if (!assertion)
|
||||||
|
diff --git a/Examples/test-suite/csharp/preproc_constants_runme.cs b/Examples/test-suite/csharp/preproc_constants_runme.cs
|
||||||
|
index 9fae591..6b02e30 100644
|
||||||
|
--- a/Examples/test-suite/csharp/preproc_constants_runme.cs
|
||||||
|
+++ b/Examples/test-suite/csharp/preproc_constants_runme.cs
|
||||||
|
@@ -60,6 +60,8 @@ public class runme {
|
||||||
|
assert( typeof(bool) == preproc_constants.EXPR_LAND.GetType() );
|
||||||
|
assert( typeof(bool) == preproc_constants.EXPR_LOR.GetType() );
|
||||||
|
assert( typeof(double) == preproc_constants.EXPR_CONDITIONAL.GetType() );
|
||||||
|
+ assert( typeof(int) == preproc_constants.EXPR_WCHAR_MAX.GetType() );
|
||||||
|
+ assert( typeof(int) == preproc_constants.EXPR_WCHAR_MIN.GetType() );
|
||||||
|
|
||||||
|
}
|
||||||
|
static void assert(bool assertion) {
|
||||||
|
diff --git a/Examples/test-suite/d/preproc_constants_c_runme.1.d b/Examples/test-suite/d/preproc_constants_c_runme.1.d
|
||||||
|
index d846c71..2b349af 100644
|
||||||
|
--- a/Examples/test-suite/d/preproc_constants_c_runme.1.d
|
||||||
|
+++ b/Examples/test-suite/d/preproc_constants_c_runme.1.d
|
||||||
|
@@ -61,4 +61,6 @@ void main() {
|
||||||
|
static assert(is(int == typeof(EXPR_LAND())));
|
||||||
|
static assert(is(int == typeof(EXPR_LOR())));
|
||||||
|
static assert(is(double == typeof(EXPR_CONDITIONAL())));
|
||||||
|
+ static assert(is(int == typeof(EXPR_WCHAR_MAX())));
|
||||||
|
+ static assert(is(int == typeof(EXPR_WCHAR_MIN())));
|
||||||
|
}
|
||||||
|
diff --git a/Examples/test-suite/d/preproc_constants_c_runme.2.d b/Examples/test-suite/d/preproc_constants_c_runme.2.d
|
||||||
|
index 9bdbb93..1bac525 100644
|
||||||
|
--- a/Examples/test-suite/d/preproc_constants_c_runme.2.d
|
||||||
|
+++ b/Examples/test-suite/d/preproc_constants_c_runme.2.d
|
||||||
|
@@ -61,4 +61,6 @@ void main() {
|
||||||
|
static assert(is(int == typeof(EXPR_LAND())));
|
||||||
|
static assert(is(int == typeof(EXPR_LOR())));
|
||||||
|
static assert(is(double == typeof(EXPR_CONDITIONAL())));
|
||||||
|
+ static assert(is(int == typeof(EXPR_WCHAR_MAX())));
|
||||||
|
+ static assert(is(int == typeof(EXPR_WCHAR_MIN())));
|
||||||
|
}
|
||||||
|
diff --git a/Examples/test-suite/d/preproc_constants_runme.1.d b/Examples/test-suite/d/preproc_constants_runme.1.d
|
||||||
|
index 009405f..f743f48 100644
|
||||||
|
--- a/Examples/test-suite/d/preproc_constants_runme.1.d
|
||||||
|
+++ b/Examples/test-suite/d/preproc_constants_runme.1.d
|
||||||
|
@@ -60,4 +60,6 @@ void main() {
|
||||||
|
static assert(is(bool == typeof(EXPR_LAND())));
|
||||||
|
static assert(is(bool == typeof(EXPR_LOR())));
|
||||||
|
static assert(is(double == typeof(EXPR_CONDITIONAL())));
|
||||||
|
+ static assert(is(int == typeof(EXPR_WCHAR_MAX())));
|
||||||
|
+ static assert(is(int == typeof(EXPR_WCHAR_MIN())));
|
||||||
|
}
|
||||||
|
diff --git a/Examples/test-suite/d/preproc_constants_runme.2.d b/Examples/test-suite/d/preproc_constants_runme.2.d
|
||||||
|
index 2d92ef0..0d96c37 100644
|
||||||
|
--- a/Examples/test-suite/d/preproc_constants_runme.2.d
|
||||||
|
+++ b/Examples/test-suite/d/preproc_constants_runme.2.d
|
||||||
|
@@ -60,4 +60,6 @@ void main() {
|
||||||
|
static assert(is(bool == typeof(EXPR_LAND())));
|
||||||
|
static assert(is(bool == typeof(EXPR_LOR())));
|
||||||
|
static assert(is(double == typeof(EXPR_CONDITIONAL())));
|
||||||
|
+ static assert(is(int == typeof(EXPR_WCHAR_MAX())));
|
||||||
|
+ static assert(is(int == typeof(EXPR_WCHAR_MIN())));
|
||||||
|
}
|
||||||
|
diff --git a/Examples/test-suite/php/preproc_constants_c_runme.php b/Examples/test-suite/php/preproc_constants_c_runme.php
|
||||||
|
index af9b76e..e59fe18 100644
|
||||||
|
--- a/Examples/test-suite/php/preproc_constants_c_runme.php
|
||||||
|
+++ b/Examples/test-suite/php/preproc_constants_c_runme.php
|
||||||
|
@@ -62,5 +62,7 @@ check::equal(gettype(preproc_constants_c::EXPR_OR), "integer", "preproc_constant
|
||||||
|
check::equal(gettype(preproc_constants_c::EXPR_LAND), "integer", "preproc_constants.EXPR_LAND has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants_c::EXPR_LOR), "integer", "preproc_constants.EXPR_LOR has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants_c::EXPR_CONDITIONAL), "double", "preproc_constants.EXPR_CONDITIONAL has unexpected type");
|
||||||
|
+check::equal(gettype(preproc_constants_c::EXPR_WCHAR_MAX), "integer", "preproc_constants.EXPR_WCHAR_MAX has unexpected type");
|
||||||
|
+check::equal(gettype(preproc_constants_c::EXPR_WCHAR_MIN), "integer", "preproc_constants.EXPR_WCHAR_MIN has unexpected type");
|
||||||
|
|
||||||
|
?>
|
||||||
|
diff --git a/Examples/test-suite/php/preproc_constants_runme.php b/Examples/test-suite/php/preproc_constants_runme.php
|
||||||
|
index 5c9119b..8e117ea 100644
|
||||||
|
--- a/Examples/test-suite/php/preproc_constants_runme.php
|
||||||
|
+++ b/Examples/test-suite/php/preproc_constants_runme.php
|
||||||
|
@@ -61,5 +61,7 @@ check::equal(gettype(preproc_constants::EXPR_OR), "integer", "preproc_constants.
|
||||||
|
check::equal(gettype(preproc_constants::EXPR_LAND), "boolean", "preproc_constants.EXPR_LAND has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants::EXPR_LOR), "boolean", "preproc_constants.EXPR_LOR has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants::EXPR_CONDITIONAL), "double", "preproc_constants.EXPR_CONDITIONAL has unexpected type");
|
||||||
|
+check::equal(gettype(preproc_constants::EXPR_WCHAR_MAX), "integer", "preproc_constants.EXPR_WCHAR_MAX has unexpected type");
|
||||||
|
+check::equal(gettype(preproc_constants::EXPR_WCHAR_MIN), "integer", "preproc_constants.EXPR_WCHAR_MIN has unexpected type");
|
||||||
|
|
||||||
|
?>
|
||||||
|
diff --git a/Examples/test-suite/php5/preproc_constants_c_runme.php b/Examples/test-suite/php5/preproc_constants_c_runme.php
|
||||||
|
index 1ea0195..d978fab 100644
|
||||||
|
--- a/Examples/test-suite/php5/preproc_constants_c_runme.php
|
||||||
|
+++ b/Examples/test-suite/php5/preproc_constants_c_runme.php
|
||||||
|
@@ -62,5 +62,7 @@ check::equal(gettype(preproc_constants_c::EXPR_OR), "integer", "preproc_constant
|
||||||
|
check::equal(gettype(preproc_constants_c::EXPR_LAND), "integer", "preproc_constants.EXPR_LAND has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants_c::EXPR_LOR), "integer", "preproc_constants.EXPR_LOR has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants_c::EXPR_CONDITIONAL), "double", "preproc_constants.EXPR_CONDITIONAL has unexpected type");
|
||||||
|
+check::equal(gettype(preproc_constants_c::EXPR_WCHAR_MAX), "integer", "preproc_constants.EXPR_WCHAR_MAX has unexpected type");
|
||||||
|
+check::equal(gettype(preproc_constants_c::EXPR_WCHAR_MIN), "integer", "preproc_constants.EXPR_WCHAR_MIN has unexpected type");
|
||||||
|
|
||||||
|
?>
|
||||||
|
diff --git a/Examples/test-suite/php5/preproc_constants_runme.php b/Examples/test-suite/php5/preproc_constants_runme.php
|
||||||
|
index fb9ee4f..7527026 100644
|
||||||
|
--- a/Examples/test-suite/php5/preproc_constants_runme.php
|
||||||
|
+++ b/Examples/test-suite/php5/preproc_constants_runme.php
|
||||||
|
@@ -70,5 +70,7 @@ check::equal(gettype(preproc_constants::EXPR_LAND), "integer", "preproc_constant
|
||||||
|
check::equal(gettype(preproc_constants::EXPR_LOR), "integer", "preproc_constants.EXPR_LOR has unexpected type");
|
||||||
|
|
||||||
|
check::equal(gettype(preproc_constants::EXPR_CONDITIONAL), "double", "preproc_constants.EXPR_CONDITIONAL has unexpected type");
|
||||||
|
+check::equal(gettype(preproc_constants::EXPR_WCHAR_MAX), "integer", "preproc_constants.EXPR_WCHAR_MAX has unexpected type");
|
||||||
|
+check::equal(gettype(preproc_constants::EXPR_WCHAR_MIN), "integer", "preproc_constants.EXPR_WCHAR_MIN has unexpected type");
|
||||||
|
|
||||||
|
?>
|
||||||
|
diff --git a/Examples/test-suite/preproc_constants.i b/Examples/test-suite/preproc_constants.i
|
||||||
|
index 3a999ad..16b44c9 100644
|
||||||
|
--- a/Examples/test-suite/preproc_constants.i
|
||||||
|
+++ b/Examples/test-suite/preproc_constants.i
|
||||||
|
@@ -87,6 +87,9 @@
|
||||||
|
#define EXPR_LOR 0xFF || 1
|
||||||
|
#define EXPR_CONDITIONAL true ? 2 : 2.2
|
||||||
|
|
||||||
|
+#define EXPR_WCHAR_MAX (0x7fffffff + L'\0')
|
||||||
|
+#define EXPR_WCHAR_MIN (-EXPR_WCHAR_MAX - 1)
|
||||||
|
+
|
||||||
|
#define EXPR_CHAR_COMPOUND_ADD 'A' + 12
|
||||||
|
#define EXPR_CHAR_COMPOUND_LSHIFT 'B' << 6
|
||||||
|
#define H_SUPPRESS_SCALING_MAGIC (('s'<<24) | ('u'<<16) | ('p'<<8) | 'p')
|
||||||
|
diff --git a/Source/CParse/parser.y b/Source/CParse/parser.y
|
||||||
|
index 2e92cd0..273dadb 100644
|
||||||
|
--- a/Source/CParse/parser.y
|
||||||
|
+++ b/Source/CParse/parser.y
|
||||||
|
@@ -194,7 +194,7 @@ int SWIG_cparse_template_reduce(int treduce) {
|
||||||
|
* ----------------------------------------------------------------------------- */
|
||||||
|
|
||||||
|
static int promote_type(int t) {
|
||||||
|
- if (t <= T_UCHAR || t == T_CHAR) return T_INT;
|
||||||
|
+ if (t <= T_UCHAR || t == T_CHAR || t == T_WCHAR) return T_INT;
|
||||||
|
return t;
|
||||||
|
}
|
||||||
|
|
||||||
|
--
|
||||||
|
2.9.5
|
||||||
|
|
@ -0,0 +1,185 @@
|
|||||||
|
From 9e2a12416cf6ce7b926829aff353fe2d9019f135 Mon Sep 17 00:00:00 2001
|
||||||
|
From: William S Fulton <wsf@fultondesigns.co.uk>
|
||||||
|
Date: Mon, 18 Sep 2017 07:06:27 +0100
|
||||||
|
Subject: [PATCH 2/2] Fix type promotion wrapping some non-trivial constant
|
||||||
|
expressions
|
||||||
|
|
||||||
|
This was previously an integral type instead of a floating point type:
|
||||||
|
---
|
||||||
|
CHANGES.current | 5 +++++
|
||||||
|
Examples/test-suite/csharp/preproc_constants_c_runme.cs | 1 +
|
||||||
|
Examples/test-suite/csharp/preproc_constants_runme.cs | 1 +
|
||||||
|
Examples/test-suite/d/preproc_constants_c_runme.1.d | 1 +
|
||||||
|
Examples/test-suite/d/preproc_constants_c_runme.2.d | 1 +
|
||||||
|
Examples/test-suite/d/preproc_constants_runme.1.d | 1 +
|
||||||
|
Examples/test-suite/d/preproc_constants_runme.2.d | 1 +
|
||||||
|
Examples/test-suite/php/preproc_constants_c_runme.php | 1 +
|
||||||
|
Examples/test-suite/php/preproc_constants_runme.php | 1 +
|
||||||
|
Examples/test-suite/php5/preproc_constants_c_runme.php | 1 +
|
||||||
|
Examples/test-suite/php5/preproc_constants_runme.php | 1 +
|
||||||
|
Examples/test-suite/preproc_constants.i | 1 +
|
||||||
|
Source/CParse/parser.y | 1 +
|
||||||
|
13 files changed, 17 insertions(+)
|
||||||
|
|
||||||
|
#diff --git a/CHANGES.current b/CHANGES.current
|
||||||
|
#index b455a9f..f76e5a5 100644
|
||||||
|
#--- a/CHANGES.current
|
||||||
|
#+++ b/CHANGES.current
|
||||||
|
#@@ -7,6 +7,11 @@ the issue number to the end of the URL: https://github.com/swig/swig/issues/
|
||||||
|
# Version 4.0.0 (in progress)
|
||||||
|
# ===========================
|
||||||
|
#
|
||||||
|
#+2017-09-18: wsfulton
|
||||||
|
#+ Fix type promotion wrapping constant expressions of the form:
|
||||||
|
#+ # define EXPR_MIXED1 (0x80 + 11.1) - 1
|
||||||
|
#+ This was previously an integral type instead of a floating point type.
|
||||||
|
#+
|
||||||
|
# 2017-09-17: wsfulton
|
||||||
|
# Fix generated code for constant expressions containing wchar_t L literals such as:
|
||||||
|
# # define __WCHAR_MAX (0x7fffffff + L'\0')
|
||||||
|
diff --git a/Examples/test-suite/csharp/preproc_constants_c_runme.cs b/Examples/test-suite/csharp/preproc_constants_c_runme.cs
|
||||||
|
index 1c28e49..7f40ce4 100644
|
||||||
|
--- a/Examples/test-suite/csharp/preproc_constants_c_runme.cs
|
||||||
|
+++ b/Examples/test-suite/csharp/preproc_constants_c_runme.cs
|
||||||
|
@@ -61,6 +61,7 @@ public class runme {
|
||||||
|
assert( typeof(int) == preproc_constants_c.EXPR_LAND.GetType() );
|
||||||
|
assert( typeof(int) == preproc_constants_c.EXPR_LOR.GetType() );
|
||||||
|
assert( typeof(double) == preproc_constants_c.EXPR_CONDITIONAL.GetType() );
|
||||||
|
+ assert( typeof(double) == preproc_constants_c.EXPR_MIXED1.GetType() );
|
||||||
|
assert( typeof(int) == preproc_constants_c.EXPR_WCHAR_MAX.GetType() );
|
||||||
|
assert( typeof(int) == preproc_constants_c.EXPR_WCHAR_MIN.GetType() );
|
||||||
|
}
|
||||||
|
diff --git a/Examples/test-suite/csharp/preproc_constants_runme.cs b/Examples/test-suite/csharp/preproc_constants_runme.cs
|
||||||
|
index 6b02e30..0d8981f 100644
|
||||||
|
--- a/Examples/test-suite/csharp/preproc_constants_runme.cs
|
||||||
|
+++ b/Examples/test-suite/csharp/preproc_constants_runme.cs
|
||||||
|
@@ -60,6 +60,7 @@ public class runme {
|
||||||
|
assert( typeof(bool) == preproc_constants.EXPR_LAND.GetType() );
|
||||||
|
assert( typeof(bool) == preproc_constants.EXPR_LOR.GetType() );
|
||||||
|
assert( typeof(double) == preproc_constants.EXPR_CONDITIONAL.GetType() );
|
||||||
|
+ assert( typeof(double) == preproc_constants.EXPR_MIXED1.GetType() );
|
||||||
|
assert( typeof(int) == preproc_constants.EXPR_WCHAR_MAX.GetType() );
|
||||||
|
assert( typeof(int) == preproc_constants.EXPR_WCHAR_MIN.GetType() );
|
||||||
|
|
||||||
|
diff --git a/Examples/test-suite/d/preproc_constants_c_runme.1.d b/Examples/test-suite/d/preproc_constants_c_runme.1.d
|
||||||
|
index 2b349af..b79ee3b 100644
|
||||||
|
--- a/Examples/test-suite/d/preproc_constants_c_runme.1.d
|
||||||
|
+++ b/Examples/test-suite/d/preproc_constants_c_runme.1.d
|
||||||
|
@@ -61,6 +61,7 @@ void main() {
|
||||||
|
static assert(is(int == typeof(EXPR_LAND())));
|
||||||
|
static assert(is(int == typeof(EXPR_LOR())));
|
||||||
|
static assert(is(double == typeof(EXPR_CONDITIONAL())));
|
||||||
|
+ static assert(is(double == typeof(EXPR_MIXED1())));
|
||||||
|
static assert(is(int == typeof(EXPR_WCHAR_MAX())));
|
||||||
|
static assert(is(int == typeof(EXPR_WCHAR_MIN())));
|
||||||
|
}
|
||||||
|
diff --git a/Examples/test-suite/d/preproc_constants_c_runme.2.d b/Examples/test-suite/d/preproc_constants_c_runme.2.d
|
||||||
|
index 1bac525..260bf8d 100644
|
||||||
|
--- a/Examples/test-suite/d/preproc_constants_c_runme.2.d
|
||||||
|
+++ b/Examples/test-suite/d/preproc_constants_c_runme.2.d
|
||||||
|
@@ -61,6 +61,7 @@ void main() {
|
||||||
|
static assert(is(int == typeof(EXPR_LAND())));
|
||||||
|
static assert(is(int == typeof(EXPR_LOR())));
|
||||||
|
static assert(is(double == typeof(EXPR_CONDITIONAL())));
|
||||||
|
+ static assert(is(double == typeof(EXPR_MIXED1())));
|
||||||
|
static assert(is(int == typeof(EXPR_WCHAR_MAX())));
|
||||||
|
static assert(is(int == typeof(EXPR_WCHAR_MIN())));
|
||||||
|
}
|
||||||
|
diff --git a/Examples/test-suite/d/preproc_constants_runme.1.d b/Examples/test-suite/d/preproc_constants_runme.1.d
|
||||||
|
index f743f48..84a99c8 100644
|
||||||
|
--- a/Examples/test-suite/d/preproc_constants_runme.1.d
|
||||||
|
+++ b/Examples/test-suite/d/preproc_constants_runme.1.d
|
||||||
|
@@ -60,6 +60,7 @@ void main() {
|
||||||
|
static assert(is(bool == typeof(EXPR_LAND())));
|
||||||
|
static assert(is(bool == typeof(EXPR_LOR())));
|
||||||
|
static assert(is(double == typeof(EXPR_CONDITIONAL())));
|
||||||
|
+ static assert(is(double == typeof(EXPR_MIXED1())));
|
||||||
|
static assert(is(int == typeof(EXPR_WCHAR_MAX())));
|
||||||
|
static assert(is(int == typeof(EXPR_WCHAR_MIN())));
|
||||||
|
}
|
||||||
|
diff --git a/Examples/test-suite/d/preproc_constants_runme.2.d b/Examples/test-suite/d/preproc_constants_runme.2.d
|
||||||
|
index 0d96c37..f6638f4 100644
|
||||||
|
--- a/Examples/test-suite/d/preproc_constants_runme.2.d
|
||||||
|
+++ b/Examples/test-suite/d/preproc_constants_runme.2.d
|
||||||
|
@@ -60,6 +60,7 @@ void main() {
|
||||||
|
static assert(is(bool == typeof(EXPR_LAND())));
|
||||||
|
static assert(is(bool == typeof(EXPR_LOR())));
|
||||||
|
static assert(is(double == typeof(EXPR_CONDITIONAL())));
|
||||||
|
+ static assert(is(double == typeof(EXPR_MIXED1())));
|
||||||
|
static assert(is(int == typeof(EXPR_WCHAR_MAX())));
|
||||||
|
static assert(is(int == typeof(EXPR_WCHAR_MIN())));
|
||||||
|
}
|
||||||
|
diff --git a/Examples/test-suite/php/preproc_constants_c_runme.php b/Examples/test-suite/php/preproc_constants_c_runme.php
|
||||||
|
index e59fe18..20868dc 100644
|
||||||
|
--- a/Examples/test-suite/php/preproc_constants_c_runme.php
|
||||||
|
+++ b/Examples/test-suite/php/preproc_constants_c_runme.php
|
||||||
|
@@ -62,6 +62,7 @@ check::equal(gettype(preproc_constants_c::EXPR_OR), "integer", "preproc_constant
|
||||||
|
check::equal(gettype(preproc_constants_c::EXPR_LAND), "integer", "preproc_constants.EXPR_LAND has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants_c::EXPR_LOR), "integer", "preproc_constants.EXPR_LOR has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants_c::EXPR_CONDITIONAL), "double", "preproc_constants.EXPR_CONDITIONAL has unexpected type");
|
||||||
|
+check::equal(gettype(preproc_constants_c::EXPR_MIXED1), "double", "preproc_constants.EXPR_MIXED1 has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants_c::EXPR_WCHAR_MAX), "integer", "preproc_constants.EXPR_WCHAR_MAX has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants_c::EXPR_WCHAR_MIN), "integer", "preproc_constants.EXPR_WCHAR_MIN has unexpected type");
|
||||||
|
|
||||||
|
diff --git a/Examples/test-suite/php/preproc_constants_runme.php b/Examples/test-suite/php/preproc_constants_runme.php
|
||||||
|
index 8e117ea..ef32867 100644
|
||||||
|
--- a/Examples/test-suite/php/preproc_constants_runme.php
|
||||||
|
+++ b/Examples/test-suite/php/preproc_constants_runme.php
|
||||||
|
@@ -63,5 +63,6 @@ check::equal(gettype(preproc_constants::EXPR_LOR), "boolean", "preproc_constants
|
||||||
|
check::equal(gettype(preproc_constants::EXPR_CONDITIONAL), "double", "preproc_constants.EXPR_CONDITIONAL has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants::EXPR_WCHAR_MAX), "integer", "preproc_constants.EXPR_WCHAR_MAX has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants::EXPR_WCHAR_MIN), "integer", "preproc_constants.EXPR_WCHAR_MIN has unexpected type");
|
||||||
|
+check::equal(gettype(preproc_constants::EXPR_MIXED1), "integer", "preproc_constants.EXPR_MIXED1 has unexpected type");
|
||||||
|
|
||||||
|
?>
|
||||||
|
diff --git a/Examples/test-suite/php5/preproc_constants_c_runme.php b/Examples/test-suite/php5/preproc_constants_c_runme.php
|
||||||
|
index d978fab..d55d423 100644
|
||||||
|
--- a/Examples/test-suite/php5/preproc_constants_c_runme.php
|
||||||
|
+++ b/Examples/test-suite/php5/preproc_constants_c_runme.php
|
||||||
|
@@ -62,6 +62,7 @@ check::equal(gettype(preproc_constants_c::EXPR_OR), "integer", "preproc_constant
|
||||||
|
check::equal(gettype(preproc_constants_c::EXPR_LAND), "integer", "preproc_constants.EXPR_LAND has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants_c::EXPR_LOR), "integer", "preproc_constants.EXPR_LOR has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants_c::EXPR_CONDITIONAL), "double", "preproc_constants.EXPR_CONDITIONAL has unexpected type");
|
||||||
|
+check::equal(gettype(preproc_constants_c::EXPR_MIXED1), "double", "preproc_constants.EXPR_MIXED1 has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants_c::EXPR_WCHAR_MAX), "integer", "preproc_constants.EXPR_WCHAR_MAX has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants_c::EXPR_WCHAR_MIN), "integer", "preproc_constants.EXPR_WCHAR_MIN has unexpected type");
|
||||||
|
|
||||||
|
diff --git a/Examples/test-suite/php5/preproc_constants_runme.php b/Examples/test-suite/php5/preproc_constants_runme.php
|
||||||
|
index 7527026..01137b0 100644
|
||||||
|
--- a/Examples/test-suite/php5/preproc_constants_runme.php
|
||||||
|
+++ b/Examples/test-suite/php5/preproc_constants_runme.php
|
||||||
|
@@ -70,6 +70,7 @@ check::equal(gettype(preproc_constants::EXPR_LAND), "integer", "preproc_constant
|
||||||
|
check::equal(gettype(preproc_constants::EXPR_LOR), "integer", "preproc_constants.EXPR_LOR has unexpected type");
|
||||||
|
|
||||||
|
check::equal(gettype(preproc_constants::EXPR_CONDITIONAL), "double", "preproc_constants.EXPR_CONDITIONAL has unexpected type");
|
||||||
|
+check::equal(gettype(preproc_constants::EXPR_MIXED1), "double", "preproc_constants.EXPR_MIXED1 has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants::EXPR_WCHAR_MAX), "integer", "preproc_constants.EXPR_WCHAR_MAX has unexpected type");
|
||||||
|
check::equal(gettype(preproc_constants::EXPR_WCHAR_MIN), "integer", "preproc_constants.EXPR_WCHAR_MIN has unexpected type");
|
||||||
|
|
||||||
|
diff --git a/Examples/test-suite/preproc_constants.i b/Examples/test-suite/preproc_constants.i
|
||||||
|
index 16b44c9..628cae1 100644
|
||||||
|
--- a/Examples/test-suite/preproc_constants.i
|
||||||
|
+++ b/Examples/test-suite/preproc_constants.i
|
||||||
|
@@ -86,6 +86,7 @@
|
||||||
|
#define EXPR_LAND 0xFF && 1
|
||||||
|
#define EXPR_LOR 0xFF || 1
|
||||||
|
#define EXPR_CONDITIONAL true ? 2 : 2.2
|
||||||
|
+#define EXPR_MIXED1 (0x80 + 11.1) - 1
|
||||||
|
|
||||||
|
#define EXPR_WCHAR_MAX (0x7fffffff + L'\0')
|
||||||
|
#define EXPR_WCHAR_MIN (-EXPR_WCHAR_MAX - 1)
|
||||||
|
diff --git a/Source/CParse/parser.y b/Source/CParse/parser.y
|
||||||
|
index 273dadb..3df9896 100644
|
||||||
|
--- a/Source/CParse/parser.y
|
||||||
|
+++ b/Source/CParse/parser.y
|
||||||
|
@@ -6338,6 +6338,7 @@ valexpr : exprnum { $$ = $1; }
|
||||||
|
break;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
+ $$.type = promote($2.type, $4.type);
|
||||||
|
}
|
||||||
|
| LPAREN expr pointer RPAREN expr %prec CAST {
|
||||||
|
$$ = $5;
|
||||||
|
--
|
||||||
|
2.9.5
|
||||||
|
|
16
swig.spec
16
swig.spec
@ -31,7 +31,7 @@
|
|||||||
Summary: Connects C/C++/Objective C to some high-level programming languages
|
Summary: Connects C/C++/Objective C to some high-level programming languages
|
||||||
Name: swig
|
Name: swig
|
||||||
Version: 3.0.12
|
Version: 3.0.12
|
||||||
Release: 11%{?dist}
|
Release: 12%{?dist}
|
||||||
License: GPLv3+ and BSD
|
License: GPLv3+ and BSD
|
||||||
URL: http://swig.sourceforge.net/
|
URL: http://swig.sourceforge.net/
|
||||||
Source0: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
|
Source0: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
|
||||||
@ -45,6 +45,11 @@ Patch0: swig308-Do-not-use-isystem.patch
|
|||||||
Patch1: swig-3.0.12-Fix-testsuite-to-work-without-.-in-INC.patch
|
Patch1: swig-3.0.12-Fix-testsuite-to-work-without-.-in-INC.patch
|
||||||
# Upstream pull request to support Node v7/v8
|
# Upstream pull request to support Node v7/v8
|
||||||
Patch2: https://patch-diff.githubusercontent.com/raw/swig/swig/pull/968/swig-node-v7.patch
|
Patch2: https://patch-diff.githubusercontent.com/raw/swig/swig/pull/968/swig-node-v7.patch
|
||||||
|
# Fix generated code for constant expressions containing wchar_t L
|
||||||
|
# literals.
|
||||||
|
Patch3: swig-3.0.12-Fix-generated-code-for-constant-expressions-containi.patch
|
||||||
|
Patch4: swig-3.0.12-Fix-type-promotion-wrapping-some-non-trivial-constan.patch
|
||||||
|
Patch5: swig-3.0.12-Correct-php-testcase.patch
|
||||||
|
|
||||||
BuildRequires: perl-interpreter, pcre-devel
|
BuildRequires: perl-interpreter, pcre-devel
|
||||||
BuildRequires: python2-devel, python3-devel
|
BuildRequires: python2-devel, python3-devel
|
||||||
@ -63,6 +68,8 @@ BuildRequires: perl(Test::More)
|
|||||||
BuildRequires: perl(vars)
|
BuildRequires: perl(vars)
|
||||||
BuildRequires: perl(warnings)
|
BuildRequires: perl(warnings)
|
||||||
BuildRequires: boost-devel
|
BuildRequires: boost-devel
|
||||||
|
# Need when Source/CParse/parser.y is patched
|
||||||
|
BuildRequires: bison
|
||||||
%if %{tcl}
|
%if %{tcl}
|
||||||
BuildRequires: tcl-devel
|
BuildRequires: tcl-devel
|
||||||
%endif
|
%endif
|
||||||
@ -138,6 +145,9 @@ in gdb.
|
|||||||
%patch0 -p1 -b .isystem
|
%patch0 -p1 -b .isystem
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1 -b .bak
|
%patch2 -p1 -b .bak
|
||||||
|
%patch3 -p1
|
||||||
|
%patch4 -p1
|
||||||
|
%patch5 -p1
|
||||||
|
|
||||||
for all in CHANGES README; do
|
for all in CHANGES README; do
|
||||||
iconv -f ISO88591 -t UTF8 < $all > $all.new
|
iconv -f ISO88591 -t UTF8 < $all > $all.new
|
||||||
@ -284,6 +294,10 @@ install -pm 644 Tools/swig.gdb %{buildroot}%{_datadir}/%{name}/gdb
|
|||||||
%{_datadir}/%{name}/gdb
|
%{_datadir}/%{name}/gdb
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 20 2017 Jitka Plesnikova <jplesnik@redhat.com> - 3.0.12-12
|
||||||
|
- Fix generated code for constant expressions containing wchar_t L
|
||||||
|
literals
|
||||||
|
|
||||||
* Thu Sep 07 2017 Jared Smith <jsmith@fedoraproject.org> - 3.0.12-11
|
* Thu Sep 07 2017 Jared Smith <jsmith@fedoraproject.org> - 3.0.12-11
|
||||||
- Add patch to support NodeJS versions 7 and 8, fixes FTBFS
|
- Add patch to support NodeJS versions 7 and 8, fixes FTBFS
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user