Update to 4.0.1
This commit is contained in:
parent
84ea8a4c67
commit
0390543ac4
1
.gitignore
vendored
1
.gitignore
vendored
@ -23,3 +23,4 @@ swig-2.0.0.tar.gz
|
|||||||
/swig-3.0.11.tar.gz
|
/swig-3.0.11.tar.gz
|
||||||
/swig-3.0.12.tar.gz
|
/swig-3.0.12.tar.gz
|
||||||
/swig-4.0.0.tar.gz
|
/swig-4.0.0.tar.gz
|
||||||
|
/swig-4.0.1.tar.gz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (swig-4.0.0.tar.gz) = c897b87fb8b21caf8d1bee2c39cb9675a3b0ee047110e808c310a2787f8b89585738726e9f517c64e9d2f1b8311136365c569528f399b444b1081f69689b7165
|
SHA512 (swig-4.0.1.tar.gz) = 595ef01cb83adfa960ceed9c325a9429192549e8d1e9aa3ab35a4301512a61d82e2e89a8c7939c2a5a0811254ea1832a443bd387e11459eb2b0bafc563ad1308
|
||||||
|
@ -1,16 +0,0 @@
|
|||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 1873797..754238f 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -1114,7 +1114,10 @@ if test -n "$OCTAVE"; then
|
|
||||||
|
|
||||||
AC_MSG_CHECKING([for Octave linker flags])
|
|
||||||
OCTAVE_LDFLAGS=
|
|
||||||
- for var in RDYNAMIC_FLAG LFLAGS RLD_FLAG OCTAVE_LIBS LIBS; do
|
|
||||||
+ for var in OCTLIBDIR; do
|
|
||||||
+ OCTAVE_LDFLAGS="${OCTAVE_LDFLAGS} "-L`env - ${mkoctfile} -p ${var}`
|
|
||||||
+ done
|
|
||||||
+ for var in RDYNAMIC_FLAG RLD_FLAG OCTAVE_LIBS LIBS; do
|
|
||||||
OCTAVE_LDFLAGS="${OCTAVE_LDFLAGS} "`env - ${mkoctfile} -p ${var}`
|
|
||||||
done
|
|
||||||
AC_MSG_RESULT([$OCTAVE_LDFLAGS])
|
|
@ -1,28 +0,0 @@
|
|||||||
commit c38b7de6a120e6392abff50afd9bb919cc858cfc
|
|
||||||
Author: Orion Poplawski <orion@nwra.com>
|
|
||||||
Date: Sun Mar 10 11:47:27 2019 -0600
|
|
||||||
|
|
||||||
Fix format-security error with octave 5.1
|
|
||||||
|
|
||||||
diff --git a/Lib/octave/octrun.swg b/Lib/octave/octrun.swg
|
|
||||||
index 3012331..ff614e6 100644
|
|
||||||
--- a/Lib/octave/octrun.swg
|
|
||||||
+++ b/Lib/octave/octrun.swg
|
|
||||||
@@ -51,7 +51,7 @@ SWIGRUNTIME octave_value SWIG_Error(int code, const char *msg) {
|
|
||||||
octave_value type(SWIG_ErrorType(code));
|
|
||||||
std::string r = msg;
|
|
||||||
r += " (" + type.string_value() + ")";
|
|
||||||
- error(r.c_str());
|
|
||||||
+ error("%s", r.c_str());
|
|
||||||
return octave_value(r);
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -840,7 +840,7 @@ SWIGRUNTIME void swig_acquire_ownership_obj(void *vptr, int own);
|
|
||||||
const std::string opname = std::string("__") + octave_base_value::get_umap_name(umap) + std::string("__");
|
|
||||||
octave_value ret;
|
|
||||||
if (!dispatch_unary_op(opname, ret)) {
|
|
||||||
- error((opname + std::string(" method not found")).c_str());
|
|
||||||
+ error("%s", (opname + std::string(" method not found")).c_str());
|
|
||||||
return octave_value();
|
|
||||||
}
|
|
||||||
return ret;
|
|
21
swig.spec
21
swig.spec
@ -52,8 +52,8 @@
|
|||||||
|
|
||||||
Summary: Connects C/C++/Objective C to some high-level programming languages
|
Summary: Connects C/C++/Objective C to some high-level programming languages
|
||||||
Name: swig
|
Name: swig
|
||||||
Version: 4.0.0
|
Version: 4.0.1
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3+ and BSD
|
License: GPLv3+ and BSD
|
||||||
URL: http://swig.sourceforge.net/
|
URL: http://swig.sourceforge.net/
|
||||||
Source0: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
|
Source0: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
|
||||||
@ -66,12 +66,6 @@ Source4: ccache-swig.csh
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Patch0: swig308-Do-not-use-isystem.patch
|
Patch0: swig308-Do-not-use-isystem.patch
|
||||||
# https://github.com/swig/swig/pull/1522
|
|
||||||
Patch1: swig-octave-ldflags.patch
|
|
||||||
# Fix Go tests for Go 1.13-beta1 (BZ#1736731)
|
|
||||||
Patch2: swig400-Fix-all-Go-tests-to-build-with-go-build.patch
|
|
||||||
Patch3: swig400-Restore-setting-of-GOVERSIONOPTION.patch
|
|
||||||
Patch4: swig400-Fix-Go-version-check-and-Go-in-tree-example-tests.patch
|
|
||||||
|
|
||||||
BuildRequires: perl-interpreter, pcre-devel
|
BuildRequires: perl-interpreter, pcre-devel
|
||||||
%if %{python2lang}
|
%if %{python2lang}
|
||||||
@ -173,10 +167,6 @@ in gdb.
|
|||||||
%setup -q -n swig-%{version}
|
%setup -q -n swig-%{version}
|
||||||
|
|
||||||
%patch0 -p1 -b .isystem
|
%patch0 -p1 -b .isystem
|
||||||
%patch1 -p1 -b .octave-ldflags
|
|
||||||
%patch2 -p1
|
|
||||||
%patch3 -p1
|
|
||||||
%patch4 -p1
|
|
||||||
|
|
||||||
for all in CHANGES README; do
|
for all in CHANGES README; do
|
||||||
iconv -f ISO88591 -t UTF8 < $all > $all.new
|
iconv -f ISO88591 -t UTF8 < $all > $all.new
|
||||||
@ -349,6 +339,13 @@ install -pm 644 Tools/swig.gdb %{buildroot}%{_datadir}/%{name}/gdb
|
|||||||
%{_datadir}/%{name}/gdb
|
%{_datadir}/%{name}/gdb
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Aug 21 2019 Jitka Plesnikova <jplesnik@redhat.com> - 4.0.1-1
|
||||||
|
- Update to 4.0.0
|
||||||
|
- Add Python 3.8 support
|
||||||
|
- Python Sphinx compatibility added for Doxygen comments
|
||||||
|
- Fix some C++17 compatibility problems in Python and Ruby generated
|
||||||
|
code
|
||||||
|
|
||||||
* Mon Aug 12 2019 Jitka Plesnikova <jplesnik@redhat.com> - 4.0.0-5
|
* Mon Aug 12 2019 Jitka Plesnikova <jplesnik@redhat.com> - 4.0.0-5
|
||||||
- Backport upstream fix for Go tests (BZ#1736731)
|
- Backport upstream fix for Go tests (BZ#1736731)
|
||||||
|
|
||||||
|
@ -1,54 +0,0 @@
|
|||||||
From 62136ff782e9bf6641970f716d7d40afcf6c49ea Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ian Lance Taylor <iant@golang.org>
|
|
||||||
Date: Fri, 9 Aug 2019 14:06:45 -0700
|
|
||||||
Subject: [PATCH] Fix Go version check and Go in-tree example tests
|
|
||||||
|
|
||||||
Fixes #1607
|
|
||||||
---
|
|
||||||
Examples/Makefile.in | 4 ++--
|
|
||||||
configure.ac | 5 +++--
|
|
||||||
2 files changed, 5 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/Examples/Makefile.in b/Examples/Makefile.in
|
|
||||||
index 9e05d2763..6fbca29db 100644
|
|
||||||
--- a/Examples/Makefile.in
|
|
||||||
+++ b/Examples/Makefile.in
|
|
||||||
@@ -1484,7 +1484,7 @@ go: $(SRCDIR_SRCS) $(GOPATHPARENTDIR)/go.mod
|
|
||||||
rm -f gopath/$(GOMOD)/src/runme/*; \
|
|
||||||
fi
|
|
||||||
if test -f $(SRCDIR)$(RUNME).go; then \
|
|
||||||
- cp $(SRCDIR)/$(RUNME).go gopath/$(GOMOD)/src/runme/; \
|
|
||||||
+ cp $(SRCDIR)$(RUNME).go gopath/$(GOMOD)/src/runme/; \
|
|
||||||
fi
|
|
||||||
GOPATH=`pwd`/gopath/$(GOMOD); \
|
|
||||||
export GOPATH; \
|
|
||||||
@@ -1533,7 +1533,7 @@ go_cpp: $(SRCDIR_SRCS) $(GOPATHPARENTDIR)/go.mod
|
|
||||||
rm -f gopath/$(GOMOD)/src/runme/*; \
|
|
||||||
fi
|
|
||||||
if test -f $(SRCDIR)$(RUNME).go; then \
|
|
||||||
- cp $(SRCDIR)/$(RUNME).go gopath/$(GOMOD)/src/runme/; \
|
|
||||||
+ cp $(SRCDIR)$(RUNME).go gopath/$(GOMOD)/src/runme/; \
|
|
||||||
fi
|
|
||||||
GOPATH=`pwd`/gopath/$(GOMOD); \
|
|
||||||
export GOPATH; \
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 73c38a72c..63509cd66 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -2391,10 +2391,11 @@ else
|
|
||||||
|
|
||||||
if test -n "$GO" ; then
|
|
||||||
GOVERSIONOPTION=version
|
|
||||||
+ go_version=$($GO $GOVERSIONOPTION | sed -e 's/go version //')
|
|
||||||
AC_MSG_CHECKING([whether go version is too old])
|
|
||||||
case $go_version in
|
|
||||||
- go1.[012345]*)
|
|
||||||
- AC_MSG_RESULT([yes - minimum version is 1.6])
|
|
||||||
+ go1.[012]*)
|
|
||||||
+ AC_MSG_RESULT([yes - minimum version is 1.3])
|
|
||||||
GO=
|
|
||||||
GOOPT="-intgosize 32"
|
|
||||||
;;
|
|
||||||
--
|
|
||||||
2.20.1
|
|
||||||
|
|
File diff suppressed because it is too large
Load Diff
@ -1,25 +0,0 @@
|
|||||||
From 6b108c19e1504c937e1a7d50147575dd8e624b73 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ian Lance Taylor <iant@golang.org>
|
|
||||||
Date: Thu, 8 Aug 2019 22:59:57 -0700
|
|
||||||
Subject: [PATCH 2/2] Restore setting of GOVERSIONOPTION
|
|
||||||
|
|
||||||
Accidentally removed in last commit.
|
|
||||||
---
|
|
||||||
configure.ac | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index a38e97d2a..73c38a72c 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -2390,6 +2390,7 @@ else
|
|
||||||
GOVERSIONOPTION=
|
|
||||||
|
|
||||||
if test -n "$GO" ; then
|
|
||||||
+ GOVERSIONOPTION=version
|
|
||||||
AC_MSG_CHECKING([whether go version is too old])
|
|
||||||
case $go_version in
|
|
||||||
go1.[012345]*)
|
|
||||||
--
|
|
||||||
2.20.1
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user