Update to 44.2
This commit is contained in:
parent
e4bd27eaae
commit
b36fec98c5
1
.gitignore
vendored
1
.gitignore
vendored
@ -52,3 +52,4 @@
|
||||
/sushi-41.2.tar.xz
|
||||
/sushi-42.0.tar.xz
|
||||
/sushi-43.0.tar.xz
|
||||
/sushi-44.2.tar.xz
|
||||
|
@ -1,35 +0,0 @@
|
||||
From 3f50da04fe4f224f28c3146b3ecb512fef58449f Mon Sep 17 00:00:00 2001
|
||||
From: "FeRD (Frank Dana)" <ferdnyc@gmail.com>
|
||||
Date: Thu, 8 Dec 2022 11:52:57 -0500
|
||||
Subject: [PATCH] Evince: Don't use GFile for file:/// paths.
|
||||
|
||||
Signed-off-by: FeRD (Frank Dana) <ferdnyc@gmail.com>
|
||||
|
||||
Evince: Use file.has_uri_scheme()
|
||||
---
|
||||
src/viewers/evince.js | 9 ++++++++-
|
||||
1 file changed, 8 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/viewers/evince.js b/src/viewers/evince.js
|
||||
index 4257870..79ad339 100644
|
||||
--- a/src/viewers/evince.js
|
||||
+++ b/src/viewers/evince.js
|
||||
@@ -79,7 +79,14 @@ var Klass = GObject.registerClass({
|
||||
}
|
||||
|
||||
_loadFile(file) {
|
||||
- let job = EvinceView.JobLoadGFile.new(file, EvinceDocument.DocumentLoadFlags.NONE);
|
||||
+ let job;
|
||||
+ if (file.has_uri_scheme("file")) {
|
||||
+ job = EvinceView.JobLoad.new(file.get_uri());
|
||||
+ } else {
|
||||
+ job = EvinceView.JobLoadGFile.new(
|
||||
+ file, EvinceDocument.DocumentLoadFlags.NONE);
|
||||
+ }
|
||||
+
|
||||
job.connect('finished', this._onLoadJobFinished.bind(this));
|
||||
job.scheduler_push_job(EvinceView.JobPriority.PRIORITY_NONE);
|
||||
}
|
||||
--
|
||||
2.38.1
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (sushi-43.0.tar.xz) = 0a909f685e49bbddb7fc2cf17338eba08723a796e1e42f09ed404487620437b36c2bdaede3efbb6bd49cd7efde0141e971ac9869f73c0c30bea9b6658978b19e
|
||||
SHA512 (sushi-44.2.tar.xz) = 0e2cd6e619872e7ebd29b01bf6038b3db7f8202f20a77034451e69b722e46ee9f8e20378253f49ccb12b6060490c25555581f10823c778c42ab9edf41016a1da
|
||||
|
10
sushi.spec
10
sushi.spec
@ -3,17 +3,14 @@
|
||||
%global __provides_exclude_from ^%{_libdir}/%{name}/.*\\.so.*$
|
||||
|
||||
Name: sushi
|
||||
Version: 43.0
|
||||
Release: 3%{?dist}
|
||||
Version: 44.2
|
||||
Release: 1%{?dist}
|
||||
Summary: A quick previewer for Nautilus
|
||||
|
||||
License: GPLv2+ with exceptions
|
||||
URL: https://gitlab.gnome.org/GNOME/sushi
|
||||
Source0: https://download.gnome.org/sources/%{name}/%{url_ver}/%{name}-%{version}.tar.xz
|
||||
|
||||
# Submitted upstream: https://gitlab.gnome.org/GNOME/sushi/-/merge_requests/39
|
||||
Patch0: 0001-Evince-Don-t-use-GFile-for-file-paths.patch
|
||||
|
||||
BuildRequires: gettext
|
||||
BuildRequires: gjs-devel
|
||||
BuildRequires: meson
|
||||
@ -59,6 +56,9 @@ file manager.
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed May 31 2023 Kalev Lember <klember@redhat.com> - 44.2-1
|
||||
- Update to 44.2
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 43.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user