8e5b1df1b9
- added --with-audit configure option - removed call to libtoolize
33 lines
1.1 KiB
Diff
33 lines
1.1 KiB
Diff
diff -up sudo-1.7.2p2/configure.in.libaudit sudo-1.7.2p2/configure.in
|
|
--- sudo-1.7.2p2/configure.in.libaudit 2010-02-10 16:21:26.000000000 +0100
|
|
+++ sudo-1.7.2p2/configure.in 2010-02-10 16:21:26.000000000 +0100
|
|
@@ -1752,7 +1752,6 @@ dnl
|
|
: ${mansectsu='8'}
|
|
: ${mansectform='5'}
|
|
|
|
-AC_SUBST(LIBAUDIT)
|
|
if test "$with_audit" = "yes"; then
|
|
# See if we have the audit library
|
|
AC_CHECK_HEADER(libaudit.h, [audit_header="yes"], [audit_header="no"])
|
|
@@ -1770,6 +1769,8 @@ if test "$with_audit" = "yes"; then
|
|
fi
|
|
fi
|
|
|
|
+AC_SUBST(LIBAUDIT)
|
|
+
|
|
dnl
|
|
dnl Add in any libpaths or libraries specified via configure
|
|
dnl
|
|
diff -up sudo-1.7.2p2/Makefile.in.libaudit sudo-1.7.2p2/Makefile.in
|
|
--- sudo-1.7.2p2/Makefile.in.libaudit 2010-02-10 16:26:06.000000000 +0100
|
|
+++ sudo-1.7.2p2/Makefile.in 2010-02-10 16:26:40.000000000 +0100
|
|
@@ -44,7 +44,7 @@ INSTALL = $(SHELL) $(srcdir)/install-sh
|
|
# Libraries
|
|
LIBS = @LIBS@
|
|
NET_LIBS = @NET_LIBS@
|
|
-SUDO_LIBS = @SUDO_LIBS@ @AFS_LIBS@ @GETGROUPS_LIB@ $(LIBS) $(NET_LIBS)
|
|
+SUDO_LIBS = @SUDO_LIBS@ @AFS_LIBS@ @GETGROUPS_LIB@ @LIBAUDIT@ $(LIBS) $(NET_LIBS)
|
|
|
|
# C preprocessor flags
|
|
CPPFLAGS = -I. -I$(srcdir) @CPPFLAGS@
|