update to new upstream version

This commit is contained in:
Daniel Kopeček 2010-03-01 11:54:07 +00:00
parent 0d6a144061
commit cd64307f4c
2 changed files with 48 additions and 11 deletions

View File

@ -0,0 +1,40 @@
diff -up sudo-1.7.2p4/check.c.getgrouplist sudo-1.7.2p4/check.c
--- sudo-1.7.2p4/check.c.getgrouplist 2009-05-25 14:02:41.000000000 +0200
+++ sudo-1.7.2p4/check.c 2010-03-01 11:27:38.000000000 +0100
@@ -353,6 +353,24 @@ user_is_exempt()
return(TRUE);
}
+#ifdef HAVE_GETGROUPLIST
+ {
+ gid_t *grouplist, grouptmp;
+ int n_groups, i;
+ n_groups = 1;
+ if (getgrouplist(user_name, user_gid, &grouptmp, &n_groups) == -1) {
+ grouplist = (gid_t *) emalloc(sizeof(gid_t) * (n_groups + 1));
+ if (getgrouplist(user_name, user_gid, grouplist, &n_groups) > 0)
+ for (i = 0; i < n_groups; i++)
+ if (grouplist[i] == grp->gr_gid) {
+ free(grouplist);
+ return(TRUE);
+ }
+ free(grouplist);
+ }
+ }
+#endif
+
return(FALSE);
}
diff -up sudo-1.7.2p4/configure.in.getgrouplist sudo-1.7.2p4/configure.in
--- sudo-1.7.2p4/configure.in.getgrouplist 2010-03-01 11:27:38.000000000 +0100
+++ sudo-1.7.2p4/configure.in 2010-03-01 11:29:45.000000000 +0100
@@ -1852,7 +1852,7 @@ dnl
AC_FUNC_GETGROUPS
AC_CHECK_FUNCS(strchr strrchr memchr memcpy memset sysconf tzset \
strftime setrlimit initgroups getgroups fstat gettimeofday \
- setlocale getaddrinfo setsid setenv setrlimit64)
+ setlocale getaddrinfo setsid setenv setrlimit64 getgrouplist)
AC_CHECK_FUNCS(unsetenv, SUDO_FUNC_UNSETENV_VOID)
SUDO_FUNC_PUTENV_CONST
if test -z "$SKIP_SETRESUID"; then

View File

@ -1,7 +1,7 @@
Summary: Allows restricted root access for specified users Summary: Allows restricted root access for specified users
Name: sudo Name: sudo
Version: 1.7.2p2 Version: 1.7.2p5
Release: 5%{?dist} Release: 1%{?dist}
License: BSD License: BSD
Group: Applications/System Group: Applications/System
URL: http://www.courtesan.com/sudo/ URL: http://www.courtesan.com/sudo/
@ -28,15 +28,11 @@ Patch2: sudo-1.7.2p1-login.patch
Patch3: sudo-1.7.2p1-envdebug.patch Patch3: sudo-1.7.2p1-envdebug.patch
Patch4: sudo-1.7.1-libtool.patch Patch4: sudo-1.7.1-libtool.patch
# getgrouplist() to determine group membership (#235915) # getgrouplist() to determine group membership (#235915)
Patch5: sudo-1.7.1-getgrouplist.patch Patch5: sudo-1.7.2p4-getgrouplist.patch
# audit support improvement # audit support improvement
Patch6: sudo-1.7.2p1-audit.patch Patch6: sudo-1.7.2p1-audit.patch
# segfault when #include directive is used in cycles (#561336)
Patch7: sudo-1.7.2p2-loopsegv3.patch
# audit related Makefile.in and configure.in corrections # audit related Makefile.in and configure.in corrections
Patch8: sudo-1.7.2p2-libaudit.patch Patch7: sudo-1.7.2p2-libaudit.patch
# no valid sudoers sources found (#558875)
Patch9: sudo-1.7.2p2-emptyincldir.patch
%description %description
Sudo (superuser do) allows a system administrator to give certain Sudo (superuser do) allows a system administrator to give certain
@ -57,9 +53,7 @@ on many different machines.
%patch4 -p1 -b .libtool %patch4 -p1 -b .libtool
%patch5 -p1 -b .getgrouplist %patch5 -p1 -b .getgrouplist
%patch6 -p1 -b .audit %patch6 -p1 -b .audit
%patch7 -p1 -b .loopsegv3 %patch7 -p1 -b .libaudit
%patch8 -p1 -b .libaudit
%patch9 -p1 -b .emptyincldir
%build %build
# handle newer autoconf # handle newer autoconf
@ -150,6 +144,9 @@ rm -rf $RPM_BUILD_ROOT
/bin/chmod 0440 /etc/sudoers || : /bin/chmod 0440 /etc/sudoers || :
%changelog %changelog
* Mon Mar 1 2010 Daniel Kopecek <dkopecek@redhat.com> - 1.7.2p5-1
- update to new upstream version
* Tue Feb 16 2010 Daniel Kopecek <dkopecek@redhat.com> - 1.7.2p2-5 * Tue Feb 16 2010 Daniel Kopecek <dkopecek@redhat.com> - 1.7.2p2-5
- fixed no valid sudoers sources found (#558875) - fixed no valid sudoers sources found (#558875)