update to 1.8.6p3
- drop -pipelist patch (fixed in upstream)
This commit is contained in:
parent
41b07d49de
commit
a9963cd1b9
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@ sudo-1.7.2p2-sudoers
|
||||
/sudo-1.8.3p1.tar.gz
|
||||
/sudo-1.8.5.tar.gz
|
||||
/sudo-1.8.6.tar.gz
|
||||
/sudo-1.8.6p3.tar.gz
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
3d400e84c3a1e2164171db8d54b11aab sudo-1.8.6.tar.gz
|
||||
56f74aed3a7b32f2b01a34d65ac86f85 sudo-1.7.4p4-sudoers
|
||||
a7b5c39a904721956eccddd30689250f sudo-1.8.6p3.tar.gz
|
||||
|
@ -1,31 +0,0 @@
|
||||
diff -up sudo-1.8.6/plugins/sudoers/sudo_nss.c.pipelist sudo-1.8.6/plugins/sudoers/sudo_nss.c
|
||||
--- sudo-1.8.6/plugins/sudoers/sudo_nss.c.pipelist 2012-09-06 14:27:34.467290727 +0200
|
||||
+++ sudo-1.8.6/plugins/sudoers/sudo_nss.c 2012-09-06 14:27:39.877315395 +0200
|
||||
@@ -18,6 +18,8 @@
|
||||
|
||||
#include <sys/types.h>
|
||||
#include <sys/param.h>
|
||||
+#include <sys/stat.h>
|
||||
+
|
||||
#include <stdio.h>
|
||||
#ifdef STDC_HEADERS
|
||||
# include <stdlib.h>
|
||||
@@ -257,11 +259,15 @@ display_privs(struct sudo_nss_list *snl,
|
||||
{
|
||||
struct sudo_nss *nss;
|
||||
struct lbuf defs, privs;
|
||||
- int count, olen;
|
||||
+ struct stat sb;
|
||||
+ int cols, count, olen;
|
||||
debug_decl(display_privs, SUDO_DEBUG_NSS)
|
||||
|
||||
- lbuf_init(&defs, output, 4, NULL, sudo_user.cols);
|
||||
- lbuf_init(&privs, output, 4, NULL, sudo_user.cols);
|
||||
+ cols = sudo_user.cols;
|
||||
+ if (fstat(STDOUT_FILENO, &sb) == 0 && S_ISFIFO(sb.st_mode))
|
||||
+ cols = 0;
|
||||
+ lbuf_init(&defs, output, 4, NULL, cols);
|
||||
+ lbuf_init(&privs, output, 4, NULL, cols);
|
||||
|
||||
/* Display defaults from all sources. */
|
||||
lbuf_append(&defs, _("Matching Defaults entries for %s on this host:\n"),
|
@ -1,6 +1,6 @@
|
||||
Summary: Allows restricted root access for specified users
|
||||
Name: sudo
|
||||
Version: 1.8.6
|
||||
Version: 1.8.6p3
|
||||
Release: 1%{?dist}
|
||||
License: ISC
|
||||
Group: Applications/System
|
||||
@ -25,8 +25,6 @@ BuildRequires: gettext
|
||||
Patch1: sudo-1.6.7p5-strip.patch
|
||||
# configure.in fix
|
||||
Patch2: sudo-1.7.2p1-envdebug.patch
|
||||
# disable word wrapping if the ouput is piped
|
||||
Patch3: sudo-1.8.6-pipelist.patch
|
||||
|
||||
%description
|
||||
Sudo (superuser do) allows a system administrator to give certain
|
||||
@ -53,7 +51,6 @@ plugins that use %{name}.
|
||||
|
||||
%patch1 -p1 -b .strip
|
||||
%patch2 -p1 -b .envdebug
|
||||
%patch3 -p1 -b .pipelist
|
||||
|
||||
%build
|
||||
autoreconf -I m4 -fv --install
|
||||
@ -163,6 +160,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_mandir}/man8/sudo_plugin.8*
|
||||
|
||||
%changelog
|
||||
* Tue Sep 25 2012 Daniel Kopecek <dkopecek@redhat.com> - 1.8.6p3-1
|
||||
- update to 1.8.6p3
|
||||
- drop -pipelist patch (fixed in upstream)
|
||||
|
||||
* Thu Sep 6 2012 Daniel Kopecek <dkopecek@redhat.com> - 1.8.6-1
|
||||
- update to 1.8.6
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user