- audit related Makefile.in and configure.in corrections
- added --with-audit configure option - removed call to libtoolize
This commit is contained in:
parent
46cc5da5fe
commit
8e5b1df1b9
32
sudo-1.7.2p2-libaudit.patch
Normal file
32
sudo-1.7.2p2-libaudit.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
diff -up sudo-1.7.2p2/configure.in.libaudit sudo-1.7.2p2/configure.in
|
||||||
|
--- sudo-1.7.2p2/configure.in.libaudit 2010-02-10 16:21:26.000000000 +0100
|
||||||
|
+++ sudo-1.7.2p2/configure.in 2010-02-10 16:21:26.000000000 +0100
|
||||||
|
@@ -1752,7 +1752,6 @@ dnl
|
||||||
|
: ${mansectsu='8'}
|
||||||
|
: ${mansectform='5'}
|
||||||
|
|
||||||
|
-AC_SUBST(LIBAUDIT)
|
||||||
|
if test "$with_audit" = "yes"; then
|
||||||
|
# See if we have the audit library
|
||||||
|
AC_CHECK_HEADER(libaudit.h, [audit_header="yes"], [audit_header="no"])
|
||||||
|
@@ -1770,6 +1769,8 @@ if test "$with_audit" = "yes"; then
|
||||||
|
fi
|
||||||
|
fi
|
||||||
|
|
||||||
|
+AC_SUBST(LIBAUDIT)
|
||||||
|
+
|
||||||
|
dnl
|
||||||
|
dnl Add in any libpaths or libraries specified via configure
|
||||||
|
dnl
|
||||||
|
diff -up sudo-1.7.2p2/Makefile.in.libaudit sudo-1.7.2p2/Makefile.in
|
||||||
|
--- sudo-1.7.2p2/Makefile.in.libaudit 2010-02-10 16:26:06.000000000 +0100
|
||||||
|
+++ sudo-1.7.2p2/Makefile.in 2010-02-10 16:26:40.000000000 +0100
|
||||||
|
@@ -44,7 +44,7 @@ INSTALL = $(SHELL) $(srcdir)/install-sh
|
||||||
|
# Libraries
|
||||||
|
LIBS = @LIBS@
|
||||||
|
NET_LIBS = @NET_LIBS@
|
||||||
|
-SUDO_LIBS = @SUDO_LIBS@ @AFS_LIBS@ @GETGROUPS_LIB@ $(LIBS) $(NET_LIBS)
|
||||||
|
+SUDO_LIBS = @SUDO_LIBS@ @AFS_LIBS@ @GETGROUPS_LIB@ @LIBAUDIT@ $(LIBS) $(NET_LIBS)
|
||||||
|
|
||||||
|
# C preprocessor flags
|
||||||
|
CPPFLAGS = -I. -I$(srcdir) @CPPFLAGS@
|
17
sudo.spec
17
sudo.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Allows restricted root access for specified users
|
Summary: Allows restricted root access for specified users
|
||||||
Name: sudo
|
Name: sudo
|
||||||
Version: 1.7.2p2
|
Version: 1.7.2p2
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
URL: http://www.courtesan.com/sudo/
|
URL: http://www.courtesan.com/sudo/
|
||||||
@ -33,6 +33,8 @@ Patch5: sudo-1.7.1-getgrouplist.patch
|
|||||||
Patch6: sudo-1.7.2p1-audit.patch
|
Patch6: sudo-1.7.2p1-audit.patch
|
||||||
# segfault when #include directive is used in cycles (#561336)
|
# segfault when #include directive is used in cycles (#561336)
|
||||||
Patch7: sudo-1.7.2p2-loopsegv3.patch
|
Patch7: sudo-1.7.2p2-loopsegv3.patch
|
||||||
|
# audit related Makefile.in and configure.in corrections
|
||||||
|
Patch8: sudo-1.7.2p2-libaudit.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Sudo (superuser do) allows a system administrator to give certain
|
Sudo (superuser do) allows a system administrator to give certain
|
||||||
@ -54,10 +56,13 @@ on many different machines.
|
|||||||
%patch5 -p1 -b .getgrouplist
|
%patch5 -p1 -b .getgrouplist
|
||||||
%patch6 -p1 -b .audit
|
%patch6 -p1 -b .audit
|
||||||
%patch7 -p1 -b .loopsegv3
|
%patch7 -p1 -b .loopsegv3
|
||||||
|
%patch8 -p1 -b .libaudit
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# handle newer autoconf
|
# handle newer autoconf
|
||||||
libtoolize --force && rm acsite.m4 && mv aclocal.m4 acinclude.m4 && autoreconf
|
rm acsite.m4
|
||||||
|
mv aclocal.m4 acinclude.m4
|
||||||
|
autoreconf -fv --install
|
||||||
|
|
||||||
%ifarch s390 s390x sparc64
|
%ifarch s390 s390x sparc64
|
||||||
F_PIE=-fPIE
|
F_PIE=-fPIE
|
||||||
@ -81,7 +86,8 @@ export CFLAGS="$RPM_OPT_FLAGS $F_PIE" LDFLAGS="-pie"
|
|||||||
--with-tty-tickets \
|
--with-tty-tickets \
|
||||||
--with-ldap \
|
--with-ldap \
|
||||||
--with-selinux \
|
--with-selinux \
|
||||||
--with-passprompt="[sudo] password for %p: "
|
--with-passprompt="[sudo] password for %p: " \
|
||||||
|
--with-audit
|
||||||
# --without-kerb5 \
|
# --without-kerb5 \
|
||||||
# --without-kerb4
|
# --without-kerb4
|
||||||
make
|
make
|
||||||
@ -141,6 +147,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
/bin/chmod 0440 /etc/sudoers || :
|
/bin/chmod 0440 /etc/sudoers || :
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 10 2010 Daniel Kopecek <dkopecek@redhat.com> - 1.7.2p2-4
|
||||||
|
- audit related Makefile.in and configure.in corrections
|
||||||
|
- added --with-audit configure option
|
||||||
|
- removed call to libtoolize
|
||||||
|
|
||||||
* Wed Feb 10 2010 Daniel Kopecek <dkopecek@redhat.com> - 1.7.2p2-3
|
* Wed Feb 10 2010 Daniel Kopecek <dkopecek@redhat.com> - 1.7.2p2-3
|
||||||
- fixed segfault when #include directive is used in cycles (#561336)
|
- fixed segfault when #include directive is used in cycles (#561336)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user