Rebase to 1.9.3p1
Signed-off-by: Radovan Sroka <rsroka@redhat.com>
This commit is contained in:
parent
35c555c44a
commit
68203ed1a2
1
.gitignore
vendored
1
.gitignore
vendored
@ -24,3 +24,4 @@
|
||||
/sudo-1.9.0b4.tar.gz
|
||||
/sudo-1.9.1.tar.gz
|
||||
/sudo-1.9.2.tar.gz
|
||||
/sudo-1.9.3p1.tar.gz
|
||||
|
@ -1,43 +0,0 @@
|
||||
From 0d7a041f18c5016abb78b74f3cfa505797e704ee Mon Sep 17 00:00:00 2001
|
||||
From: Evan Anderson <evan@eaanderson.com>
|
||||
Date: Sun, 6 Sep 2020 14:30:54 -0500
|
||||
Subject: [PATCH] configure: Fix runstatedir handling for distros that do not
|
||||
support it
|
||||
|
||||
runstatedir was added in yet-to-be released autoconf 2.70. Some distros
|
||||
are shipping this addition in their autoconf packages, but others, such as Fedora,
|
||||
are not. This causes the rundir variable to be set incorrectly if the configure script
|
||||
is regenerated with an unpatched autoconf since the runstatedir variable set is deleted
|
||||
after regeneration. This change works around that problem by checking that runstatedir
|
||||
is non-empty before potentially using it to set the rundir variable
|
||||
---
|
||||
configure | 2 +-
|
||||
m4/sudo.m4 | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index 0f6ceb16c..2e0838e01 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -26718,7 +26718,7 @@ EOF
|
||||
$as_echo_n "checking for sudo run dir location... " >&6; }
|
||||
if test -n "$with_rundir"; then
|
||||
rundir="$with_rundir"
|
||||
-elif test "$runstatedir" != '${localstatedir}/run'; then
|
||||
+elif test -n "$runstatedir" && test "$runstatedir" != '${localstatedir}/run'; then
|
||||
rundir="$runstatedir/sudo"
|
||||
else
|
||||
# No --with-rundir or --runstatedir specified
|
||||
diff --git a/m4/sudo.m4 b/m4/sudo.m4
|
||||
index a5a972b3c..b3a40b208 100644
|
||||
--- a/m4/sudo.m4
|
||||
+++ b/m4/sudo.m4
|
||||
@@ -120,7 +120,7 @@ dnl
|
||||
AC_DEFUN([SUDO_RUNDIR], [AC_MSG_CHECKING(for sudo run dir location)
|
||||
if test -n "$with_rundir"; then
|
||||
rundir="$with_rundir"
|
||||
-elif test "$runstatedir" != '${localstatedir}/run'; then
|
||||
+elif test -n "$runstatedir" && test "$runstatedir" != '${localstatedir}/run'; then
|
||||
rundir="$runstatedir/sudo"
|
||||
else
|
||||
# No --with-rundir or --runstatedir specified
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (sudo-1.9.2.tar.gz) = 20afdf2604b1c93395157382b24f225cd1ff88d3a892362e2d69fecd240c4e7171f05032c08be1778cd1dea6e460025e4241f57272fac0ea3550e220b6d73d21
|
||||
SHA512 (sudo-1.9.3p1.tar.gz) = 3ad13fd03e5b371fd6bf7909731ffc11431d2182a744b654f7e5d4b810e47955d49bc78f551afe13ec56acbce694139c33a15bc022cea41b17af5496b8b7f89f
|
||||
|
12
sudo.spec
12
sudo.spec
@ -1,6 +1,6 @@
|
||||
Summary: Allows restricted root access for specified users
|
||||
Name: sudo
|
||||
Version: 1.9.2
|
||||
Version: 1.9.3p1
|
||||
Release: 1%{?dist}
|
||||
License: ISC
|
||||
URL: http://www.courtesan.com/sudo/
|
||||
@ -21,10 +21,10 @@ BuildRequires: libselinux-devel
|
||||
BuildRequires: sendmail
|
||||
BuildRequires: gettext
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: python3-devel
|
||||
|
||||
# don't strip
|
||||
Patch1: sudo-1.6.7p5-strip.patch
|
||||
Patch2: configure-runstatedir.patch
|
||||
|
||||
%description
|
||||
Sudo (superuser do) allows a system administrator to give certain
|
||||
@ -60,7 +60,6 @@ It can be used to implement centralized logging of sudo logs.
|
||||
%setup -q
|
||||
|
||||
%patch1 -p1 -b .strip
|
||||
%patch2 -p1 -b .runstatedir
|
||||
|
||||
%build
|
||||
# Remove bundled copy of zlib
|
||||
@ -93,6 +92,7 @@ export CFLAGS="$RPM_OPT_FLAGS $F_PIE" LDFLAGS="-pie -Wl,-z,relro -Wl,-z,now"
|
||||
--with-ldap \
|
||||
--with-selinux \
|
||||
--with-passprompt="[sudo] password for %p: " \
|
||||
--enable-python \
|
||||
--with-linux-audit \
|
||||
--with-sssd
|
||||
# --without-kerb5 \
|
||||
@ -181,6 +181,7 @@ EOF
|
||||
%attr(0644,root,root) %{_libexecdir}/sudo/sudoers.so
|
||||
%attr(0644,root,root) %{_libexecdir}/sudo/audit_json.so
|
||||
%attr(0644,root,root) %{_libexecdir}/sudo/group_file.so
|
||||
%attr(0644,root,root) %{_libexecdir}/sudo/python_plugin.so
|
||||
%attr(0644,root,root) %{_libexecdir}/sudo/sample_approval.so
|
||||
%attr(0644,root,root) %{_libexecdir}/sudo/system_group.so
|
||||
%attr(0644,root,root) %{_libexecdir}/sudo/libsudo_util.so.?.?.?
|
||||
@ -217,6 +218,11 @@ EOF
|
||||
%{_mandir}/man8/sudo_sendlog.8.gz
|
||||
|
||||
%changelog
|
||||
* Mon Oct 05 2020 Radovan Sroka <rsroka@redhat.com> - 1.9.3p1-1
|
||||
- rebase to 1.9.3p1
|
||||
- enable python modules
|
||||
Resolves: rhbz#1881112
|
||||
|
||||
* Tue Sep 15 2020 Radovan Sroka <rsroka@redhat.com> - 1.9.2-1
|
||||
- rebase to 1.9.2
|
||||
Resolves: rhbz#1859577
|
||||
|
Loading…
Reference in New Issue
Block a user