update to 1.8.18rc2
- dropped sudo-1.8.14p1-ldapconfpatch.patch upstreamed --> https://www.sudo.ws/pipermail/sudo-workers/2016-September/001006.html
This commit is contained in:
parent
3859d5ec51
commit
4884b56d12
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
|||||||
/sudo-1.8.16.tar.gz
|
/sudo-1.8.16.tar.gz
|
||||||
/sudo-1.8.17p1.tar.gz
|
/sudo-1.8.17p1.tar.gz
|
||||||
/sudo-1.8.18b2.tar.gz
|
/sudo-1.8.18b2.tar.gz
|
||||||
|
/sudo-1.8.18rc2.tar.gz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
17c7ccada7659cb5877ede799d459540 sudo-1.8.18b2.tar.gz
|
8944dc81070487cbabd7dcf717f2928a sudo-1.8.18rc2.tar.gz
|
||||||
|
@ -1,55 +0,0 @@
|
|||||||
diff -up sudo-1.8.14b3/plugins/sudoers/ldap.c.ldapconfpatch sudo-1.8.14b3/plugins/sudoers/ldap.c
|
|
||||||
--- sudo-1.8.14b3/plugins/sudoers/ldap.c.ldapconfpatch 2015-07-07 18:51:11.000000000 +0200
|
|
||||||
+++ sudo-1.8.14b3/plugins/sudoers/ldap.c 2015-07-09 11:03:25.686645581 +0200
|
|
||||||
@@ -1922,6 +1922,33 @@ sudo_check_krb5_ccname(const char *ccnam
|
|
||||||
}
|
|
||||||
#endif /* HAVE_LDAP_SASL_INTERACTIVE_BIND_S */
|
|
||||||
|
|
||||||
+/*
|
|
||||||
+ * Read a line of input, remove whole line comments and strip off leading
|
|
||||||
+ * and trailing spaces. Returns static storage that is reused.
|
|
||||||
+ */
|
|
||||||
+static char *
|
|
||||||
+sudo_ldap_parseln(fp)
|
|
||||||
+ FILE *fp;
|
|
||||||
+{
|
|
||||||
+ size_t len;
|
|
||||||
+ char *cp = NULL;
|
|
||||||
+ static char buf[LINE_MAX];
|
|
||||||
+
|
|
||||||
+ if (fgets(buf, sizeof(buf), fp) != NULL) {
|
|
||||||
+ /* Remove comments */
|
|
||||||
+ if (*buf == '#')
|
|
||||||
+ *buf = '\0';
|
|
||||||
+
|
|
||||||
+ /* Trim leading and trailing whitespace/newline */
|
|
||||||
+ len = strlen(buf);
|
|
||||||
+ while (len > 0 && isspace((unsigned char)buf[len - 1]))
|
|
||||||
+ buf[--len] = '\0';
|
|
||||||
+ for (cp = buf; isblank(*cp); cp++)
|
|
||||||
+ continue;
|
|
||||||
+ }
|
|
||||||
+ return(cp);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
static bool
|
|
||||||
sudo_ldap_read_config(void)
|
|
||||||
{
|
|
||||||
@@ -1955,7 +1982,7 @@ sudo_ldap_read_config(void)
|
|
||||||
if ((fp = fopen(path_ldap_conf, "r")) == NULL)
|
|
||||||
debug_return_bool(false);
|
|
||||||
|
|
||||||
- while (sudo_parseln(&line, &linesize, NULL, fp) != -1) {
|
|
||||||
+ while ((line = sudo_ldap_parseln(fp)) != NULL) {
|
|
||||||
if (*line == '\0')
|
|
||||||
continue; /* skip empty line */
|
|
||||||
|
|
||||||
@@ -1975,7 +2002,7 @@ sudo_ldap_read_config(void)
|
|
||||||
if (!sudo_ldap_parse_keyword(keyword, value, ldap_conf_global))
|
|
||||||
sudo_ldap_parse_keyword(keyword, value, ldap_conf_conn);
|
|
||||||
}
|
|
||||||
- free(line);
|
|
||||||
+
|
|
||||||
fclose(fp);
|
|
||||||
|
|
||||||
if (!ldap_conf.host) {
|
|
10
sudo.spec
10
sudo.spec
@ -1,6 +1,6 @@
|
|||||||
Summary: Allows restricted root access for specified users
|
Summary: Allows restricted root access for specified users
|
||||||
Name: sudo
|
Name: sudo
|
||||||
Version: 1.8.18b2
|
Version: 1.8.18rc2
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: ISC
|
License: ISC
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
@ -26,8 +26,6 @@ BuildRequires: zlib-devel
|
|||||||
|
|
||||||
# don't strip
|
# don't strip
|
||||||
Patch1: sudo-1.6.7p5-strip.patch
|
Patch1: sudo-1.6.7p5-strip.patch
|
||||||
# Patch to read ldap.conf more closely to nss_ldap
|
|
||||||
Patch2: sudo-1.8.14p1-ldapconfpatch.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Sudo (superuser do) allows a system administrator to give certain
|
Sudo (superuser do) allows a system administrator to give certain
|
||||||
@ -53,7 +51,6 @@ plugins that use %{name}.
|
|||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch1 -p1 -b .strip
|
%patch1 -p1 -b .strip
|
||||||
%patch2 -p1 -b .ldapconfpatch
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Remove bundled copy of zlib
|
# Remove bundled copy of zlib
|
||||||
@ -195,6 +192,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libexecdir}/sudo/libsudo_util.so
|
%{_libexecdir}/sudo/libsudo_util.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 14 2016 Radovan Sroka <rsroka@redhat.com> 1.8.18rc2-1
|
||||||
|
- update to 1.8.18rc2
|
||||||
|
- dropped sudo-1.8.14p1-ldapconfpatch.patch
|
||||||
|
upstreamed --> https://www.sudo.ws/pipermail/sudo-workers/2016-September/001006.html
|
||||||
|
|
||||||
* Fri Aug 26 2016 Radovan Sroka <rsroka@redhat.com> 1.8.18b2-1
|
* Fri Aug 26 2016 Radovan Sroka <rsroka@redhat.com> 1.8.18b2-1
|
||||||
- update to 1.8.18b2
|
- update to 1.8.18b2
|
||||||
- added --disable-root-mailer as configure option
|
- added --disable-root-mailer as configure option
|
||||||
|
Loading…
Reference in New Issue
Block a user