update to 1.8.3p1
disable output word wrapping if the output is piped
This commit is contained in:
parent
911d5c1fe9
commit
0894814a99
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@ sudo-1.7.2p2-sudoers
|
|||||||
/sudo-1.7.4p4-sudoers
|
/sudo-1.7.4p4-sudoers
|
||||||
/sudo-1.7.4p5.tar.gz
|
/sudo-1.7.4p5.tar.gz
|
||||||
/sudo-1.8.1p2.tar.gz
|
/sudo-1.8.1p2.tar.gz
|
||||||
|
/sudo-1.8.3p1.tar.gz
|
||||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
e8330f0e63b0ecb2e12b5c76922818cc sudo-1.8.1p2.tar.gz
|
7becc572fa97f94cf721a2ee8299c45b sudo-1.8.3p1.tar.gz
|
||||||
56f74aed3a7b32f2b01a34d65ac86f85 sudo-1.7.4p4-sudoers
|
56f74aed3a7b32f2b01a34d65ac86f85 sudo-1.7.4p4-sudoers
|
||||||
|
28
sudo-1.8.3-pipelist.patch
Normal file
28
sudo-1.8.3-pipelist.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
diff -up sudo-1.8.3/src/ttysize.c.pipelist sudo-1.8.3/src/ttysize.c
|
||||||
|
--- sudo-1.8.3/src/ttysize.c.pipelist 2011-10-21 15:01:26.000000000 +0200
|
||||||
|
+++ sudo-1.8.3/src/ttysize.c 2011-10-26 02:09:39.582790562 +0200
|
||||||
|
@@ -20,6 +20,7 @@
|
||||||
|
|
||||||
|
#include <sys/types.h>
|
||||||
|
#include <sys/ioctl.h>
|
||||||
|
+#include <sys/stat.h>
|
||||||
|
#include <stdio.h>
|
||||||
|
#ifdef STDC_HEADERS
|
||||||
|
# include <stdlib.h>
|
||||||
|
@@ -48,6 +49,16 @@ void
|
||||||
|
get_ttysize(int *rowp, int *colp)
|
||||||
|
{
|
||||||
|
char *p;
|
||||||
|
+ struct stat st;
|
||||||
|
+
|
||||||
|
+ if (fstat(STDOUT_FILENO, &st) == 0) {
|
||||||
|
+ if (S_ISFIFO(st.st_mode)) {
|
||||||
|
+ *rowp = 0;
|
||||||
|
+ *colp = 0;
|
||||||
|
+ return;
|
||||||
|
+ }
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
#ifdef TIOCGWINSZ
|
||||||
|
struct winsize wsize;
|
||||||
|
|
26
sudo.spec
26
sudo.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Allows restricted root access for specified users
|
Summary: Allows restricted root access for specified users
|
||||||
Name: sudo
|
Name: sudo
|
||||||
Version: 1.8.1p2
|
Version: 1.8.3p1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: ISC
|
License: ISC
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
URL: http://www.courtesan.com/sudo/
|
URL: http://www.courtesan.com/sudo/
|
||||||
@ -19,6 +19,7 @@ BuildRequires: automake autoconf libtool
|
|||||||
BuildRequires: audit-libs-devel libcap-devel
|
BuildRequires: audit-libs-devel libcap-devel
|
||||||
BuildRequires: libselinux-devel
|
BuildRequires: libselinux-devel
|
||||||
BuildRequires: sendmail
|
BuildRequires: sendmail
|
||||||
|
BuildRequires: gettext
|
||||||
|
|
||||||
# don't strip
|
# don't strip
|
||||||
Patch1: sudo-1.6.7p5-strip.patch
|
Patch1: sudo-1.6.7p5-strip.patch
|
||||||
@ -26,9 +27,8 @@ Patch1: sudo-1.6.7p5-strip.patch
|
|||||||
Patch2: sudo-1.7.2p1-envdebug.patch
|
Patch2: sudo-1.7.2p1-envdebug.patch
|
||||||
# add m4/ to paths in aclocal.m4
|
# add m4/ to paths in aclocal.m4
|
||||||
Patch3: sudo-1.7.4p3-m4path.patch
|
Patch3: sudo-1.7.4p3-m4path.patch
|
||||||
# getgrouplist() to determine group membership (#235915)
|
# disable word wrapping if the ouput is piped
|
||||||
# - version with CVE-2009-0034 fixed
|
Patch4: sudo-1.8.3-pipelist.patch
|
||||||
Patch4: sudo-1.8.1p2-getgrouplist.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Sudo (superuser do) allows a system administrator to give certain
|
Sudo (superuser do) allows a system administrator to give certain
|
||||||
@ -56,7 +56,7 @@ plugins that use %{name}.
|
|||||||
%patch1 -p1 -b .strip
|
%patch1 -p1 -b .strip
|
||||||
%patch2 -p1 -b .envdebug
|
%patch2 -p1 -b .envdebug
|
||||||
%patch3 -p1 -b .m4path
|
%patch3 -p1 -b .m4path
|
||||||
%patch4 -p1 -b .getgrouplist
|
%patch4 -p1 -b .pipelist
|
||||||
|
|
||||||
# Remove execute permission on this script so we don't pull in perl deps
|
# Remove execute permission on this script so we don't pull in perl deps
|
||||||
chmod -x plugins/sudoers/sudoers2ldif
|
chmod -x plugins/sudoers/sudoers2ldif
|
||||||
@ -96,11 +96,18 @@ make
|
|||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
make install DESTDIR="$RPM_BUILD_ROOT" install_uid=`id -u` install_gid=`id -g` sudoers_uid=`id -u` sudoers_gid=`id -g`
|
make install DESTDIR="$RPM_BUILD_ROOT" install_uid=`id -u` install_gid=`id -g` sudoers_uid=`id -u` sudoers_gid=`id -g`
|
||||||
|
|
||||||
chmod 755 $RPM_BUILD_ROOT%{_bindir}/* $RPM_BUILD_ROOT%{_sbindir}/*
|
chmod 755 $RPM_BUILD_ROOT%{_bindir}/* $RPM_BUILD_ROOT%{_sbindir}/*
|
||||||
install -p -d -m 700 $RPM_BUILD_ROOT/var/db/sudo
|
install -p -d -m 700 $RPM_BUILD_ROOT/var/db/sudo
|
||||||
install -p -d -m 750 $RPM_BUILD_ROOT/etc/sudoers.d
|
install -p -d -m 750 $RPM_BUILD_ROOT/etc/sudoers.d
|
||||||
install -p -c -m 0440 %{SOURCE1} $RPM_BUILD_ROOT/etc/sudoers
|
install -p -c -m 0440 %{SOURCE1} $RPM_BUILD_ROOT/etc/sudoers
|
||||||
|
|
||||||
|
%find_lang sudo
|
||||||
|
%find_lang sudoers
|
||||||
|
|
||||||
|
cat sudo.lang sudoers.lang > sudo_all.lang
|
||||||
|
rm sudo.lang sudoers.lang
|
||||||
|
|
||||||
mkdir -p $RPM_BUILD_ROOT/etc/pam.d
|
mkdir -p $RPM_BUILD_ROOT/etc/pam.d
|
||||||
cat > $RPM_BUILD_ROOT/etc/pam.d/sudo << EOF
|
cat > $RPM_BUILD_ROOT/etc/pam.d/sudo << EOF
|
||||||
#%PAM-1.0
|
#%PAM-1.0
|
||||||
@ -124,7 +131,7 @@ EOF
|
|||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
%files
|
%files -f sudo_all.lang
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%doc ChangeLog NEWS README* MANIFEST
|
%doc ChangeLog NEWS README* MANIFEST
|
||||||
%doc doc/HISTORY doc/LICENSE doc/TROUBLESHOOTING doc/UPGRADE
|
%doc doc/HISTORY doc/LICENSE doc/TROUBLESHOOTING doc/UPGRADE
|
||||||
@ -148,6 +155,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man8/sudoreplay.8*
|
%{_mandir}/man8/sudoreplay.8*
|
||||||
%{_mandir}/man8/visudo.8*
|
%{_mandir}/man8/visudo.8*
|
||||||
|
|
||||||
|
|
||||||
# Make sure permissions are ok even if we're updating
|
# Make sure permissions are ok even if we're updating
|
||||||
%post
|
%post
|
||||||
/bin/chmod 0440 /etc/sudoers || :
|
/bin/chmod 0440 /etc/sudoers || :
|
||||||
@ -159,6 +167,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man8/sudo_plugin.8*
|
%{_mandir}/man8/sudo_plugin.8*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 10 2011 Daniel Kopecek <dkopecek@redhat.com> - 1.8.3p1-1
|
||||||
|
- update to 1.8.3p1
|
||||||
|
- disable output word wrapping if the output is piped
|
||||||
|
|
||||||
* Wed Sep 7 2011 Peter Robinson <pbrobinson@fedoraproject.org> - 1.8.1p2-2
|
* Wed Sep 7 2011 Peter Robinson <pbrobinson@fedoraproject.org> - 1.8.1p2-2
|
||||||
- Remove execute bit from sample script in docs so we don't pull in perl
|
- Remove execute bit from sample script in docs so we don't pull in perl
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user