Resolves: rhbz#1812195 Resolves: rhbz#1840565
This commit is contained in:
parent
7f9b0e8ee8
commit
f8836c5c33
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (subversion-1.14.0-rc2.tar.bz2) = 149e961939bf12aafa8b545b3bd1713dfee95d05134b500a8e4279cd1719528f13ff4fdda7ed77ce74630dbd2390f9c7cfcd0a0595f92d95c4ba914f8bd3a76c
|
SHA512 (subversion-1.14.0.tar.bz2) = af6b706fdc91f7ab292fce9d9de582da306fd11e92767dc852687e71a6a8b65bb867fa70d5afd7f76a46005acb1b3c2d3193e690def48cd26875b3a7851cd13b
|
||||||
|
@ -1,26 +0,0 @@
|
|||||||
|
|
||||||
get_rev_contents() has signed integer overflow with "long int" rev
|
|
||||||
and behaves unpredictably.
|
|
||||||
|
|
||||||
--- subversion-1.12.2/subversion/tests/libsvn_fs_fs/fs-fs-pack-test.c.fsfspacktest
|
|
||||||
+++ subversion-1.12.2/subversion/tests/libsvn_fs_fs/fs-fs-pack-test.c
|
|
||||||
@@ -59,7 +59,8 @@
|
|
||||||
get_rev_contents(svn_revnum_t rev, apr_pool_t *pool)
|
|
||||||
{
|
|
||||||
/* Toss in a bunch of magic numbers for spice. */
|
|
||||||
- apr_int64_t num = ((rev * 1234353 + 4358) * 4583 + ((rev % 4) << 1)) / 42;
|
|
||||||
+ apr_int64_t rev64 = rev;
|
|
||||||
+ apr_int64_t num = ((rev64 * 1234353 + 4358) * 4583 + ((rev64 % 4) << 1)) / 42;
|
|
||||||
return apr_psprintf(pool, "%" APR_INT64_T_FMT "\n", num);
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -407,7 +408,8 @@
|
|
||||||
|
|
||||||
if (! svn_stringbuf_compare(rstring, sb))
|
|
||||||
return svn_error_createf(SVN_ERR_FS_GENERAL, NULL,
|
|
||||||
- "Bad data in revision %ld.", i);
|
|
||||||
+ "Bad data in revision %ld - [%s] not [%s].",
|
|
||||||
+ i, rstring->data, sb->data);
|
|
||||||
}
|
|
||||||
|
|
||||||
return SVN_NO_ERROR;
|
|
@ -1,35 +0,0 @@
|
|||||||
# ./pullrev.sh 1865987 1866588
|
|
||||||
http://svn.apache.org/viewvc?view=revision&revision=1865987
|
|
||||||
http://svn.apache.org/viewvc?view=revision&revision=1866588
|
|
||||||
|
|
||||||
--- subversion-1.12.2/subversion/libsvn_fs_fs/verify.c
|
|
||||||
+++ subversion-1.12.2/subversion/libsvn_fs_fs/verify.c
|
|
||||||
@@ -681,10 +681,10 @@
|
|
||||||
NULL,
|
|
||||||
_("p2l index entry for revision r%ld"
|
|
||||||
" at offset %s contains invalid item"
|
|
||||||
- " type %d"),
|
|
||||||
+ " type %u"),
|
|
||||||
start,
|
|
||||||
apr_off_t_toa(pool, offset),
|
|
||||||
- entry->type);
|
|
||||||
+ (unsigned int)entry->type);
|
|
||||||
|
|
||||||
/* There can be only one changes entry and that has a fixed type
|
|
||||||
* and item number. Its presence and parse-ability will be checked
|
|
||||||
@@ -694,11 +694,12 @@
|
|
||||||
return svn_error_createf(SVN_ERR_FS_INDEX_CORRUPTION,
|
|
||||||
NULL,
|
|
||||||
_("p2l index entry for changes in"
|
|
||||||
- " revision r%ld is item %ld of type"
|
|
||||||
- " %d at offset %s"),
|
|
||||||
+ " revision r%ld is item"
|
|
||||||
+ " %"APR_UINT64_T_FMT
|
|
||||||
+ " of type %u at offset %s"),
|
|
||||||
entry->item.revision,
|
|
||||||
entry->item.number,
|
|
||||||
- entry->type,
|
|
||||||
+ (unsigned int)entry->type,
|
|
||||||
apr_off_t_toa(pool, offset));
|
|
||||||
|
|
||||||
/* Check contents. */
|
|
14
subversion-1.14.0-testwarn.patch
Normal file
14
subversion-1.14.0-testwarn.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
|
||||||
|
Suppress gcc 10 warning.
|
||||||
|
|
||||||
|
--- subversion-1.14.0/subversion/tests/svn_test.h.testwarn
|
||||||
|
+++ subversion-1.14.0/subversion/tests/svn_test.h
|
||||||
|
@@ -128,7 +128,7 @@
|
||||||
|
return svn_error_createf(SVN_ERR_TEST_FAILED, NULL, \
|
||||||
|
"Strings not equal\n Expected: '%s'\n Found: '%s'" \
|
||||||
|
"\n at %s:%d", \
|
||||||
|
- tst_str2, tst_str1, __FILE__, __LINE__); \
|
||||||
|
+ tst_str2 ? tst_str2 : "(NULL)", tst_str1 ? tst_str1 : "(NULL)", __FILE__, __LINE__); \
|
||||||
|
} while(0)
|
||||||
|
|
||||||
|
/** Handy macro for testing integer equality.
|
@ -49,12 +49,12 @@
|
|||||||
|
|
||||||
Summary: A Modern Concurrent Version Control System
|
Summary: A Modern Concurrent Version Control System
|
||||||
Name: subversion
|
Name: subversion
|
||||||
Version: 1.14.0~rc2
|
Version: 1.14.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
URL: https://subversion.apache.org/
|
URL: https://subversion.apache.org/
|
||||||
|
|
||||||
Source0: https://downloads.apache.org/dist/subversion/subversion-1.14.0-rc2.tar.bz2
|
Source0: https://downloads.apache.org/subversion/subversion-1.14.0.tar.bz2
|
||||||
Source1: subversion.conf
|
Source1: subversion.conf
|
||||||
Source3: filter-requires.sh
|
Source3: filter-requires.sh
|
||||||
Source4: http://www.xsteve.at/prg/emacs/psvn.el
|
Source4: http://www.xsteve.at/prg/emacs/psvn.el
|
||||||
@ -63,6 +63,7 @@ Source6: svnserve.service
|
|||||||
Source7: svnserve.tmpfiles
|
Source7: svnserve.tmpfiles
|
||||||
Source8: svnserve.sysconf
|
Source8: svnserve.sysconf
|
||||||
Patch1: subversion-1.12.0-linking.patch
|
Patch1: subversion-1.12.0-linking.patch
|
||||||
|
Patch2: subversion-1.14.0-testwarn.patch
|
||||||
Patch4: subversion-1.8.0-rubybind.patch
|
Patch4: subversion-1.8.0-rubybind.patch
|
||||||
Patch5: subversion-1.8.5-swigplWall.patch
|
Patch5: subversion-1.8.5-swigplWall.patch
|
||||||
BuildRequires: autoconf, libtool, texinfo, which
|
BuildRequires: autoconf, libtool, texinfo, which
|
||||||
@ -216,21 +217,26 @@ Requires: subversion-libs%{?_isa} = %{version}-%{release}
|
|||||||
This package includes supplementary tools for use with Subversion.
|
This package includes supplementary tools for use with Subversion.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n subversion-1.14.0-rc2
|
%setup -q
|
||||||
%patch1 -p1 -b .linking
|
%patch1 -p1 -b .linking
|
||||||
|
%patch2 -p1 -b .testwarn
|
||||||
%patch4 -p1 -b .rubybind
|
%patch4 -p1 -b .rubybind
|
||||||
%patch5 -p1 -b .swigplWall
|
%patch5 -p1 -b .swigplWall
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Regenerate the buildsystem, so that:
|
# Regenerate the buildsystem, so that any patches applied to
|
||||||
# 1) patches applied to configure.in take effect
|
# configure, swig bindings etc take effect.
|
||||||
# 2) the swig bindings are regenerated using the system swig
|
|
||||||
# (2) is not ideal since typically upstream test with a different
|
|
||||||
# swig version
|
|
||||||
# This PATH order makes the fugly test for libtoolize work...
|
|
||||||
mv build-outputs.mk build-outputs.mk.old
|
mv build-outputs.mk build-outputs.mk.old
|
||||||
export PYTHON=%{svn_python}
|
export PYTHON=%{svn_python}
|
||||||
|
|
||||||
|
### Force regeneration of swig bindings with the buildroot's SWIG.
|
||||||
|
# Generated files depend on the build/generator/swig/*.py which
|
||||||
|
# generates them, so when autogen-standalone.mk's autogen-swig target
|
||||||
|
# is run by autogen.sh it will regenerate them:
|
||||||
|
touch build/generator/swig/*.py
|
||||||
|
|
||||||
|
### Regenerate everything:
|
||||||
|
# This PATH order makes the fugly test for libtoolize work...
|
||||||
PATH=/usr/bin:$PATH ./autogen.sh --release
|
PATH=/usr/bin:$PATH ./autogen.sh --release
|
||||||
|
|
||||||
# fix shebang lines, #111498
|
# fix shebang lines, #111498
|
||||||
@ -541,6 +547,9 @@ make check-javahl
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 1 2020 Joe Orton <jorton@redhat.com> - 1.14.0-1
|
||||||
|
- update to 1.14.0 (#1840565, #1812195)
|
||||||
|
|
||||||
* Tue May 19 2020 Joe Orton <jorton@redhat.com> - 1.14.0~rc2-2
|
* Tue May 19 2020 Joe Orton <jorton@redhat.com> - 1.14.0~rc2-2
|
||||||
- switch subpackages to lock-step requires on -libs rather than subversion
|
- switch subpackages to lock-step requires on -libs rather than subversion
|
||||||
- fixed the build-requires (Jitka Plesnikova)
|
- fixed the build-requires (Jitka Plesnikova)
|
||||||
|
Loading…
Reference in New Issue
Block a user