improve library versioning so filenames are unique across releases
This commit is contained in:
parent
a369b2c68c
commit
d5d79903b7
@ -1,19 +0,0 @@
|
|||||||
|
|
||||||
Use the minor version as the revision in the libtool version, so the library
|
|
||||||
soversion is not always 0.0.0. (Does not influence the soname)
|
|
||||||
|
|
||||||
--- subversion-1.14.0/configure.ac.soversion
|
|
||||||
+++ subversion-1.14.0/configure.ac
|
|
||||||
@@ -112,7 +112,11 @@
|
|
||||||
SVN_APR_MAJOR_VERSION=1
|
|
||||||
fi
|
|
||||||
AC_SUBST(SVN_APR_MAJOR_VERSION)
|
|
||||||
-SVN_LT_SOVERSION="-version-info $svn_lib_ver"
|
|
||||||
+
|
|
||||||
+m4_define([svn_ver_minor], m4_bpatsubst(AC_PACKAGE_VERSION, [[0-9]*\.\([0-9]*\)\.[0-9]*], [\1]))
|
|
||||||
+
|
|
||||||
+SVN_LT_SOVERSION="-version-info $svn_lib_ver:svn_ver_minor"
|
|
||||||
+AC_MSG_NOTICE([SVN_LT_SOVERSION $SVN_LT_SOVERSION])
|
|
||||||
AC_SUBST(SVN_LT_SOVERSION)
|
|
||||||
AC_DEFINE_UNQUOTED(SVN_SOVERSION, $svn_lib_ver,
|
|
||||||
[Subversion library major verson])
|
|
23
subversion-1.14.2-soversion.patch
Normal file
23
subversion-1.14.2-soversion.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
|
||||||
|
Subversion libraries don't get properly versioned so the library
|
||||||
|
names are always "libsvn_foo-1.so.0.0.0". Provide proper
|
||||||
|
versioning information to libtool *without* changing the soname
|
||||||
|
for compatibility with upstream, so on-disk filenames are
|
||||||
|
unique across different releases.
|
||||||
|
|
||||||
|
--- subversion-1.14.2/configure.ac.soversion
|
||||||
|
+++ subversion-1.14.2/configure.ac
|
||||||
|
@@ -112,7 +112,12 @@
|
||||||
|
SVN_APR_MAJOR_VERSION=1
|
||||||
|
fi
|
||||||
|
AC_SUBST(SVN_APR_MAJOR_VERSION)
|
||||||
|
-SVN_LT_SOVERSION="-version-info $svn_lib_ver"
|
||||||
|
+
|
||||||
|
+m4_define([svn_ver_minor], m4_bpatsubst(AC_PACKAGE_VERSION, [[0-9]*\.\([0-9]*\)\.[0-9]*], [\1]))
|
||||||
|
+m4_define([svn_ver_patch], m4_bpatsubst(AC_PACKAGE_VERSION, [[0-9]*\.[0-9]*\.\([0-9]*\)], [\1]))
|
||||||
|
+svn_ver_current="`expr $svn_lib_ver + svn_ver_minor`"
|
||||||
|
+
|
||||||
|
+SVN_LT_SOVERSION="-version-info $svn_ver_current:svn_ver_patch:svn_ver_minor"
|
||||||
|
AC_SUBST(SVN_LT_SOVERSION)
|
||||||
|
AC_DEFINE_UNQUOTED(SVN_SOVERSION, $svn_lib_ver,
|
||||||
|
[Subversion library major verson])
|
@ -59,7 +59,7 @@
|
|||||||
Summary: A Modern Concurrent Version Control System
|
Summary: A Modern Concurrent Version Control System
|
||||||
Name: subversion
|
Name: subversion
|
||||||
Version: 1.14.2
|
Version: 1.14.2
|
||||||
Release: 6%{?dist}
|
Release: 7%{?dist}
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
URL: https://subversion.apache.org/
|
URL: https://subversion.apache.org/
|
||||||
Source0: https://downloads.apache.org/subversion/subversion-%{version}.tar.bz2
|
Source0: https://downloads.apache.org/subversion/subversion-%{version}.tar.bz2
|
||||||
@ -72,7 +72,7 @@ Source7: svnserve.tmpfiles
|
|||||||
Source8: svnserve.sysconf
|
Source8: svnserve.sysconf
|
||||||
Patch1: subversion-1.12.0-linking.patch
|
Patch1: subversion-1.12.0-linking.patch
|
||||||
Patch2: subversion-1.14.0-testwarn.patch
|
Patch2: subversion-1.14.0-testwarn.patch
|
||||||
Patch3: subversion-1.14.0-soversion.patch
|
Patch3: subversion-1.14.2-soversion.patch
|
||||||
Patch4: subversion-1.8.0-rubybind.patch
|
Patch4: subversion-1.8.0-rubybind.patch
|
||||||
Patch5: subversion-1.8.5-swigplWall.patch
|
Patch5: subversion-1.8.5-swigplWall.patch
|
||||||
Patch6: subversion-1.14.1-testnomagic.patch
|
Patch6: subversion-1.14.1-testnomagic.patch
|
||||||
@ -581,6 +581,9 @@ make check-javahl
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 29 2022 Joe Orton <jorton@redhat.com> - 1.14.2-7
|
||||||
|
- improve library versioning so filenames are unique across releases
|
||||||
|
|
||||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.14.2-6
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.14.2-6
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user