- update to 1.1.0

This commit is contained in:
jorton 2004-09-30 12:04:30 +00:00
parent 41c83b6c27
commit cbe0f4646d
2 changed files with 19 additions and 21 deletions

View File

@ -4,9 +4,9 @@ ensure that executables in the test suite are *not* build using
-pie, since that doesn't work when main() is not itself an
object built with -pie.
--- subversion-1.0.4/build/generator/gen_base.py.pie
+++ subversion-1.0.4/build/generator/gen_base.py
@@ -393,6 +393,9 @@
--- subversion-1.1.0/build/generator/gen_base.py.pie
+++ subversion-1.1.0/build/generator/gen_base.py
@@ -386,6 +386,9 @@
self.manpages = options.get('manpages', '')
self.testing = options.get('testing')
@ -16,9 +16,9 @@ object built with -pie.
def add_dependencies(self, graph, cfg, extmap):
TargetLinked.add_dependencies(self, graph, cfg, extmap)
@@ -429,8 +432,11 @@
self.msvc_static = options.get('msvc-static') == 'yes' # is a static lib
@@ -426,8 +429,11 @@
self.msvc_fake = options.get('msvc-fake') == 'yes' # has fake target
self.msvc_export = string.split(options.get('msvc-export', ''))
- ### hmm. this is Makefile-specific
- self.link_cmd = '$(LINK_LIB)'
@ -30,23 +30,24 @@ object built with -pie.
class TargetApacheMod(TargetLib):
--- subversion-1.0.4/Makefile.in.pie
+++ subversion-1.0.4/Makefile.in
@@ -123,8 +123,9 @@
--- subversion-1.1.0/Makefile.in.pie
+++ subversion-1.1.0/Makefile.in
@@ -140,9 +140,10 @@
CPPFLAGS = @CPPFLAGS@ $(EXTRA_CPPFLAGS)
LDFLAGS = @LDFLAGS@ $(EXTRA_LDFLAGS)
-COMPILE = $(CC) $(CPPFLAGS) $(CFLAGS) $(INCLUDES)
-LT_COMPILE = $(LIBTOOL) $(LTFLAGS) --mode=compile $(COMPILE)
+BASE_COMPILE = $(CC) $(CPPFLAGS) $(CFLAGS) $(INCLUDES)
+COMPILE = $(BASE_COMPILE) -fpie
+COMPILE = $(COMPILE) -fpie
COMPILE_CXX = $(CXX) $(CPPFLAGS) $(CFLAGS) $(CXXFLAGS) $(INCLUDES)
-LT_COMPILE = $(LIBTOOL) $(LTFLAGS) --mode=compile $(COMPILE)
+LT_COMPILE = $(LIBTOOL) $(LTFLAGS) --mode=compile $(BASE_COMPILE)
# special compilation for files destined for mod_dav_svn
COMPILE_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=compile $(CC) $(CPPFLAGS) $(CFLAGS) $(APACHE_INCLUDES) $(INCLUDES) -o $@ -c
@@ -134,8 +135,11 @@
COMPILE_SWIG_JAVA = $(LIBTOOL) $(LTFLAGS) --mode=compile $(CC) $(CPPFLAGS) $(CFLAGS) $(SWIG_JAVA_INCLUDES) $(INCLUDES) -o $@ -c
COMPILE_SWIG_PL = $(LIBTOOL) $(LTFLAGS) --mode=compile $(CC) $(CPPFLAGS) $(CFLAGS) $(SWIG_PL_INCLUDES) $(INCLUDES) -o $@ -c
@@ -160,8 +161,11 @@
# special compilation for files destined for SWIG/Java
COMPILE_SWIG_JAVA_JAVAC = $(JAVAC) $(JAVAC_FLAGS)
-LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS)
-LINK_LIB = $(LINK) -rpath $(libdir)

View File

@ -5,8 +5,8 @@
Summary: Modern Version Control System designed to replace CVS
Name: subversion
Version: 1.0.8
Release: 2
Version: 1.1.0
Release: 1
License: BSD
Group: Development/Tools
URL: http://subversion.tigris.org/
@ -14,11 +14,8 @@ Source0: http://subversion.tigris.org/tarballs/subversion-%{version}.tar.gz
Source1: subversion.conf
Source3: filter-requires.sh
Source4: http://www.xsteve.at/prg/emacs/psvn.el
Patch1: subversion-0.24.2-swig.patch
Patch2: subversion-0.20.1-deplibs.patch
Patch3: subversion-0.31.0-rpath.patch
Patch4: subversion-1.0.2-blame.patch
Patch5: subversion-r8822.patch
Patch6: subversion-1.0.3-pie.patch
BuildPreReq: autoconf, libtool, python, python-devel, texinfo
BuildPreReq: db4-devel >= 4.1.25, swig >= 1.3.15, docbook-style-xsl
@ -72,11 +69,8 @@ This package includes the Perl bindings to the Subversion libraries.
%prep
%setup -q
%patch1 -p1 -b .swig
%patch2 -p1 -b .deplibs
%patch3 -p1 -b .rpath
%patch4 -p1 -b .blame
%patch5 -p1 -b .r8822
%patch6 -p1 -b .pie
rm -rf neon apr apr-util db4
@ -198,6 +192,9 @@ rm -rf ${RPM_BUILD_ROOT}
%{_mandir}/man*/*::*
%changelog
* Thu Sep 30 2004 Joe Orton <jorton@redhat.com> 1.1.0-1
- update to 1.1.0
* Thu Sep 23 2004 Joe Orton <jorton@redhat.com> 1.0.8-2
- update to 1.0.8
- remove -neonver patch