RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/subversion#3d5f8d900a066a77c81766ea91fcb3fd49ed0d4e
This commit is contained in:
parent
b3a45da761
commit
b76e4d08d6
3
.gitignore
vendored
3
.gitignore
vendored
@ -0,0 +1,3 @@
|
|||||||
|
/subversion-*.tar.bz2
|
||||||
|
/subversion-1\.[0-9]*\.[0-9]*/
|
||||||
|
/results_subversion/
|
27
clog2markdown
Executable file
27
clog2markdown
Executable file
@ -0,0 +1,27 @@
|
|||||||
|
#!/bin/sh
|
||||||
|
|
||||||
|
version=$1
|
||||||
|
|
||||||
|
echo "This update includes the latest stable release of _Apache Subversion_, version **${1}**".
|
||||||
|
echo
|
||||||
|
|
||||||
|
curl --silent -n "http://svn.apache.org/repos/asf/subversion/tags/$1/CHANGES" | \
|
||||||
|
sed -n "
|
||||||
|
/^#/d;
|
||||||
|
/^Version ${1/-rc*/}/,/^Version /{
|
||||||
|
/, from \/branches/d;
|
||||||
|
/repos\/asf\/subversion\/tags/d;
|
||||||
|
s,#\([0-9]*\),[SVN-\1](https://issues.apache.org/jira/browse/SVN-\1),;
|
||||||
|
s/(r[0-9, retal]+)\*//g;
|
||||||
|
s/^ *//;
|
||||||
|
s/ +/ /g;
|
||||||
|
s/^ *- \(.*\)$/#### \1/;
|
||||||
|
s/\(.*visible changes.*:\)$/### \1/;
|
||||||
|
/^ *$/d;
|
||||||
|
/Windows/d
|
||||||
|
/^Version /d
|
||||||
|
s,(r1.*),,g
|
||||||
|
s,\(@[0-9]*\),\\\1,g
|
||||||
|
p;
|
||||||
|
}
|
||||||
|
" -
|
13
filter-requires.sh
Executable file
13
filter-requires.sh
Executable file
@ -0,0 +1,13 @@
|
|||||||
|
#!/bin/sh
|
||||||
|
# Munge Perl requirements:
|
||||||
|
# - remove dependency on Config::Inifiles
|
||||||
|
# - only require File::Path >= 1.04, not >= 1.404
|
||||||
|
# (since rpmvercmp thinks 04 < 1.404, not unreasonably)
|
||||||
|
# - filter out requirements for SVN:: modules; otherwise
|
||||||
|
# subversion requires subversion-perl
|
||||||
|
/usr/lib/rpm/perl.req $* |
|
||||||
|
sed -e '/perl(Config::IniFiles)/d' \
|
||||||
|
-e '/perl(SVN::/d' \
|
||||||
|
-e 's/perl(File::Path) >= 1.0404/perl(File::Path) >= 1.04/'
|
||||||
|
|
||||||
|
|
3
psvn-init.el
Normal file
3
psvn-init.el
Normal file
@ -0,0 +1,3 @@
|
|||||||
|
(defalias 'svn-examine 'svn-status)
|
||||||
|
(autoload 'svn-status "psvn" "Examine the status of Subversion working copy in
|
||||||
|
directory DIR.")
|
53
pullrev.sh
Executable file
53
pullrev.sh
Executable file
@ -0,0 +1,53 @@
|
|||||||
|
#!/bin/sh -e
|
||||||
|
|
||||||
|
if [ $# -lt 1 ]; then
|
||||||
|
echo "What?"
|
||||||
|
exit 1
|
||||||
|
fi
|
||||||
|
|
||||||
|
repo="https://svn.apache.org/repos/asf/subversion/trunk"
|
||||||
|
#repo="https://svn.apache.org/repos/asf/subversion/branches/1.11.x"
|
||||||
|
prefix=`rpmspec -q --queryformat='%{name}-%{version}\n' ./subversion.spec | sed 1q`
|
||||||
|
suffix="r$1${2:++}"
|
||||||
|
fn="${prefix}-${suffix}.patch"
|
||||||
|
vcurl="http://svn.apache.org/viewvc?view=revision&revision="
|
||||||
|
|
||||||
|
if test -f ${fn}; then
|
||||||
|
mv -v -f ${fn} ${fn}\~
|
||||||
|
echo "# $0 $*" > ${fn}
|
||||||
|
sed '1{/#.*pullrev/d;};/^--- /,$d' < ${fn}\~ >> ${fn}
|
||||||
|
else
|
||||||
|
echo "# $0 $*" > ${fn}
|
||||||
|
fi
|
||||||
|
|
||||||
|
new=0
|
||||||
|
for r in $*; do
|
||||||
|
if ! grep -q "${vcurl}${r}" ${fn}; then
|
||||||
|
echo "${vcurl}${r}"
|
||||||
|
new=1
|
||||||
|
fi
|
||||||
|
done >> ${fn}
|
||||||
|
|
||||||
|
[ $new -eq 0 ] || echo >> ${fn}
|
||||||
|
|
||||||
|
prev=/dev/null
|
||||||
|
for r in $*; do
|
||||||
|
echo "+ fetching ${r}"
|
||||||
|
this=`mktemp /tmp/pullrevXXXXXX`
|
||||||
|
svn diff -c ${r} ${repo} | filterdiff --remove-timestamps --clean -x 'CHANGES' -x 'next-number' -x 'STATUS' \
|
||||||
|
--addprefix="${prefix}/" > ${this}
|
||||||
|
next=`mktemp /tmp/pullrevXXXXXX`
|
||||||
|
combinediff --quiet ${prev} ${this} > ${next}
|
||||||
|
rm -f "${this}"
|
||||||
|
[ "${prev}" = "/dev/null" ] || rm -f "${prev}"
|
||||||
|
prev=${next}
|
||||||
|
done
|
||||||
|
|
||||||
|
cat ${prev} >> ${fn}
|
||||||
|
|
||||||
|
vi "${fn}"
|
||||||
|
echo "+ git add ${fn}"
|
||||||
|
git add "${fn}"
|
||||||
|
echo "+ spec template:"
|
||||||
|
echo "PatchN: ${fn}"
|
||||||
|
echo "%patchN -p1 -b .${suffix}"
|
1
sources
Normal file
1
sources
Normal file
@ -0,0 +1 @@
|
|||||||
|
SHA512 (subversion-1.14.0.tar.bz2) = af6b706fdc91f7ab292fce9d9de582da306fd11e92767dc852687e71a6a8b65bb867fa70d5afd7f76a46005acb1b3c2d3193e690def48cd26875b3a7851cd13b
|
84
subversion-1.12.0-linking.patch
Normal file
84
subversion-1.12.0-linking.patch
Normal file
@ -0,0 +1,84 @@
|
|||||||
|
|
||||||
|
Fix the way libtool is used to match standard practice:
|
||||||
|
|
||||||
|
a) link ONLY libraries using -rpath $(libdir), not executables
|
||||||
|
.. this avoids adding an RPATH for $libdir to executables
|
||||||
|
b) link non-installable test binaries using -no-install
|
||||||
|
.. only for convenience but should speed up builds slightly(?)
|
||||||
|
|
||||||
|
--- subversion-1.12.0/build.conf.linking
|
||||||
|
+++ subversion-1.12.0/build.conf
|
||||||
|
@@ -572,7 +572,7 @@
|
||||||
|
path = subversion/bindings/swig/python/libsvn_swig_py
|
||||||
|
libs = libsvn_client libsvn_wc libsvn_ra libsvn_delta libsvn_subr
|
||||||
|
apriconv apr python swig
|
||||||
|
-link-cmd = $(LINK)
|
||||||
|
+link-cmd = $(LINK_LIB)
|
||||||
|
install = swig-py-lib
|
||||||
|
# need special build rule to include -DSWIGPYTHON
|
||||||
|
compile-cmd = $(COMPILE_SWIG_PY)
|
||||||
|
@@ -598,7 +598,7 @@
|
||||||
|
lang = ruby
|
||||||
|
path = subversion/bindings/swig/ruby/libsvn_swig_ruby
|
||||||
|
libs = libsvn_client libsvn_wc libsvn_delta libsvn_subr apriconv apr ruby swig
|
||||||
|
-link-cmd = $(LINK) $(SWIG_RB_LIBS)
|
||||||
|
+link-cmd = $(LINK_LIB) $(SWIG_RB_LIBS)
|
||||||
|
install = swig-rb-lib
|
||||||
|
# need special build rule to include
|
||||||
|
compile-cmd = $(COMPILE_SWIG_RB)
|
||||||
|
@@ -769,6 +769,7 @@
|
||||||
|
libs = libsvn_repos libsvn_fs libsvn_delta libsvn_subr aprutil apriconv apr
|
||||||
|
msvc-static = yes
|
||||||
|
undefined-lib-symbols = yes
|
||||||
|
+link-cmd = $(LINK_TEST_LIB)
|
||||||
|
|
||||||
|
# ----------------------------------------------------------------------------
|
||||||
|
# Tests for libsvn_fs_base
|
||||||
|
--- subversion-1.12.0/build/generator/gen_base.py.linking
|
||||||
|
+++ subversion-1.12.0/build/generator/gen_base.py
|
||||||
|
@@ -599,7 +599,7 @@
|
||||||
|
self.install = options.get('install')
|
||||||
|
self.compile_cmd = options.get('compile-cmd')
|
||||||
|
self.sources = options.get('sources', '*.c *.cpp')
|
||||||
|
- self.link_cmd = options.get('link-cmd', '$(LINK)')
|
||||||
|
+ self.link_cmd = options.get('link-cmd', '$(LINK_LIB)')
|
||||||
|
|
||||||
|
self.external_lib = options.get('external-lib')
|
||||||
|
self.external_project = options.get('external-project')
|
||||||
|
@@ -659,6 +659,14 @@
|
||||||
|
|
||||||
|
self.msvc_force_static = options.get('msvc-force-static') == 'yes'
|
||||||
|
|
||||||
|
+ if self.install in ['test', 'bdb-test', 'sub-test', ]:
|
||||||
|
+ self.link_cmd = '$(LINK_TEST)'
|
||||||
|
+ elif self.install in ['bin', 'tools']:
|
||||||
|
+ self.link_cmd = '$(LINK_EXE)'
|
||||||
|
+ elif self.link_cmd == '$(LINK_LIB)':
|
||||||
|
+ raise GenError('ERROR: Unknown executable link type for ' + self.name + \
|
||||||
|
+ ': ' + self.link_cmd + ' (' + self.install + ')')
|
||||||
|
+
|
||||||
|
def add_dependencies(self):
|
||||||
|
TargetLinked.add_dependencies(self)
|
||||||
|
|
||||||
|
--- subversion-1.12.0/Makefile.in.linking
|
||||||
|
+++ subversion-1.12.0/Makefile.in
|
||||||
|
@@ -268,11 +268,14 @@
|
||||||
|
COMPILE_SVNXX = $(LT_COMPILE_CXX) $(SVNXX_INCLUDES) -o $@ -c
|
||||||
|
COMPILE_SVNXX_TEST = $(LT_COMPILE_CXX) $(SVNXX_INCLUDES) $(BOOST_TEST_CPPFLAGS) -o $@ -c
|
||||||
|
|
||||||
|
-LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(libdir)
|
||||||
|
-LINK_LIB = $(LINK) $(LT_SO_VERSION)
|
||||||
|
-LINK_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=link $(CXX) $(LT_LDFLAGS) $(CXXFLAGS) $(LDFLAGS) -rpath $(libdir)
|
||||||
|
-LINK_CXX_LIB = $(LINK_CXX) $(LT_SO_VERSION)
|
||||||
|
-LINK_SVNXX_TEST = $(LINK_CXX) $(BOOST_TEST_LDFLAGS)
|
||||||
|
+LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS)
|
||||||
|
+LINK_LIB = $(LINK) $(LT_SO_VERSION) -rpath $(libdir)
|
||||||
|
+LINK_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=link $(CXX) $(LT_LDFLAGS) $(CXXFLAGS) $(LDFLAGS)
|
||||||
|
+LINK_CXX_LIB = $(LINK_CXX) $(LT_SO_VERSION) -rpath $(libdir)
|
||||||
|
+LINK_SVNXX_TEST = $(LINK_CXX) $(BOOST_TEST_LDFLAGS) -no-install
|
||||||
|
+LINK_TEST = $(LINK) -no-install
|
||||||
|
+LINK_TEST_LIB = $(LINK_TEST) -avoid-version
|
||||||
|
+LINK_EXE = $(LINK)
|
||||||
|
|
||||||
|
# special link rule for mod_dav_svn
|
||||||
|
LINK_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(APACHE_LIBEXECDIR) -avoid-version -module $(APACHE_LDFLAGS) -shared
|
19
subversion-1.14.0-soversion.patch
Normal file
19
subversion-1.14.0-soversion.patch
Normal file
@ -0,0 +1,19 @@
|
|||||||
|
|
||||||
|
Use the minor version as the revision in the libtool version, so the library
|
||||||
|
soversion is not always 0.0.0. (Does not influence the soname)
|
||||||
|
|
||||||
|
--- subversion-1.14.0/configure.ac.soversion
|
||||||
|
+++ subversion-1.14.0/configure.ac
|
||||||
|
@@ -112,7 +112,11 @@
|
||||||
|
SVN_APR_MAJOR_VERSION=1
|
||||||
|
fi
|
||||||
|
AC_SUBST(SVN_APR_MAJOR_VERSION)
|
||||||
|
-SVN_LT_SOVERSION="-version-info $svn_lib_ver"
|
||||||
|
+
|
||||||
|
+m4_define([svn_ver_minor], m4_bpatsubst(AC_PACKAGE_VERSION, [[0-9]*\.\([0-9]*\)\.[0-9]*], [\1]))
|
||||||
|
+
|
||||||
|
+SVN_LT_SOVERSION="-version-info $svn_lib_ver:svn_ver_minor"
|
||||||
|
+AC_MSG_NOTICE([SVN_LT_SOVERSION $SVN_LT_SOVERSION])
|
||||||
|
AC_SUBST(SVN_LT_SOVERSION)
|
||||||
|
AC_DEFINE_UNQUOTED(SVN_SOVERSION, $svn_lib_ver,
|
||||||
|
[Subversion library major verson])
|
14
subversion-1.14.0-testwarn.patch
Normal file
14
subversion-1.14.0-testwarn.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
|
||||||
|
Suppress gcc 10 warning.
|
||||||
|
|
||||||
|
--- subversion-1.14.0/subversion/tests/svn_test.h.testwarn
|
||||||
|
+++ subversion-1.14.0/subversion/tests/svn_test.h
|
||||||
|
@@ -128,7 +128,7 @@
|
||||||
|
return svn_error_createf(SVN_ERR_TEST_FAILED, NULL, \
|
||||||
|
"Strings not equal\n Expected: '%s'\n Found: '%s'" \
|
||||||
|
"\n at %s:%d", \
|
||||||
|
- tst_str2, tst_str1, __FILE__, __LINE__); \
|
||||||
|
+ tst_str2 ? tst_str2 : "(NULL)", tst_str1 ? tst_str1 : "(NULL)", __FILE__, __LINE__); \
|
||||||
|
} while(0)
|
||||||
|
|
||||||
|
/** Handy macro for testing integer equality.
|
24
subversion-1.8.0-rubybind.patch
Normal file
24
subversion-1.8.0-rubybind.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
|
||||||
|
Try a little harder to avoid svnserve() bind failures.
|
||||||
|
|
||||||
|
--- subversion-1.8.0/subversion/bindings/swig/ruby/test/util.rb.rubybind
|
||||||
|
+++ subversion-1.8.0/subversion/bindings/swig/ruby/test/util.rb
|
||||||
|
@@ -39,7 +39,8 @@ module SvnTestUtil
|
||||||
|
@realm = "sample realm"
|
||||||
|
|
||||||
|
@svnserve_host = "127.0.0.1"
|
||||||
|
- @svnserve_ports = (64152..64282).collect{|x| x.to_s}
|
||||||
|
+ sport = (50000 + rand(100) * 100)
|
||||||
|
+ @svnserve_ports = (sport..sport + 99).collect{|x| x.to_s}
|
||||||
|
|
||||||
|
@tmp_path = Dir.mktmpdir
|
||||||
|
@wc_path = File.join(@tmp_path, "wc")
|
||||||
|
@@ -252,6 +253,8 @@ realm = #{@realm}
|
||||||
|
"--listen-port", port,
|
||||||
|
"-d", "--foreground")
|
||||||
|
}
|
||||||
|
+ # wait a while for svnserve to attempt a bind() and possibly fail
|
||||||
|
+ sleep(1)
|
||||||
|
pid, status = Process.waitpid2(@svnserve_pid, Process::WNOHANG)
|
||||||
|
if status and status.exited?
|
||||||
|
if $DEBUG
|
16
subversion-1.8.5-swigplWall.patch
Normal file
16
subversion-1.8.5-swigplWall.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
|
||||||
|
Don't drop -Wall in the swig Perl bindings, otherwise building with
|
||||||
|
e.g. -Wformat-security might break.
|
||||||
|
|
||||||
|
https://bugzilla.redhat.com/show_bug.cgi?id=1037341
|
||||||
|
|
||||||
|
--- subversion-1.8.5/subversion/bindings/swig/perl/native/Makefile.PL.in.swigplWall
|
||||||
|
+++ subversion-1.8.5/subversion/bindings/swig/perl/native/Makefile.PL.in
|
||||||
|
@@ -54,7 +54,6 @@ my $includes = ' -I/usr/include/apr-1
|
||||||
|
# SWIG is using C++ style comments in an extern "C" code.
|
||||||
|
$cflags =~ s/-ansi\s+//g;
|
||||||
|
$cflags =~ s/-std=c89\s+//g;
|
||||||
|
-$cflags =~ s/-Wall//g;
|
||||||
|
$cflags =~ s/-Wunused//g;
|
||||||
|
$cflags =~ s/-Wshadow//g;
|
||||||
|
$cflags =~ s/-Wstrict-prototypes//g;
|
41
subversion.conf
Normal file
41
subversion.conf
Normal file
@ -0,0 +1,41 @@
|
|||||||
|
|
||||||
|
LoadModule dav_svn_module modules/mod_dav_svn.so
|
||||||
|
LoadModule authz_svn_module modules/mod_authz_svn.so
|
||||||
|
LoadModule dontdothat_module modules/mod_dontdothat.so
|
||||||
|
|
||||||
|
#
|
||||||
|
# Example configuration to enable HTTP access for a directory
|
||||||
|
# containing Subversion repositories, "/var/www/svn". Each repository
|
||||||
|
# must be both:
|
||||||
|
#
|
||||||
|
# a) readable and writable by the 'apache' user, and
|
||||||
|
#
|
||||||
|
# b) labelled with the 'httpd_sys_content_t' context if using
|
||||||
|
# SELinux
|
||||||
|
#
|
||||||
|
|
||||||
|
#
|
||||||
|
# To create a new repository "http://localhost/repos/stuff" using
|
||||||
|
# this configuration, run as root:
|
||||||
|
#
|
||||||
|
# # cd /var/www/svn
|
||||||
|
# # svnadmin create stuff
|
||||||
|
# # chown -R apache:apache stuff
|
||||||
|
# # chcon -R -t httpd_sys_content_t stuff
|
||||||
|
#
|
||||||
|
|
||||||
|
#<Location /repos>
|
||||||
|
# DAV svn
|
||||||
|
# SVNParentPath /var/www/svn
|
||||||
|
#
|
||||||
|
# # Limit write permission to list of valid users.
|
||||||
|
# <LimitExcept GET PROPFIND OPTIONS REPORT>
|
||||||
|
# # Require SSL connection for password protection.
|
||||||
|
# # SSLRequireSSL
|
||||||
|
#
|
||||||
|
# AuthType Basic
|
||||||
|
# AuthName "Authorization Realm"
|
||||||
|
# AuthUserFile /path/to/passwdfile
|
||||||
|
# Require valid-user
|
||||||
|
# </LimitExcept>
|
||||||
|
#</Location>
|
1004
subversion.spec
Normal file
1004
subversion.spec
Normal file
File diff suppressed because it is too large
Load Diff
13
svnserve.service
Normal file
13
svnserve.service
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
[Unit]
|
||||||
|
Description=Subversion protocol daemon
|
||||||
|
After=syslog.target network.target
|
||||||
|
Documentation=man:svnserve(8)
|
||||||
|
|
||||||
|
[Service]
|
||||||
|
Type=forking
|
||||||
|
EnvironmentFile=/etc/sysconfig/svnserve
|
||||||
|
ExecStart=/usr/bin/svnserve --daemon --pid-file=/run/svnserve/svnserve.pid $OPTIONS
|
||||||
|
PrivateTmp=yes
|
||||||
|
|
||||||
|
[Install]
|
||||||
|
WantedBy=multi-user.target
|
4
svnserve.sysconf
Normal file
4
svnserve.sysconf
Normal file
@ -0,0 +1,4 @@
|
|||||||
|
# OPTIONS is used to pass command-line arguments to svnserve.
|
||||||
|
#
|
||||||
|
# Specify the repository location in -r parameter:
|
||||||
|
OPTIONS="-r /var/svn"
|
1
svnserve.tmpfiles
Normal file
1
svnserve.tmpfiles
Normal file
@ -0,0 +1 @@
|
|||||||
|
D /run/svnserve 0700 root root -
|
2358
upstream-key.gpg
Normal file
2358
upstream-key.gpg
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user