rebase to version 1.14.3 (#2256062)

This commit is contained in:
Richard Lescak 2024-01-05 19:00:26 +01:00
parent 2a7e15c28a
commit b0ad4baf4f
5 changed files with 11 additions and 226 deletions

View File

@ -1 +1 @@
SHA512 (subversion-1.14.2.tar.bz2) = 20ada4688ca07d9fb8da4b7d53b5084568652a3b9418c65e688886bae950a16a3ff37710fcfc9c29ef14a89e75b2ceec4e9cf35d5876a7896ebc2b512cfb9ecc
SHA512 (subversion-1.14.3.tar.bz2) = 40b172492005fd3b0cd9e457b4444af8ea5d8ff8fc161a9a0c6dc3a7314c6ad4ff75a4676f68a1919ae6273ae03e34d04eba8c1c37b8c0b4ec70d6731b527b41

View File

@ -1,14 +0,0 @@
Use read_file instead of deprecated readfp - removed in Python 3.11
diff -ur subversion-1.14.1/build/generator/gen_base.py subversion-1.14.1-patched/build/generator/gen_base.py
--- subversion-1.14.1/build/generator/gen_base.py 2019-11-04 06:59:36.000000000 +0100
+++ subversion-1.14.1-patched/build/generator/gen_base.py 2021-12-15 14:04:50.041649320 +0100
@@ -76,7 +76,7 @@
# Now read and parse build.conf
parser = configparser.ConfigParser()
- parser.readfp(open(fname))
+ parser.read_file(open(fname))
self.conf = build_path(os.path.abspath(fname))

View File

@ -1,131 +0,0 @@
------------------------------------------------------------------------
r1904472 | hartmannathan | 2022-10-09 21:50:28 +0900 (Sun, 09 Oct 2022) | 22 lines
swig-rb: Use Ruby API 'File.exist?' instead of deprecated 'File.exists?'
The Ruby API 'File.exists?' has been deprecated since Ruby 2.1 and is removed
as of Ruby 3.2. Use 'File.exist?' instead, which exists at least as far back
as Ruby 1.8. (According to our configure.ac, we support Ruby 1.8.x and newer,
except between 1.9 and 1.9.3.)
* subversion/bindings/swig/ruby/svn/util.rb
(): As above.
* subversion/bindings/swig/ruby/test/test_wc.rb
(SvnWcTest::test_adm_ensure,
SvnWcTest::test_delete,
SvnWcTest::test_update_editor,
SvnWcTest::test_update_editor_options,
SvnWcTest::test_switch_editor): As above.
* subversion/bindings/swig/ruby/test/windows_util.rb
(SvnTestUtil::Windows::SetupEnvironment::gen_make_opts): As above.
Found by: Mamoru TASAKA (mtasaka {_AT_} fedoraproject (dot) org)
------------------------------------------------------------------------
Index: subversion/bindings/swig/ruby/svn/util.rb
===================================================================
--- subversion/bindings/swig/ruby/svn/util.rb (revision 1904471)
+++ subversion/bindings/swig/ruby/svn/util.rb (revision 1904472)
@@ -20,7 +20,7 @@
if /cygwin|mingw|mswin32|bccwin32/.match(RUBY_PLATFORM)
$LOAD_PATH.each do |load_path|
svn_ext_path = File.join(load_path, "svn", "ext")
- if File.exists?(svn_ext_path)
+ if File.exist?(svn_ext_path)
svn_ext_path_win = File.expand_path(svn_ext_path)
svn_ext_path_win = svn_ext_path.gsub(File::SEPARATOR, File::ALT_SEPARATOR)
unless ENV["PATH"].split(";").find {|path| path == svn_ext_path_win}
Index: subversion/bindings/swig/ruby/test/test_wc.rb
===================================================================
--- subversion/bindings/swig/ruby/test/test_wc.rb (revision 1904471)
+++ subversion/bindings/swig/ruby/test/test_wc.rb (revision 1904472)
@@ -342,11 +342,11 @@
def test_adm_ensure
adm_dir = Dir.glob(File.join(@wc_path, "{.,_}svn")).first
- assert(File.exists?(adm_dir))
+ assert(File.exist?(adm_dir))
FileUtils.rm_rf(adm_dir)
- assert(!File.exists?(adm_dir))
+ assert(!File.exist?(adm_dir))
Svn::Wc.ensure_adm(@wc_path, @fs.uuid, @repos_uri, @repos_uri, 0)
- assert(File.exists?(adm_dir))
+ assert(File.exist?(adm_dir))
end
def test_merge
@@ -474,19 +474,19 @@
ctx.add(path)
ctx.ci(@wc_path).revision
- assert(File.exists?(path))
+ assert(File.exist?(path))
Svn::Wc::AdmAccess.open(nil, @wc_path, true, 5) do |access|
access.delete(path)
end
- assert(!File.exists?(path))
+ assert(!File.exist?(path))
ctx.revert(path)
- assert(File.exists?(path))
+ assert(File.exist?(path))
Svn::Wc::AdmAccess.open(nil, @wc_path, true, 5) do |access|
access.delete(path, nil, nil, true)
end
- assert(File.exists?(path))
+ assert(File.exist?(path))
end
end
@@ -808,9 +808,9 @@
ctx.add(path2)
rev2 = ctx.commit(@wc_path).revision
- assert(File.exists?(path2))
+ assert(File.exist?(path2))
assert_equal(0, ctx.up(@wc_path, 0))
- assert(!File.exists?(path2))
+ assert(!File.exist?(path2))
Svn::Wc::AdmAccess.open(nil, @wc_path) do |access|
editor = access.update_editor('', 0)
assert_equal(0, editor.target_revision)
@@ -848,9 +848,9 @@
ctx.add(path2)
rev2 = ctx.commit(@wc_path).revision
- assert(File.exists?(path2))
+ assert(File.exist?(path2))
assert_equal(0, ctx.up(@wc_path, 0))
- assert(!File.exists?(path2))
+ assert(!File.exist?(path2))
notification_count = 0
Svn::Wc::AdmAccess.open(nil, @wc_path) do |access|
notify_func = Proc.new {|n| notification_count += 1}
@@ -946,9 +946,9 @@
ctx.add(dir2_path)
rev2 = ctx.commit(@wc_path).revision
- assert(File.exists?(path1))
+ assert(File.exist?(path1))
assert_equal(rev2, ctx.switch(@wc_path, dir2_uri))
- assert(File.exists?(File.join(@wc_path, file2)))
+ assert(File.exist?(File.join(@wc_path, file2)))
Svn::Wc::AdmAccess.open_anchor(@wc_path) do |access, dir_access, target|
editor = dir_access.switch_editor('', dir1_uri, rev2)
assert_equal(rev2, editor.target_revision)
Index: subversion/bindings/swig/ruby/test/windows_util.rb
===================================================================
--- subversion/bindings/swig/ruby/test/windows_util.rb (revision 1904471)
+++ subversion/bindings/swig/ruby/test/windows_util.rb (revision 1904472)
@@ -115,7 +115,7 @@
lines = []
gen_make_opts = File.join(@@top_dir, "gen-make.opts")
lines =
- File.read(gen_make_opts).lines.to_a if File.exists?(gen_make_opts)
+ File.read(gen_make_opts).lines.to_a if File.exist?(gen_make_opts)
config = Hash.new do |hash, key|
if /^--with-(.*)$/ =~ key
hash[key] = File.join(@@top_dir, $1)

View File

@ -1,64 +0,0 @@
From 8ff4cfd06ce554e9df31a088c9d09f45278c6de4 Mon Sep 17 00:00:00 2001
From: Yasuhito Futatsuki <futatuki@apache.org>
Date: Tue, 20 Sep 2022 12:57:06 +0000
Subject: [PATCH] swig-py: Fix conditionals by SWIG version and by Python
version for proxy code.
We are using different code for proxy object, by Python version and by SWIG
version. The distinguish between Python 2 and Python 3 was done by SWIG
macro "SWIGPYTHON_PY3". However, the macro was dropped since SWIG commit
a343b7e[1], between SWIG 4.0.2 release and upcoming SWIG 4.1.0 release.
As we already dropped support for the combination of SWIG >= 4.0 and Python 2,
we should detect Python 2 only in SWIG < 4.0 case. So we can rely on the macro
only in the case.
* subversion/bindings/swig/include/proxy.swg ():
Reorder the conditionals distinguish SWIG versions and Python versions,
as described above.
Found by: Jitka Plesnikova (jplesnik {_AT_} redhat.com)
Suggested by: Julien Schueller (schueller {_AT_} phimeca.com) [2]
[1] https://github.com/swig/swig/commit/a343b7e254567a64761bc1be7dc55b7b7424ec52
[2] https://github.com/swig/swig/issues/2373#issuecomment-1250997124
git-svn-id: https://svn.apache.org/repos/asf/subversion/trunk@1904167 13f79535-47bb-0310-9956-ffa450edef68
---
subversion/bindings/swig/include/proxy.swg | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/subversion/bindings/swig/include/proxy.swg b/subversion/bindings/swig/include/proxy.swg
index ac67d434ca..7d2d0dd033 100644
--- a/subversion/bindings/swig/include/proxy.swg
+++ b/subversion/bindings/swig/include/proxy.swg
@@ -66,7 +66,6 @@
fn()
%}
-#if defined(SWIGPYTHON_PY3)
#if SWIG_VERSION >= 0x040000
%pythoncode %{
# -classic and -modern options have been dropped and this variable
@@ -76,7 +75,7 @@
_set_instance_attr = _swig_setattr_nondynamic_instance_variable(object.__setattr__)
%}
-#else
+#elif defined(SWIGPYTHON_PY3)
%pythoncode %{
# SWIG classes generated with -modern do not define this variable
try:
@@ -90,7 +89,6 @@
_set_instance_attr = _swig_setattr_nondynamic_method(object.__setattr__)
%}
-#endif
#else
%pythoncode %{
# SWIG classes generated with -classic do not define this variable,
--
2.37.3

View File

@ -1,9 +1,6 @@
# Disable to avoid all the test suites
%if 0%{?rhel} > 9 || 0%{?eln}
%bcond_with tests
%else
%bcond_without tests
%endif
# Disable automatic .la file removal
%global __brp_remove_la_files %nil
@ -62,8 +59,8 @@
Summary: A Modern Concurrent Version Control System
Name: subversion
Version: 1.14.2
Release: 23%{?dist}
Version: 1.14.3
Release: 1%{?dist}
License: Apache-2.0
URL: https://subversion.apache.org/
Source0: https://downloads.apache.org/subversion/subversion-%{version}.tar.bz2
@ -80,11 +77,8 @@ Patch3: subversion-1.14.2-soversion.patch
Patch4: subversion-1.8.0-rubybind.patch
Patch5: subversion-1.8.5-swigplWall.patch
Patch6: subversion-1.14.1-testnomagic.patch
Patch8: subversion-1.14.1-python-3.11-build.patch
Patch9: subversion-1.14.2-swig-py-Fix-conditionals-by-SWIG-version-and-by-Pyth.patch
Patch10: subversion-1.14.2-ruby32-remove-deprecated-api.patch
Patch11: subversion-ruby-c99.patch
Patch12: subversion-1.14.2-modsyms.patch
Patch7: subversion-ruby-c99.patch
Patch8: subversion-1.14.2-modsyms.patch
BuildRequires: make
BuildRequires: autoconf, libtool, texinfo, which, gcc, gcc-c++
BuildRequires: swig >= 1.3.24, gettext
@ -247,11 +241,8 @@ This package includes supplementary tools for use with Subversion.
%patch -P4 -p1 -b .rubybind
%patch -P5 -p1 -b .swigplWall
%patch -P6 -p1 -b .testnomagic
%patch -P8 -p1 -b .pythonbuild
%patch -P9 -p1 -b .swigfix
%patch -P10 -p0 -b .ruby32
%patch -P11 -p1
%patch -P12 -p1 -b .modsyms
%patch -P7 -p1
%patch -P8 -p1 -b .modsyms
:
: === Building:
@ -593,6 +584,9 @@ make check-javahl
%endif
%changelog
* Fri Jan 05 2024 Richard Lescak <rlescak@redhat.com> - 1.14.3-1
- rebase to version 1.14.3 (#2256062)
* Wed Jan 03 2024 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.14.2-23
- Rebuild for https://fedoraproject.org/wiki/Changes/Ruby_3.3