- update to 1.6.0

This commit is contained in:
jorton 2009-03-31 16:15:40 +00:00
parent 6868f5144f
commit abad95ccc1
11 changed files with 136 additions and 217 deletions

View File

@ -1 +1 @@
subversion-1.5.6.tar.gz
subversion-1.6.0.tar.gz

View File

@ -1 +1 @@
ad81e54058e64b5d399d3eda5f8bfcd1 subversion-1.5.6.tar.gz
b74985c9191d4a652a9f618a06171880 subversion-1.6.0.tar.gz

View File

@ -1,84 +0,0 @@
--- subversion-1.5.2/build.conf.pie
+++ subversion-1.5.2/build.conf
@@ -452,7 +452,7 @@ type = swig_lib
lang = python
path = subversion/bindings/swig/python/libsvn_swig_py
libs = libsvn_client libsvn_wc libsvn_ra libsvn_delta libsvn_subr apriconv apr
-link-cmd = $(LINK) $(SWIG_PY_LIBS)
+link-cmd = $(LINK_LIB) $(SWIG_PY_LIBS)
install = swig-py-lib
# need special build rule to include -DSWIGPYTHON
compile-cmd = $(COMPILE_SWIG_PY)
@@ -475,7 +475,7 @@ type = swig_lib
lang = ruby
path = subversion/bindings/swig/ruby/libsvn_swig_ruby
libs = libsvn_client libsvn_wc libsvn_delta libsvn_subr apriconv apr
-link-cmd = $(LINK) $(SWIG_RB_LIBS)
+link-cmd = $(LINK_LIB) $(SWIG_RB_LIBS)
install = swig-rb-lib
# need special build rule to include
compile-cmd = $(COMPILE_SWIG_RB)
--- subversion-1.5.2/build/generator/gen_base.py.pie
+++ subversion-1.5.2/build/generator/gen_base.py
@@ -411,6 +411,9 @@ class TargetExe(TargetLinked):
self.manpages = options.get('manpages', '')
self.testing = options.get('testing')
+ if self.install == 'test' or self.install == 'bdb-test':
+ self.link_cmd = '$(LINK_TEST)'
+
def add_dependencies(self):
TargetLinked.add_dependencies(self)
@@ -453,8 +456,11 @@ class TargetLib(TargetLinked):
self.msvc_fake = options.get('msvc-fake') == 'yes' # has fake target
self.msvc_export = string.split(options.get('msvc-export', ''))
- ### hmm. this is Makefile-specific
- self.link_cmd = '$(LINK_LIB)'
+ ### more Makefile-specific stuff:
+ if self.install == 'test':
+ self.link_cmd = '$(LINK_TEST_LIB)'
+ elif self.link_cmd == '$(LINK)':
+ self.link_cmd = '$(LINK_LIB)'
class TargetApacheMod(TargetLib):
--- subversion-1.5.2/Makefile.in.pie
+++ subversion-1.5.2/Makefile.in
@@ -2,7 +2,7 @@
# Makefile.in: template Makefile for Subversion
#
# ====================================================================
-# Copyright (c) 2000-2006 CollabNet. All rights reserved.
+# Copyright (c) 2000-2006, 2008 CollabNet. All rights reserved.
#
# This software is licensed as described in the file COPYING, which
# you should have received as part of this distribution. The terms
@@ -151,9 +151,10 @@ CPPFLAGS = @CPPFLAGS@ $(EXTRA_CPPFLAGS)
LDFLAGS = @LDFLAGS@ $(EXTRA_LDFLAGS)
SWIG_LDFLAGS = @SWIG_LDFLAGS@ $(EXTRA_SWIG_LDFLAGS)
-COMPILE = $(CC) $(CPPFLAGS) $(CFLAGS) $(INCLUDES)
+BASE_COMPILE = $(CC) $(CPPFLAGS) $(CFLAGS) $(INCLUDES)
+COMPILE = $(BASE_COMPILE) -fpie
COMPILE_CXX = $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(INCLUDES)
-LT_COMPILE = $(LIBTOOL) $(LTFLAGS) --mode=compile $(COMPILE)
+LT_COMPILE = $(LIBTOOL) $(LTFLAGS) --mode=compile $(BASE_COMPILE)
# special compilation for files destined for mod_dav_svn
COMPILE_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=compile $(CC) $(CPPFLAGS) $(CFLAGS) $(APACHE_INCLUDES) $(INCLUDES) -o $@ -c
@@ -168,8 +169,11 @@ COMPILE_JAVAHL_CXX = $(LIBTOOL) $(LTCXXF
COMPILE_JAVAHL_JAVAC = $(JAVAC) $(JAVAC_FLAGS)
COMPILE_JAVAHL_JAVAH = $(JAVAH)
-LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS)
-LINK_LIB = $(LINK) -rpath $(libdir)
+BASE_LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS)
+LINK = $(BASE_LINK) -pie
+LINK_TEST = $(BASE_LINK) -no-install
+LINK_LIB = $(BASE_LINK) -rpath $(libdir)
+LINK_TEST_LIB = $(BASE_LINK)
# special link rule for mod_dav_svn
LINK_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(APACHE_LIBEXECDIR) -avoid-version -module $(APACHE_LDFLAGS)

View File

@ -1,85 +0,0 @@
--- subversion-1.5.6/autogen.sh.lt22
+++ subversion-1.5.6/autogen.sh
@@ -48,53 +48,7 @@ if [ "x$libtoolize" = "x" ]; then
fi
rm -f build/config.guess build/config.sub
-$libtoolize --copy --automake --force
-
-ltpath="`dirname $libtoolize`"
-ltfile=${LIBTOOL_M4-`cd $ltpath/../share/aclocal ; pwd`/libtool.m4}
-
-if [ ! -f $ltfile ]; then
- echo "$ltfile not found (try setting the LIBTOOL_M4 environment variable)"
- exit 1
-fi
-
-echo "Copying libtool helper: $ltfile"
-# An ancient helper might already be present from previous builds,
-# and it might be write-protected (e.g. mode 444, seen on FreeBSD).
-# This would cause cp to fail and print an error message, but leave
-# behind a potentially outdated libtool helper. So, remove before
-# copying:
-rm -f build/libtool.m4
-cp $ltfile build/libtool.m4
-
-for file in ltoptions.m4 ltsugar.m4 ltversion.m4 lt~obsolete.m4; do
- rm -f build/$file
-
- if [ $lt_major_version -ge 2 ]; then
- ltfile=${LIBTOOL_M4-`cd $ltpath/../share/aclocal ; pwd`/$file}
-
- if [ ! -f $ltfile ]; then
- echo "$ltfile not found (try setting the LIBTOOL_M4 environment variable)"
- exit 1
- fi
-
- echo "Copying libtool helper: $ltfile"
- cp $ltfile build/$file
- fi
-done
-
-if [ $lt_major_version -ge 2 ]; then
- for file in config.guess config.sub; do
- configfile=${LIBTOOL_CONFIG-`cd $ltpath/../share/libtool/config ; pwd`/$file}
-
- if [ ! -f $configfile ]; then
- echo "$configfile not found (try setting the LIBTOOL_CONFIG environment variable)"
- exit 1
- fi
-
- cp $configfile build/$file
- done
-fi
+$libtoolize --copy --automake --force --install
# Create the file detailing all of the build outputs for SVN.
#
--- subversion-1.5.6/configure.ac.lt22
+++ subversion-1.5.6/configure.ac
@@ -11,6 +11,7 @@ AC_INIT([subversion],
AC_CONFIG_SRCDIR(subversion/include/svn_types.h)
AC_CONFIG_AUX_DIR([build])
+AC_CONFIG_MACRO_DIR([build])
AC_MSG_NOTICE([Configuring Subversion ]AC_PACKAGE_VERSION)
@@ -27,6 +28,7 @@ SVN_CONFIG_NICE(config.nice)
# Look for a C compiler (before anything can set CFLAGS)
AC_PROG_CC
+AC_PROG_CXX
# Look for a C pre-processor
AC_PROG_CPP
@@ -687,8 +689,7 @@ if test "$do_javahl_build" = "yes"; then
Please specify a suitable JDK using the --with-jdk option.])
fi
- AC_PROG_CXX
-
+
dnl The temporary directory where libtool compiles libsvnjavahl.
dnl N.B. objdir is "the name of the directory that contains temporary
dnl libtool files" and it is set by libtool.m4

View File

@ -1,10 +1,21 @@
APR and APR-util are patched to store dependencies in the .la file.
--- subversion-0.20.1/build/ac-macros/aprutil.m4.deplibs 2003-03-26 16:34:47.000000000 +0000
+++ subversion-0.20.1/build/ac-macros/aprutil.m4 2003-04-29 11:03:54.000000000 +0100
@@ -64,11 +64,9 @@
AC_MSG_ERROR([apu-config --includes failed])
--- subversion-1.6.0/build/ac-macros/apr.m4.deplibs
+++ subversion-1.6.0/build/ac-macros/apr.m4
@@ -76,9 +76,9 @@ AC_DEFUN(SVN_LIB_APR,
dnl When APR stores the dependent libs in the .la file, we don't need
dnl --libs.
- SVN_APR_LIBS="`$apr_config --link-libtool --libs`"
+ SVN_APR_LIBS="`$apr_config --link-libtool`"
if test $? -ne 0; then
- AC_MSG_ERROR([apr-config --link-libtool --libs failed])
+ AC_MSG_ERROR([apr-config --link-libtool failed])
fi
SVN_APR_EXPORT_LIBS="`$apr_config --link-ld --libs`"
--- subversion-1.6.0/build/ac-macros/aprutil.m4.deplibs
+++ subversion-1.6.0/build/ac-macros/aprutil.m4
@@ -77,11 +77,9 @@ AC_DEFUN(SVN_LIB_APRUTIL,
AC_MSG_ERROR([apu-config --prefix failed])
fi
- dnl When APR stores the dependent libs in the .la file, we don't need
@ -17,17 +28,3 @@ APR and APR-util are patched to store dependencies in the .la file.
fi
SVN_APRUTIL_EXPORT_LIBS="`$apu_config --link-ld --libs`"
--- subversion-0.20.1/build/ac-macros/apr.m4.deplibs 2003-03-26 16:34:47.000000000 +0000
+++ subversion-0.20.1/build/ac-macros/apr.m4 2003-04-29 11:03:45.000000000 +0100
@@ -68,9 +68,9 @@
dnl When APR stores the dependent libs in the .la file, we don't need
dnl --libs.
- SVN_APR_LIBS="`$apr_config --link-libtool --libs`"
+ SVN_APR_LIBS="`$apr_config --link-libtool`"
if test $? -ne 0; then
- AC_MSG_ERROR([apr-config --link-libtool --libs failed])
+ AC_MSG_ERROR([apr-config --link-libtool failed])
fi
SVN_APR_EXPORT_LIBS="`$apr_config --link-ld --libs`"

View File

@ -0,0 +1,62 @@
--- subversion-1.6.0/build.conf.pie
+++ subversion-1.6.0/build.conf
@@ -472,7 +472,7 @@ type = swig_lib
lang = python
path = subversion/bindings/swig/python/libsvn_swig_py
libs = libsvn_client libsvn_wc libsvn_ra libsvn_delta libsvn_subr apriconv apr
-link-cmd = $(LINK) $(SWIG_PY_LIBS)
+link-cmd = $(LINK_LIB) $(SWIG_PY_LIBS)
install = swig-py-lib
# need special build rule to include -DSWIGPYTHON
compile-cmd = $(COMPILE_SWIG_PY)
@@ -495,7 +495,7 @@ type = swig_lib
lang = ruby
path = subversion/bindings/swig/ruby/libsvn_swig_ruby
libs = libsvn_client libsvn_wc libsvn_delta libsvn_subr apriconv apr
-link-cmd = $(LINK) $(SWIG_RB_LIBS)
+link-cmd = $(LINK_LIB) $(SWIG_RB_LIBS)
install = swig-rb-lib
# need special build rule to include
compile-cmd = $(COMPILE_SWIG_RB)
--- subversion-1.6.0/build/generator/gen_base.py.pie
+++ subversion-1.6.0/build/generator/gen_base.py
@@ -413,6 +413,9 @@ class TargetExe(TargetLinked):
self.manpages = options.get('manpages', '')
self.testing = options.get('testing')
+ if self.install == 'test' or self.install == 'bdb-test':
+ self.link_cmd = '$(LINK_TEST)'
+
def add_dependencies(self):
TargetLinked.add_dependencies(self)
@@ -455,8 +458,11 @@ class TargetLib(TargetLinked):
self.msvc_fake = options.get('msvc-fake') == 'yes' # has fake target
self.msvc_export = options.get('msvc-export', '').split()
- ### hmm. this is Makefile-specific
- self.link_cmd = '$(LINK_LIB)'
+ ### more Makefile-specific stuff:
+ if self.install == 'test':
+ self.link_cmd = '$(LINK_TEST_LIB)'
+ elif self.link_cmd == '$(LINK)':
+ self.link_cmd = '$(LINK_LIB)'
class TargetApacheMod(TargetLib):
--- subversion-1.6.0/Makefile.in.pie
+++ subversion-1.6.0/Makefile.in
@@ -184,8 +185,11 @@ COMPILE_JAVAHL_CXX = $(LIBTOOL) $(LTCXXF
COMPILE_JAVAHL_JAVAC = $(JAVAC) $(JAVAC_FLAGS)
COMPILE_JAVAHL_JAVAH = $(JAVAH)
-LINK_LIB = $(LINK) -rpath $(libdir)
-LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(libdir)
+BASE_LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS)
+LINK = $(BASE_LINK) -pie
+LINK_TEST = $(BASE_LINK) -no-install
+LINK_LIB = $(BASE_LINK) -rpath $(libdir)
+LINK_TEST_LIB = $(BASE_LINK)
LINK_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=link $(CXX) $(LT_LDFLAGS) $(CXXFLAGS) $(LDFLAGS) -rpath $(libdir)
# special link rule for mod_dav_svn

View File

@ -7,11 +7,11 @@ The redundant RPATH can also cause obscure build failures by causing
in-build binaries to pick up libraries from the system environment,
which libtool will otherwise avoid.
--- subversion-1.5.1/build/generator/gen_base.py.rpath
+++ subversion-1.5.1/build/generator/gen_base.py
@@ -453,6 +453,9 @@ class TargetLib(TargetLinked):
--- subversion-1.6.0/build/generator/gen_base.py.rpath
+++ subversion-1.6.0/build/generator/gen_base.py
@@ -455,6 +455,9 @@ class TargetLib(TargetLinked):
self.msvc_fake = options.get('msvc-fake') == 'yes' # has fake target
self.msvc_export = string.split(options.get('msvc-export', ''))
self.msvc_export = options.get('msvc-export', '').split()
+ ### hmm. this is Makefile-specific
+ self.link_cmd = '$(LINK_LIB)'
@ -19,15 +19,13 @@ which libtool will otherwise avoid.
class TargetApacheMod(TargetLib):
def __init__(self, name, options, gen_obj):
--- subversion-1.5.1/Makefile.in.rpath
+++ subversion-1.5.1/Makefile.in
@@ -167,7 +167,8 @@ COMPILE_JAVAHL_CXX = $(LIBTOOL) $(LTCXXF
--- subversion-1.6.0/Makefile.in.rpath
+++ subversion-1.6.0/Makefile.in
@@ -184,6 +184,7 @@ COMPILE_JAVAHL_CXX = $(LIBTOOL) $(LTCXXF
COMPILE_JAVAHL_JAVAC = $(JAVAC) $(JAVAC_FLAGS)
COMPILE_JAVAHL_JAVAH = $(JAVAH)
-LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(libdir)
+LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS)
+LINK_LIB = $(LINK) -rpath $(libdir)
LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(libdir)
LINK_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=link $(CXX) $(LT_LDFLAGS) $(CXXFLAGS) $(LDFLAGS) -rpath $(libdir)
# special link rule for mod_dav_svn
LINK_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(APACHE_LIBEXECDIR) -avoid-version -module $(APACHE_LDFLAGS)

View File

@ -0,0 +1,28 @@
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
iEYEABECAAYFAknClnUACgkQCwOubk4kUXzzrwCeP6g1IJ5tC/dcTaSon+AFeH0V
zNYAoKY0ZhzX0oLmSdNDeZb5IbE0/BMl
=cV+A
-----END PGP SIGNATURE-----
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (FreeBSD)
iEYEABECAAYFAknCqHAACgkQ/P1jBZgh97LYHQCdFFNSRiPWNFaHf00fzTUJRVHI
ZdwAn0SIV4WEu2ek8PWYjY9Dfs1SOgEo
=DXbN
-----END PGP SIGNATURE-----
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
iEYEABECAAYFAknCqzUACgkQokEGqRcG/W6M6wCcDH7uBuRCRRSp/MozjJJ+P1RZ
l0sAn2pLD/nyYTKMofWAG1Ce5B6rAWMg
=rhHR
-----END PGP SIGNATURE-----
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
iEYEABECAAYFAknDRyEACgkQvJ27E9sAokjuQACfSPnJdzy7XV9PuFTl7y9R4nCV
fawAnjZdVWUBYwi6boWYlltmxHPDVk1O
=LYDm
-----END PGP SIGNATURE-----

View File

@ -5,11 +5,12 @@ LoadModule authz_svn_module modules/mod_authz_svn.so
#
# Example configuration to enable HTTP access for a directory
# containing Subversion repositories, "/var/www/svn". Each repository
# must be readable and writable by the 'apache' user. Note that if
# SELinux is enabled, the repositories must be labelled with a context
# which httpd can write to; this will happen by default for
# directories created in /var/www. Use "restorecon -R /var/www/svn"
# to label the repositories if upgrading from a previous release.
# must be both:
#
# a) readable and writable by the 'apache' user, and
#
# b) labelled with the 'http_sys_content_rw_t' context if using
# SELinux
#
#
@ -19,6 +20,7 @@ LoadModule authz_svn_module modules/mod_authz_svn.so
# # cd /var/www/svn
# # svnadmin create stuff
# # chown -R apache.apache stuff
# # chcon -R -t -t http_sys_content_rw_t stuff
#
#<Location /repos>

View File

@ -14,8 +14,8 @@
Summary: A Modern Concurrent Version Control System
Name: subversion
Version: 1.5.6
Release: 4
Version: 1.6.0
Release: 2
License: ASL 1.1
Group: Development/Tools
URL: http://subversion.tigris.org/
@ -24,10 +24,9 @@ Source1: subversion.conf
Source3: filter-requires.sh
Source4: http://www.xsteve.at/prg/emacs/psvn.el
Source5: psvn-init.el
Patch1: subversion-1.5.6-lt22.patch
Patch2: subversion-0.20.1-deplibs.patch
Patch3: subversion-1.5.1-rpath.patch
Patch6: subversion-1.5.2-pie.patch
Patch2: subversion-1.6.0-deplibs.patch
Patch3: subversion-1.6.0-rpath.patch
Patch6: subversion-1.6.0-pie.patch
Patch7: subversion-1.1.3-java.patch
BuildRequires: autoconf, libtool, python, python-devel, texinfo, which
BuildRequires: db4-devel >= 4.1.25, swig >= 1.3.24, gettext
@ -105,7 +104,6 @@ This package includes the Ruby bindings to the Subversion libraries.
%prep
%setup -q
%patch1 -p1 -b .lt22
%patch2 -p1 -b .deplibs
%patch3 -p1 -b .rpath
%patch6 -p1 -b .pie
@ -130,7 +128,7 @@ export svn_cv_ruby_link="%{__cc} -shared"
export svn_cv_ruby_sitedir_libsuffix=""
export svn_cv_ruby_sitedir_archsuffix=""
export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path}
export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path} CFLAGS="$RPM_OPT_FLAGS -fPIE"
%configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
--with-swig --with-neon=%{_prefix} \
--with-ruby-sitedir=%{ruby_sitearch} \
@ -287,6 +285,9 @@ rm -rf ${RPM_BUILD_ROOT}
%endif
%changelog
* Tue Mar 31 2009 Joe Orton <jorton@redhat.com> 1.6.0-1
- update to 1.6.0
* Thu Mar 12 2009 Dennis Gilmore <dennis@ausil.us> - 1.5.6-4
- use -fPIE on sparc64

View File

@ -1 +1 @@
subversion-1.5.6.tar.gz
subversion-1.6.0.tar.gz