Remove obsolete patches.
This commit is contained in:
parent
26d2f416ea
commit
a6aa7f6ff5
@ -1,38 +0,0 @@
|
||||
--- subversion-1.10.0/build/ac-macros/libsecret.m4.pkgsecret
|
||||
+++ subversion-1.10.0/build/ac-macros/libsecret.m4
|
||||
@@ -54,6 +54,7 @@
|
||||
[Is libsecret support enabled?])
|
||||
SVN_GNOME_KEYRING_INCLUDES="`$PKG_CONFIG --cflags libsecret-1`"
|
||||
SVN_GNOME_KEYRING_LIBS="`$PKG_CONFIG --libs libsecret-1`"
|
||||
+ SVN_GNOME_KEYRING_PCLIBS="libsecret-1"
|
||||
found_gnome_keyring="yes"
|
||||
else
|
||||
if test "$with_gnome_keyring" = "yes"; then
|
||||
@@ -90,4 +91,5 @@
|
||||
fi
|
||||
AC_SUBST(SVN_GNOME_KEYRING_INCLUDES)
|
||||
AC_SUBST(SVN_GNOME_KEYRING_LIBS)
|
||||
+ AC_SUBST(SVN_GNOME_KEYRING_PCLIBS)
|
||||
])
|
||||
--- subversion-1.10.0/build.conf.pkgsecret
|
||||
+++ subversion-1.10.0/build.conf
|
||||
@@ -1464,7 +1464,8 @@
|
||||
[gnome-keyring]
|
||||
type = lib
|
||||
external-lib = $(SVN_GNOME_KEYRING_LIBS)
|
||||
-pkg-config = gnome-keyring-1
|
||||
+pkg-config = @SVN_GNOME_KEYRING_PCLIBS@
|
||||
+pkg-config-private = yes
|
||||
|
||||
[kwallet]
|
||||
type = lib
|
||||
--- subversion-1.10.0/configure.ac.pkgsecret
|
||||
+++ subversion-1.10.0/configure.ac
|
||||
@@ -593,6 +593,7 @@
|
||||
[Is GNOME Keyring support enabled?])
|
||||
CPPFLAGS="$old_CPPFLAGS"
|
||||
SVN_GNOME_KEYRING_LIBS="`$PKG_CONFIG --libs glib-2.0 gnome-keyring-1`"
|
||||
+ SVN_GNOME_KEYRING_PCLIBS="glib-2.0 gnome-keyring-1"
|
||||
else
|
||||
AC_MSG_RESULT([no])
|
||||
if test "$with_old_gnome_keyring" = "yes"; then
|
@ -1,32 +0,0 @@
|
||||
|
||||
Ensure that python scripts executed during the build use the same python
|
||||
interpreter specified as $PYTHON by the spec file.
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1552079
|
||||
|
||||
--- subversion-1.9.7/build/generator/gen_make.py.pybinary
|
||||
+++ subversion-1.9.7/build/generator/gen_make.py
|
||||
@@ -507,7 +507,7 @@
|
||||
standalone.write('top_srcdir = .\n')
|
||||
standalone.write('top_builddir = .\n')
|
||||
standalone.write('SWIG = swig\n')
|
||||
- standalone.write('PYTHON = python\n')
|
||||
+ standalone.write('PYTHON = ' + sys.executable + '\n')
|
||||
standalone.write('\n')
|
||||
standalone.write(open("build-outputs.mk","r").read())
|
||||
standalone.close()
|
||||
--- subversion-1.9.7/subversion/tests/cmdline/svntest/main.py.pybinary
|
||||
+++ subversion-1.9.7/subversion/tests/cmdline/svntest/main.py
|
||||
@@ -410,9 +410,9 @@
|
||||
should be passed to wait_on_pipe."""
|
||||
command = [str(x) for x in command]
|
||||
|
||||
- # On Windows subprocess.Popen() won't accept a Python script as
|
||||
- # a valid program to execute, rather it wants the Python executable.
|
||||
- if (sys.platform == 'win32') and (command[0].endswith('.py')):
|
||||
+ # Always run python scripts under the same Python executable as used
|
||||
+ # for the test suite.
|
||||
+ if command[0].endswith('.py'):
|
||||
command.insert(0, sys.executable)
|
||||
|
||||
command_string = command[0] + ' ' + ' '.join(map(_quote_arg, command[1:]))
|
Loading…
Reference in New Issue
Block a user