add build conditionals for python2, python3 and kwallet

Resolves: rhbz#1552079
This commit is contained in:
Joe Orton 2018-03-27 20:48:07 +01:00
parent 193e2e3a7d
commit 98ddd79d86
2 changed files with 33 additions and 1 deletions

View File

@ -1,3 +1,9 @@
Ensure that python scripts executed during the build use the same python
interpreter specified as $PYTHON by the spec file.
https://bugzilla.redhat.com/show_bug.cgi?id=1552079
--- subversion-1.9.7/build/generator/gen_make.py.pybinary
+++ subversion-1.9.7/build/generator/gen_make.py
@@ -507,7 +507,7 @@
@ -9,3 +15,27 @@
standalone.write('\n')
standalone.write(open("build-outputs.mk","r").read())
standalone.close()
--- subversion-1.9.7/subversion/tests/cmdline/svntest/main.py.pybinary
+++ subversion-1.9.7/subversion/tests/cmdline/svntest/main.py
@@ -126,7 +126,7 @@
if windows:
svneditor_script = os.path.join(sys.path[0], 'svneditor.bat')
else:
- svneditor_script = os.path.join(sys.path[0], 'svneditor.py')
+ svneditor_script = sys.executable + ' ' + os.path.join(sys.path[0], 'svneditor.py')
# Username and password used by the working copies
wc_author = 'jrandom'
@@ -410,9 +410,9 @@
should be passed to wait_on_pipe."""
command = [str(x) for x in command]
- # On Windows subprocess.Popen() won't accept a Python script as
- # a valid program to execute, rather it wants the Python executable.
- if (sys.platform == 'win32') and (command[0].endswith('.py')):
+ # Always run python scripts under the same Python executable as used
+ # for the test suite.
+ if command[0].endswith('.py'):
command.insert(0, sys.executable)
command_string = command[0] + ' ' + ' '.join(map(_quote_arg, command[1:]))

View File

@ -19,6 +19,8 @@
# set JDK path to build javahl; default for JPackage
%define jdk_path /usr/lib/jvm/java
%{!?_httpd_mmn: %{expand: %%global _httpd_mmn %%(cat %{_includedir}/httpd/.mmn 2>/dev/null || echo 0-0)}}
%define perl_vendorarch %(eval "`%{__perl} -V:installvendorarch`"; echo $installvendorarch)
%if %{with python2}
@ -153,7 +155,7 @@ passwords in the KDE Wallet.
%package -n mod_dav_svn
Group: System Environment/Daemons
Summary: Apache httpd module for Subversion server
Requires: httpd-mmn = %{?_httpd_mmn}
Requires: httpd-mmn = %{_httpd_mmn}
Requires: subversion-libs%{?_isa} = %{version}-%{release}
BuildRequires: httpd-devel >= 2.0.45