update to 1.12.2
This commit is contained in:
parent
d3d820b4ed
commit
7a2266fa94
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (subversion-1.12.0.tar.bz2) = 87a00b23bdac63124fa00642e2ac7e6f7818b092bc6422cabdeb2ca8fbc8c481fb8c1e4fbd86aac94e8e1fc099fa163aa0609aca23265ceb96ef4ebe78a64c13
|
||||
SHA512 (subversion-1.12.2.tar.bz2) = b1f859b460afa54598778d8633f648acb4fa46138f7d6f0c1451e3c6a1de71df859233cd9ac7f19f0f20d7237ed3988f0a38da7552ffa58391e19d957bc7c136
|
||||
|
@ -1,72 +0,0 @@
|
||||
|
||||
Link executables using -pie, link test executables using -no-install.
|
||||
|
||||
diff -uap subversion-1.10.0/build.conf.pie subversion-1.10.0/build.conf
|
||||
--- subversion-1.10.0/build.conf.pie
|
||||
+++ subversion-1.10.0/build.conf
|
||||
@@ -783,6 +783,7 @@
|
||||
libs = libsvn_repos libsvn_fs libsvn_delta libsvn_subr aprutil apriconv apr
|
||||
msvc-static = yes
|
||||
undefined-lib-symbols = yes
|
||||
+link-cmd = $(LINK_TEST_LIB)
|
||||
|
||||
# ----------------------------------------------------------------------------
|
||||
# Tests for libsvn_fs_base
|
||||
diff -uap subversion-1.10.0/build/generator/gen_base.py.pie subversion-1.10.0/build/generator/gen_base.py
|
||||
--- subversion-1.10.0/build/generator/gen_base.py.pie
|
||||
+++ subversion-1.10.0/build/generator/gen_base.py
|
||||
@@ -599,7 +599,7 @@
|
||||
self.install = options.get('install')
|
||||
self.compile_cmd = options.get('compile-cmd')
|
||||
self.sources = options.get('sources', '*.c *.cpp')
|
||||
- self.link_cmd = options.get('link-cmd', '$(LINK)')
|
||||
+ self.link_cmd = options.get('link-cmd', '$(LINK_LIB)')
|
||||
|
||||
self.external_lib = options.get('external-lib')
|
||||
self.external_project = options.get('external-project')
|
||||
@@ -659,6 +659,17 @@
|
||||
|
||||
self.msvc_force_static = options.get('msvc-force-static') == 'yes'
|
||||
|
||||
+ if self.install in ['test', 'bdb-test', 'sub-test', ]:
|
||||
+ self.link_cmd = '$(LINK_TEST)'
|
||||
+ elif self.install in ['cxxhl-tests', ]:
|
||||
+ self.link_cmd = '$(LINK_TEST_CXX)'
|
||||
+ elif self.link_cmd == '$(LINK_LIB)':
|
||||
+ # Over-ride the default for TargetLinked.
|
||||
+ self.link_cmd = '$(LINK_EXE)'
|
||||
+ else:
|
||||
+ raise GenError('ERROR: Unknown executable link type for ' + self.name + \
|
||||
+ ': ' + self.link_cmd + ' (' + self.install + ')')
|
||||
+
|
||||
def add_dependencies(self):
|
||||
TargetLinked.add_dependencies(self)
|
||||
|
||||
diff -uap subversion-1.10.0/Makefile.in.pie subversion-1.10.0/Makefile.in
|
||||
--- subversion-1.10.0/Makefile.in.pie
|
||||
+++ subversion-1.10.0/Makefile.in
|
||||
@@ -268,6 +268,11 @@
|
||||
LINK_LIB = $(LINK) $(LT_SO_VERSION) -rpath $(libdir)
|
||||
LINK_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=link $(CXX) $(LT_LDFLAGS) $(CXXFLAGS) $(LDFLAGS)
|
||||
LINK_CXX_LIB = $(LINK_CXX) $(LT_SO_VERSION) -rpath $(libdir)
|
||||
+LINK_TEST = $(LINK) -no-install
|
||||
+LINK_TEST_LIB = $(LINK) -avoid-version
|
||||
+LINK_TEST_CXX_LIB = $(LINK_CXX) -avoid-version
|
||||
+LINK_EXE = $(LINK) -pie
|
||||
+LINK_CXX_EXE = $(LINK) -pie
|
||||
|
||||
# special link rule for mod_dav_svn
|
||||
LINK_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(APACHE_LIBEXECDIR) -avoid-version -module $(APACHE_LDFLAGS) -shared
|
||||
@@ -780,10 +785,10 @@
|
||||
$(PYTHON) $(top_srcdir)/build/transform_sql.py $< $(top_srcdir)/$@
|
||||
|
||||
.c.o:
|
||||
- $(COMPILE) -o $@ -c $<
|
||||
+ $(COMPILE) -fPIE -o $@ -c $<
|
||||
|
||||
.cpp.o:
|
||||
- $(COMPILE_CXX) -o $@ -c $<
|
||||
+ $(COMPILE_CXX) -fPIE -o $@ -c $<
|
||||
|
||||
.c.lo:
|
||||
$(LT_COMPILE) -o $@ -c $<
|
@ -1,72 +0,0 @@
|
||||
# ./pullrev.sh 1857391
|
||||
http://svn.apache.org/viewvc?view=revision&revision=1857391
|
||||
|
||||
--- subversion-1.11.1/subversion/bindings/swig/python/libsvn_swig_py/swigutil_py.c
|
||||
+++ subversion-1.11.1/subversion/bindings/swig/python/libsvn_swig_py/swigutil_py.c
|
||||
@@ -46,7 +46,7 @@
|
||||
#include "svn_mergeinfo.h"
|
||||
#include "svn_types.h"
|
||||
|
||||
-#include "svn_private_config.h" /* for SVN_APR_INT64_T_PYCFMT */
|
||||
+#include "svn_private_config.h"
|
||||
|
||||
#include "swig_python_external_runtime.swg"
|
||||
#include "swigutil_py.h"
|
||||
@@ -3394,10 +3394,9 @@
|
||||
svn_swig_py_acquire_py_lock();
|
||||
|
||||
if ((result = PyObject_CallFunction(receiver,
|
||||
- (char *)
|
||||
- (SVN_APR_INT64_T_PYCFMT "lsssO&"),
|
||||
- line_no, revision, author, date, line,
|
||||
- make_ob_pool, pool)) == NULL)
|
||||
+ (char *)"LlsssO&",
|
||||
+ (PY_LONG_LONG)line_no, revision, author,
|
||||
+ date, line, make_ob_pool, pool)) == NULL)
|
||||
{
|
||||
err = callback_exception_error();
|
||||
}
|
||||
--- subversion-1.11.1/build/ac-macros/swig.m4
|
||||
+++ subversion-1.11.1/build/ac-macros/swig.m4
|
||||
@@ -128,41 +128,6 @@
|
||||
ac_cv_python_libs="`$PYTHON ${abs_srcdir}/build/get-py-info.py --libs`"
|
||||
])
|
||||
SWIG_PY_LIBS="`SVN_REMOVE_STANDARD_LIB_DIRS($ac_cv_python_libs)`"
|
||||
-
|
||||
- dnl Sun Forte adds an extra space before substituting APR_INT64_T_FMT
|
||||
- dnl gcc-2.95 adds an extra space after substituting APR_INT64_T_FMT
|
||||
- dnl thus the egrep patterns have a + in them.
|
||||
- SVN_PYCFMT_SAVE_CPPFLAGS="$CPPFLAGS"
|
||||
- CPPFLAGS="$CPPFLAGS $SVN_APR_INCLUDES"
|
||||
- AC_CACHE_CHECK([for apr_int64_t Python/C API format string],
|
||||
- [svn_cv_pycfmt_apr_int64_t], [
|
||||
- if test "x$svn_cv_pycfmt_apr_int64_t" = "x"; then
|
||||
- AC_EGREP_CPP([MaTcHtHiS +\"lld\" +EnDeNd],
|
||||
- [#include <apr.h>
|
||||
- MaTcHtHiS APR_INT64_T_FMT EnDeNd],
|
||||
- [svn_cv_pycfmt_apr_int64_t="L"])
|
||||
- fi
|
||||
- if test "x$svn_cv_pycfmt_apr_int64_t" = "x"; then
|
||||
- AC_EGREP_CPP([MaTcHtHiS +\"ld\" +EnDeNd],r
|
||||
- [#include <apr.h>
|
||||
- MaTcHtHiS APR_INT64_T_FMT EnDeNd],
|
||||
- [svn_cv_pycfmt_apr_int64_t="l"])
|
||||
- fi
|
||||
- if test "x$svn_cv_pycfmt_apr_int64_t" = "x"; then
|
||||
- AC_EGREP_CPP([MaTcHtHiS +\"d\" +EnDeNd],
|
||||
- [#include <apr.h>
|
||||
- MaTcHtHiS APR_INT64_T_FMT EnDeNd],
|
||||
- [svn_cv_pycfmt_apr_int64_t="i"])
|
||||
- fi
|
||||
- ])
|
||||
- CPPFLAGS="$SVN_PYCFMT_SAVE_CPPFLAGS"
|
||||
- if test "x$svn_cv_pycfmt_apr_int64_t" = "x"; then
|
||||
- AC_MSG_ERROR([failed to recognize APR_INT64_T_FMT on this platform])
|
||||
- fi
|
||||
- AC_DEFINE_UNQUOTED([SVN_APR_INT64_T_PYCFMT],
|
||||
- ["$svn_cv_pycfmt_apr_int64_t"],
|
||||
- [Define to the Python/C API format character suitable]
|
||||
- [ for apr_int64_t])
|
||||
fi
|
||||
|
||||
if test "$PERL" != "none"; then
|
@ -36,8 +36,8 @@
|
||||
|
||||
Summary: A Modern Concurrent Version Control System
|
||||
Name: subversion
|
||||
Version: 1.12.0
|
||||
Release: 2%{?dist}
|
||||
Version: 1.12.2
|
||||
Release: 1%{?dist}
|
||||
License: ASL 2.0
|
||||
URL: https://subversion.apache.org/
|
||||
|
||||
@ -52,7 +52,6 @@ Source8: svnserve.sysconf
|
||||
Patch1: subversion-1.12.0-linking.patch
|
||||
Patch4: subversion-1.8.0-rubybind.patch
|
||||
Patch5: subversion-1.8.5-swigplWall.patch
|
||||
Patch6: subversion-1.11.1-r1857391.patch
|
||||
BuildRequires: autoconf, libtool, texinfo, which
|
||||
BuildRequires: swig >= 1.3.24, gettext
|
||||
%if %{with bdb}
|
||||
@ -207,7 +206,6 @@ This package includes supplementary tools for use with Subversion.
|
||||
%patch1 -p1 -b .linking
|
||||
%patch4 -p1 -b .rubybind
|
||||
%patch5 -p1 -b .swigplWall
|
||||
%patch6 -p1 -b .r1857391
|
||||
|
||||
%build
|
||||
# Regenerate the buildsystem, so that:
|
||||
@ -522,6 +520,9 @@ make check-javahl
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Jul 25 2019 Joe Orton <jorton@redhat.com> - 1.12.2-1
|
||||
- update to 1.12.2
|
||||
|
||||
* Sat Jun 01 2019 Jitka Plesnikova <jplesnik@redhat.com> - 1.12.0-2
|
||||
- Perl 5.30 rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user