update patches for 1.8.0
This commit is contained in:
parent
b3a52efdbf
commit
5f612c9ef9
@ -1,7 +1,7 @@
|
|||||||
diff -uap subversion-1.7.0/build/generator/gen_base.py.pie subversion-1.7.0/build/generator/gen_base.py
|
diff -uap subversion-1.7.0/build/generator/gen_base.py.pie subversion-1.7.0/build/generator/gen_base.py
|
||||||
--- subversion-1.7.0/build/generator/gen_base.py.pie 2011-10-12 09:25:30.510524103 +0100
|
--- subversion-1.8.0/build/generator/gen_base.py.pie
|
||||||
+++ subversion-1.7.0/build/generator/gen_base.py 2011-10-12 09:25:30.515650110 +0100
|
+++ subversion-1.8.0/build/generator/gen_base.py
|
||||||
@@ -406,7 +406,7 @@ class TargetLinked(Target):
|
@@ -409,7 +409,7 @@ class TargetLinked(Target):
|
||||||
self.install = options.get('install')
|
self.install = options.get('install')
|
||||||
self.compile_cmd = options.get('compile-cmd')
|
self.compile_cmd = options.get('compile-cmd')
|
||||||
self.sources = options.get('sources', '*.c *.cpp')
|
self.sources = options.get('sources', '*.c *.cpp')
|
||||||
@ -10,7 +10,7 @@ diff -uap subversion-1.7.0/build/generator/gen_base.py.pie subversion-1.7.0/buil
|
|||||||
|
|
||||||
self.external_lib = options.get('external-lib')
|
self.external_lib = options.get('external-lib')
|
||||||
self.external_project = options.get('external-project')
|
self.external_project = options.get('external-project')
|
||||||
@@ -462,6 +462,11 @@ class TargetExe(TargetLinked):
|
@@ -465,6 +465,11 @@ class TargetExe(TargetLinked):
|
||||||
self.manpages = options.get('manpages', '')
|
self.manpages = options.get('manpages', '')
|
||||||
self.testing = options.get('testing')
|
self.testing = options.get('testing')
|
||||||
|
|
||||||
@ -22,7 +22,7 @@ diff -uap subversion-1.7.0/build/generator/gen_base.py.pie subversion-1.7.0/buil
|
|||||||
def add_dependencies(self):
|
def add_dependencies(self):
|
||||||
TargetLinked.add_dependencies(self)
|
TargetLinked.add_dependencies(self)
|
||||||
|
|
||||||
@@ -507,8 +512,8 @@ class TargetLib(TargetLinked):
|
@@ -515,8 +520,8 @@ class TargetLib(TargetLinked):
|
||||||
self.msvc_export = options.get('msvc-export', '').split()
|
self.msvc_export = options.get('msvc-export', '').split()
|
||||||
|
|
||||||
### hmm. this is Makefile-specific
|
### hmm. this is Makefile-specific
|
||||||
@ -33,10 +33,9 @@ diff -uap subversion-1.7.0/build/generator/gen_base.py.pie subversion-1.7.0/buil
|
|||||||
|
|
||||||
class TargetApacheMod(TargetLib):
|
class TargetApacheMod(TargetLib):
|
||||||
|
|
||||||
diff -uap subversion-1.7.0/Makefile.in.pie subversion-1.7.0/Makefile.in
|
--- subversion-1.8.0/Makefile.in.pie
|
||||||
--- subversion-1.7.0/Makefile.in.pie 2011-10-12 09:25:30.511600030 +0100
|
+++ subversion-1.8.0/Makefile.in
|
||||||
+++ subversion-1.7.0/Makefile.in 2011-10-12 09:26:16.757524426 +0100
|
@@ -203,6 +203,9 @@ COMPILE_CXXHL_CXX = $(LIBTOOL) $(LTCXXFL
|
||||||
@@ -205,6 +205,9 @@ COMPILE_JAVAHL_JAVAH = $(JAVAH)
|
|
||||||
|
|
||||||
LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS)
|
LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS)
|
||||||
LINK_LIB = $(LINK) $(LT_SO_VERSION) -rpath $(libdir)
|
LINK_LIB = $(LINK) $(LT_SO_VERSION) -rpath $(libdir)
|
||||||
@ -46,7 +45,7 @@ diff -uap subversion-1.7.0/Makefile.in.pie subversion-1.7.0/Makefile.in
|
|||||||
LINK_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=link $(CXX) $(LT_LDFLAGS) $(CXXFLAGS) $(LDFLAGS) -rpath $(libdir)
|
LINK_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=link $(CXX) $(LT_LDFLAGS) $(CXXFLAGS) $(LDFLAGS) -rpath $(libdir)
|
||||||
LINK_CXX_LIB = $(LINK_CXX) $(LT_SO_VERSION)
|
LINK_CXX_LIB = $(LINK_CXX) $(LT_SO_VERSION)
|
||||||
|
|
||||||
@@ -657,7 +660,7 @@ schema-clean:
|
@@ -676,7 +679,7 @@ schema-clean:
|
||||||
$(PYTHON) $(top_srcdir)/build/transform_sql.py $< $(top_srcdir)/$@
|
$(PYTHON) $(top_srcdir)/build/transform_sql.py $< $(top_srcdir)/$@
|
||||||
|
|
||||||
.c.o:
|
.c.o:
|
@ -1,7 +1,7 @@
|
|||||||
diff -uap subversion-1.7.0/build.conf.rpath subversion-1.7.0/build.conf
|
diff -uap subversion-1.7.0/build.conf.rpath subversion-1.7.0/build.conf
|
||||||
--- subversion-1.7.0/build.conf.rpath 2011-08-04 21:18:50.000000000 +0100
|
--- subversion-1.8.0/build.conf.rpath
|
||||||
+++ subversion-1.7.0/build.conf 2011-10-12 09:23:43.844525530 +0100
|
+++ subversion-1.8.0/build.conf
|
||||||
@@ -478,7 +478,7 @@ type = swig_lib
|
@@ -501,7 +501,7 @@ type = swig_lib
|
||||||
lang = python
|
lang = python
|
||||||
path = subversion/bindings/swig/python/libsvn_swig_py
|
path = subversion/bindings/swig/python/libsvn_swig_py
|
||||||
libs = libsvn_client libsvn_wc libsvn_ra libsvn_delta libsvn_subr apriconv apr
|
libs = libsvn_client libsvn_wc libsvn_ra libsvn_delta libsvn_subr apriconv apr
|
||||||
@ -10,7 +10,7 @@ diff -uap subversion-1.7.0/build.conf.rpath subversion-1.7.0/build.conf
|
|||||||
install = swig-py-lib
|
install = swig-py-lib
|
||||||
# need special build rule to include -DSWIGPYTHON
|
# need special build rule to include -DSWIGPYTHON
|
||||||
compile-cmd = $(COMPILE_SWIG_PY)
|
compile-cmd = $(COMPILE_SWIG_PY)
|
||||||
@@ -501,7 +501,7 @@ type = swig_lib
|
@@ -524,7 +524,7 @@ type = swig_lib
|
||||||
lang = ruby
|
lang = ruby
|
||||||
path = subversion/bindings/swig/ruby/libsvn_swig_ruby
|
path = subversion/bindings/swig/ruby/libsvn_swig_ruby
|
||||||
libs = libsvn_client libsvn_wc libsvn_delta libsvn_subr apriconv apr
|
libs = libsvn_client libsvn_wc libsvn_delta libsvn_subr apriconv apr
|
||||||
@ -19,10 +19,9 @@ diff -uap subversion-1.7.0/build.conf.rpath subversion-1.7.0/build.conf
|
|||||||
install = swig-rb-lib
|
install = swig-rb-lib
|
||||||
# need special build rule to include
|
# need special build rule to include
|
||||||
compile-cmd = $(COMPILE_SWIG_RB)
|
compile-cmd = $(COMPILE_SWIG_RB)
|
||||||
diff -uap subversion-1.7.0/build/generator/gen_base.py.rpath subversion-1.7.0/build/generator/gen_base.py
|
--- subversion-1.8.0/build/generator/gen_base.py.rpath
|
||||||
--- subversion-1.7.0/build/generator/gen_base.py.rpath 2011-06-22 17:44:54.000000000 +0100
|
+++ subversion-1.8.0/build/generator/gen_base.py
|
||||||
+++ subversion-1.7.0/build/generator/gen_base.py 2011-10-12 09:23:15.368649375 +0100
|
@@ -514,6 +514,10 @@ class TargetLib(TargetLinked):
|
||||||
@@ -506,6 +506,10 @@ class TargetLib(TargetLinked):
|
|
||||||
self.msvc_fake = options.get('msvc-fake') == 'yes' # has fake target
|
self.msvc_fake = options.get('msvc-fake') == 'yes' # has fake target
|
||||||
self.msvc_export = options.get('msvc-export', '').split()
|
self.msvc_export = options.get('msvc-export', '').split()
|
||||||
|
|
||||||
@ -33,12 +32,11 @@ diff -uap subversion-1.7.0/build/generator/gen_base.py.rpath subversion-1.7.0/bu
|
|||||||
class TargetApacheMod(TargetLib):
|
class TargetApacheMod(TargetLib):
|
||||||
|
|
||||||
def __init__(self, name, options, gen_obj):
|
def __init__(self, name, options, gen_obj):
|
||||||
diff -uap subversion-1.7.0/Makefile.in.rpath subversion-1.7.0/Makefile.in
|
--- subversion-1.8.0/Makefile.in.rpath
|
||||||
--- subversion-1.7.0/Makefile.in.rpath 2011-07-16 12:50:53.000000000 +0100
|
+++ subversion-1.8.0/Makefile.in
|
||||||
+++ subversion-1.7.0/Makefile.in 2011-10-12 09:24:36.165524732 +0100
|
@@ -201,8 +201,8 @@ COMPILE_JAVAHL_JAVAH = $(JAVAH)
|
||||||
@@ -203,8 +203,8 @@ COMPILE_JAVAHL_CXX = $(LIBTOOL) $(LTCXXF
|
# special compilation for files destined for cxxhl
|
||||||
COMPILE_JAVAHL_JAVAC = $(JAVAC) $(JAVAC_FLAGS)
|
COMPILE_CXXHL_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=compile $(COMPILE_CXX) $(LT_CFLAGS) $(CXXHL_INCLUDES) -o $@ -c
|
||||||
COMPILE_JAVAHL_JAVAH = $(JAVAH)
|
|
||||||
|
|
||||||
-LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(libdir)
|
-LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(libdir)
|
||||||
-LINK_LIB = $(LINK) $(LT_SO_VERSION)
|
-LINK_LIB = $(LINK) $(LT_SO_VERSION)
|
@ -38,8 +38,8 @@ Source5: psvn-init.el
|
|||||||
Source6: svnserve.service
|
Source6: svnserve.service
|
||||||
Source7: svnserve.tmpfiles
|
Source7: svnserve.tmpfiles
|
||||||
Source8: svnserve.sysconf
|
Source8: svnserve.sysconf
|
||||||
Patch1: subversion-1.7.0-rpath.patch
|
Patch1: subversion-1.8.0-rpath.patch
|
||||||
Patch2: subversion-1.7.0-pie.patch
|
Patch2: subversion-1.8.0-pie.patch
|
||||||
Patch3: subversion-1.8.0-kwallet.patch
|
Patch3: subversion-1.8.0-kwallet.patch
|
||||||
Patch4: subversion-1.8.0-rubybind.patch
|
Patch4: subversion-1.8.0-rubybind.patch
|
||||||
Patch5: subversion-1.8.0-aarch64.patch
|
Patch5: subversion-1.8.0-aarch64.patch
|
||||||
|
Loading…
Reference in New Issue
Block a user