remove build and -devel deps on libgnome-keyring-devel

This commit is contained in:
Joe Orton 2018-05-01 18:04:51 +01:00
parent 13ecf2b759
commit 28a2e483e9
2 changed files with 45 additions and 3 deletions

View File

@ -0,0 +1,38 @@
--- subversion-1.10.0/build/ac-macros/libsecret.m4.pkgsecret
+++ subversion-1.10.0/build/ac-macros/libsecret.m4
@@ -54,6 +54,7 @@
[Is libsecret support enabled?])
SVN_GNOME_KEYRING_INCLUDES="`$PKG_CONFIG --cflags libsecret-1`"
SVN_GNOME_KEYRING_LIBS="`$PKG_CONFIG --libs libsecret-1`"
+ SVN_GNOME_KEYRING_PCLIBS="libsecret-1"
found_gnome_keyring="yes"
else
if test "$with_gnome_keyring" = "yes"; then
@@ -90,4 +91,5 @@
fi
AC_SUBST(SVN_GNOME_KEYRING_INCLUDES)
AC_SUBST(SVN_GNOME_KEYRING_LIBS)
+ AC_SUBST(SVN_GNOME_KEYRING_PCLIBS)
])
--- subversion-1.10.0/build.conf.pkgsecret
+++ subversion-1.10.0/build.conf
@@ -1464,7 +1464,8 @@
[gnome-keyring]
type = lib
external-lib = $(SVN_GNOME_KEYRING_LIBS)
-pkg-config = gnome-keyring-1
+pkg-config = @SVN_GNOME_KEYRING_PCLIBS@
+pkg-config-private = yes
[kwallet]
type = lib
--- subversion-1.10.0/configure.ac.pkgsecret
+++ subversion-1.10.0/configure.ac
@@ -593,6 +593,7 @@
[Is GNOME Keyring support enabled?])
CPPFLAGS="$old_CPPFLAGS"
SVN_GNOME_KEYRING_LIBS="`$PKG_CONFIG --libs glib-2.0 gnome-keyring-1`"
+ SVN_GNOME_KEYRING_PCLIBS="glib-2.0 gnome-keyring-1"
else
AC_MSG_RESULT([no])
if test "$with_old_gnome_keyring" = "yes"; then

View File

@ -34,7 +34,7 @@
Summary: A Modern Concurrent Version Control System
Name: subversion
Version: 1.10.0
Release: 4%{?dist}
Release: 5%{?dist}
License: ASL 2.0
Group: Development/Tools
URL: https://subversion.apache.org/
@ -52,7 +52,7 @@ Patch2: subversion-1.10.0-pie.patch
Patch4: subversion-1.8.0-rubybind.patch
Patch5: subversion-1.8.5-swigplWall.patch
Patch6: subversion-1.9.7-pybinary.patch
Patch7: subversion-1.10.0-pkgsecret.patch
BuildRequires: autoconf, libtool, texinfo, which
BuildRequires: swig >= 1.3.24, gettext
%if %{with bdb}
@ -137,7 +137,7 @@ for developers interacting with the subversion package.
Group: Development/Tools
Summary: GNOME Keyring support for Subversion
Requires: subversion%{?_isa} = %{version}-%{release}
BuildRequires: libgnome-keyring-devel, dbus-devel, libsecret-devel
BuildRequires: dbus-devel, libsecret-devel
%description gnome
The subversion-gnome package adds support for storing Subversion
@ -219,6 +219,7 @@ This package includes supplementary tools for use with Subversion.
%patch4 -p1 -b .rubybind
%patch5 -p1 -b .swigplWall
%patch6 -p1 -b .pybinary
%patch7 -p1 -b .pkgsecret
%build
# Regenerate the buildsystem, so that:
@ -524,6 +525,9 @@ make check-javahl
%endif
%changelog
* Tue May 1 2018 Joe Orton <jorton@redhat.com> - 1.10.0-5
- remove build and -devel deps on libgnome-keyring-devel
* Tue May 1 2018 Joe Orton <jorton@redhat.com> - 1.10.0-4
- drop -devel dep on libserf-devel