import subversion-1.14.1-1.module+el8.4.0+9885+2150d1b0
This commit is contained in:
commit
10d41cbe2e
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/subversion-1.14.1.tar.bz2
|
1
.subversion.metadata
Normal file
1
.subversion.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
ee4283c21b5925ee499f8cb9cb0ff546ac7b4b9a SOURCES/subversion-1.14.1.tar.bz2
|
13
SOURCES/filter-requires.sh
Executable file
13
SOURCES/filter-requires.sh
Executable file
@ -0,0 +1,13 @@
|
|||||||
|
#!/bin/sh
|
||||||
|
# Munge Perl requirements:
|
||||||
|
# - remove dependency on Config::Inifiles
|
||||||
|
# - only require File::Path >= 1.04, not >= 1.404
|
||||||
|
# (since rpmvercmp thinks 04 < 1.404, not unreasonably)
|
||||||
|
# - filter out requirements for SVN:: modules; otherwise
|
||||||
|
# subversion requires subversion-perl
|
||||||
|
/usr/lib/rpm/perl.req $* |
|
||||||
|
sed -e '/perl(Config::IniFiles)/d' \
|
||||||
|
-e '/perl(SVN::/d' \
|
||||||
|
-e 's/perl(File::Path) >= 1.0404/perl(File::Path) >= 1.04/'
|
||||||
|
|
||||||
|
|
3
SOURCES/psvn-init.el
Normal file
3
SOURCES/psvn-init.el
Normal file
@ -0,0 +1,3 @@
|
|||||||
|
(defalias 'svn-examine 'svn-status)
|
||||||
|
(autoload 'svn-status "psvn" "Examine the status of Subversion working copy in
|
||||||
|
directory DIR.")
|
6562
SOURCES/psvn.el
Normal file
6562
SOURCES/psvn.el
Normal file
File diff suppressed because it is too large
Load Diff
84
SOURCES/subversion-1.12.0-linking.patch
Normal file
84
SOURCES/subversion-1.12.0-linking.patch
Normal file
@ -0,0 +1,84 @@
|
|||||||
|
|
||||||
|
Fix the way libtool is used to match standard practice:
|
||||||
|
|
||||||
|
a) link ONLY libraries using -rpath $(libdir), not executables
|
||||||
|
.. this avoids adding an RPATH for $libdir to executables
|
||||||
|
b) link non-installable test binaries using -no-install
|
||||||
|
.. only for convenience but should speed up builds slightly(?)
|
||||||
|
|
||||||
|
--- subversion-1.12.0/build.conf.linking
|
||||||
|
+++ subversion-1.12.0/build.conf
|
||||||
|
@@ -572,7 +572,7 @@
|
||||||
|
path = subversion/bindings/swig/python/libsvn_swig_py
|
||||||
|
libs = libsvn_client libsvn_wc libsvn_ra libsvn_delta libsvn_subr
|
||||||
|
apriconv apr python swig
|
||||||
|
-link-cmd = $(LINK)
|
||||||
|
+link-cmd = $(LINK_LIB)
|
||||||
|
install = swig-py-lib
|
||||||
|
# need special build rule to include -DSWIGPYTHON
|
||||||
|
compile-cmd = $(COMPILE_SWIG_PY)
|
||||||
|
@@ -598,7 +598,7 @@
|
||||||
|
lang = ruby
|
||||||
|
path = subversion/bindings/swig/ruby/libsvn_swig_ruby
|
||||||
|
libs = libsvn_client libsvn_wc libsvn_delta libsvn_subr apriconv apr ruby swig
|
||||||
|
-link-cmd = $(LINK) $(SWIG_RB_LIBS)
|
||||||
|
+link-cmd = $(LINK_LIB) $(SWIG_RB_LIBS)
|
||||||
|
install = swig-rb-lib
|
||||||
|
# need special build rule to include
|
||||||
|
compile-cmd = $(COMPILE_SWIG_RB)
|
||||||
|
@@ -769,6 +769,7 @@
|
||||||
|
libs = libsvn_repos libsvn_fs libsvn_delta libsvn_subr aprutil apriconv apr
|
||||||
|
msvc-static = yes
|
||||||
|
undefined-lib-symbols = yes
|
||||||
|
+link-cmd = $(LINK_TEST_LIB)
|
||||||
|
|
||||||
|
# ----------------------------------------------------------------------------
|
||||||
|
# Tests for libsvn_fs_base
|
||||||
|
--- subversion-1.12.0/build/generator/gen_base.py.linking
|
||||||
|
+++ subversion-1.12.0/build/generator/gen_base.py
|
||||||
|
@@ -599,7 +599,7 @@
|
||||||
|
self.install = options.get('install')
|
||||||
|
self.compile_cmd = options.get('compile-cmd')
|
||||||
|
self.sources = options.get('sources', '*.c *.cpp')
|
||||||
|
- self.link_cmd = options.get('link-cmd', '$(LINK)')
|
||||||
|
+ self.link_cmd = options.get('link-cmd', '$(LINK_LIB)')
|
||||||
|
|
||||||
|
self.external_lib = options.get('external-lib')
|
||||||
|
self.external_project = options.get('external-project')
|
||||||
|
@@ -659,6 +659,14 @@
|
||||||
|
|
||||||
|
self.msvc_force_static = options.get('msvc-force-static') == 'yes'
|
||||||
|
|
||||||
|
+ if self.install in ['test', 'bdb-test', 'sub-test', ]:
|
||||||
|
+ self.link_cmd = '$(LINK_TEST)'
|
||||||
|
+ elif self.install in ['bin', 'tools']:
|
||||||
|
+ self.link_cmd = '$(LINK_EXE)'
|
||||||
|
+ elif self.link_cmd == '$(LINK_LIB)':
|
||||||
|
+ raise GenError('ERROR: Unknown executable link type for ' + self.name + \
|
||||||
|
+ ': ' + self.link_cmd + ' (' + self.install + ')')
|
||||||
|
+
|
||||||
|
def add_dependencies(self):
|
||||||
|
TargetLinked.add_dependencies(self)
|
||||||
|
|
||||||
|
--- subversion-1.12.0/Makefile.in.linking
|
||||||
|
+++ subversion-1.12.0/Makefile.in
|
||||||
|
@@ -268,11 +268,14 @@
|
||||||
|
COMPILE_SVNXX = $(LT_COMPILE_CXX) $(SVNXX_INCLUDES) -o $@ -c
|
||||||
|
COMPILE_SVNXX_TEST = $(LT_COMPILE_CXX) $(SVNXX_INCLUDES) $(BOOST_TEST_CPPFLAGS) -o $@ -c
|
||||||
|
|
||||||
|
-LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(libdir)
|
||||||
|
-LINK_LIB = $(LINK) $(LT_SO_VERSION)
|
||||||
|
-LINK_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=link $(CXX) $(LT_LDFLAGS) $(CXXFLAGS) $(LDFLAGS) -rpath $(libdir)
|
||||||
|
-LINK_CXX_LIB = $(LINK_CXX) $(LT_SO_VERSION)
|
||||||
|
-LINK_SVNXX_TEST = $(LINK_CXX) $(BOOST_TEST_LDFLAGS)
|
||||||
|
+LINK = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS)
|
||||||
|
+LINK_LIB = $(LINK) $(LT_SO_VERSION) -rpath $(libdir)
|
||||||
|
+LINK_CXX = $(LIBTOOL) $(LTCXXFLAGS) --mode=link $(CXX) $(LT_LDFLAGS) $(CXXFLAGS) $(LDFLAGS)
|
||||||
|
+LINK_CXX_LIB = $(LINK_CXX) $(LT_SO_VERSION) -rpath $(libdir)
|
||||||
|
+LINK_SVNXX_TEST = $(LINK_CXX) $(BOOST_TEST_LDFLAGS) -no-install
|
||||||
|
+LINK_TEST = $(LINK) -no-install
|
||||||
|
+LINK_TEST_LIB = $(LINK_TEST) -avoid-version
|
||||||
|
+LINK_EXE = $(LINK)
|
||||||
|
|
||||||
|
# special link rule for mod_dav_svn
|
||||||
|
LINK_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(APACHE_LIBEXECDIR) -avoid-version -module $(APACHE_LDFLAGS) -shared
|
11
SOURCES/subversion-1.14.0-findpy.patch
Normal file
11
SOURCES/subversion-1.14.0-findpy.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- subversion-1.14.0/build/find_python.sh.findpy
|
||||||
|
+++ subversion-1.14.0/build/find_python.sh
|
||||||
|
@@ -26,7 +26,7 @@
|
||||||
|
for pypath in "$PYTHON" "$PYTHON2" "$PYTHON3" python python2 python3; do
|
||||||
|
if [ "x$pypath" != "x" ]; then
|
||||||
|
DETECT_PYTHON="import sys;sys.exit((sys.hexversion < $VERSION) and 1 or 0)"
|
||||||
|
- if "$pypath" -c "$DETECT_PYTHON" >/dev/null 2>/dev/null; then
|
||||||
|
+ if "$pypath" -c "$DETECT_PYTHON"; then
|
||||||
|
echo $pypath
|
||||||
|
exit 0
|
||||||
|
fi
|
19
SOURCES/subversion-1.14.0-soversion.patch
Normal file
19
SOURCES/subversion-1.14.0-soversion.patch
Normal file
@ -0,0 +1,19 @@
|
|||||||
|
|
||||||
|
Use the minor version as the revision in the libtool version, so the library
|
||||||
|
soversion is not always 0.0.0. (Does not influence the soname)
|
||||||
|
|
||||||
|
--- subversion-1.14.0/configure.ac.soversion
|
||||||
|
+++ subversion-1.14.0/configure.ac
|
||||||
|
@@ -112,7 +112,11 @@
|
||||||
|
SVN_APR_MAJOR_VERSION=1
|
||||||
|
fi
|
||||||
|
AC_SUBST(SVN_APR_MAJOR_VERSION)
|
||||||
|
-SVN_LT_SOVERSION="-version-info $svn_lib_ver"
|
||||||
|
+
|
||||||
|
+m4_define([svn_ver_minor], m4_bpatsubst(AC_PACKAGE_VERSION, [[0-9]*\.\([0-9]*\)\.[0-9]*], [\1]))
|
||||||
|
+
|
||||||
|
+SVN_LT_SOVERSION="-version-info $svn_lib_ver:svn_ver_minor"
|
||||||
|
+AC_MSG_NOTICE([SVN_LT_SOVERSION $SVN_LT_SOVERSION])
|
||||||
|
AC_SUBST(SVN_LT_SOVERSION)
|
||||||
|
AC_DEFINE_UNQUOTED(SVN_SOVERSION, $svn_lib_ver,
|
||||||
|
[Subversion library major verson])
|
14
SOURCES/subversion-1.14.0-testwarn.patch
Normal file
14
SOURCES/subversion-1.14.0-testwarn.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
|
||||||
|
Suppress gcc 10 warning.
|
||||||
|
|
||||||
|
--- subversion-1.14.0/subversion/tests/svn_test.h.testwarn
|
||||||
|
+++ subversion-1.14.0/subversion/tests/svn_test.h
|
||||||
|
@@ -128,7 +128,7 @@
|
||||||
|
return svn_error_createf(SVN_ERR_TEST_FAILED, NULL, \
|
||||||
|
"Strings not equal\n Expected: '%s'\n Found: '%s'" \
|
||||||
|
"\n at %s:%d", \
|
||||||
|
- tst_str2, tst_str1, __FILE__, __LINE__); \
|
||||||
|
+ tst_str2 ? tst_str2 : "(NULL)", tst_str1 ? tst_str1 : "(NULL)", __FILE__, __LINE__); \
|
||||||
|
} while(0)
|
||||||
|
|
||||||
|
/** Handy macro for testing integer equality.
|
24
SOURCES/subversion-1.8.0-rubybind.patch
Normal file
24
SOURCES/subversion-1.8.0-rubybind.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
|
||||||
|
Try a little harder to avoid svnserve() bind failures.
|
||||||
|
|
||||||
|
--- subversion-1.8.0/subversion/bindings/swig/ruby/test/util.rb.rubybind
|
||||||
|
+++ subversion-1.8.0/subversion/bindings/swig/ruby/test/util.rb
|
||||||
|
@@ -39,7 +39,8 @@ module SvnTestUtil
|
||||||
|
@realm = "sample realm"
|
||||||
|
|
||||||
|
@svnserve_host = "127.0.0.1"
|
||||||
|
- @svnserve_ports = (64152..64282).collect{|x| x.to_s}
|
||||||
|
+ sport = (50000 + rand(100) * 100)
|
||||||
|
+ @svnserve_ports = (sport..sport + 99).collect{|x| x.to_s}
|
||||||
|
|
||||||
|
@tmp_path = Dir.mktmpdir
|
||||||
|
@wc_path = File.join(@tmp_path, "wc")
|
||||||
|
@@ -252,6 +253,8 @@ realm = #{@realm}
|
||||||
|
"--listen-port", port,
|
||||||
|
"-d", "--foreground")
|
||||||
|
}
|
||||||
|
+ # wait a while for svnserve to attempt a bind() and possibly fail
|
||||||
|
+ sleep(1)
|
||||||
|
pid, status = Process.waitpid2(@svnserve_pid, Process::WNOHANG)
|
||||||
|
if status and status.exited?
|
||||||
|
if $DEBUG
|
16
SOURCES/subversion-1.8.5-swigplWall.patch
Normal file
16
SOURCES/subversion-1.8.5-swigplWall.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
|
||||||
|
Don't drop -Wall in the swig Perl bindings, otherwise building with
|
||||||
|
e.g. -Wformat-security might break.
|
||||||
|
|
||||||
|
https://bugzilla.redhat.com/show_bug.cgi?id=1037341
|
||||||
|
|
||||||
|
--- subversion-1.8.5/subversion/bindings/swig/perl/native/Makefile.PL.in.swigplWall
|
||||||
|
+++ subversion-1.8.5/subversion/bindings/swig/perl/native/Makefile.PL.in
|
||||||
|
@@ -54,7 +54,6 @@ my $includes = ' -I/usr/include/apr-1
|
||||||
|
# SWIG is using C++ style comments in an extern "C" code.
|
||||||
|
$cflags =~ s/-ansi\s+//g;
|
||||||
|
$cflags =~ s/-std=c89\s+//g;
|
||||||
|
-$cflags =~ s/-Wall//g;
|
||||||
|
$cflags =~ s/-Wunused//g;
|
||||||
|
$cflags =~ s/-Wshadow//g;
|
||||||
|
$cflags =~ s/-Wstrict-prototypes//g;
|
41
SOURCES/subversion.conf
Normal file
41
SOURCES/subversion.conf
Normal file
@ -0,0 +1,41 @@
|
|||||||
|
|
||||||
|
LoadModule dav_svn_module modules/mod_dav_svn.so
|
||||||
|
LoadModule authz_svn_module modules/mod_authz_svn.so
|
||||||
|
LoadModule dontdothat_module modules/mod_dontdothat.so
|
||||||
|
|
||||||
|
#
|
||||||
|
# Example configuration to enable HTTP access for a directory
|
||||||
|
# containing Subversion repositories, "/var/www/svn". Each repository
|
||||||
|
# must be both:
|
||||||
|
#
|
||||||
|
# a) readable and writable by the 'apache' user, and
|
||||||
|
#
|
||||||
|
# b) labelled with the 'httpd_sys_content_t' context if using
|
||||||
|
# SELinux
|
||||||
|
#
|
||||||
|
|
||||||
|
#
|
||||||
|
# To create a new repository "http://localhost/repos/stuff" using
|
||||||
|
# this configuration, run as root:
|
||||||
|
#
|
||||||
|
# # cd /var/www/svn
|
||||||
|
# # svnadmin create stuff
|
||||||
|
# # chown -R apache:apache stuff
|
||||||
|
# # chcon -R -t httpd_sys_content_t stuff
|
||||||
|
#
|
||||||
|
|
||||||
|
#<Location /repos>
|
||||||
|
# DAV svn
|
||||||
|
# SVNParentPath /var/www/svn
|
||||||
|
#
|
||||||
|
# # Limit write permission to list of valid users.
|
||||||
|
# <LimitExcept GET PROPFIND OPTIONS REPORT>
|
||||||
|
# # Require SSL connection for password protection.
|
||||||
|
# # SSLRequireSSL
|
||||||
|
#
|
||||||
|
# AuthType Basic
|
||||||
|
# AuthName "Authorization Realm"
|
||||||
|
# AuthUserFile /path/to/passwdfile
|
||||||
|
# Require valid-user
|
||||||
|
# </LimitExcept>
|
||||||
|
#</Location>
|
13
SOURCES/svnserve.service
Normal file
13
SOURCES/svnserve.service
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
[Unit]
|
||||||
|
Description=Subversion protocol daemon
|
||||||
|
After=syslog.target network.target
|
||||||
|
Documentation=man:svnserve(8)
|
||||||
|
|
||||||
|
[Service]
|
||||||
|
Type=forking
|
||||||
|
EnvironmentFile=/etc/sysconfig/svnserve
|
||||||
|
ExecStart=/usr/bin/svnserve --daemon --pid-file=/run/svnserve/svnserve.pid $OPTIONS
|
||||||
|
PrivateTmp=yes
|
||||||
|
|
||||||
|
[Install]
|
||||||
|
WantedBy=multi-user.target
|
4
SOURCES/svnserve.sysconf
Normal file
4
SOURCES/svnserve.sysconf
Normal file
@ -0,0 +1,4 @@
|
|||||||
|
# OPTIONS is used to pass command-line arguments to svnserve.
|
||||||
|
#
|
||||||
|
# Specify the repository location in -r parameter:
|
||||||
|
OPTIONS="-r /var/svn"
|
1
SOURCES/svnserve.tmpfiles
Normal file
1
SOURCES/svnserve.tmpfiles
Normal file
@ -0,0 +1 @@
|
|||||||
|
D /run/svnserve 0700 root root -
|
1018
SPECS/subversion.spec
Normal file
1018
SPECS/subversion.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user