import UBI subscription-manager-1.28.40-1.el8_9

This commit is contained in:
eabdullin 2023-11-14 18:52:17 +00:00
parent 721503844c
commit 869cb90578
4 changed files with 93 additions and 227 deletions

4
.gitignore vendored
View File

@ -1,2 +1,2 @@
SOURCES/subscription-manager-1.28.36.tar.gz
SOURCES/subscription-manager-cockpit-1.28.36.tar.gz
SOURCES/subscription-manager-1.28.40.tar.gz
SOURCES/subscription-manager-cockpit-1.28.40.tar.gz

View File

@ -1,2 +1,2 @@
6f4343d358f15c4a62d6c9e99bcd0cef4666a415 SOURCES/subscription-manager-1.28.36.tar.gz
563cd7a7b586d72f5e9b4032593ba5befad64dff SOURCES/subscription-manager-cockpit-1.28.36.tar.gz
5326ac57a950e727a7c88b703bbc16b5b1cbe108 SOURCES/subscription-manager-1.28.40.tar.gz
79fd54731e17471f43d144a9c8e24d2fcd722d7b SOURCES/subscription-manager-cockpit-1.28.40.tar.gz

View File

@ -1,99 +0,0 @@
diff --git a/etc-conf/dbus/system.d/com.redhat.RHSM1.conf b/etc-conf/dbus/system.d/com.redhat.RHSM1.conf
index e21c57263..11adf1d79 100644
--- a/etc-conf/dbus/system.d/com.redhat.RHSM1.conf
+++ b/etc-conf/dbus/system.d/com.redhat.RHSM1.conf
@@ -7,23 +7,9 @@
<policy user="root">
<allow own="com.redhat.RHSM1"/>
- <!-- Basic D-Bus API stuff -->
- <allow send_destination="com.redhat.RHSM1"
- send_interface="org.freedesktop.DBus.Introspectable"/>
- <allow send_destination="com.redhat.RHSM1"
- send_interface="org.freedesktop.DBus.Properties"/>
- <allow send_destination="com.redhat.RHSM1"
- send_interface="org.freedesktop.DBus.ObjectManager"/>
-
- <!-- allow Config.Set from root -->
- <allow send_destination="com.redhat.RHSM1"
- send_interface="com.redhat.RHSM1.Config"
- send_member="Set"/>
- </policy>
-
-
- <policy context="default">
- <!-- TODO: make these read-only by default -->
+ <!--
+ Lock down the objects to root access only
+ -->
<allow send_destination="com.redhat.RHSM1"
send_interface="com.redhat.RHSM1"/>
@@ -37,11 +23,6 @@
<allow send_destination="com.redhat.RHSM1"
send_interface="com.redhat.RHSM1.Config"/>
- <!-- deny Config.Set by default -->
- <deny send_destination="com.redhat.RHSM1"
- send_interface="com.redhat.RHSM1.Config"
- send_member="Set"/>
-
<allow send_destination="com.redhat.RHSM1"
send_interface="com.redhat.RHSM1.RegisterServer"/>
@@ -65,5 +46,54 @@
<allow send_destination="com.redhat.RHSM1"
send_interface="org.freedesktop.DBus.ObjectManager"/>
</policy>
-</busconfig>
+
+ <policy context="default">
+
+ <!--
+ Non-root users can execute only methods providing
+ information from files readable by non-root users.
+ -->
+
+ <allow send_destination="com.redhat.RHSM1"
+ send_interface="com.redhat.RHSM1.Entitlement"
+ send_member="GetStatus"/>
+
+ <allow send_destination="com.redhat.RHSM1"
+ send_interface="com.redhat.RHSM1.Products"
+ send_member="ListInstalledProducts"/>
+
+ <allow send_destination="com.redhat.RHSM1"
+ send_interface="com.redhat.RHSM1.Syspurpose"
+ send_member="GetSyspurpose"/>
+
+ <allow send_destination="com.redhat.RHSM1"
+ send_interface="com.redhat.RHSM1.Syspurpose"
+ send_member="GetSyspurposeStatus"/>
+
+ <allow send_destination="com.redhat.RHSM1"
+ send_interface="com.redhat.RHSM1.Config"
+ send_member="GetAll"/>
+
+ <allow send_destination="com.redhat.RHSM1"
+ send_interface="com.redhat.RHSM1.Config"
+ send_member="Get"/>
+
+ <!--
+ The UUID returned by following method is read
+ from consumer cert. Only this file is not
+ readable by non-root users.
+ -->
+ <allow send_destination="com.redhat.RHSM1"
+ send_interface="com.redhat.RHSM1.Consumer"
+ send_member="GetUuid"/>
+
+ <!-- Basic D-Bus API stuff -->
+ <allow send_destination="com.redhat.RHSM1"
+ send_interface="org.freedesktop.DBus.Introspectable"/>
+ <allow send_destination="com.redhat.RHSM1"
+ send_interface="org.freedesktop.DBus.Properties"/>
+ <allow send_destination="com.redhat.RHSM1"
+ send_interface="org.freedesktop.DBus.ObjectManager"/>
+ </policy>
+</busconfig>

View File

@ -15,9 +15,7 @@
%global use_container_plugin 1
%endif
%if (0%{?rhel} >= 7 || 0%{?fedora})
%global dmidecode_version >= 3.12.2-2
%endif
%global dmidecode_arches %{ix86} x86_64 aarch64
# We use the tmpfiles_create macro from systemd-rpm-macros rpm.
# Because of an incorrect version labelling of that rpm in SLES 12 which
@ -51,13 +49,6 @@
%global use_subman_gui 1
%endif
# Install subscription-manager-migration only for rhel8 and lower
%if 0%{?rhel} && 0%{?rhel} <= 8
%global use_subscription_manager_migration 1
%else
%global use_subscription_manager_migration 0
%endif
%if 0%{?suse_version} && 0%{?suse_version} < 1200
%global completion_dir %{_sysconfdir}/bash_completion.d
%else
@ -188,12 +179,6 @@
%global with_subman_gui WITH_SUBMAN_GUI=false
%endif
%if %{use_subscription_manager_migration}
%global with_subman_migration WITH_SUBMAN_MIGRATION=true
%else
%global with_subman_migration WITH_SUBMAN_MIGRATION=false
%endif
%if %{use_cockpit} && !0%{use_subman_gui}
%global with_cockpit WITH_COCKPIT=true
%else
@ -230,10 +215,6 @@
%global exclude_packages %{exclude_packages}*.plugin.container,
%endif
%if !%{use_subscription_manager_migration}
%global exclude_packages %{exclude_packages}subscription_manager.migrate,
%endif
# add new exclude_packages items before me
%global exclude_packages %{exclude_packages}"
@ -244,8 +225,8 @@
%global use_rhsm_icons 0%{use_cockpit} || 0%{use_rhsm_gtk}
Name: subscription-manager
Version: 1.28.36
Release: 3%{?dist}
Version: 1.28.40
Release: 1%{?dist}
Summary: Tools and libraries for subscription and repository management
%if 0%{?suse_version}
Group: Productivity/Networking/System
@ -291,6 +272,10 @@ Requires: %{py_package_prefix}-ethtool
Requires: %{py_package_prefix}-iniparse
Requires: %{py_package_prefix}-decorator
Requires: virt-what
%ifarch %{dmidecode_arches}
Requires: dmidecode
%endif
%if 0%{?suse_version}
Requires: logrotate
Requires: cron
@ -337,11 +322,6 @@ Requires: python3-gobject-base
%else
Requires: %{?gtk3:gobject-introspection, pygobject3-base} %{!?gtk3:pygobject2}
%endif
# There's no dmi to read on these arches, so don't pull in this dep.
# Additionally, dmidecode isn't packaged at all on SUSE
%ifnarch aarch64 ppc ppc64 ppc64le s390 s390x
Requires: %{py_package_prefix}-dmidecode %{?dmidecode_version}
%endif
%endif
%if %use_inotify
@ -366,7 +346,6 @@ BuildRequires: gcc
BuildRequires: %{py_package_prefix}-setuptools
BuildRequires: gettext
BuildRequires: intltool
BuildRequires: libnotify-devel
BuildRequires: %{py_package_prefix}-six
%if %{use_subman_gui} || %{use_cockpit}
@ -384,10 +363,7 @@ BuildRequires: libzypp
%endif
%if %{use_subman_gui}
BuildRequires: %{?suse_version:gconf2-devel} %{!?suse_version:GConf2-devel}
BuildRequires: %{?suse_version:update-desktop-files} %{!?suse_version:scrollkeeper}
BuildRequires: %{?suse_version:dbus-1-glib-devel} %{!?suse_version:dbus-glib-devel}
BuildRequires: %{?gtk3:gtk3-devel} %{!?gtk3:gtk2-devel}
%endif
%if %use_systemd
@ -398,12 +374,12 @@ BuildRequires: systemd-rpm-macros
BuildRequires: systemd
%endif
Obsoletes: subscription-manager-migration <= %{version}-%{release}
%if !%{use_container_plugin}
Obsoletes: subscription-manager-plugin-container
%endif
Patch00001: 00001-fix-dbus-policy.patch
%description
The Subscription Manager package provides programs and libraries to allow users
to manage subscriptions and yum repositories from the Red Hat entitlement
@ -475,7 +451,6 @@ Group: System Environment/Base
Requires: %{name} = %{version}-%{release}
Requires: gnome-icon-theme
# We need pygtk3 and gtk2 until rhsm-icon is ported to gtk3
Requires: rhsm-gtk = %{version}-%{release}
# Renamed from -gnome, so obsolete it properly
@ -495,29 +470,6 @@ subscriptions.
%endif
%if %{use_subscription_manager_migration}
%package -n subscription-manager-migration
Summary: Migration scripts for moving to certificate based subscriptions
%if 0%{?suse_version}
Group: Productivity/Networking/System
%else
Group: System Environment/Base
%endif
Requires: %{name} = %{version}-%{release}
Requires: rhnlib
# Since the migration data package is not in Fedora, we can only require it
# on RHEL.
%if 0%{?rhel}
Requires: subscription-manager-migration-data
%endif
%description -n subscription-manager-migration
This package contains scripts that aid in moving to certificate based
subscriptions
%endif
%if %use_dnf
%package -n dnf-plugin-subscription-manager
Summary: Subscription Manager plugins for DNF
@ -690,21 +642,6 @@ Entitlement Platform. This interface is used for the management of system
entitlements, certificates, and access to content.
%endif
%package -n subscription-manager-rhsm-certificates
Summary: Certificates required to communicate with a Red Hat Unified Entitlement Platform
%if 0%{?suse_version}
Group: Development/Libraries/Python
%else
Group: Development/Libraries
%endif
Provides: python-rhsm-certificates = %{version}-%{release}
Obsoletes: python-rhsm-certificates <= 1.20.3-1
%description -n subscription-manager-rhsm-certificates
This package contains certificates required for communicating with the REST interface
of a Red Hat Unified Entitlement Platform, used for the management of system entitlements
and to receive access to content.
%if %use_cockpit
%package -n subscription-manager-cockpit
Summary: Subscription Manager Cockpit UI
@ -748,8 +685,8 @@ subscription-manager-initial-setup-addon, and subscription-manager-cockpit-plugi
Summary: Python package for detection of public cloud provider
License: GPLv2
Requires: python3-requests
%ifnarch aarch64 ppc ppc64 ppc64le s390 s390x
Requires: %{py_package_prefix}-dmidecode %{?dmidecode_version}
%ifarch %{dmidecode_arches}
Requires: dmidecode
%endif
%description -n python3-cloud-what
@ -760,13 +697,11 @@ cloud metadata and signatures.
%prep
%setup -q
%autopatch -p1
%build
make -f Makefile VERSION=%{version}-%{release} CFLAGS="%{optflags}" \
LDFLAGS="%{__global_ldflags}" OS_DIST="%{dist}" PYTHON="%{__python}" \
%{?gtk_version} \
%{exclude_packages} %{?with_subman_gui} %{?with_subman_migration}
%{exclude_packages} %{?with_subman_gui}
%if %{with python2_rhsm}
python2 ./setup.py build --quiet --gtk-version=%{?gtk3:3}%{?!gtk3:2} --rpm-version=%{version}-%{release}
@ -795,7 +730,6 @@ make -f Makefile install VERSION=%{version}-%{release} \
%{?install_zypper_plugins} \
%{?with_systemd} \
%{?with_subman_gui} \
%{?with_subman_migration} \
%{?with_cockpit} \
%{?exclude_packages}
@ -825,7 +759,6 @@ cp %{buildroot}%{python_sitearch}/rhsm/*.py %{buildroot}%{python2_sitearch}/rhsm
%endif
%if %use_subman_gui
desktop-file-validate %{buildroot}/etc/xdg/autostart/rhsm-icon.desktop
desktop-file-validate %{buildroot}/usr/share/applications/subscription-manager-gui.desktop
%else
@ -852,13 +785,9 @@ mkdir -p %{buildroot}%{_sysconfdir}/pki/entitlement
# Setup cert directories for the container plugin:
mkdir -p %{buildroot}%{_sysconfdir}/docker/certs.d/
mkdir %{buildroot}%{_sysconfdir}/docker/certs.d/cdn.redhat.com
install -m 644 %{_builddir}/%{buildsubdir}/etc-conf/redhat-entitlement-authority.pem %{buildroot}%{_sysconfdir}/docker/certs.d/cdn.redhat.com/redhat-entitlement-authority.crt
install -m 644 %{_builddir}/%{buildsubdir}/src/content_plugins/redhat-entitlement-authority.pem %{buildroot}%{_sysconfdir}/docker/certs.d/cdn.redhat.com/redhat-entitlement-authority.crt
%endif
mkdir -p %{buildroot}%{_sysconfdir}/etc/rhsm/ca
install -m 644 %{_builddir}/%{buildsubdir}/etc-conf/redhat-entitlement-authority.pem %{buildroot}/%{_sysconfdir}/rhsm/ca/redhat-entitlement-authority.pem
install -m 644 %{_builddir}/%{buildsubdir}/etc-conf/redhat-uep.pem %{buildroot}/%{_sysconfdir}/rhsm/ca/redhat-uep.pem
%if %use_cockpit
# install cockpit dist targz
tar --strip-components=1 -xzf %{SOURCE1} -C %{buildroot}
@ -943,6 +872,7 @@ find %{buildroot} -name \*.py* -exec touch -r %{SOURCE0} '{}' \;
%attr(755,root,root) %{_bindir}/rhsmcertd
%attr(755,root,root) %{_libexecdir}/rhsmcertd-worker
%attr(755,root,root) %{_libexecdir}/rhsm-package-profile-uploader
# our config dirs and files
@ -1003,14 +933,6 @@ find %{buildroot} -name \*.py* -exec touch -r %{SOURCE0} '{}' \;
%{completion_dir}/rhsm-debug
%{completion_dir}/rhsmcertd
%if %{use_subscription_manager_migration}
%{completion_dir}/rhn-migrate-classic-to-rhsm
%endif
%if %use_subman_gui
%{completion_dir}/rhsm-icon
%endif
%dir %{python_sitearch}/subscription_manager
# code, python modules and packages
@ -1165,7 +1087,6 @@ find %{buildroot} -name \*.py* -exec touch -r %{SOURCE0} '{}' \;
%{_bindir}/subscription-manager-gui
%endif
%{_bindir}/rhsm-icon
%doc %{_datadir}/gnome/help/subscription-manager/C/figures/*.png
%doc %{_datadir}/gnome/help/subscription-manager/C/*.xml
@ -1174,8 +1095,7 @@ find %{buildroot} -name \*.py* -exec touch -r %{SOURCE0} '{}' \;
%{_datadir}/applications/subscription-manager-gui.desktop
%{_datadir}/appdata/subscription-manager-gui.appdata.xml
# desktop config files
%{_sysconfdir}/xdg/autostart/rhsm-icon.desktop
%if !0%{?suse_version}
%{_sysconfdir}/pam.d/subscription-manager-gui
%{_sysconfdir}/security/console.apps/subscription-manager-gui
@ -1185,7 +1105,6 @@ find %{buildroot} -name \*.py* -exec touch -r %{SOURCE0} '{}' \;
%doc
%{_mandir}/man8/subscription-manager-gui.8*
%{_mandir}/man8/rhsm-icon.8*
%doc LICENSE
%endif
@ -1211,24 +1130,6 @@ find %{buildroot} -name \*.py* -exec touch -r %{SOURCE0} '{}' \;
%endif
%if 0%{?use_subscription_manager_migration}
%files -n subscription-manager-migration
%defattr(-,root,root,-)
%dir %{python_sitearch}/subscription_manager/migrate
%{python_sitearch}/subscription_manager/migrate/*.py*
%if %{with python3}
%{python_sitearch}/subscription_manager/migrate/__pycache__
%endif
%attr(755,root,root) %{_sbindir}/rhn-migrate-classic-to-rhsm
%doc
%{_mandir}/man8/rhn-migrate-classic-to-rhsm.8*
%doc LICENSE
%if 0%{?fedora}
%doc README.Fedora
%endif
%endif
%files -n %{py_package_prefix}-syspurpose -f syspurpose.lang
%defattr(-,root,root,-)
%dir %{python_sitelib}/syspurpose*.egg-info
@ -1328,13 +1229,6 @@ find %{buildroot} -name \*.py* -exec touch -r %{SOURCE0} '{}' \;
%{python_sitearch}/cloud_what/providers/__pycache__
%endif
%files -n subscription-manager-rhsm-certificates
%attr(755,root,root) %dir %{_sysconfdir}/rhsm
%attr(755,root,root) %dir %{_sysconfdir}/rhsm/ca
%attr(644,root,root) %{_sysconfdir}/rhsm/ca/redhat-entitlement-authority.pem
%attr(644,root,root) %{_sysconfdir}/rhsm/ca/redhat-uep.pem
%if %use_cockpit
%files -n subscription-manager-cockpit
%defattr(-,root,root,-)
@ -1487,9 +1381,80 @@ gtk-update-icon-cache -f %{_datadir}/icons/hicolor &>/dev/null || :
%endif
%changelog
* Tue Aug 08 2023 Jiri Hnidek <jhnidek@redhat.com> 1.28.36-3
- 2225442: Fix D-Bus policy (jhnidek@redhat.com)
* Wed Feb 22 2023 Pino Toscano <ptoscano@redhat.com> 1.28.36-2
* Thu Sep 14 2023 Pino Toscano <ptoscano@redhat.com> 1.28.40-1
- Translated using Weblate (Chinese (Simplified) (zh_CN)) (ptoscano@redhat.com)
* Wed Aug 23 2023 Pino Toscano <ptoscano@redhat.com> 1.28.39-1
- Translated using Weblate (Korean) (simmon@nplob.com)
- Update translation files (noreply@weblate.org)
- 2225443: [1.28] Hotfix of D-Bus policy (jhnidek@redhat.com)
- New extraction for translatable strings (ptoscano@redhat.com)
- Translated using Weblate (Punjabi) (jsefler@redhat.com)
- Translated using Weblate (Korean) (simmon@nplob.com)
- [1.28] Update messaging around the "container mode" (#3310)
(34436146+grunwmar@users.noreply.github.com)
- ENT-5624: Properly translate error strings (mhorky@redhat.com)
- ENT-5610: Explicitly check for provided entitlement certificates
(mhorky@redhat.com)
- Fix flake8 errors (mhorky@redhat.com)
- Run flake8 and rpmlint on CI (mhorky@redhat.com)
- Mock IOError for Insights fact collection tests (mhorky@redhat.com)
- Collect GCP Project information as cloud facts (chambrid@redhat.com)
- Collect Azure Subscription ID as a cloud fact (#3285) (chambrid@redhat.com)
- Update cockpit test lib for Chromium 113 fix (martin@piware.de)
- tests: repair attach cases in SCA mode (ptoscano@redhat.com)
- 2091269: Make locking more reliable (jhnidek@redhat.com)
* Wed May 17 2023 Pino Toscano <ptoscano@redhat.com> 1.28.38-1
- Translated using Weblate (Italian) (toscano.pino@tiscali.it)
- Update translation files (noreply@weblate.org)
- Clean up tests using Cloud What detectors properly (mhorky@redhat.com)
- spec: Obsolete subscription-manager-migration (ptoscano@redhat.com)
- New extraction for translatable strings (ptoscano@redhat.com)
- Translated using Weblate (Italian) (toscano.pino@tiscali.it)
- 2150814: Drop RHN migration (ptoscano@redhat.com)
- ci: stop testing on Fedora Rawhide (ptoscano@redhat.com)
- Drop redhat-uep.pem (ptoscano@redhat.com)
- Move redhat-entitlement-authority.pem to container plugin
(ptoscano@redhat.com)
- Drop subscription-manager-rhsm-certificates package (ptoscano@redhat.com)
- utils: import pkg_resources only when needed (ptoscano@redhat.com)
- ENT-5532: Call rhsm-package-profile-uploader with --force-upload
(jhnidek@redhat.com)
- rhsmcertd reads default_log_level from rhsm.conf (jhnidek@redhat.com)
- Create log dir by rhsmcertd, when log dir does not exist (jhnidek@redhat.com)
- Fix issue with old glib not containing one macro (jhnidek@redhat.com)
- 2132242: [1.28] Outsource uploading DNF profile to rhsmcertd
(jhnidek@redhat.com)
- 1890080: Handle IOErrors and Exceptions when looking for process names
(csnyder@redhat.com)
- ci: install nodejs-npm on Fedora (ptoscano@redhat.com)
- tito: add centos-8-stream releaser (ptoscano@redhat.com)
* Wed Apr 19 2023 Pino Toscano <ptoscano@redhat.com> 1.28.37-1
- 2174887: register: do a simple strip() on environment(s) input
(ptoscano@redhat.com)
- [1.28] Remove source code of rhsm-icon (jhnidek@redhat.com)
- Fix of unit tests of d-bus register: extended list of exceptions for
catching. (jhnidek@redhat.com)
- [1.28] Include D-Bus sender in User-Agent http header; Singleton
(jhnidek@redhat.com)
- Revert "Try to use --forked for all unit tests." (ptoscano@redhat.com)
- test: add simple test for 1982670 (ptoscano@redhat.com)
- 2076948: [1.28] Fix issue with race condition in rhsm.service
(jhnidek@redhat.com)
- 1982670: do not collect unentitled products in SCA mode (ptoscano@redhat.com)
- Use dmidecode on aarch64 (jhnidek@redhat.com)
- Fix possible parsing issues of dmidecode output (mhorky@redhat.com)
- zypper: drop dead python-dmidecode usage (ptoscano@redhat.com)
- facts: drop DmiFirmwareInfoCollector (ptoscano@redhat.com)
- facts: switch to DmidecodeFactCollector for DMI facts (ptoscano@redhat.com)
- facts: add dmidecode parser and facts collector (ptoscano@redhat.com)
- cloud-what: switch MiniHostCollector to dmidecode(1) (ptoscano@redhat.com)
- Remove pytest arguments for CentOS 9 Stream image (mhorky@redhat.com)
- tests: Install dnf-plugins-core every time (mhorky@redhat.com)
* Wed Feb 22 2023 Pino Toscano <ptoscano@redhat.com> 1.28.36-1
- Translated using Weblate (French) (ljanda@redhat.com)
- Translated using Weblate (French) (suanand@redhat.com)
- Translated using Weblate (Korean) (jsefler@redhat.com)