dfaeaaee32
- Fixed incorrect reporting of fips status in configure.ac at compile time - Fixed default OpenSSL directory issue by using with-ssl - Updates local patches - 1155977: Fixes man page issues
53 lines
2.9 KiB
Diff
53 lines
2.9 KiB
Diff
diff -urNp stunnel-5.08/doc/stunnel.8 stunnel-5.08-patched/doc/stunnel.8
|
|
--- stunnel-5.08/doc/stunnel.8 2014-11-15 10:25:48.000000000 -0500
|
|
+++ stunnel-5.08-patched/doc/stunnel.8 2014-11-23 01:06:17.213015545 -0500
|
|
@@ -202,7 +202,7 @@ info (6), or debug (7). All logs for th
|
|
all levels numerically less than it will be shown. Use \fIdebug = debug\fR or
|
|
\&\fIdebug = 7\fR for greatest debugging output. The default is notice (5).
|
|
.Sp
|
|
-The syslog facility 'daemon' will be used unless a facility name is supplied.
|
|
+The syslog facility 'authpriv' will be used unless a facility name is supplied.
|
|
(Facilities are not supported on Win32.)
|
|
.Sp
|
|
Case is ignored for both facilities and levels.
|
|
diff -urNp stunnel-5.08/doc/stunnel.html stunnel-5.08-patched/doc/stunnel.html
|
|
--- stunnel-5.08/doc/stunnel.html 2014-11-15 10:25:48.000000000 -0500
|
|
+++ stunnel-5.08-patched/doc/stunnel.html 2014-11-23 01:07:01.905520548 -0500
|
|
@@ -202,7 +202,7 @@
|
|
|
|
<p>Level is a one of the syslog level names or numbers emerg (0), alert (1), crit (2), err (3), warning (4), notice (5), info (6), or debug (7). All logs for the specified level and all levels numerically less than it will be shown. Use <i>debug = debug</i> or <i>debug = 7</i> for greatest debugging output. The default is notice (5).</p>
|
|
|
|
-<p>The syslog facility 'daemon' will be used unless a facility name is supplied. (Facilities are not supported on Win32.)</p>
|
|
+<p>The syslog facility 'authpriv' will be used unless a facility name is supplied. (Facilities are not supported on Win32.)</p>
|
|
|
|
<p>Case is ignored for both facilities and levels.</p>
|
|
|
|
diff -urNp stunnel-5.08/doc/stunnel.pod stunnel-5.08-patched/doc/stunnel.pod
|
|
--- stunnel-5.08/doc/stunnel.pod 2014-11-15 10:25:48.000000000 -0500
|
|
+++ stunnel-5.08-patched/doc/stunnel.pod 2014-11-23 01:07:13.002397392 -0500
|
|
@@ -188,7 +188,7 @@ info (6), or debug (7). All logs for th
|
|
all levels numerically less than it will be shown. Use I<debug = debug> or
|
|
I<debug = 7> for greatest debugging output. The default is notice (5).
|
|
|
|
-The syslog facility 'daemon' will be used unless a facility name is supplied.
|
|
+The syslog facility 'authpriv' will be used unless a facility name is supplied.
|
|
(Facilities are not supported on Win32.)
|
|
|
|
Case is ignored for both facilities and levels.
|
|
diff -urNp stunnel-5.08/src/options.c stunnel-5.08-patched/src/options.c
|
|
--- stunnel-5.08/src/options.c 2014-11-14 13:55:39.000000000 -0500
|
|
+++ stunnel-5.08-patched/src/options.c 2014-11-23 01:07:36.967131425 -0500
|
|
@@ -461,8 +461,12 @@ NOEXPORT char *parse_global_option(CMD c
|
|
case CMD_BEGIN:
|
|
new_global_options.debug_level=LOG_NOTICE;
|
|
#if !defined (USE_WIN32) && !defined (__vms)
|
|
+#if defined(LOG_AUTHPRIV)
|
|
+ new_global_options.facility=LOG_AUTHPRIV;
|
|
+#else
|
|
new_global_options.facility=LOG_DAEMON;
|
|
#endif
|
|
+#endif
|
|
break;
|
|
case CMD_EXEC:
|
|
if(strcasecmp(opt, "debug"))
|