- New upstream realease 4.29
- Updated authpriv and sample patches for the new release - Modified spec file to include dist tag
This commit is contained in:
parent
ccbf4939b7
commit
66a8720362
@ -1,2 +1,4 @@
|
|||||||
stunnel-4.27.tar.gz
|
stunnel-4.27.tar.gz
|
||||||
stunnel-4.27.tar.gz.asc
|
stunnel-4.27.tar.gz.asc
|
||||||
|
stunnel-4.29.tar.gz
|
||||||
|
stunnel-4.29.tar.gz.asc
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
3c655d815576f50046a1c28744b88681 stunnel-4.27.tar.gz
|
14dc3f8412947f0548975cbce74d6863 stunnel-4.29.tar.gz
|
||||||
1219d667d1a1306f392d180587c6b50e stunnel-4.27.tar.gz.asc
|
655172db10aa297e2085009af22797fb stunnel-4.29.tar.gz.asc
|
||||||
|
@ -1,21 +0,0 @@
|
|||||||
diff -urN stunnel/src/libwrap.c stunnel-4.27/src/libwrap.c
|
|
||||||
--- stunnel/src/libwrap.c 2009-04-16 10:48:49.000000000 +0200
|
|
||||||
+++ stunnel-4.27/src/libwrap.c 2009-04-29 11:34:05.000000000 +0200
|
|
||||||
@@ -246,7 +246,7 @@
|
|
||||||
s_log(LOG_ERR, "control type != SCM_RIGHTS");
|
|
||||||
return -1;
|
|
||||||
}
|
|
||||||
- *recvfd=*((int *)CMSG_DATA(cmptr));
|
|
||||||
+ memcpy(recvfd, CMSG_DATA(cmptr), sizeof(int));
|
|
||||||
#else
|
|
||||||
if(msg.msg_accrightslen==sizeof(int))
|
|
||||||
*recvfd=newfd;
|
|
||||||
@@ -273,7 +273,7 @@
|
|
||||||
cmptr->cmsg_len=CMSG_LEN(sizeof(int));
|
|
||||||
cmptr->cmsg_level=SOL_SOCKET;
|
|
||||||
cmptr->cmsg_type=SCM_RIGHTS;
|
|
||||||
- *((int *)CMSG_DATA(cmptr))=sendfd;
|
|
||||||
+ memcpy(CMSG_DATA(cmptr), &sendfd, sizeof(int));
|
|
||||||
#else
|
|
||||||
msg.msg_accrights=(caddr_t)&sendfd;
|
|
||||||
msg.msg_accrightslen=sizeof(int);
|
|
@ -1,32 +1,7 @@
|
|||||||
Change the default log facility from LOG_DAEMON to LOG_AUTHPRIV.
|
diff -urNp stunnel-4.29-orig/doc/stunnel.8 stunnel-4.29/doc/stunnel.8
|
||||||
diff -urN stunnel/doc/stunnel.html stunnel-4.27/doc/stunnel.html
|
--- stunnel-4.29-orig/doc/stunnel.8 2009-11-20 15:50:52.000000000 -0500
|
||||||
--- stunnel/doc/stunnel.html 2009-04-16 11:17:26.000000000 +0200
|
+++ stunnel-4.29/doc/stunnel.8 2009-12-09 16:44:25.000000000 -0500
|
||||||
+++ stunnel-4.27/doc/stunnel.html 2009-04-16 18:09:06.000000000 +0200
|
@@ -169,7 +169,7 @@ info (6), or debug (7). All logs for th
|
||||||
@@ -189,7 +189,7 @@
|
|
||||||
info (6), or debug (7). All logs for the specified level and
|
|
||||||
all levels numerically less than it will be shown. Use <strong>debug = debug</strong> or
|
|
||||||
<strong>debug = 7</strong> for greatest debugging output. The default is notice (5).</p>
|
|
||||||
-<p>The syslog facility 'daemon' will be used unless a facility name is supplied.
|
|
||||||
+<p>The syslog facility 'authpriv' will be used unless a facility name is supplied.
|
|
||||||
(Facilities are not supported on Win32.)</p>
|
|
||||||
<p>Case is ignored for both facilities and levels.</p>
|
|
||||||
</dd>
|
|
||||||
diff -urN stunnel/doc/stunnel.pod stunnel-4.27/doc/stunnel.pod
|
|
||||||
--- stunnel/doc/stunnel.pod 2009-04-16 10:38:41.000000000 +0200
|
|
||||||
+++ stunnel-4.27/doc/stunnel.pod 2009-04-16 18:08:49.000000000 +0200
|
|
||||||
@@ -139,7 +139,7 @@
|
|
||||||
all levels numerically less than it will be shown. Use B<debug = debug> or
|
|
||||||
B<debug = 7> for greatest debugging output. The default is notice (5).
|
|
||||||
|
|
||||||
-The syslog facility 'daemon' will be used unless a facility name is supplied.
|
|
||||||
+The syslog facility 'authpriv' will be used unless a facility name is supplied.
|
|
||||||
(Facilities are not supported on Win32.)
|
|
||||||
|
|
||||||
Case is ignored for both facilities and levels.
|
|
||||||
diff -urN stunnel/doc/stunnel.8 stunnel-4.27/doc/stunnel.8
|
|
||||||
--- stunnel/doc/stunnel.8 2009-04-16 11:17:25.000000000 +0200
|
|
||||||
+++ stunnel-4.27/doc/stunnel.8 2009-04-16 18:08:49.000000000 +0200
|
|
||||||
@@ -226,7 +226,7 @@
|
|
||||||
all levels numerically less than it will be shown. Use \fBdebug = debug\fR or
|
all levels numerically less than it will be shown. Use \fBdebug = debug\fR or
|
||||||
\&\fBdebug = 7\fR for greatest debugging output. The default is notice (5).
|
\&\fBdebug = 7\fR for greatest debugging output. The default is notice (5).
|
||||||
.Sp
|
.Sp
|
||||||
@ -35,10 +10,34 @@ diff -urN stunnel/doc/stunnel.8 stunnel-4.27/doc/stunnel.8
|
|||||||
(Facilities are not supported on Win32.)
|
(Facilities are not supported on Win32.)
|
||||||
.Sp
|
.Sp
|
||||||
Case is ignored for both facilities and levels.
|
Case is ignored for both facilities and levels.
|
||||||
diff -urN stunnel/src/options.c stunnel-4.27/src/options.c
|
diff -urNp stunnel-4.29-orig/doc/stunnel.html stunnel-4.29/doc/stunnel.html
|
||||||
--- stunnel/src/options.c 2009-04-16 10:49:20.000000000 +0200
|
--- stunnel-4.29-orig/doc/stunnel.html 2009-11-20 15:50:52.000000000 -0500
|
||||||
+++ stunnel-4.27/src/options.c 2009-04-16 18:08:49.000000000 +0200
|
+++ stunnel-4.29/doc/stunnel.html 2009-12-09 16:43:09.000000000 -0500
|
||||||
@@ -136,8 +136,12 @@
|
@@ -192,7 +192,7 @@ emerg (0), alert (1), crit (2), err (3),
|
||||||
|
info (6), or debug (7). All logs for the specified level and
|
||||||
|
all levels numerically less than it will be shown. Use <strong>debug = debug</strong> or
|
||||||
|
<strong>debug = 7</strong> for greatest debugging output. The default is notice (5).</p>
|
||||||
|
-<p>The syslog facility 'daemon' will be used unless a facility name is supplied.
|
||||||
|
+<p>The syslog facility 'authpriv' will be used unless a facility name is supplied.
|
||||||
|
(Facilities are not supported on Win32.)</p>
|
||||||
|
<p>Case is ignored for both facilities and levels.</p>
|
||||||
|
</dd>
|
||||||
|
diff -urNp stunnel-4.29-orig/doc/stunnel.pod stunnel-4.29/doc/stunnel.pod
|
||||||
|
--- stunnel-4.29-orig/doc/stunnel.pod 2009-11-20 15:48:33.000000000 -0500
|
||||||
|
+++ stunnel-4.29/doc/stunnel.pod 2009-12-09 16:43:52.000000000 -0500
|
||||||
|
@@ -144,7 +144,7 @@ info (6), or debug (7). All logs for th
|
||||||
|
all levels numerically less than it will be shown. Use B<debug = debug> or
|
||||||
|
B<debug = 7> for greatest debugging output. The default is notice (5).
|
||||||
|
|
||||||
|
-The syslog facility 'daemon' will be used unless a facility name is supplied.
|
||||||
|
+The syslog facility 'authpriv' will be used unless a facility name is supplied.
|
||||||
|
(Facilities are not supported on Win32.)
|
||||||
|
|
||||||
|
Case is ignored for both facilities and levels.
|
||||||
|
diff -urNp stunnel-4.29-orig/src/options.c stunnel-4.29/src/options.c
|
||||||
|
--- stunnel-4.29-orig/src/options.c 2009-11-20 15:55:12.000000000 -0500
|
||||||
|
+++ stunnel-4.29/src/options.c 2009-12-09 16:45:57.000000000 -0500
|
||||||
|
@@ -136,8 +136,12 @@ static char *global_options(CMD cmd, cha
|
||||||
case CMD_INIT:
|
case CMD_INIT:
|
||||||
options.debug_level=5;
|
options.debug_level=5;
|
||||||
#if !defined (USE_WIN32) && !defined (__vms)
|
#if !defined (USE_WIN32) && !defined (__vms)
|
@ -1,39 +1,37 @@
|
|||||||
You shouldn't use the sample as-is, but people do.
|
diff -urNp stunnel-4.29-orig/tools/stunnel.conf-sample.in stunnel-4.29/tools/stunnel.conf-sample.in
|
||||||
|
--- stunnel-4.29-orig/tools/stunnel.conf-sample.in 2009-11-08 14:40:24.000000000 -0500
|
||||||
diff -urN stunnel/tools/stunnel.conf-sample.in stunnel-4.27/tools/stunnel.conf-sample.in
|
+++ stunnel-4.29/tools/stunnel.conf-sample.in 2009-12-09 16:51:38.000000000 -0500
|
||||||
--- stunnel/tools/stunnel.conf-sample.in 2009-04-16 11:10:09.000000000 +0200
|
|
||||||
+++ stunnel-4.27/tools/stunnel.conf-sample.in 2009-04-16 18:14:02.000000000 +0200
|
|
||||||
@@ -3,14 +3,14 @@
|
@@ -3,14 +3,14 @@
|
||||||
; Please make sure you understand them (especially the effect of the chroot jail)
|
; Please make sure you understand them (especially the effect of the chroot jail)
|
||||||
|
|
||||||
; Certificate/key is needed in server mode and optional in client mode
|
; Certificate/key is needed in server mode and optional in client mode
|
||||||
-cert = @prefix@/etc/stunnel/mail.pem
|
-cert = @prefix@/etc/stunnel/mail.pem
|
||||||
-;key = @prefix@/etc/stunnel/mail.pem
|
-;key = @prefix@/etc/stunnel/mail.pem
|
||||||
+cert = @sysconfdir@/stunnel/mail.crt
|
+cert = @sysconfdir@/etc/stunnel/mail.pem
|
||||||
+;key = @sysconfdir@/stunnel/mail.key
|
+;key = @sysconfdir@/etc/stunnel/mail.pem
|
||||||
|
|
||||||
; Protocol version (all, SSLv2, SSLv3, TLSv1)
|
; Protocol version (all, SSLv2, SSLv3, TLSv1)
|
||||||
sslVersion = SSLv3
|
sslVersion = SSLv3
|
||||||
|
|
||||||
; Some security enhancements for UNIX systems - comment them out on Win32
|
; Some security enhancements for UNIX systems - comment them out on Win32
|
||||||
-chroot = @prefix@/var/lib/stunnel/
|
-chroot = @prefix@/var/lib/stunnel/
|
||||||
+chroot = @localstatedir@/run/stunnel/
|
+chroot = @localstatedir@/var/lib/stunnel/
|
||||||
setuid = nobody
|
setuid = nobody
|
||||||
setgid = @DEFAULT_GROUP@
|
setgid = @DEFAULT_GROUP@
|
||||||
; PID is created inside the chroot jail
|
; PID is created inside the chroot jail
|
||||||
@@ -30,12 +30,13 @@
|
@@ -30,12 +30,13 @@ socket = r:TCP_NODELAY=1
|
||||||
; CApath is located inside chroot jail
|
; CApath is located inside chroot jail
|
||||||
;CApath = /certs
|
;CApath = /certs
|
||||||
; It's often easier to use CAfile
|
; It's often easier to use CAfile
|
||||||
-;CAfile = @prefix@/etc/stunnel/certs.pem
|
-;CAfile = @prefix@/etc/stunnel/certs.pem
|
||||||
+;CAfile = @sysconfdir@/stunnel/certs.pem
|
+;CAfile = @sysconfdir@/etc/stunnel/certs.pem
|
||||||
+;CAfile = @sysconfdir@/pki/tls/certs/ca-bundle.crt
|
+;CAfile = @sysconfdir@/pki/tls/certs/ca-bundle.crt
|
||||||
; Don't forget to c_rehash CRLpath
|
; Don't forget to c_rehash CRLpath
|
||||||
; CRLpath is located inside chroot jail
|
; CRLpath is located inside chroot jail
|
||||||
;CRLpath = /crls
|
;CRLpath = /crls
|
||||||
; Alternatively you can use CRLfile
|
; Alternatively you can use CRLfile
|
||||||
-;CRLfile = @prefix@/etc/stunnel/crls.pem
|
-;CRLfile = @prefix@/etc/stunnel/crls.pem
|
||||||
+;CRLfile = @sysconfdir@/stunnel/crls.pem
|
+;CRLfile = @sysconfdir@/etc/stunnel/crls.pem
|
||||||
|
|
||||||
; Some debugging stuff useful for troubleshooting
|
; Some debugging stuff useful for troubleshooting
|
||||||
;debug = 7
|
;debug = 7
|
17
stunnel.spec
17
stunnel.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: An SSL-encrypting socket wrapper
|
Summary: An SSL-encrypting socket wrapper
|
||||||
Name: stunnel
|
Name: stunnel
|
||||||
Version: 4.27
|
Version: 4.29
|
||||||
Release: 5
|
Release: 1%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
URL: http://stunnel.mirt.net/
|
URL: http://stunnel.mirt.net/
|
||||||
@ -12,9 +12,9 @@ Source3: sfinger.xinetd
|
|||||||
Source4: stunnel-sfinger.conf
|
Source4: stunnel-sfinger.conf
|
||||||
Source5: pop3-redirect.xinetd
|
Source5: pop3-redirect.xinetd
|
||||||
Source6: stunnel-pop3s-client.conf
|
Source6: stunnel-pop3s-client.conf
|
||||||
Patch0: stunnel-4.27-authpriv.patch
|
Patch0: stunnel-4.29-authpriv.patch
|
||||||
Patch1: stunnel-4.27-sample.patch
|
Patch1: stunnel-4.29-sample.patch
|
||||||
Patch2: stunnel-4.27-aliasing.patch
|
#Patch2: stunnel-4.27-aliasing.patch
|
||||||
Buildroot: %{_tmppath}/stunnel-root
|
Buildroot: %{_tmppath}/stunnel-root
|
||||||
# util-linux is needed for rename
|
# util-linux is needed for rename
|
||||||
BuildRequires: openssl-devel, pkgconfig, tcp_wrappers-devel, util-linux
|
BuildRequires: openssl-devel, pkgconfig, tcp_wrappers-devel, util-linux
|
||||||
@ -28,7 +28,7 @@ in conjunction with imapd to create an SSL secure IMAP server.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .authpriv
|
%patch0 -p1 -b .authpriv
|
||||||
%patch1 -p1 -b .sample
|
%patch1 -p1 -b .sample
|
||||||
%patch2 -p1 -b .aliasing
|
#%patch2 -p1 -b .aliasing
|
||||||
|
|
||||||
iconv -f iso-8859-1 -t utf-8 < doc/stunnel.fr.8 > doc/stunnel.fr.8_
|
iconv -f iso-8859-1 -t utf-8 < doc/stunnel.fr.8 > doc/stunnel.fr.8_
|
||||||
mv doc/stunnel.fr.8_ doc/stunnel.fr.8
|
mv doc/stunnel.fr.8_ doc/stunnel.fr.8
|
||||||
@ -81,6 +81,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%exclude %{_sysconfdir}/stunnel/*
|
%exclude %{_sysconfdir}/stunnel/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Dec 09 2009 Avesh Agrwal <avagarwa@redhat.com> - 4.29-1
|
||||||
|
- New upstream realease 4.29
|
||||||
|
- Updated authpriv and sample patches for the new release
|
||||||
|
- Modified spec file to include dist tag
|
||||||
|
|
||||||
* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 4.27-5
|
* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 4.27-5
|
||||||
- rebuilt with new openssl
|
- rebuilt with new openssl
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user