stress-ng: Add -fPIC flag to improve annocheck results
Add -fPIC flag to improve annocheck results Resolves: RHEL-33521 Signed-off-by: John Kacur <jkacur@redhat.com>
This commit is contained in:
parent
6c3adc9285
commit
75a9f2fc76
28
stress-ng-Add-fPIC-to-Makefile.patch
Normal file
28
stress-ng-Add-fPIC-to-Makefile.patch
Normal file
@ -0,0 +1,28 @@
|
||||
From f7ce349f5e1c3f4f4c9da9c2040bf6b6b71eccd6 Mon Sep 17 00:00:00 2001
|
||||
From: John Kacur <jkacur@redhat.com>
|
||||
Date: Tue, 11 Feb 2025 16:34:04 -0500
|
||||
Subject: [PATCH] stress-ng: Add fPIC to Makefile
|
||||
|
||||
Add fPIC to Makefile
|
||||
|
||||
Signed-off-by: John Kacur <jkacur@redhat.com>
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index cb395115cd64..372960503621 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -114,7 +114,7 @@ endif
|
||||
MACHINE = $(shell make -f Makefile.machine)
|
||||
ifneq ($(PRESERVE_CFLAGS),1)
|
||||
ifneq ($(MACHINE),$(filter $(MACHINE),alpha hppa ia64))
|
||||
-flag = -Wformat -fstack-protector-strong -Werror=format-security
|
||||
+flag = -Wformat -fstack-protector-strong -Werror=format-security -fPIC
|
||||
#
|
||||
# add -D_FORTIFY_SOURCE=2 if _FORTIFY_SOURCE is not already defined
|
||||
#
|
||||
--
|
||||
2.48.1
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: stress-ng
|
||||
Version: 0.18.06
|
||||
Release: 8%{?dist}
|
||||
Release: 9%{?dist}
|
||||
Summary: Stress test a computer system in various ways
|
||||
|
||||
License: GPL-2.0-or-later
|
||||
@ -33,6 +33,7 @@ Patch5: core-shim-use-shim-d-types-for-shim_poll-args.patch
|
||||
Patch6: core-shim-limit-_FORTIFY_SOURCE-to-2-for-ALT-linux-g.patch
|
||||
Patch7: core-target-clones-add-more-power9-10-11-target-clon.patch
|
||||
Patch8: stress-brk-ensure-the-failure-sbrk-errno-is-being-ch.patch
|
||||
Patch9: stress-ng-Add-fPIC-to-Makefile.patch
|
||||
|
||||
%description
|
||||
Stress test a computer system in various ways. It was designed to exercise
|
||||
@ -62,6 +63,10 @@ install -pm 644 bash-completion/%{name} \
|
||||
%{_datadir}/bash-completion/completions/%{name}
|
||||
|
||||
%changelog
|
||||
* Tue Feb 11 2025 John Kacur <jkacur@redhat.com> - 0.18.06-9
|
||||
- Add -fPIC flag to improve annocheck results
|
||||
Resolves: RHEL-33521
|
||||
|
||||
* Thu Jan 30 2025 John Kacur <jkacur@redhat.com> - 0.18.06-8
|
||||
- Moving the annocheck rules back from gating.yaml to rpminspect.yaml
|
||||
Resolves: RHEL-33521
|
||||
|
Loading…
Reference in New Issue
Block a user