version 0.5.3-1

Signed-off-by: Andy Grover <agrover@redhat.com>
This commit is contained in:
Andy Grover 2018-06-04 21:04:19 -07:00
parent fa64785dfd
commit 986be8a7df
5 changed files with 9 additions and 104 deletions

1
.gitignore vendored
View File

@ -3,3 +3,4 @@
/stratisd-0.5.0.tar.gz
/stratisd-0.5.1.tar.gz
/stratisd-0.5.2.tar.gz
/stratisd-0.5.3.tar.gz

View File

@ -1,26 +0,0 @@
From 0d47857807d6091daa1e7b4748cc0f70708068cb Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <ignatenko@redhat.com>
Date: Wed, 2 May 2018 11:56:35 +0200
Subject: [PATCH] deps: update uuid to 0.6
Signed-off-by: Igor Gnatenko <ignatenko@redhat.com>
---
Cargo.toml | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Cargo.toml b/Cargo.toml
index 73f70b5..e91a391 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -26,7 +26,7 @@ error-chain = "0.11.0"
libudev = "0.2.0"
[dependencies.uuid]
-version = "0.5"
+version = "0.6"
features = ["serde", "v4"]
[dev-dependencies]
--
2.17.0

View File

@ -1,70 +0,0 @@
From 66fb5f44bf9adcdf6bcedd4810217686a5c8d74d Mon Sep 17 00:00:00 2001
From: Andy Grover <agrover@redhat.com>
Date: Fri, 4 May 2018 12:30:45 -0700
Subject: [PATCH] Prefix commands with entire path
When invoked via dbus activation, we don't have /usr/sbin in our path, so
these commands are failing.
Signed-off-by: Andy Grover <agrover@redhat.com>
---
src/engine/strat_engine/thinpool/thinpool.rs | 4 ++--
src/engine/strat_engine/thinpool/util.rs | 8 +++++---
2 files changed, 7 insertions(+), 5 deletions(-)
diff --git a/src/engine/strat_engine/thinpool/thinpool.rs b/src/engine/strat_engine/thinpool/thinpool.rs
index 15245f5..c153882 100644
--- a/src/engine/strat_engine/thinpool/thinpool.rs
+++ b/src/engine/strat_engine/thinpool/thinpool.rs
@@ -785,7 +785,7 @@ fn setup_metadev
// TODO: Refine policy about failure to run thin_check.
// If, e.g., thin_check is unavailable, that doesn't necessarily
// mean that data is corrupted.
- if execute_cmd(Command::new("thin_check")
+ if execute_cmd(Command::new("/usr/sbin/thin_check")
.arg("-q")
.arg(&meta_dev.devnode()),
&format!("thin_check failed for pool {}", thinpool_name))
@@ -812,7 +812,7 @@ fn attempt_thin_repair(pool_uuid: PoolUuid,
Some(&dm_uuid),
segs_to_table(device, spare_segments))?;
- execute_cmd(Command::new("thin_repair")
+ execute_cmd(Command::new("/usr/sbin/thin_repair")
.arg("-i")
.arg(&meta_dev.devnode())
.arg("-o")
diff --git a/src/engine/strat_engine/thinpool/util.rs b/src/engine/strat_engine/thinpool/util.rs
index 2c1447d..245e6fd 100644
--- a/src/engine/strat_engine/thinpool/util.rs
+++ b/src/engine/strat_engine/thinpool/util.rs
@@ -30,7 +30,7 @@ pub fn execute_cmd(cmd: &mut Command, error_msg: &str) -> StratisResult<()> {
/// Create a filesystem on devnode.
pub fn create_fs(devnode: &Path, uuid: Uuid) -> StratisResult<()> {
- execute_cmd(Command::new("mkfs.xfs")
+ execute_cmd(Command::new("/usr/sbin/mkfs.xfs")
.arg("-f")
.arg("-q")
.arg(&devnode)
@@ -42,13 +42,15 @@ pub fn create_fs(devnode: &Path, uuid: Uuid) -> StratisResult<()> {
/// Use the xfs_growfs command to expand a filesystem mounted at the given
/// mount point.
pub fn xfs_growfs(mount_point: &Path) -> StratisResult<()> {
- execute_cmd(Command::new("xfs_growfs").arg(mount_point).arg("-d"),
+ execute_cmd(Command::new("/usr/sbin/xfs_growfs")
+ .arg(mount_point)
+ .arg("-d"),
&format!("Failed to expand filesystem {:?}", mount_point))
}
/// Set a new UUID for filesystem on the devnode.
pub fn set_uuid(devnode: &Path, uuid: Uuid) -> StratisResult<()> {
- execute_cmd(Command::new("xfs_admin")
+ execute_cmd(Command::new("/usr/sbin/xfs_admin")
.arg("-U")
.arg(format!("{}", uuid))
.arg(&devnode),
--
2.14.3

View File

@ -1 +1 @@
SHA512 (stratisd-0.5.2.tar.gz) = 1875510437066302ce0241914001f780cad729c15adf3d30319e0c9ab5fd33f21438d9515d09162f72e9cf7a9ba6637ad924f6356d0ffc04157a2fbac6399b20
SHA512 (stratisd-0.5.3.tar.gz) = 53c2c9e1271cb593c6ee03a04da676a32b261420df40d00af7719a8daad5da14c812b339270d482b494fdfdbc8f23b02b8a86bae81494375f8e2775988a53b0e

View File

@ -8,16 +8,13 @@
%global __cargo_common_opts %{__cargo_common_opts} --features dbus_enabled
Name: stratisd
Version: 0.5.2
Release: 2%{?dist}
Version: 0.5.3
Release: 1%{?dist}
Summary: Daemon that manages block devices to create filesystems
License: MPLv2.0
URL: https://github.com/stratis-storage/stratisd
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
# https://github.com/stratis-storage/stratisd/pull/916
Patch0001: 0001-deps-update-uuid-to-0.6.patch
Patch0002: 0002-Prefix-commands-with-entire-path.patch
ExclusiveArch: %{rust_arches}
@ -28,7 +25,7 @@ BuildRequires: (crate(chrono) >= 0.4.0 with crate(chrono) < 0.5.0)
BuildRequires: (crate(clap) >= 2.0.0 with crate(clap) < 3.0.0)
BuildRequires: (crate(crc) >= 1.0.0 with crate(crc) < 2.0.0)
BuildRequires: (crate(dbus) >= 0.6.1 with crate(dbus) < 0.7.0)
BuildRequires: (crate(devicemapper) >= 0.20.0 with crate(devicemapper) < 0.21.0)
BuildRequires: (crate(devicemapper) >= 0.21.0 with crate(devicemapper) < 0.22.0)
BuildRequires: (crate(env_logger) >= 0.4.0 with crate(env_logger) < 0.5.0)
BuildRequires: (crate(error-chain) >= 0.11.0 with crate(error-chain) < 0.12.0)
BuildRequires: (crate(libc) >= 0.2.36 with crate(libc) < 0.3.0)
@ -41,7 +38,7 @@ BuildRequires: (crate(rand) >= 0.4.0 with crate(rand) < 0.5.0)
BuildRequires: (crate(serde) >= 1.0.0 with crate(serde) < 2.0.0)
BuildRequires: (crate(serde_derive) >= 1.0.0 with crate(serde_derive) < 2.0.0)
BuildRequires: (crate(serde_json) >= 1.0.0 with crate(serde_json) < 2.0.0)
BuildRequires: (crate(tempdir) >= 0.3.5 with crate(tempdir) < 0.4.0)
BuildRequires: (crate(tempfile) >= 3.0.0 with crate(tempfile) < 4.0.0)
BuildRequires: ((crate(uuid) >= 0.6.0 with crate(uuid) < 0.7.0) with crate(uuid/serde) with crate(uuid/v4))
%if %{with check}
# [dev-dependencies]
@ -89,6 +86,9 @@ mv %{buildroot}%{_bindir}/stratisd %{buildroot}%{_libexecdir}/stratisd
%{_mandir}/man8/stratisd.8*
%changelog
* Mon Jun 4 2018 Andy Grover <agrover@redhat.com> - 0.5.3-1
- Update to 0.5.3
* Fri May 4 2018 Andy Grover <agrover@redhat.com> - 0.5.2-2
- Add 0002-Prefix-commands-with-entire-path.patch