Update to 1.0.5
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
0fcc7dbba1
commit
92c23b60cb
1
.gitignore
vendored
1
.gitignore
vendored
@ -12,3 +12,4 @@
|
||||
/stratisd-1.0.2.tar.gz
|
||||
/stratisd-1.0.3.tar.gz
|
||||
/stratisd-1.0.4.tar.gz
|
||||
/stratisd-1.0.5.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (stratisd-1.0.4.tar.gz) = 67428c827f2ae02af0a821c8330254ee6b00f9c918146ea495b2c2b970b686a1b89d0fc7828db60ad99dfcf3fbd24d41c9d19ee58786825d64912113859ad85d
|
||||
SHA512 (stratisd-1.0.5.tar.gz) = 619f10fe6f2998980e42284469d64f1c39bf622679362748ab5938b2f9422d71713ea2bf45a4f1db96cae510c3bdc10cca39509b13115fe2d9ca9c4d17d21425
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- stratisd/Cargo.toml 2019-06-04T23:39:07.962690+00:00
|
||||
+++ stratisd/Cargo.toml 2019-06-04T23:39:07.962690+00:00
|
||||
@@ -7,7 +7,7 @@
|
||||
[dependencies]
|
||||
dbus = {version = "0.6.4", optional = true}
|
||||
clap = "2"
|
||||
-nix = "0.13"
|
||||
+nix = "0.14"
|
||||
devicemapper = "0.27.0"
|
||||
crc = "1"
|
||||
byteorder = "1"
|
@ -1,56 +1,24 @@
|
||||
# Generated by rust2rpm
|
||||
# XXX: https://github.com/stratis-storage/stratisd/issues/1496
|
||||
%bcond_with check
|
||||
%global __cargo_skip_build 0
|
||||
|
||||
# Not interested in packaging lib
|
||||
# stratisd is supposed to be daemon used through dbus
|
||||
%global __cargo_is_lib() false
|
||||
|
||||
Name: stratisd
|
||||
Version: 1.0.4
|
||||
Release: 3%{?dist}
|
||||
Version: 1.0.5
|
||||
Release: 1%{?dist}
|
||||
Summary: Daemon that manages block devices to create filesystems
|
||||
|
||||
License: MPLv2.0
|
||||
URL: https://github.com/stratis-storage/stratisd
|
||||
Source: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
# Initial patched metadata
|
||||
# * Bump nix to 0.14, https://github.com/stratis-storage/stratisd/pull/1552
|
||||
Patch0: stratisd-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
BuildRequires: (crate(byteorder/default) >= 1.0.0 with crate(byteorder/default) < 2.0.0)
|
||||
BuildRequires: (crate(chrono/default) >= 0.4.0 with crate(chrono/default) < 0.5.0)
|
||||
BuildRequires: (crate(clap/default) >= 2.0.0 with crate(clap/default) < 3.0.0)
|
||||
BuildRequires: (crate(crc/default) >= 1.0.0 with crate(crc/default) < 2.0.0)
|
||||
BuildRequires: (crate(dbus/default) >= 0.6.4 with crate(dbus/default) < 0.7.0)
|
||||
BuildRequires: (crate(devicemapper/default) >= 0.27.0 with crate(devicemapper/default) < 0.28.0)
|
||||
BuildRequires: (crate(env_logger/default) >= 0.5.0 with crate(env_logger/default) < 0.6.0)
|
||||
BuildRequires: (crate(lazy_static/default) >= 1.0.0 with crate(lazy_static/default) < 2.0.0)
|
||||
BuildRequires: (crate(libc/default) >= 0.2.47 with crate(libc/default) < 0.3.0)
|
||||
BuildRequires: (crate(libmount/default) >= 0.1.10 with crate(libmount/default) < 0.2.0)
|
||||
BuildRequires: (crate(libudev/default) >= 0.2.0 with crate(libudev/default) < 0.3.0)
|
||||
BuildRequires: (crate(log/default) >= 0.4.0 with crate(log/default) < 0.5.0)
|
||||
BuildRequires: (crate(nix/default) >= 0.14.0 with crate(nix/default) < 0.15.0)
|
||||
BuildRequires: (crate(rand/default) >= 0.4.0 with crate(rand/default) < 0.5.0)
|
||||
BuildRequires: (crate(serde/default) >= 1.0.0 with crate(serde/default) < 2.0.0)
|
||||
BuildRequires: (crate(serde_derive/default) >= 1.0.0 with crate(serde_derive/default) < 2.0.0)
|
||||
BuildRequires: (crate(serde_json/default) >= 1.0.0 with crate(serde_json/default) < 2.0.0)
|
||||
BuildRequires: (crate(tempfile/default) >= 3.0.1 with crate(tempfile/default) < 4.0.0)
|
||||
BuildRequires: (crate(timerfd/default) >= 1.0.0 with crate(timerfd/default) < 2.0.0)
|
||||
BuildRequires: (crate(uuid/default) >= 0.7.0 with crate(uuid/default) < 0.8.0)
|
||||
BuildRequires: (crate(uuid/serde) >= 0.7.0 with crate(uuid/serde) < 0.8.0)
|
||||
BuildRequires: (crate(uuid/v4) >= 0.7.0 with crate(uuid/v4) < 0.8.0)
|
||||
%if %{with check}
|
||||
BuildRequires: (crate(either/default) >= 1.1.0 with crate(either/default) < 2.0.0)
|
||||
BuildRequires: (crate(error-chain/default) >= 0.12.0 with crate(error-chain/default) < 0.13.0)
|
||||
BuildRequires: (crate(loopdev/default) >= 0.2.0 with crate(loopdev/default) < 0.3.0)
|
||||
BuildRequires: (crate(matches/default) >= 0.1.8 with crate(matches/default) < 0.2.0)
|
||||
BuildRequires: (crate(proptest/default) >= 0.8.0 with crate(proptest/default) < 0.9.0)
|
||||
%endif
|
||||
BuildRequires: %{_bindir}/a2x
|
||||
BuildRequires: systemd
|
||||
|
||||
%{?systemd_requires}
|
||||
@ -64,6 +32,10 @@ Requires: device-mapper-persistent-data
|
||||
%autosetup -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
echo '/usr/bin/a2x'
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
%cargo_build -n
|
||||
@ -109,6 +81,9 @@ mv %{buildroot}%{_bindir}/stratisd %{buildroot}%{_sbindir}/stratisd-init
|
||||
%{_unitdir}/stratisd.service
|
||||
|
||||
%changelog
|
||||
* Fri Sep 06 20:52:06 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.0.5-1
|
||||
- Update to 1.0.5
|
||||
|
||||
* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user