Update to 0.5.1
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
9f1b90fb5a
commit
8e5e69182a
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
|||||||
/stratisd-0.1.4.tar.gz
|
/stratisd-0.1.4.tar.gz
|
||||||
/stratisd-0.1.5.tar.gz
|
/stratisd-0.1.5.tar.gz
|
||||||
/stratisd-0.5.0.tar.gz
|
/stratisd-0.5.0.tar.gz
|
||||||
|
/stratisd-0.5.1.tar.gz
|
||||||
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/src/engine/strat_engine/thinpool/filesystem.rs b/src/engine/strat_engine/thinpool/filesystem.rs
|
|
||||||
index ae6c66b..ffcf962 100644
|
|
||||||
--- a/src/engine/strat_engine/thinpool/filesystem.rs
|
|
||||||
+++ b/src/engine/strat_engine/thinpool/filesystem.rs
|
|
||||||
@@ -225,6 +225,6 @@ pub fn fs_usage(mount_point: &Path) -> EngineResult<(Bytes, Bytes)> {
|
|
||||||
// Upcast to u64.
|
|
||||||
let f_bsize = stat.block_size() as u64;
|
|
||||||
|
|
||||||
- let blocks = stat.blocks();
|
|
||||||
- Ok((Bytes(f_bsize * blocks), Bytes(f_bsize * (blocks - stat.blocks_free()))))
|
|
||||||
+ let blocks = stat.blocks() as u64;
|
|
||||||
+ Ok((Bytes(f_bsize * blocks), Bytes(f_bsize * (blocks - stat.blocks_free() as u64))))
|
|
||||||
}
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (stratisd-0.5.0.tar.gz) = f5e29a61be6d4de5b81c80d251e71f10acd376861ed04cd9d9d273ff80c806367aa6c9772c563a4511f4ac879df15fb4ca4b631a548efbabc58b13d7a5111aa6
|
SHA512 (stratisd-0.5.1.tar.gz) = 0b06594f59fdd228e975204c30c9454d7874fe213b2707e0139d83b5b0d48303716d9c5b39f53567aabb4f287b43390f0b33cf771ce0f886f99d8dafcc8d0090
|
||||||
|
@ -8,27 +8,24 @@
|
|||||||
%global __cargo_common_opts %{__cargo_common_opts} --features dbus_enabled
|
%global __cargo_common_opts %{__cargo_common_opts} --features dbus_enabled
|
||||||
|
|
||||||
Name: stratisd
|
Name: stratisd
|
||||||
Version: 0.5.0
|
Version: 0.5.1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Daemon that manages block devices to create filesystems
|
Summary: Daemon that manages block devices to create filesystems
|
||||||
|
|
||||||
License: MPLv2.0
|
License: MPLv2.0
|
||||||
URL: https://github.com/stratis-storage/stratisd
|
URL: https://github.com/stratis-storage/stratisd
|
||||||
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||||
Patch0: 32bit-fix.diff
|
|
||||||
|
|
||||||
ExclusiveArch: %{rust_arches}
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
BuildRequires: rust-packaging
|
BuildRequires: rust-packaging
|
||||||
BuildRequires: asciidoc
|
|
||||||
|
|
||||||
# [dependencies]
|
# [dependencies]
|
||||||
BuildRequires: (crate(byteorder) >= 1.0.0 with crate(byteorder) < 2.0.0)
|
BuildRequires: (crate(byteorder) >= 1.0.0 with crate(byteorder) < 2.0.0)
|
||||||
BuildRequires: (crate(chrono) >= 0.4.0 with crate(chrono) < 0.5.0)
|
BuildRequires: (crate(chrono) >= 0.4.0 with crate(chrono) < 0.5.0)
|
||||||
BuildRequires: (crate(clap) >= 2.0.0 with crate(clap) < 3.0.0)
|
BuildRequires: (crate(clap) >= 2.0.0 with crate(clap) < 3.0.0)
|
||||||
BuildRequires: (crate(crc) >= 1.0.0 with crate(crc) < 2.0.0)
|
BuildRequires: (crate(crc) >= 1.0.0 with crate(crc) < 2.0.0)
|
||||||
BuildRequires: (crate(dbus) >= 0.6.1 with crate(dbus) < 0.7.0)
|
BuildRequires: (crate(dbus) >= 0.6.1 with crate(dbus) < 0.7.0)
|
||||||
BuildRequires: (crate(devicemapper) >= 0.19.0 with crate(devicemapper) < 0.20.0)
|
BuildRequires: (crate(devicemapper) >= 0.20.0 with crate(devicemapper) < 0.21.0)
|
||||||
BuildRequires: (crate(env_logger) >= 0.4.0 with crate(env_logger) < 0.5.0)
|
BuildRequires: (crate(env_logger) >= 0.4.0 with crate(env_logger) < 0.5.0)
|
||||||
BuildRequires: (crate(error-chain) >= 0.11.0 with crate(error-chain) < 0.12.0)
|
BuildRequires: (crate(error-chain) >= 0.11.0 with crate(error-chain) < 0.12.0)
|
||||||
BuildRequires: (crate(libc) >= 0.2.36 with crate(libc) < 0.3.0)
|
BuildRequires: (crate(libc) >= 0.2.36 with crate(libc) < 0.3.0)
|
||||||
@ -48,6 +45,7 @@ BuildRequires: ((crate(uuid) >= 0.5.0 with crate(uuid) < 0.6.0) with crate(uuid
|
|||||||
BuildRequires: (crate(loopdev) >= 0.2.0 with crate(loopdev) < 0.3.0)
|
BuildRequires: (crate(loopdev) >= 0.2.0 with crate(loopdev) < 0.3.0)
|
||||||
BuildRequires: (crate(quickcheck) >= 0.6.0 with crate(quickcheck) < 0.7.0)
|
BuildRequires: (crate(quickcheck) >= 0.6.0 with crate(quickcheck) < 0.7.0)
|
||||||
%endif
|
%endif
|
||||||
|
BuildRequires: %{_bindir}/a2x
|
||||||
|
|
||||||
Requires: xfsprogs
|
Requires: xfsprogs
|
||||||
Requires: device-mapper-persistent-data
|
Requires: device-mapper-persistent-data
|
||||||
@ -63,7 +61,7 @@ sed -i -e "/^clippy/d" Cargo.toml
|
|||||||
|
|
||||||
%build
|
%build
|
||||||
%cargo_build
|
%cargo_build
|
||||||
make stratisd.8
|
a2x -f manpage docs/stratisd.txt
|
||||||
|
|
||||||
%install
|
%install
|
||||||
%cargo_install
|
%cargo_install
|
||||||
@ -72,7 +70,7 @@ make stratisd.8
|
|||||||
# Daemon should be really private
|
# Daemon should be really private
|
||||||
mkdir -p %{buildroot}%{_libexecdir}
|
mkdir -p %{buildroot}%{_libexecdir}
|
||||||
mv %{buildroot}%{_bindir}/stratisd %{buildroot}%{_libexecdir}/stratisd
|
mv %{buildroot}%{_bindir}/stratisd %{buildroot}%{_libexecdir}/stratisd
|
||||||
%{__install} -Dpm0644 -t %{buildroot}%{_mandir}/man8/ docs/stratisd.8
|
%{__install} -Dpm0644 -t %{buildroot}%{_mandir}/man8 docs/stratisd.8
|
||||||
|
|
||||||
%if %{with check}
|
%if %{with check}
|
||||||
%check
|
%check
|
||||||
@ -85,9 +83,12 @@ mv %{buildroot}%{_bindir}/stratisd %{buildroot}%{_libexecdir}/stratisd
|
|||||||
%{_libexecdir}/stratisd
|
%{_libexecdir}/stratisd
|
||||||
%{_datadir}/dbus-1/system.d/stratisd.conf
|
%{_datadir}/dbus-1/system.d/stratisd.conf
|
||||||
%{_datadir}/dbus-1/system-services/org.storage.stratis1.service
|
%{_datadir}/dbus-1/system-services/org.storage.stratis1.service
|
||||||
%{_mandir}/man8/stratisd.8.gz
|
%{_mandir}/man8/stratisd.8*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.1-1
|
||||||
|
- Update to 0.5.1
|
||||||
|
|
||||||
* Tue Mar 13 2018 Andy Grover <agrover@redhat.com> - 0.5.0-2
|
* Tue Mar 13 2018 Andy Grover <agrover@redhat.com> - 0.5.0-2
|
||||||
- Add stratisd manpage
|
- Add stratisd manpage
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user