remove unneeded patches
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
67cd222845
commit
1a9632bf73
@ -1,40 +0,0 @@
|
|||||||
From abc8ac7620ef08b10cdf61676686ea3d20b0cd30 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
||||||
Date: Thu, 19 Jul 2018 04:18:51 +0200
|
|
||||||
Subject: [PATCH 1/2] deps: update nix to 0.11
|
|
||||||
|
|
||||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
||||||
---
|
|
||||||
Cargo.toml | 2 +-
|
|
||||||
src/engine/strat_engine/backstore/device.rs | 2 +-
|
|
||||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/Cargo.toml b/Cargo.toml
|
|
||||||
index 44b3635..685eca9 100644
|
|
||||||
--- a/Cargo.toml
|
|
||||||
+++ b/Cargo.toml
|
|
||||||
@@ -6,7 +6,7 @@ authors = ["Stratis Developers <stratis-devel@lists.fedorahosted.com>"]
|
|
||||||
[dependencies]
|
|
||||||
dbus = {version = "0.6.1", optional = true}
|
|
||||||
clap = "2"
|
|
||||||
-nix = "0.10"
|
|
||||||
+nix = "0.11"
|
|
||||||
devicemapper = "0.22.0"
|
|
||||||
crc = "1"
|
|
||||||
byteorder = "1"
|
|
||||||
diff --git a/src/engine/strat_engine/backstore/device.rs b/src/engine/strat_engine/backstore/device.rs
|
|
||||||
index fe803bc..dad8267 100644
|
|
||||||
--- a/src/engine/strat_engine/backstore/device.rs
|
|
||||||
+++ b/src/engine/strat_engine/backstore/device.rs
|
|
||||||
@@ -16,7 +16,7 @@ use super::super::super::types::{DevUuid, PoolUuid};
|
|
||||||
use super::metadata::StaticHeader;
|
|
||||||
use super::util::get_udev_block_device;
|
|
||||||
|
|
||||||
-ioctl!(read blkgetsize64 with 0x12, 114; u64);
|
|
||||||
+ioctl_read!(blkgetsize64, 0x12, 114, u64);
|
|
||||||
|
|
||||||
pub fn blkdev_size(file: &File) -> StratisResult<Bytes> {
|
|
||||||
let mut val: u64 = 0;
|
|
||||||
--
|
|
||||||
2.18.0
|
|
||||||
|
|
@ -1,26 +0,0 @@
|
|||||||
From a006c481db21c8d9061bae7acb4f9c4d28b52f31 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
||||||
Date: Thu, 19 Jul 2018 04:20:09 +0200
|
|
||||||
Subject: [PATCH 2/2] deps: update error-chain to 0.12
|
|
||||||
|
|
||||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
||||||
---
|
|
||||||
Cargo.toml | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/Cargo.toml b/Cargo.toml
|
|
||||||
index 685eca9..e4ce6e9 100644
|
|
||||||
--- a/Cargo.toml
|
|
||||||
+++ b/Cargo.toml
|
|
||||||
@@ -21,7 +21,7 @@ log = "0.4"
|
|
||||||
env_logger="0.5"
|
|
||||||
libc = "0.2.36"
|
|
||||||
libmount = "0.1.10"
|
|
||||||
-error-chain = "0.11.0"
|
|
||||||
+error-chain = "0.12"
|
|
||||||
libudev = "0.2.0"
|
|
||||||
lazy_static = "1.0.0"
|
|
||||||
|
|
||||||
--
|
|
||||||
2.18.0
|
|
||||||
|
|
@ -12,9 +12,6 @@ Summary: Daemon that manages block devices to create filesystems
|
|||||||
License: MPLv2.0
|
License: MPLv2.0
|
||||||
URL: https://github.com/stratis-storage/stratisd
|
URL: https://github.com/stratis-storage/stratisd
|
||||||
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||||
# https://github.com/stratis-storage/stratisd/pull/1062
|
|
||||||
Patch0001: 0001-deps-update-nix-to-0.11.patch
|
|
||||||
Patch0002: 0002-deps-update-error-chain-to-0.12.patch
|
|
||||||
|
|
||||||
ExclusiveArch: %{rust_arches}
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user