Use upstream crate for Rust source
This commit is contained in:
parent
537346f84e
commit
01f395c0d1
1
.gitignore
vendored
1
.gitignore
vendored
@ -35,3 +35,4 @@
|
|||||||
/stratisd-3.0.3-vendor.tar.gz
|
/stratisd-3.0.3-vendor.tar.gz
|
||||||
/stratisd-3.0.4.tar.gz
|
/stratisd-3.0.4.tar.gz
|
||||||
/stratisd-3.0.4-vendor.tar.gz
|
/stratisd-3.0.4-vendor.tar.gz
|
||||||
|
/stratisd-3.0.4.crate
|
||||||
|
1
sources
1
sources
@ -1,2 +1,3 @@
|
|||||||
|
SHA512 (stratisd-3.0.4.crate) = fa6edd7d9051bbd5c3e1aefb0301993f32271804cf5002f293a13e9b18409d65ce878d543d64e02299d97764930ae4fc0143f33026378b26bd4cb347fd056481
|
||||||
SHA512 (stratisd-3.0.4.tar.gz) = 2da560302f6b7c6cd502fa521259cb5b265bc952556523af5cba1440a9e7bcd2ac61d6e341fff1320eb4e4d5aca84b9f555af62c268360b1014af78e97f15025
|
SHA512 (stratisd-3.0.4.tar.gz) = 2da560302f6b7c6cd502fa521259cb5b265bc952556523af5cba1440a9e7bcd2ac61d6e341fff1320eb4e4d5aca84b9f555af62c268360b1014af78e97f15025
|
||||||
SHA512 (stratisd-3.0.4-vendor.tar.gz) = 4c2adf231e3361c80d0eea93f7d55e35989641fe17b87e9c8f62420e2b2c360d56c656f147573e4a6f238a62fc0fe567320861e22f98fd5df178dd56cedbecf1
|
SHA512 (stratisd-3.0.4-vendor.tar.gz) = 4c2adf231e3361c80d0eea93f7d55e35989641fe17b87e9c8f62420e2b2c360d56c656f147573e4a6f238a62fc0fe567320861e22f98fd5df178dd56cedbecf1
|
||||||
|
@ -1,15 +0,0 @@
|
|||||||
--- stratisd/Cargo.toml 2021-12-21 10:54:57.964593614 -0500
|
|
||||||
+++ stratisd/Cargo.toml 2021-12-21 10:55:56.364280448 -0500
|
|
||||||
@@ -72,12 +72,9 @@
|
|
||||||
|
|
||||||
[dependencies.devicemapper]
|
|
||||||
version = "0.32.0"
|
|
||||||
-git = "https://github.com/stratis-storage/devicemapper-rs"
|
|
||||||
-branch = "crates-io-patch-0.32.0"
|
|
||||||
|
|
||||||
[dependencies.stratisd_proc_macros]
|
|
||||||
version = "0.1.0"
|
|
||||||
-path = "./stratisd_proc_macros"
|
|
||||||
|
|
||||||
[dependencies.libcryptsetup-rs]
|
|
||||||
version = "0.5.0"
|
|
@ -10,7 +10,7 @@
|
|||||||
|
|
||||||
Name: stratisd
|
Name: stratisd
|
||||||
Version: 3.0.4
|
Version: 3.0.4
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Daemon that manages block devices to create filesystems
|
Summary: Daemon that manages block devices to create filesystems
|
||||||
|
|
||||||
# 0BSD or MIT or ASL 2.0
|
# 0BSD or MIT or ASL 2.0
|
||||||
@ -26,8 +26,7 @@ License: MPLv2.0 and ASL 2.0 and BSD and MIT
|
|||||||
URL: https://github.com/stratis-storage/stratisd
|
URL: https://github.com/stratis-storage/stratisd
|
||||||
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||||
Source1: %{url}/releases/download/v%{version}/%{name}-%{version}-vendor.tar.gz
|
Source1: %{url}/releases/download/v%{version}/%{name}-%{version}-vendor.tar.gz
|
||||||
# Fix the metadata so all dependencies are on packaged, upstreamed, packages
|
Source2: %{crates_source}
|
||||||
Patch0: stratisd-fix-metadata.diff
|
|
||||||
|
|
||||||
ExclusiveArch: %{rust_arches}
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
@ -71,6 +70,7 @@ a Linux install.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup -p1
|
%autosetup -p1
|
||||||
|
tar xvf %{SOURCE2}
|
||||||
%if 0%{?rhel} && !0%{?eln}
|
%if 0%{?rhel} && !0%{?eln}
|
||||||
# Source1 is vendored dependencies
|
# Source1 is vendored dependencies
|
||||||
%cargo_prep -V 1
|
%cargo_prep -V 1
|
||||||
@ -171,6 +171,9 @@ install -Dpm0755 -t %{buildroot}%{_systemd_util_dir} systemd/stratis-fstab-setup
|
|||||||
%{_systemdgeneratordir}/stratis-setup-generator
|
%{_systemdgeneratordir}/stratis-setup-generator
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 14 2022 mulhern <amulhern@redhat.com> - 3.0.4-2
|
||||||
|
- Use upstream crate for Rust source
|
||||||
|
|
||||||
* Sat Feb 12 2022 mulhern <amulhern@redhat.com> - 3.0.4-1
|
* Sat Feb 12 2022 mulhern <amulhern@redhat.com> - 3.0.4-1
|
||||||
- Update to 3.0.4
|
- Update to 3.0.4
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user