Update to version 3.1.0

- Revise stratis-cli.spec file to unified format
- Add rpminspect.yaml file

Resolves: rhbz#2039947

Signed-off-by: Bryan Gurney <bgurney@redhat.com>
This commit is contained in:
Bryan Gurney 2022-05-27 13:01:53 -04:00
parent 649775617f
commit 001ddc5d3b
6 changed files with 43 additions and 17 deletions

1
.gitignore vendored
View File

@ -17,3 +17,4 @@
/stratis-cli-2.4.1.tar.gz
/stratis-cli-2.4.2.tar.gz
/stratis-cli-2.4.3.tar.gz
/stratis-cli-3.1.0.tar.gz

View File

@ -1,11 +0,0 @@
--- setup.py.orig 2021-07-19 10:27:56.107557330 -0400
+++ setup.py 2021-07-19 10:29:17.047557330 -0400
@@ -50,8 +50,6 @@ setuptools.setup(
"dbus-python-client-gen>=0.7",
"justbytes>=0.14",
"python-dateutil",
- "semantic_version",
- "wcwidth",
],
package_dir={"": "src"},
packages=setuptools.find_packages("src"),

17
rpminspect.yaml Normal file
View File

@ -0,0 +1,17 @@
---
inspections:
# stratis-cli has no ABI
abidiff: off
# stratis-cli is a Python program
annocheck: off
# the project does not use .desktop files
desktop: off
# stratis-cli is a Python program
elf: off
# the project uses no Java
javabytecode: off
# stratis-cli is a Python program
lto: off
# The info is fine, but we'll assume that all the filesize changes are as intended.
filesize: info

View File

@ -1 +1 @@
SHA512 (stratis-cli-2.4.3.tar.gz) = ba253fbbaaa3daecd1a798425c6dd6bfeeeb0c74924613fed8134862a4b91e3add63e4e04312088bd38c6ef19dfbbe4707cea67cea79c6c737b08055676754ae
SHA512 (stratis-cli-3.1.0.tar.gz) = 5b5e903401d01ee179f62f314c22d8d05ebaf3014265e5c3153c63a8560f062899dccd0811f858b2cde6bbb179df82877fc738b617167de93b148926c67a324b

View File

@ -1,25 +1,29 @@
Name: stratis-cli
Version: 2.4.3
Release: 2%{?dist}
Version: 3.1.0
Release: 1%{?dist}
Summary: Command-line tool for interacting with the Stratis daemon
License: ASL 2.0
URL: https://github.com/stratis-storage/stratis-cli
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
Patch0: remove-semantic_version-and-wcwidth-deps.patch
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: %{_bindir}/a2x
%if 0%{?rhel} && !0%{?eln}
Requires: platform-python
%else
%endif
# It runs without, but totally useless
Requires: stratisd >= 2.4
Requires: (stratisd >= 3.1.0 with stratisd < 4.0.0)
# stratisd only available on certain arches
ExclusiveArch: %{rust_arches} noarch
%if 0%{?rhel} && !0%{?eln}
ExcludeArch: i686
%endif
BuildArch: noarch
%description
@ -36,10 +40,15 @@ a2x -f manpage docs/stratis.txt
%install
%py3_install
# Do not install tab-completion files for RHEL
%if !0%{?rhel}
%{__install} -Dpm0644 -t %{buildroot}%{_datadir}/bash-completion/completions \
shell-completion/bash/stratis
%{__install} -Dpm0644 -t %{buildroot}%{_datadir}/zsh/site-functions \
shell-completion/zsh/_stratis
%{__install} -Dpm0644 -t %{buildroot}%{_datadir}/fish/vendor_completions.d \
shell-completion/fish/stratis.fish
%endif
%{__install} -Dpm0644 -t %{buildroot}%{_mandir}/man8 docs/stratis.8
%files
@ -47,16 +56,26 @@ a2x -f manpage docs/stratis.txt
%doc README.rst
%{_bindir}/stratis
%{_mandir}/man8/stratis.8*
%if !0%{?rhel}
%dir %{_datadir}/bash-completion
%dir %{_datadir}/bash-completion/completions
%{_datadir}/bash-completion/completions/stratis
%dir %{_datadir}/zsh
%dir %{_datadir}/zsh/site-functions
%{_datadir}/zsh/site-functions/_stratis
%dir %{_datadir}/fish
%dir %{_datadir}/fish/vendor_completions.d
%{_datadir}/fish/vendor_completions.d/stratis.fish
%endif
%{python3_sitelib}/stratis_cli/
%{python3_sitelib}/stratis_cli-*.egg-info/
%changelog
* Tue May 31 2022 Bryan Gurney <bgurney@redhat.com> - 3.1.0-1
- Update to 3.1.0
- Resolves: rhbz#2039946
- Revise stratis-cli.spec file to unified format
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 2.4.3-2
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688

View File

@ -18,4 +18,4 @@
repositories:
- repo: "https://github.com/stratis-storage/testing.git"
dest: "testing"
version: "v2.4.0"
version: "v3.1.0"