e80309331c
- Add 0168-m4-fix-st_SELINUX-check.patch (v5.15~18 "m4: fix st_SELINUX check") - Add 0169-Implement-displaying-of-expected-context-upon-mismat.patch (v5.16~31 "Implement displaying of expected context upon mismatch") - Add 0170-tests-linkat-reset-errno-before-SELinux-context-mani.patch - Add 0171-tests-secontext-add-secontext-field-getters.patch - Add 0172-tests-linkat-provide-fallback-values-for-secontext-f.patch - Add 0173-tests-secontext-eliminate-separate-secontext_format-.patch - Add 0174-tests-linkat-reset-context-to-the-expected-one-if-a-.patch * 0168-m4-fix-st_SELINUX-check.patch: New file. * 0169-Implement-displaying-of-expected-context-upon-mismat.patch: Ditto. * 0170-tests-linkat-reset-errno-before-SELinux-context-mani.patch: Ditto. * 0171-tests-secontext-add-secontext-field-getters.patch: Ditto. * 0172-tests-linkat-provide-fallback-values-for-secontext-f.patch: Ditto. * 0173-tests-secontext-eliminate-separate-secontext_format-.patch: Ditto. * 0174-tests-linkat-reset-context-to-the-expected-one-if-a-.patch: Ditto. * strace.spec strace.spec (Release): Bump to 6. (Patch168, Patch169, Patch170, Patch171, Patch172, Patch173, Patch164): New patches. (%prep): Apply them. (%changelog): Mention it. Resolves: #2038965 Signed-off-by: Eugene Syromiatnikov <esyr@redhat.com>
32 lines
880 B
Diff
32 lines
880 B
Diff
From 6e8aa3749cb7e11e9a59db996f79f036bf7ef263 Mon Sep 17 00:00:00 2001
|
|
From: Eugene Syromyatnikov <evgsyr@gmail.com>
|
|
Date: Tue, 18 Jan 2022 18:05:19 +0100
|
|
Subject: [PATCH 173/174] tests/secontext: eliminate separate secontext_format
|
|
declaration
|
|
|
|
* tests/secontext.c (secontext_format): Remove declaration, supply
|
|
the attributes to the definition.
|
|
---
|
|
tests/secontext.c | 5 +----
|
|
1 file changed, 1 insertion(+), 4 deletions(-)
|
|
|
|
diff --git a/tests/secontext.c b/tests/secontext.c
|
|
index 52211ed..ba271c8 100644
|
|
--- a/tests/secontext.c
|
|
+++ b/tests/secontext.c
|
|
@@ -23,10 +23,7 @@
|
|
# define TEST_SECONTEXT
|
|
# include "secontext.h"
|
|
|
|
-static char *
|
|
-secontext_format(char *context, const char *fmt)
|
|
- ATTRIBUTE_FORMAT((printf, 2, 0)) ATTRIBUTE_MALLOC;
|
|
-
|
|
+ATTRIBUTE_FORMAT((printf, 2, 0)) ATTRIBUTE_MALLOC
|
|
static char *
|
|
secontext_format(char *context, const char *fmt)
|
|
{
|
|
--
|
|
2.1.4
|
|
|