c32cef440f
- Add 0175-src-xlat-remove-remnants-of-unnecessary-idx-usage-in.patch (v5.18-5-g2bf0696 "src/xlat: remove remnants of unnecessary idx usage in xlookup") - Add 0176-strauss-tips-whitespace-and-phrasing-cleanups.patch (v5.18-7-ge604d7b "strauss: tips whitespace and phrasing cleanups") - Add 0177-strauss-fix-off-by-one-error-in-strauss-array-access.patch (v5.18-8-g968789d "strauss: fix off-by-one error in strauss array access") - Add 0178-util-add-offs-sanity-check-to-print_clock_t.patch (v5.18-9-g6d3e97e "util: add offs sanity check to print_clock_t") - Add 0179-secontext-print-context-of-Unix-socket-s-sun_path-fi.patch (v5.18-13-g960e78f "secontext: print context of Unix socket's sun_path field") - Add 0180-pathtrace-util-do-not-print-deleted-as-part-of-the-p.patch (v5.18-18-g676979f "pathtrace, util: do not print " (deleted)" as part of the path") - Add 0181-secontext-fix-expected-SELinux-context-check-for-unl.patch )v5.18-19-g3f0e534 "secontext: fix expected SELinux context check for unlinked FDs") - Add 0182-tests-bpf-fix-sloppy-low-FD-number-usage.patch (v5.18-21-g5338636 "tests/bpf: fix sloppy low FD number usage") * 0175-src-xlat-remove-remnants-of-unnecessary-idx-usage-in.patch: New patch. * 0176-strauss-tips-whitespace-and-phrasing-cleanups.patch: Likewise. * 0177-strauss-fix-off-by-one-error-in-strauss-array-access.patch: Likewise. * 0178-util-add-offs-sanity-check-to-print_clock_t.patch: Likewise. * 0179-secontext-print-context-of-Unix-socket-s-sun_path-fi.patch: Likewise. * 0180-pathtrace-util-do-not-print-deleted-as-part-of-the-p.patch: Likewise. * 0181-secontext-fix-expected-SELinux-context-check-for-unl.patch: Likewise. * 0182-tests-bpf-fix-sloppy-low-FD-number-usage.patch: Likewise. * strace.spec (Release): Bump to 2. (Patch175, Patch176, Patch177, Patch178, Patch179, Patch180, Patch181, Patch182): Add. (%prep): Apply them. (%changelog): New record about 5.18-2. Resolves: #2087693 Resolves: #2103068 Resolves: #2103032 Signed-off-by: Eugene Syromiatnikov <esyr@redhat.com>
57 lines
2.4 KiB
Diff
57 lines
2.4 KiB
Diff
From e604d7bfd18cf5f29e6723091cc1db2945c918c9 Mon Sep 17 00:00:00 2001
|
|
From: Eugene Syromyatnikov <evgsyr@gmail.com>
|
|
Date: Tue, 28 Jun 2022 16:46:53 +0200
|
|
Subject: [PATCH] strauss: tips whitespace and phrasing cleanups
|
|
|
|
* src/strauss.c (tips_tricks_tweaks): Fix some whitespace and phrasing
|
|
issues.
|
|
---
|
|
src/strauss.c | 13 +++++++------
|
|
1 file changed, 7 insertions(+), 6 deletions(-)
|
|
|
|
Index: strace-5.18/src/strauss.c
|
|
===================================================================
|
|
--- strace-5.18.orig/src/strauss.c 2022-07-12 17:17:08.712197019 +0200
|
|
+++ strace-5.18/src/strauss.c 2022-07-12 17:17:20.685055717 +0200
|
|
@@ -128,8 +128,8 @@
|
|
{ "strace is about as old as the Linux kernel.",
|
|
"It has been originally written for SunOS",
|
|
"by Paul Kranenburg in 1991. The support",
|
|
- "for all OSes except Linux has been dropped",
|
|
- "since 2012, though, in strace 4.7." },
|
|
+ "for all OSes except Linux was dropped"
|
|
+ "in 2012, though, in strace 4.7." },
|
|
{ "strace is able to decode netlink messages.",
|
|
"It does so automatically for I/O performed",
|
|
"on netlink sockets. Try it yourself:", "",
|
|
@@ -187,7 +187,7 @@
|
|
"want to try --seccomp-bpf option, maybe you",
|
|
"will feel better." },
|
|
{ "-v is a shorthand for -e abbrev=none and not",
|
|
- " for -e verbose=all. It is idiosyncratic,",
|
|
+ "for -e verbose=all. It is idiosyncratic,",
|
|
"but it is the historic behaviour." },
|
|
{ "strace uses netlink for printing",
|
|
"protocol-specific information about socket",
|
|
@@ -254,7 +254,7 @@
|
|
"by invoking it with the following options:", "",
|
|
" strace -DDDqqq -enone --signal=none" },
|
|
{ "Historically, supplying -o option to strace",
|
|
- "led to silencing of messages about tracee",
|
|
+ "leads to silencing of messages about tracee",
|
|
"attach/detach and personality changes.",
|
|
"It can be now overridden with --quiet=none",
|
|
"option." },
|
|
@@ -285,8 +285,9 @@
|
|
"will trace all syscalls related to accessing",
|
|
"and modifying process's user/group IDs",
|
|
"and capability sets. Other pre-defined",
|
|
- "syscall classes include %clock, %desc,%file,",
|
|
- "%ipc,%memory, %net,%process, and %signal." },
|
|
+ "syscall classes include %clock, %desc,"
|
|
+ "%file, %ipc, %memory, %net, %process,"
|
|
+ "and %signal." },
|
|
{ "Trying to figure out communication between",
|
|
"tracees inside a different PID namespace",
|
|
"(in so-called \"containers\", for example)?",
|