strace/0173-tests-secontext-eliminate-separate-secontext_format-.patch
Eugene Syromiatnikov 4a389010ff Add missing generated/m32/mx32 chunks for --secontext=mismatch option support
* 0168-m4-fix-st_SELINUX-check.patch: Add missing configure changes.
* 0169-Implement-displaying-of-expected-context-upon-mismat.patch: Add
missing tests-m32/gen_tests.in, tests-m32/linkat.c,
tests-m32/options-syntax.test, tests-m32/secontext.c,
tests-m32/secontext.h, tests-mx32/gen_tests.in, tests-mx32/linkat.c,
tests-mx32/options-syntax.test, tests-mx32/secontext.c,
tests-mx32/secontext.h, tests/Makefile.in, tests-m32/Makefile.in,
tests-mx32/Makefile.in, and configure changes, as well as all
tests*/_mismatch.c files.
* 0170-tests-linkat-reset-errno-before-SELinux-context-mani.patch: Add
missing tests-m32/linkat.c and tests-mx32/linkat.c changes.
* 0171-tests-secontext-add-secontext-field-getters.patch: Add missing
tests-m32/secontext.c, tests-m32/secontext.h, tests-mx32/secontext.c,
and tests-mx32/secontext.h changes.
* 0172-tests-linkat-provide-fallback-values-for-secontext-f.patch: Add
missing tests-m32/linkat.c and tests-mx32/linkat.c changes.
* 0173-tests-secontext-eliminate-separate-secontext_format-.patch: Add
missing tests-m32/secontext.c and tests-mx32/secontext.c changes.
* 0174-tests-linkat-reset-context-to-the-expected-one-if-a-.patch: Add
missing tests-m32/linkat.c, tests-m32/secontext.c,
tests-m32/secontext.h, tests-mx32/linkat.c, tests-mx32/secontext.c,
and tests-mx32/secontext.h changes.
* strace.spec (Release): Bump to 7.
(%changelog): Mention the change.

Resolves: #2046264
Signed-off-by: Eugene Syromiatnikov <esyr@redhat.com>
2022-02-07 22:37:57 +01:00

64 lines
1.8 KiB
Diff

From 6e8aa3749cb7e11e9a59db996f79f036bf7ef263 Mon Sep 17 00:00:00 2001
From: Eugene Syromyatnikov <evgsyr@gmail.com>
Date: Tue, 18 Jan 2022 18:05:19 +0100
Subject: [PATCH 173/174] tests/secontext: eliminate separate secontext_format
declaration
* tests/secontext.c (secontext_format): Remove declaration, supply
the attributes to the definition.
---
tests/secontext.c | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/tests/secontext.c b/tests/secontext.c
index 52211ed..ba271c8 100644
--- a/tests/secontext.c
+++ b/tests/secontext.c
@@ -23,10 +23,7 @@
# define TEST_SECONTEXT
# include "secontext.h"
-static char *
-secontext_format(char *context, const char *fmt)
- ATTRIBUTE_FORMAT((printf, 2, 0)) ATTRIBUTE_MALLOC;
-
+ATTRIBUTE_FORMAT((printf, 2, 0)) ATTRIBUTE_MALLOC
static char *
secontext_format(char *context, const char *fmt)
{
diff --git a/tests-m32/secontext.c b/tests-m32/secontext.c
index 52211ed..ba271c8 100644
--- a/tests-m32/secontext.c
+++ b/tests-m32/secontext.c
@@ -23,10 +23,7 @@
# define TEST_SECONTEXT
# include "secontext.h"
-static char *
-secontext_format(char *context, const char *fmt)
- ATTRIBUTE_FORMAT((printf, 2, 0)) ATTRIBUTE_MALLOC;
-
+ATTRIBUTE_FORMAT((printf, 2, 0)) ATTRIBUTE_MALLOC
static char *
secontext_format(char *context, const char *fmt)
{
diff --git a/tests-mx32/secontext.c b/tests-mx32/secontext.c
index 52211ed..ba271c8 100644
--- a/tests-mx32/secontext.c
+++ b/tests-mx32/secontext.c
@@ -23,10 +23,7 @@
# define TEST_SECONTEXT
# include "secontext.h"
-static char *
-secontext_format(char *context, const char *fmt)
- ATTRIBUTE_FORMAT((printf, 2, 0)) ATTRIBUTE_MALLOC;
-
+ATTRIBUTE_FORMAT((printf, 2, 0)) ATTRIBUTE_MALLOC
static char *
secontext_format(char *context, const char *fmt)
{
--
2.1.4