fix ftbfs, modernise spec
This commit is contained in:
parent
a0c4f1ef10
commit
d35e142ea4
44
strace-fix-ftbfs.patch
Normal file
44
strace-fix-ftbfs.patch
Normal file
@ -0,0 +1,44 @@
|
|||||||
|
--- strace-4.8/process.c.orig 2013-12-06 16:18:27.682402291 +0000
|
||||||
|
+++ strace-4.8/process.c 2013-12-06 16:19:14.602165296 +0000
|
||||||
|
@@ -63,7 +63,7 @@
|
||||||
|
# ifdef HAVE_STRUCT_PT_ALL_USER_REGS
|
||||||
|
# define pt_all_user_regs XXX_pt_all_user_regs
|
||||||
|
# endif
|
||||||
|
-# include <linux/ptrace.h>
|
||||||
|
+# include <asm/ptrace.h>
|
||||||
|
# undef ia64_fpreg
|
||||||
|
# undef pt_all_user_regs
|
||||||
|
#endif
|
||||||
|
--- strace-4.8/signal.c.orig 2013-12-06 16:28:54.800551324 +0000
|
||||||
|
+++ strace-4.8/signal.c 2013-12-06 16:30:26.033019415 +0000
|
||||||
|
@@ -51,7 +51,7 @@
|
||||||
|
# ifdef HAVE_STRUCT_PT_ALL_USER_REGS
|
||||||
|
# define pt_all_user_regs XXX_pt_all_user_regs
|
||||||
|
# endif
|
||||||
|
-# include <linux/ptrace.h>
|
||||||
|
+# include <asm/ptrace.h>
|
||||||
|
# undef ia64_fpreg
|
||||||
|
# undef pt_all_user_regs
|
||||||
|
#endif
|
||||||
|
--- strace-4.8/syscall.c.orig 2013-12-06 16:29:37.912245321 +0000
|
||||||
|
+++ strace-4.8/syscall.c 2013-12-06 16:30:55.933500132 +0000
|
||||||
|
@@ -48,7 +48,7 @@
|
||||||
|
# ifdef HAVE_STRUCT_PT_ALL_USER_REGS
|
||||||
|
# define pt_all_user_regs XXX_pt_all_user_regs
|
||||||
|
# endif
|
||||||
|
-# include <linux/ptrace.h>
|
||||||
|
+# include <asm/ptrace.h>
|
||||||
|
# undef ia64_fpreg
|
||||||
|
# undef pt_all_user_regs
|
||||||
|
#endif
|
||||||
|
--- strace-4.8/util.c.orig 2013-12-06 16:29:44.382349431 +0000
|
||||||
|
+++ strace-4.8/util.c 2013-12-06 16:31:04.267634082 +0000
|
||||||
|
@@ -55,7 +55,7 @@
|
||||||
|
# ifdef HAVE_STRUCT_PT_ALL_USER_REGS
|
||||||
|
# define pt_all_user_regs XXX_pt_all_user_regs
|
||||||
|
# endif
|
||||||
|
-# include <linux/ptrace.h>
|
||||||
|
+# include <asm/ptrace.h>
|
||||||
|
# undef ia64_fpreg
|
||||||
|
# undef pt_all_user_regs
|
||||||
|
#endif
|
15
strace.spec
15
strace.spec
@ -1,12 +1,13 @@
|
|||||||
Summary: Tracks and displays system calls associated with a running process
|
Summary: Tracks and displays system calls associated with a running process
|
||||||
Name: strace
|
Name: strace
|
||||||
Version: 4.8
|
Version: 4.8
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
|
|
||||||
URL: http://sourceforge.net/projects/strace/
|
URL: http://sourceforge.net/projects/strace/
|
||||||
Source: http://downloads.sourceforge.net/strace/%{name}-%{version}.tar.xz
|
Source: http://downloads.sourceforge.net/strace/%{name}-%{version}.tar.xz
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Patch0: strace-fix-ftbfs.patch
|
||||||
|
|
||||||
BuildRequires: libacl-devel, libaio-devel, time
|
BuildRequires: libacl-devel, libaio-devel, time
|
||||||
|
|
||||||
@ -43,13 +44,13 @@ The `strace' program in the `strace' package is for 32-bit processes.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1 -b .ftbfs
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf %{buildroot}
|
|
||||||
make DESTDIR=%{buildroot} install
|
make DESTDIR=%{buildroot} install
|
||||||
|
|
||||||
# remove unpackaged files from the buildroot
|
# remove unpackaged files from the buildroot
|
||||||
@ -69,11 +70,7 @@ rm -f %{buildroot}%{_bindir}/strace-graph
|
|||||||
%check
|
%check
|
||||||
make check
|
make check
|
||||||
|
|
||||||
%clean
|
|
||||||
rm -rf %{buildroot}
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
|
||||||
%doc CREDITS ChangeLog ChangeLog-CVS COPYING NEWS README
|
%doc CREDITS ChangeLog ChangeLog-CVS COPYING NEWS README
|
||||||
%{_bindir}/strace
|
%{_bindir}/strace
|
||||||
%{_bindir}/strace-log-merge
|
%{_bindir}/strace-log-merge
|
||||||
@ -81,11 +78,13 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
%ifarch %{strace64_arches}
|
%ifarch %{strace64_arches}
|
||||||
%files -n strace64
|
%files -n strace64
|
||||||
%defattr(-,root,root)
|
|
||||||
%{_bindir}/strace64
|
%{_bindir}/strace64
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Dec 6 2013 Peter Robinson <pbrobinson@fedoraproject.org> 4.8-3
|
||||||
|
- Fix FTBFS
|
||||||
|
|
||||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.8-2
|
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.8-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user