diff --git a/import.log b/import.log
index 2c20a43..fa0ecc4 100644
--- a/import.log
+++ b/import.log
@@ -1 +1,2 @@
stix-fonts-0_9-7_fc10:HEAD:stix-fonts-0.9-7.fc10.src.rpm:1215809789
+stix-fonts-0_9-9_fc11:HEAD:stix-fonts-0.9-9.fc11.src.rpm:1229543904
diff --git a/stix-fonts-fontconfig.conf b/stix-fonts-fontconfig.conf
index 8c48db0..1541c92 100644
--- a/stix-fonts-fontconfig.conf
+++ b/stix-fonts-fontconfig.conf
@@ -1,16 +1,16 @@
-
- STIXGeneral
-
- serif
-
-
serif
STIXGeneral
+
+ STIXGeneral
+
+ serif
+
+
diff --git a/stix-fonts.spec b/stix-fonts.spec
index a68922b..00f8914 100644
--- a/stix-fonts.spec
+++ b/stix-fonts.spec
@@ -1,50 +1,49 @@
-%define fontname stix
-%define fontdir %{_datadir}/fonts/%{fontname}
-%define fontconfdir %{_sysconfdir}/fonts/conf.d
+%define fontname stix
+%define fontconf 61-%{fontname}
%define archivename STIXBeta
+%define common_desc \
+The mission of the Scientific and Technical Information Exchange (STIX) font \
+creation project is the preparation of a comprehensive set of fonts that serve \
+the scientific and engineering community in the process from manuscript \
+creation through final publication, both in electronic and print formats.
+
Name: %{fontname}-fonts
Version: 0.9
-Release: 7%{?dist}
+Release: 9%{?dist}
Summary: STIX scientific and engineering fonts
-Group: User Interface/X
-License: STIX
-URL: http://www.stixfonts.org/
-Source0: %{archivename}.zip
-Source1: %{name}-License.txt
-Source2: stix-fonts-fontconfig.conf
-Source3: stix-fonts-pua-fontconfig.conf
-Source4: stix-fonts-integrals-fontconfig.conf
-Source5: stix-fonts-sizes-fontconfig.conf
-Source6: stix-fonts-variants-fontconfig.conf
-
+Group: User Interface/X
+License: STIX
+URL: http://www.stixfonts.org/
+Source0: %{archivename}.zip
+Source1: %{name}-License.txt
+Source2: stix-fonts-fontconfig.conf
+Source3: stix-fonts-pua-fontconfig.conf
+Source4: stix-fonts-integrals-fontconfig.conf
+Source5: stix-fonts-sizes-fontconfig.conf
+Source6: stix-fonts-variants-fontconfig.conf
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
-BuildArch: noarch
+
+BuildArch: noarch
+BuildRequires: fontpackages-devel
+Requires: fontpackages-filesystem
%description
-The mission of the Scientific and Technical Information Exchange (STIX) font
-creation project is the preparation of a comprehensive set of fonts that serve
-the scientific and engineering community in the process from manuscript
-creation through final publication, both in electronic and print formats.
+%common_desc
This package includes base Unicode fonts containing most glyphs for standard
use.
-%package pua
-Group: User Interface/X
+%package pua
Summary: STIX scientific and engineering fonts, PUA glyphs
-# Does not really make sense without the core typefaces
+Group: User Interface/X
Requires: %{name} = %{version}-%{release}
-
%description pua
-The mission of the Scientific and Technical Information Exchange (STIX) font
-creation project is the preparation of a comprehensive set of fonts that serve
-the scientific and engineering community in the process from manuscript
-creation through final publication, both in electronic and print formats.
+%common_desc
This package includes fonts containing glyphs called out from the Unicode
Private Use Area (PUA) range. Glyphs in this range do not have an official
@@ -52,56 +51,49 @@ Unicode codepoint. They're generally accessible only through specialised
software. Text using them will break if they're ever accepted by the Unicode
Consortium and moved to an official codepoint.
+%_font_pkg -n pua -f %{fontconf}-pua.conf STIXNonUni*otf
-%package integrals
-Group: User Interface/X
+
+%package integrals
Summary: STIX scientific and engineering fonts, additional integral glyphs
-# Does not really make sense without the core typefaces
+Group: User Interface/X
Requires: %{name} = %{version}-%{release}
-
%description integrals
-The mission of the Scientific and Technical Information Exchange (STIX) font
-creation project is the preparation of a comprehensive set of fonts that serve
-the scientific and engineering community in the process from manuscript
-creation through final publication, both in electronic and print formats.
+%common_desc
This package includes fonts containing additional integrals of various size
and slant.
+%_font_pkg -n integrals -f %{fontconf}-integrals.conf STIXInt*.otf
-%package sizes
-Group: User Interface/X
+
+%package sizes
Summary: STIX scientific and engineering fonts, additional glyph sizes
-# Does not really make sense without the core typefaces
+Group: User Interface/X
Requires: %{name} = %{version}-%{release}
-
%description sizes
-The mission of the Scientific and Technical Information Exchange (STIX) font
-creation project is the preparation of a comprehensive set of fonts that serve
-the scientific and engineering community in the process from manuscript
-creation through final publication, both in electronic and print formats.
+%common_desc
This package includes fonts containing glyphs in additional sizes (Mostly
"fence" and "piece" glyphs).
+%_font_pkg -n sizes -f %{fontconf}-sizes.conf STIXSiz*.otf
-%package variants
-Group: User Interface/X
+
+%package variants
Summary: STIX scientific and engineering fonts, additional glyph variants
-# Does not really make sense without the core typefaces
+Group: User Interface/X
Requires: %{name} = %{version}-%{release}
-
%description variants
-The mission of the Scientific and Technical Information Exchange (STIX) font
-creation project is the preparation of a comprehensive set of fonts that serve
-the scientific and engineering community in the process from manuscript
-creation through final publication, both in electronic and print formats.
+%common_desc
This package includes fonts containing alternative variants of some glyphs.
+%_font_pkg -n variants -f %{fontconf}-variants.conf STIXVar*otf
+
%prep
%setup -c -q -n %{archivename}
@@ -115,120 +107,57 @@ done
%build
-# Nothing there
%install
rm -fr %{buildroot}
-install -m 0755 -d %{buildroot}%{fontdir}
-install -m 0644 -p *.otf %{buildroot}%{fontdir}
+install -m 0755 -d %{buildroot}%{_fontdir}
+install -m 0644 -p *.otf %{buildroot}%{_fontdir}
-install -m 0755 -d %{buildroot}%{fontconfdir}
-install -m 0644 -p %{SOURCE2} %{buildroot}%{fontconfdir}/61-%{fontname}.conf
-install -m 0644 -p %{SOURCE3} %{buildroot}%{fontconfdir}/61-%{fontname}-pua.conf
-install -m 0644 -p %{SOURCE4} %{buildroot}%{fontconfdir}/61-%{fontname}-integrals.conf
-install -m 0644 -p %{SOURCE5} %{buildroot}%{fontconfdir}/61-%{fontname}-sizes.conf
-install -m 0644 -p %{SOURCE6} %{buildroot}%{fontconfdir}/61-%{fontname}-variants.conf
+install -m 0755 -d %{buildroot}%{_fontconfig_templatedir} \
+ %{buildroot}%{_fontconfig_confdir}
+
+install -m 0644 -p %{SOURCE2} \
+ %{buildroot}%{_fontconfig_templatedir}/%{fontconf}.conf
+install -m 0644 -p %{SOURCE3} \
+ %{buildroot}%{_fontconfig_templatedir}/%{fontconf}-pua.conf
+install -m 0644 -p %{SOURCE4} \
+ %{buildroot}%{_fontconfig_templatedir}/%{fontconf}-integrals.conf
+install -m 0644 -p %{SOURCE5} \
+ %{buildroot}%{_fontconfig_templatedir}/%{fontconf}-sizes.conf
+install -m 0644 -p %{SOURCE6} \
+ %{buildroot}%{_fontconfig_templatedir}/%{fontconf}-variants.conf
+
+for fontconf in %{fontconf}.conf \
+ %{fontconf}-pua.conf \
+ %{fontconf}-integrals.conf \
+ %{fontconf}-sizes.conf \
+ %{fontconf}-variants.conf ; do
+ ln -s %{_fontconfig_templatedir}/$fontconf \
+ %{buildroot}%{_fontconfig_confdir}/$fontconf
+done
%clean
rm -fr %{buildroot}
-%post
-if [ -x %{_bindir}/fc-cache ] ; then
- %{_bindir}/fc-cache %{fontdir} || :
-fi
+%_font_pkg -f %{fontconf}.conf STIXGeneral*otf
-
-%postun
-if [ $1 -eq 0 -a -x %{_bindir}/fc-cache ] ; then
- %{_bindir}/fc-cache %{fontdir} || :
-fi
-
-
-%post pua
-if [ -x %{_bindir}/fc-cache ] ; then
- %{_bindir}/fc-cache %{fontdir} || :
-fi
-
-
-%postun pua
-if [ $1 -eq 0 -a -x %{_bindir}/fc-cache ] ; then
- %{_bindir}/fc-cache %{fontdir} || :
-fi
-
-
-%post integrals
-if [ -x %{_bindir}/fc-cache ] ; then
- %{_bindir}/fc-cache %{fontdir} || :
-fi
-
-
-%postun integrals
-if [ $1 -eq 0 -a -x %{_bindir}/fc-cache ] ; then
- %{_bindir}/fc-cache %{fontdir} || :
-fi
-
-
-%post sizes
-if [ -x %{_bindir}/fc-cache ] ; then
- %{_bindir}/fc-cache %{fontdir} || :
-fi
-
-
-%postun sizes
-if [ $1 -eq 0 -a -x %{_bindir}/fc-cache ] ; then
- %{_bindir}/fc-cache %{fontdir} || :
-fi
-
-%post variants
-if [ -x %{_bindir}/fc-cache ] ; then
- %{_bindir}/fc-cache %{fontdir} || :
-fi
-
-
-%postun variants
-if [ $1 -eq 0 -a -x %{_bindir}/fc-cache ] ; then
- %{_bindir}/fc-cache %{fontdir} || :
-fi
-
-
-%files
-%defattr(0644,root,root,0755)
%doc *.txt
-%config(noreplace) %{fontconfdir}/61-%{fontname}.conf
-
-%dir %{fontdir}/
-%{fontdir}/STIXGeneral*otf
-
-
-%files pua
-%defattr(0644,root,root,0755)
-%config(noreplace) %{fontconfdir}/61-%{fontname}-pua.conf
-%{fontdir}/STIXNonUni*otf
-
-
-%files integrals
-%defattr(0644,root,root,0755)
-%config(noreplace) %{fontconfdir}/61-%{fontname}-integrals.conf
-%{fontdir}/STIXInt*.otf
-
-
-%files sizes
-%defattr(0644,root,root,0755)
-%config(noreplace) %{fontconfdir}/61-%{fontname}-sizes.conf
-%{fontdir}/STIXSiz*.otf
-
-
-%files variants
-%defattr(0644,root,root,0755)
-%config(noreplace) %{fontconfdir}/61-%{fontname}-variants.conf
-%{fontdir}/STIXVar*otf
+%dir %{_fontdir}
%changelog
+* Sun Nov 23 2008
+- 0.9-9
+ᛤ ‘rpm-fonts’ renamed to “fontpackages”
+
+* Fri Nov 14 2008
+- 0.9-8
+▤ Rebuild using new « rpm-fonts »
+
* Fri Jul 11 2008
- 0.9-7
⌖ Fedora 10 alpha general package cleanup