Temporarily disable profiling on aarch64
This commit is contained in:
parent
3c90053e65
commit
f5e7494f53
File diff suppressed because it is too large
Load Diff
53
star-aarch64.patch
Normal file
53
star-aarch64.patch
Normal file
@ -0,0 +1,53 @@
|
||||
diff --git a/lib/libschily_p.mk b/lib/libschily_p.mk
|
||||
index 8d9cec6..9bfc9b2 100644
|
||||
--- a/lib/libschily_p.mk
|
||||
+++ b/lib/libschily_p.mk
|
||||
@@ -14,7 +14,7 @@ TARGETLIB= schily
|
||||
CPPOPTS += -Istdio
|
||||
CPPOPTS += -DUSE_SCANSTACK # Try to scan stack frames
|
||||
CPPOPTS += -DPORT_ONLY # Add missing funcs line snprintf for porting
|
||||
-COPTS += $(COPTGPROF)
|
||||
+# COPTS += $(COPTGPROF)
|
||||
include Targets
|
||||
LIBS=
|
||||
|
||||
diff --git a/libdeflt/libdeflt_p.mk b/libdeflt/libdeflt_p.mk
|
||||
index 477deb2..8542bbc 100644
|
||||
--- a/libdeflt/libdeflt_p.mk
|
||||
+++ b/libdeflt/libdeflt_p.mk
|
||||
@@ -12,7 +12,7 @@ SUBINSDIR= /profiled
|
||||
INSDIR= lib
|
||||
TARGETLIB= deflt
|
||||
#CPPOPTS += -Ispecincl
|
||||
-COPTS += $(COPTGPROF)
|
||||
+# COPTS += $(COPTGPROF)
|
||||
include Targets
|
||||
LIBS=
|
||||
|
||||
diff --git a/libfind/libfind_p.mk b/libfind/libfind_p.mk
|
||||
index f4b2a56..f61e507 100644
|
||||
--- a/libfind/libfind_p.mk
|
||||
+++ b/libfind/libfind_p.mk
|
||||
@@ -11,7 +11,7 @@ SUBINSDIR= /profiled
|
||||
#VPATH= .:stdio:$(ARCHDIR)
|
||||
INSDIR= lib
|
||||
TARGETLIB= find
|
||||
-COPTS += $(COPTGPROF)
|
||||
+#COPTS += $(COPTGPROF)
|
||||
#CPPOPTS += -Istdio
|
||||
#CPPOPTS += -DUSE_SCANSTACK
|
||||
|
||||
diff --git a/librmt/librmt_p.mk b/librmt/librmt_p.mk
|
||||
index f16fd84..565b28a 100644
|
||||
--- a/librmt/librmt_p.mk
|
||||
+++ b/librmt/librmt_p.mk
|
||||
@@ -14,7 +14,7 @@ TARGETLIB= rmt
|
||||
CPPOPTS += -DUSE_REMOTE
|
||||
CPPOPTS += -DUSE_RCMD_RSH
|
||||
CPPOPTS += -DUSE_LARGEFILES
|
||||
-COPTS += $(COPTGPROF)
|
||||
+#COPTS += $(COPTGPROF)
|
||||
include Targets
|
||||
LIBS=
|
||||
|
||||
|
24
star.spec
24
star.spec
@ -7,7 +7,9 @@
|
||||
Summary: An archiving tool with ACL support
|
||||
Name: star
|
||||
Version: 1.5.2
|
||||
Release: 8%{?dist}
|
||||
Release: 9%{?dist}
|
||||
License: CDDL
|
||||
Group: Applications/Archiving
|
||||
URL: http://cdrecord.berlios.de/old/private/star.html
|
||||
Source: ftp://ftp.berlios.de/pub/star/%{name}-%{version}.tar.bz2
|
||||
|
||||
@ -32,11 +34,8 @@ Patch7: star-1.5.1-crc.patch
|
||||
# ~> #948866
|
||||
Patch8: star-1.5.2-man-page-day.patch
|
||||
|
||||
# fix the build for aarch64 by actualization of the config.guess/config.sub
|
||||
# files with the most up2date version from git://git.savannah.gnu.org/config.git
|
||||
# ~> downstream
|
||||
# ~> #926571
|
||||
Patch9: star-1.5.2-aarch64-config.patch
|
||||
# Disable profiling on aarch64 as it's not currently supported upstream
|
||||
Patch9: star-aarch64.patch
|
||||
|
||||
# Allow rmt to access all files.
|
||||
# ~> downstream
|
||||
@ -48,14 +47,12 @@ Patch10: star-1.5.2-rmt-rh-access.patch
|
||||
# ~> related to #968980
|
||||
Patch11: star-1.5.2-use-ssh-by-default.patch
|
||||
|
||||
Requires(post): %{ALTERNATIVES}
|
||||
Requires(preun): %{ALTERNATIVES}
|
||||
|
||||
License: CDDL
|
||||
Group: Applications/Archiving
|
||||
BuildRequires: libattr-devel libacl-devel libtool libselinux-devel
|
||||
BuildRequires: e2fsprogs-devel
|
||||
|
||||
Requires(post): %{ALTERNATIVES}
|
||||
Requires(preun): %{ALTERNATIVES}
|
||||
|
||||
# Historically, star installed /usr/bin/spax binary also so we don't want to
|
||||
# break the compatibility. We don't care about scpio because scpio binary was
|
||||
# not installed.
|
||||
@ -141,7 +138,7 @@ star_recode AN-1.5 AN-1.5.2 star/star.4
|
||||
|
||||
cp -a READMEs/README.linux .
|
||||
|
||||
for PLAT in %{arm} x86_64 ppc64 s390 s390x sh3 sh4 sh4a sparcv9; do
|
||||
for PLAT in %{arm} aarch64 x86_64 ppc64 s390 s390x sh3 sh4 sh4a sparcv9; do
|
||||
for AFILE in gcc cc; do
|
||||
[ ! -e RULES/${PLAT}-linux-${AFILE}.rul ] \
|
||||
&& ln -s i586-linux-${AFILE}.rul RULES/${PLAT}-linux-${AFILE}.rul
|
||||
@ -242,6 +239,9 @@ fi
|
||||
%{_sysconfdir}/rmt
|
||||
|
||||
%changelog
|
||||
* Mon Jan 13 2014 Peter Robinson <pbrobinson@fedoraproject.org> 1.5.2-9
|
||||
- Temporarily disable profiling on aarch64
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.2-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user