upgrade 1.5a71-1
This commit is contained in:
parent
3fb639d339
commit
94c16cb373
@ -1 +1 @@
|
||||
star-1.5a69.tar.bz2
|
||||
star-1.5a71.tar.bz2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
3d70f46190b902ed252ad48d4bfd1345 star-1.5a69.tar.bz2
|
||||
3e9742f364b5aab85c961017dce04957 star-1.5a71.tar.bz2
|
||||
|
@ -1,7 +1,7 @@
|
||||
--- star-1.5/conf/configure.in.selinux 2005-10-11 04:51:05.000000000 -0400
|
||||
+++ star-1.5/conf/configure.in 2005-11-08 16:36:57.000000000 -0500
|
||||
@@ -314,6 +314,15 @@
|
||||
LIBS="$ac_save_LIBS"
|
||||
--- star-1.5/conf/configure.in.selinux 2006-02-07 11:23:13.000000000 -0500
|
||||
+++ star-1.5/conf/configure.in 2006-02-22 10:11:28.000000000 -0500
|
||||
@@ -357,6 +357,15 @@
|
||||
echo no
|
||||
fi
|
||||
|
||||
+AC_CHECK_HEADERS(selinux/selinux.h)
|
||||
@ -16,23 +16,23 @@
|
||||
dnl Checks for OS madness.
|
||||
AC_BROKEN_LINUX_EXT2_FS_H
|
||||
AC_BROKEN_SRC_LINUX_EXT2_FS_H
|
||||
@@ -329,5 +338,6 @@
|
||||
AC_SUBST(lib_acl)
|
||||
@@ -373,5 +382,6 @@
|
||||
AC_SUBST(lib_acl_test)
|
||||
AC_SUBST(lib_attr)
|
||||
AC_SUBST(lib_secdb)
|
||||
+AC_SUBST(lib_selinux)
|
||||
|
||||
AC_OUTPUT(rules.cnf)
|
||||
--- star-1.5/conf/rules.cnf.in.selinux 2004-10-07 14:32:26.000000000 -0400
|
||||
+++ star-1.5/conf/rules.cnf.in 2005-11-08 16:36:57.000000000 -0500
|
||||
@@ -9,3 +9,5 @@
|
||||
LIB_ACL= @lib_acl@
|
||||
--- star-1.5/conf/rules.cnf.in.selinux 2005-12-20 06:41:02.000000000 -0500
|
||||
+++ star-1.5/conf/rules.cnf.in 2006-02-22 10:12:56.000000000 -0500
|
||||
@@ -10,3 +10,5 @@
|
||||
LIB_ACL_TEST= @lib_acl_test@
|
||||
LIB_ATTR = @lib_attr@
|
||||
LIB_SECDB = @lib_secdb@
|
||||
+LIB_SELINUX = @lib_selinux@
|
||||
+
|
||||
--- star-1.5/star/pax.mk.selinux 2005-02-09 18:31:56.000000000 -0500
|
||||
+++ star-1.5/star/pax.mk 2005-11-08 16:36:57.000000000 -0500
|
||||
--- star-1.5/star/pax.mk.selinux 2006-02-02 10:00:31.000000000 -0500
|
||||
+++ star-1.5/star/pax.mk 2006-02-22 10:10:09.000000000 -0500
|
||||
@@ -17,6 +17,7 @@
|
||||
CPPOPTS += -DUSE_LARGEFILES
|
||||
CPPOPTS += -DUSE_ACL
|
||||
@ -51,7 +51,7 @@
|
||||
|
||||
###########################################################################
|
||||
--- star-1.5/star/star.mk.selinux 2005-08-28 07:22:30.000000000 -0400
|
||||
+++ star-1.5/star/star.mk 2005-11-08 16:36:57.000000000 -0500
|
||||
+++ star-1.5/star/star.mk 2006-02-22 10:10:09.000000000 -0500
|
||||
@@ -19,6 +19,7 @@
|
||||
CPPOPTS += -DUSE_XATTR
|
||||
CPPOPTS += -DUSE_FFLAGS
|
||||
@ -70,7 +70,7 @@
|
||||
|
||||
###########################################################################
|
||||
--- star-1.5/star/star_fat.mk.selinux 2005-11-01 15:53:51.000000000 -0500
|
||||
+++ star-1.5/star/star_fat.mk 2005-11-08 16:36:57.000000000 -0500
|
||||
+++ star-1.5/star/star_fat.mk 2006-02-22 10:10:09.000000000 -0500
|
||||
@@ -28,6 +28,7 @@
|
||||
CPPOPTS += -DUSE_FFLAGS
|
||||
CPPOPTS += -DCOPY_LINKS_DELAYED
|
||||
@ -89,7 +89,7 @@
|
||||
spaxman.mk suntarman.mk Makefile.dfl
|
||||
|
||||
--- star-1.5/star/Makefile.selinux 2005-11-01 15:53:51.000000000 -0500
|
||||
+++ star-1.5/star/Makefile 2005-11-08 16:36:57.000000000 -0500
|
||||
+++ star-1.5/star/Makefile 2006-02-22 10:10:09.000000000 -0500
|
||||
@@ -25,6 +25,7 @@
|
||||
CPPOPTS += -DUSE_FIND
|
||||
CPPOPTS += -DUSE_ACL
|
||||
@ -107,9 +107,9 @@
|
||||
XMK_FILE= Makefile.man starformatman.mk scpioman.mk gnutarman.mk \
|
||||
spaxman.mk suntarman.mk Makefile.dfl
|
||||
|
||||
--- star-1.5/star/star.c.selinux 2005-11-01 17:15:05.000000000 -0500
|
||||
+++ star-1.5/star/star.c 2005-11-08 16:36:57.000000000 -0500
|
||||
@@ -44,6 +44,10 @@
|
||||
--- star-1.5/star/star.c.selinux 2006-02-18 14:09:39.000000000 -0500
|
||||
+++ star-1.5/star/star.c 2006-02-22 10:10:09.000000000 -0500
|
||||
@@ -42,6 +42,10 @@
|
||||
#include "starsubs.h"
|
||||
#include "checkerr.h"
|
||||
|
||||
@ -120,7 +120,7 @@
|
||||
EXPORT int main __PR((int ac, char **av));
|
||||
LOCAL void star_create __PR((int ac, char *const *av));
|
||||
LOCAL void checkdumptype __PR((GINFO *gp));
|
||||
@@ -374,6 +378,11 @@
|
||||
@@ -375,6 +379,11 @@
|
||||
comerr("Panic cannot set back effective uid.\n");
|
||||
}
|
||||
my_uid = geteuid();
|
||||
@ -132,12 +132,13 @@
|
||||
/*
|
||||
* WARNING: We now are no more able to open a new remote connection
|
||||
* unless we have been called by root.
|
||||
--- star-1.5/star/extract.c.selinux 2005-11-08 16:35:01.000000000 -0500
|
||||
+++ star-1.5/star/extract.c 2005-11-08 16:41:18.000000000 -0500
|
||||
@@ -213,6 +213,16 @@
|
||||
if (prblockno)
|
||||
(void) tblocks(); /* set curblockno */
|
||||
|
||||
--- star-1.5/star/extract.c.selinux 2005-11-13 08:57:21.000000000 -0500
|
||||
+++ star-1.5/star/extract.c 2006-02-22 10:14:45.000000000 -0500
|
||||
@@ -224,6 +224,17 @@
|
||||
continue;
|
||||
}
|
||||
#endif
|
||||
+
|
||||
+#ifdef WITH_SELINUX
|
||||
+ if (!to_stdout && selinux_enabled) {
|
||||
+ if (setselinux(&finfo) == FALSE) {
|
||||
@ -151,8 +152,8 @@
|
||||
if (finfo.f_flags & F_BAD_META) {
|
||||
if (!void_bad(&finfo))
|
||||
break;
|
||||
--- star-1.5/star/cpio.mk.selinux 2005-02-09 18:31:56.000000000 -0500
|
||||
+++ star-1.5/star/cpio.mk 2005-11-08 16:36:57.000000000 -0500
|
||||
--- star-1.5/star/cpio.mk.selinux 2006-02-02 10:01:18.000000000 -0500
|
||||
+++ star-1.5/star/cpio.mk 2006-02-22 10:10:09.000000000 -0500
|
||||
@@ -18,6 +18,7 @@
|
||||
CPPOPTS += -DUSE_ACL
|
||||
CPPOPTS += -DUSE_XATTR
|
||||
@ -170,8 +171,8 @@
|
||||
XMK_FILE= scpioman.mk
|
||||
|
||||
###########################################################################
|
||||
--- star-1.5/star/gnutar.mk.selinux 2005-02-09 18:31:56.000000000 -0500
|
||||
+++ star-1.5/star/gnutar.mk 2005-11-08 16:36:57.000000000 -0500
|
||||
--- star-1.5/star/gnutar.mk.selinux 2006-02-02 10:00:31.000000000 -0500
|
||||
+++ star-1.5/star/gnutar.mk 2006-02-22 10:10:09.000000000 -0500
|
||||
@@ -18,6 +18,7 @@
|
||||
CPPOPTS += -DUSE_ACL
|
||||
CPPOPTS += -DUSE_XATTR
|
||||
@ -189,8 +190,8 @@
|
||||
XMK_FILE= gnutarman.mk
|
||||
|
||||
###########################################################################
|
||||
--- star-1.5/star/suntar.mk.selinux 2005-02-09 18:31:56.000000000 -0500
|
||||
+++ star-1.5/star/suntar.mk 2005-11-08 16:36:57.000000000 -0500
|
||||
--- star-1.5/star/suntar.mk.selinux 2006-02-02 10:00:31.000000000 -0500
|
||||
+++ star-1.5/star/suntar.mk 2006-02-22 10:10:09.000000000 -0500
|
||||
@@ -18,6 +18,7 @@
|
||||
CPPOPTS += -DUSE_ACL
|
||||
CPPOPTS += -DUSE_XATTR
|
||||
@ -209,7 +210,7 @@
|
||||
|
||||
###########################################################################
|
||||
--- star-1.5/star/starsubs.h.selinux 2005-11-01 16:32:18.000000000 -0500
|
||||
+++ star-1.5/star/starsubs.h 2005-11-08 16:36:57.000000000 -0500
|
||||
+++ star-1.5/star/starsubs.h 2006-02-22 10:10:09.000000000 -0500
|
||||
@@ -301,6 +301,11 @@
|
||||
extern BOOL get_xattr __PR((register FINFO *info));
|
||||
extern BOOL set_xattr __PR((register FINFO *info));
|
||||
@ -222,9 +223,9 @@
|
||||
#endif
|
||||
|
||||
/*
|
||||
--- star-1.5/star/xattr.c.selinux 2005-09-02 18:29:35.000000000 -0400
|
||||
+++ star-1.5/star/xattr.c 2005-11-08 16:36:57.000000000 -0500
|
||||
@@ -169,6 +169,29 @@
|
||||
--- star-1.5/star/xattr.c.selinux 2006-02-13 20:00:40.000000000 -0500
|
||||
+++ star-1.5/star/xattr.c 2006-02-22 10:16:44.000000000 -0500
|
||||
@@ -181,6 +181,29 @@
|
||||
#endif /* USE_XATTR */
|
||||
}
|
||||
|
||||
@ -254,14 +255,14 @@
|
||||
/* ARGSUSED */
|
||||
EXPORT BOOL
|
||||
set_xattr(info)
|
||||
@@ -181,6 +204,10 @@
|
||||
@@ -194,6 +217,10 @@
|
||||
return (TRUE);
|
||||
|
||||
for (xap = info->f_xattr; xap->name != NULL; xap++) {
|
||||
+#ifdef WITH_SELINUX
|
||||
+ if (selinux_enabled && (strcmp(xap->name, "security.selinux") == 0))
|
||||
+ continue;
|
||||
+ if (selinux_enabled && (strcmp(xap->name, "security.selinux") == 0))
|
||||
+ continue;
|
||||
+#endif
|
||||
if (setxattr(info->f_name, xap->name, xap->value,
|
||||
if (lsetxattr(info->f_name, xap->name, xap->value,
|
||||
xap->value_len, 0) != 0) {
|
||||
if (!errhidden(E_SETXATTR, info->f_name)) {
|
||||
|
37
star.spec
37
star.spec
@ -3,16 +3,14 @@
|
||||
%endif
|
||||
Summary: An archiving tool with ACL support
|
||||
Name: star
|
||||
Version: 1.5a69
|
||||
Release: 1.2.1
|
||||
Version: 1.5a71
|
||||
Release: 1
|
||||
URL: http://cdrecord.berlios.de/old/private/star.html
|
||||
Source: ftp://ftp.berlios.de/pub/star/alpha/%{name}-%{version}.tar.bz2
|
||||
Patch1: star-1.5-newMake.patch
|
||||
Patch2: star-1.5-nofsync.patch
|
||||
Patch3: star-1.5-davej.patch
|
||||
Patch4: star-1.5-selinux.patch
|
||||
Patch5: star-1.5-defineULLONG.patch
|
||||
Patch2: star-1.5-selinux.patch
|
||||
|
||||
License: CDDL 1.0
|
||||
License: CDDL
|
||||
Group: Applications/Archiving
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
BuildRequires: libattr-devel libacl-devel libtool libselinux-devel autoconf213
|
||||
@ -24,20 +22,9 @@ and can restore individual files from the archive. Star supports ACL.
|
||||
%prep
|
||||
%setup -q -n star-1.5
|
||||
%patch1 -p1 -b .newMake
|
||||
%patch2 -p1 -b .nofsync
|
||||
%patch3 -p1 -b .davej
|
||||
%if %{WITH_SELINUX}
|
||||
%patch4 -p1 -b .selinux
|
||||
%patch2 -p1 -b .selinux
|
||||
%endif
|
||||
%patch5 -p1 -b .defineULLONG
|
||||
|
||||
for PLAT in x86_64 ppc64 s390 s390x; do
|
||||
for AFILE in gcc cc; do
|
||||
[ ! -e RULES/${PLAT}-linux-${AFILE}.rul ] \
|
||||
&& ln -s i586-linux-${AFILE}.rul RULES/${PLAT}-linux-${AFILE}.rul
|
||||
done
|
||||
done
|
||||
cp -f /usr/share/libtool/config.sub conf/config.sub
|
||||
|
||||
%build
|
||||
export COPTOPT="$RPM_OPT_FLAGS"
|
||||
@ -47,7 +34,8 @@ export MAKEPROG=gmake
|
||||
# Disable fat binary
|
||||
(cd star; rm Makefile; cp all.mk Makefile)
|
||||
|
||||
make %{?_smp_mflags} PARCH=%{_target_cpu} CPPOPTX="-DNO_FSYNC" \
|
||||
#make %{?_smp_mflags} PARCH=%{_target_cpu} CPPOPTX="-DNO_FSYNC" \
|
||||
make %{?_smp_mflags} PARCH=%{_target_cpu} \
|
||||
K_ARCH=%{_target_cpu} \
|
||||
CONFFLAGS="%{_target_platform} --prefix=%{_prefix} \
|
||||
--exec-prefix=%{_exec_prefix} --bindir=%{_bindir} \
|
||||
@ -91,7 +79,7 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc README AN* COPYING README.ACL README.crash README.largefiles README.linux
|
||||
%doc README AN* COPYING CDDL.Schily.txt README.ACL README.crash README.largefiles README.linux
|
||||
%doc README.otherbugs README.pattern README.posix-2001 README.SSPM
|
||||
%doc STARvsGNUTAR
|
||||
%doc STATUS.alpha TODO
|
||||
@ -102,11 +90,8 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_mandir}/man1/spax.1*
|
||||
|
||||
%changelog
|
||||
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.5a69-1.2.1
|
||||
- bump again for double-long bug on ppc(64)
|
||||
|
||||
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.5a69-1.2
|
||||
- rebuilt for new gcc4.1 snapshot and glibc changes
|
||||
* Wed Feb 22 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a71-1
|
||||
- upgrade
|
||||
|
||||
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
||||
- rebuilt
|
||||
|
Loading…
Reference in New Issue
Block a user