star: use ssh for remote access by default
Version: 1.5.2-7 Resolves: #976414
This commit is contained in:
parent
ff07f28c03
commit
694d7a38b5
13
star-1.5.2-use-ssh-by-default.patch
Normal file
13
star-1.5.2-use-ssh-by-default.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/librmt/remote.c b/librmt/remote.c
|
||||
index 4606484..298ecef 100644
|
||||
--- a/librmt/remote.c
|
||||
+++ b/librmt/remote.c
|
||||
@@ -1462,7 +1462,7 @@ _rcmdrsh(ahost, inport, locuser, remuser, cmd, rsh)
|
||||
int pid;
|
||||
|
||||
if (rsh == 0)
|
||||
- rsh = "rsh";
|
||||
+ rsh = "ssh";
|
||||
|
||||
/*
|
||||
* Verify that 'locuser' is present on local host.
|
@ -43,6 +43,11 @@ Patch9: star-1.5.2-aarch64-config.patch
|
||||
# ~> #968980
|
||||
Patch10: star-1.5.2-rmt-rh-access.patch
|
||||
|
||||
# Use ssh rather than rsh by default
|
||||
# ~> downstream
|
||||
# ~> related to #968980
|
||||
Patch11: star-1.5.2-use-ssh-by-default.patch
|
||||
|
||||
Requires(post): %{ALTERNATIVES}
|
||||
Requires(preun): %{ALTERNATIVES}
|
||||
|
||||
@ -120,6 +125,7 @@ restoring files from a backup), and tar (an archiving program).
|
||||
%patch8 -p1 -b .man-page-day
|
||||
%patch9 -p1 -b .aarch64
|
||||
%patch10 -p1 -b .rmt-access-rules
|
||||
%patch11 -p1 -b .ssh-by-default
|
||||
|
||||
cp -a star/all.mk star/Makefile
|
||||
|
||||
@ -238,6 +244,7 @@ fi
|
||||
%changelog
|
||||
* Thu Jun 20 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-7
|
||||
- we should provide /etc/rmt symlink for a while (related to #968980)
|
||||
- use the ssh as the default remote access method
|
||||
|
||||
* Thu May 30 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-6
|
||||
- subpackage also 'rmt' (#968980)
|
||||
|
Loading…
Reference in New Issue
Block a user